[2.0.17] Inline Banner Ad

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
86
60%
Very Good
26
18%
Good
18
13%
Fair
4
3%
Poor
9
6%
 
Total votes: 143

Banbury
Registered User
Posts: 25
Joined: Mon Jan 15, 2007 10:11 pm

Re: [2.0.17] Inline Banner Ad

Post by Banbury » Fri Feb 15, 2008 5:49 pm

Hi, I installed this using easy mod but I am getting:

1 Warning(s) reported by the SQL Parser

1. Inconsistent display width specified "TINYINT(5)" in column "ad_id", statement: 1, table: "phpbb_inline_ads"

I dont seem to have any ads displaying for guests if I select that setting...
[EDIT] I think they are displaying OK now actually.

Banbury
Registered User
Posts: 25
Joined: Mon Jan 15, 2007 10:11 pm

Re: [2.0.17] Inline Banner Ad

Post by Banbury » Fri Feb 15, 2008 9:06 pm

OK I have just confirmed with some other people that this is not working, the ads are only displaying to me as I had it set to all users at one point I think.

I am trying to use it to display to guests, help please.

SteeLx
Registered User
Posts: 97
Joined: Mon Mar 19, 2007 10:18 am

Re:

Post by SteeLx » Tue Feb 19, 2008 7:44 am

JJ19 wrote:I am using the Acid Template, and I really want to install this inline banner mod. But I cant seem to find this

Code: Select all

#-----[ OPEN ]------------------------------------------
#
templates/subSilver/overall_header.tpl
#
#-----[ FIND ]------------------------------------------
#
.helpline { background-color: {T_TR_COLOR2}; border-style: none; }
#
#-----[ AFTER, ADD ]------------------------------------------
#
td.inlineadtitle {
	background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; border-width: 1px;
}
td.inlinead {
	background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; border-width: 1px; text-align: center;
}
#
It doesnt seem to have

Code: Select all

.helpline { background-color: {T_TR_COLOR2}; border-style: none; }
in the template I'm using. I was wondering if someone could help me. I have everything else installed perfectly exept that one part.
I'm too using the same, but as AcidTech uses AcidTech.css I edited in it.

I edited all otehr files as said + did added SQL query
Now i can see new section in my phpBB ADMIN CP as

Code: Select all

Ad Management
Ad Code
Inline Ad Config
I did added my Ad's code, & set it to display to all + show ad's afetr 1st post & after every 1 posts.

BUT in posts nothing is coming. it's just like Normal.. nothing new is coming.

the header ad is added by me from overall_header.tpl

but in-posts ad's arent coming. my Forum demo topic : http://www.warrock-hacks.com/viewtopic.php?t=40
Last edited by SteeLx on Wed Feb 20, 2008 5:36 am, edited 1 time in total.

Banbury
Registered User
Posts: 25
Joined: Mon Jan 15, 2007 10:11 pm

Re: [2.0.17] Inline Banner Ad

Post by Banbury » Tue Feb 19, 2008 7:46 pm

My adverts still will not display in guest mode, anyone have any ideas on how to fix this?

geckospyker
Registered User
Posts: 2
Joined: Fri Dec 07, 2007 3:54 pm

Re: [2.0.17] Inline Banner Ad

Post by geckospyker » Fri Feb 29, 2008 7:09 pm

HI,

It seems I am having the same issue as our friend above. Since I am not experienced at manually editing SQL I am hesitant to enter the phpAdmin to make any changes that I may be unable to reverse. The forum I am using is basically blank and I'm using it to test the MODs I'd like to use. This one is particularly important as it plays into the funding structure of the forum and main site. If someone could let me know how to fix this problem - either in SQL :? or within the instructions of the MOD I'd appreciate the guidance.

I did not finish loading the MOD once I got this error.
1 Warning(s) reported by the SQL Parser
Inconsistent display width specified "TINYINT(5)" in column "ad_id", statement: 1, table: "phpbb_inline_ads"



Proposed Database Alterations for your mysql Database Allow
1 CREATE TABLE phpbb_inline_ads (
ad_id TINYINT(5) NOT NULL AUTO_INCREMENT,
ad_code TEXT NOT NULL,
ad_name CHAR(25) NOT NULL,
PRIMARY KEY (ad_id)
);

2 INSERT INTO phpbb_inline_ads(ad_id,ad_code,ad_name) VALUES('1','Your banner code goes here','Default');

3 INSERT INTO phpbb_config(config_name,config_value) VALUES('ad_after_post','1'),('ad_post_threshold',''),('ad_every_post',''),('ad_who','1'),('ad_no_forums',''),('ad_no_groups',''),('ad_old_style','1');
Thanks in advance for your help.
Last edited by geckospyker on Sun Mar 02, 2008 4:32 am, edited 1 time in total.

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [2.0.17] Inline Banner Ad

Post by wired076 » Sat Mar 01, 2008 10:54 am

As it is a test site with no data currently on it then I would recommend that you test out and learn how to use phpmyadmin and other tools on the forum as once it is set up with data on it you will not want to do these sorts of things on it unless you know what you are doing.

Before you go any further in case you stuff it up as I don't know how much time you have put into this so far back up all your files relating to phpBB 2 onto your pc, backup your my sql database and then try those steps that you talked about in your last post.

I recommend this as if you stuff up your modded test board all you need to do to try again is re-import the database and move all the files to a new location on your webhost.

If you need this further explained let me know.

geckospyker
Registered User
Posts: 2
Joined: Fri Dec 07, 2007 3:54 pm

Re: [2.0.17] Inline Banner Ad

Post by geckospyker » Sun Mar 02, 2008 4:38 am

I am slightly familiar with phpMyAdmin. Last time I used it though I totally screwed up the forum and it was down for a month :( .

Since no help understanding the logic that was causing the error was forthcoming I got brave and processed the MOD through EM (since it automatically created backups of modified files) but manually processed the SQL queries in phpMyAdmin. The same error was not received which made me a little happier. The resulting MOD available in my ACP is cool and I can't wait to play with it.

If anyone finds out what "Inconsistent display width" actually means and why it came up I'd be interested to know. Just hope it won't be some goofy ghost error waiting to bite me in the butt later :mrgreen: .

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [2.0.17] Inline Banner Ad

Post by wired076 » Sun Mar 02, 2008 4:56 am

Well there is one way to find out...

Get a few of your mates to register on the board and you should give them all varying permissions on the board and stress test the entire board inc mods and see what happens.

Glad to hear it is working so far.

mloiz
Registered User
Posts: 4
Joined: Fri Feb 15, 2008 2:10 pm
Location: Connecticut
Contact:

Re: [2.0.17] Inline Banner Ad

Post by mloiz » Wed Mar 05, 2008 3:51 am

I have attempted to follow the install instructions for this but am getting the following error when attempting to admin this Mod:
- - - - - - - - - - - - - - - - - - - - - - - - - -
Could not query ad information

DEBUG MODE

SQL Error : 1146 Table 'thepscgr_phpb1.phpbb_inline_ads' doesn't exist

SELECT a.ad_name, a.ad_id FROM phpbb_inline_ads a

Line : 132
File : admin_inline_ad_code.php
- - - - - - - - - - - - - - - - - - - - - - - - - - - -
Can anyone tell me what I am doing wrong?

You can PM or e-mail me directly or just post a reply, I'd greatly appreciate any guidance you can provide.

Thanks
Mike

User avatar
dellsystem
Former Team Member
Posts: 3879
Joined: Sat Apr 09, 2005 8:54 pm
Location: Montreal
Name: Wendy
Contact:

Re: [2.0.17] Inline Banner Ad

Post by dellsystem » Wed Mar 05, 2008 1:36 pm

Sounds like you didn't run the SQL query.

It should be at the top of the install file, just copy and paste the query into the SQL tab page in PHPMyAdmin.
Former moderator and website team member | My MODs, and more (GitHub)

mloiz
Registered User
Posts: 4
Joined: Fri Feb 15, 2008 2:10 pm
Location: Connecticut
Contact:

Re: [2.0.17] Inline Banner Ad

Post by mloiz » Thu Mar 06, 2008 3:40 am

I found my SQL snippet to cut & paste. Where do I find PHPMyAdmin to paste it in?

User avatar
dellsystem
Former Team Member
Posts: 3879
Joined: Sat Apr 09, 2005 8:54 pm
Location: Montreal
Name: Wendy
Contact:

Re: [2.0.17] Inline Banner Ad

Post by dellsystem » Thu Mar 06, 2008 11:55 pm

mloiz wrote:I found my SQL snippet to cut & paste. Where do I find PHPMyAdmin to paste it in?
It should be through your host's control panel, perhaps under 'MySQL' or 'Databases'. If you can't find it at all you can use the db_update generator here - http://sql.phpmix.com/index.php - and copy the SQL query into the box, and follow the instructions from there.
Former moderator and website team member | My MODs, and more (GitHub)

toyouxwithlove
Registered User
Posts: 15
Joined: Fri Mar 07, 2008 9:51 pm

Re: [2.0.17] Inline Banner Ad

Post by toyouxwithlove » Thu Mar 13, 2008 10:51 pm

Okay, so, I did everything necesarry, but there's a little problem.

Seeing how I don't use subSilver, I also did the steps to the style I use, except the .helpline step, because there isn't any in styles other than subSilver. I did the steps to subSilver, but like I said, the other style as well.

The ad shows up, but at the very bottom of the page, in the footer, there is a huge gap between two images that are supposed to be together. You can see it here:

http://kissintherain.x10hosting.com/for ... ic.php?t=3

Does anyone know what to do?

toyouxwithlove
Registered User
Posts: 15
Joined: Fri Mar 07, 2008 9:51 pm

Re: [2.0.17] Inline Banner Ad

Post by toyouxwithlove » Fri Mar 14, 2008 8:53 pm

toyouxwithlove wrote:Okay, so, I did everything necesarry, but there's a little problem.

Seeing how I don't use subSilver, I also did the steps to the style I use, except the .helpline step, because there isn't any in styles other than subSilver. I did the steps to subSilver, but like I said, the other style as well.

The ad shows up, but at the very bottom of the page, in the footer, there is a huge gap between two images that are supposed to be together. You can see it here:

http://kissintherain.x10hosting.com/for ... ic.php?t=3

Does anyone know what to do?
Please, I really need help. :[

TheJediSlayer
Registered User
Posts: 50
Joined: Mon Dec 18, 2006 12:41 pm

Re: [2.0.17] Inline Banner Ad

Post by TheJediSlayer » Sat Mar 15, 2008 11:00 pm

Error:
Cannot find out where to place text in this Overall_header file.

File Code As of Right Now:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="{S_CONTENT_DIRECTION}">
<head>
<meta http-equiv="Content-Type" content="text/html; charset={S_CONTENT_ENCODING}">
<meta http-equiv="Content-Style-Type" content="text/css">
{META}
{NAV_LINKS}
<title>{SITENAME} :: {PAGE_TITLE}</title>
<link rel="stylesheet" href="templates/XboxXtreme/{T_HEAD_STYLESHEET}" type="text/css">
<style type="text/css">
</style>
<!-- BEGIN switch_enable_pm_popup -->
<script language="Javascript" type="text/javascript">
<!--
if ( {PRIVATE_MESSAGE_NEW_FLAG} )
{
window.open('{U_PRIVATEMSGS_POPUP}', '_phpbbprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');;
}
//-->
</script>
<!-- END switch_enable_pm_popup -->
<SCRIPT LANGUAGE="Javascript">
var win = null;
function Gk_PopTart(mypage,myname,w,h,scroll)
{
LeftPosition = (screen.width) ? (screen.width-w)/2 : 0;
TopPosition = (screen.height) ? (screen.height-h)/2 : 0;
settings = 'height='+h+',width='+w+',top='+TopPosition+',left='+LeftPosition+',scrollbars='+scroll+',resizable=yes';
win = window.open(mypage,myname,settings);
}
</SCRIPT>
{COUNTDOWN}

</head>
<body bgcolor="{T_BODY_BGCOLOR}" text="{T_BODY_TEXT}" link="{T_BODY_LINK}" vlink="{T_BODY_VLINK}" {COUNTDOWN_ON}/>
<div align="center">
<a name="top"></a>

<table border="0" cellspacing="0" cellpadding="0" width="100%" height="100%">
<tr>
<td width="20" align="top" background="templates/XboxXtreme/images/border_left_bkgd.gif"><img src="templates/XboxXtreme/images/spacer.gif" width="20" height="1"></td>
<td width="100%" height="100%" class="content" align="center" valign="top">

<table width="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td width="2" align="left" valign="top" background="templates/XboxXtreme/images/nav_bkgd.jpg"><img name="nav_left_cap" src="templates/XboxXtreme/images/nav_cap_left.jpg" border="0" alt=""></td>
<td width="98%" align="center" nowrap="nowrap" background="templates/XboxXtreme/images/nav_bkgd.jpg">
<a href="{U_INDEX}"><img src="templates/XboxXtreme/images/XboxXtreme_logo_top.jpg" border="0"></a>
</td>
<td width="2" align="right" valign="top" background="templates/XboxXtreme/images/nav_bkgd.jpg"><img name="nav_right_cap" src="templates/XboxXtreme/images/nav_cap_right.jpg" border="0" alt=""></td>
</tr>
<tr>
<td colspan="3" align="center"><a href="{U_INDEX}"><img src="templates/XboxXtreme/images/XboxXtreme_logo.gif" border="0"></a></td>
</tr>
<tr>
<td width="2" align="left" valign="top" background="templates/XboxXtreme/images/nav_bkgd.jpg"><img name="nav_left_cap" src="templates/XboxXtreme/images/nav_cap_left.jpg" border="0" alt=""></td>
<td width="98%" align="center" nowrap="nowrap" background="templates/XboxXtreme/images/nav_bkgd.jpg"><span class="mainmenu">
<!-- BEGIN switch_user_logged_out -->
<a href="{U_REGISTER}" class="mainmenu">{L_REGISTER}</a>&nbsp;&nbsp;
<!-- END switch_user_logged_out -->
<a href="{U_FAQ}" class="mainmenu">{L_FAQ}</a></span>&nbsp;&nbsp;&nbsp;
<a href="{U_SEARCH}" class="mainmenu">{L_SEARCH}</a>&nbsp;&nbsp;&nbsp;
<a href="{U_MEMBERLIST}" class="mainmenu">{L_MEMBERLIST}</a>&nbsp;&nbsp;&nbsp;
<a href="{U_GROUP_CP}" class="mainmenu">{L_USERGROUPS}</a>&nbsp;&nbsp;&nbsp;
<a href="{U_ACTIVITY}" class="mainmenu">{L_ACTIVITY}</a>&nbsp;&nbsp;&nbsp;
<a href="{U_PROFILE}" class="mainmenu">{L_PROFILE}</a>&nbsp;&nbsp;&nbsp;
<a href="{U_PRIVATEMSGS}" class="mainmenu">{PRIVATE_MESSAGE_INFO}</a>&nbsp;&nbsp;&nbsp;
<a href="{U_LOGIN_LOGOUT}" class="mainmenu">{L_LOGIN_LOGOUT}</a>
</span></td>
<td width="2" align="right" valign="top" background="templates/XboxXtreme/images/nav_bkgd.jpg"><img name="nav_right_cap" src="templates/XboxXtreme/images/nav_cap_right.jpg" border="0" alt=""></td>
</tr>
</table>
<!-- BEGIN switch_countdown_on -->
<form name="countdown">
<table align="center" width="100%" cellspacing="2" cellpadding="5" border="0" class="forumline">
<tr>
<th align="center" colspan="3">{TITLE}</th>
</tr>
<tr>
<td align="left" valign="center" width="20%">{IMG_LEFT}</td>
<td align="center" width="60%">
<div class="gen">{DESC}</div><br />
<div id="time_event" class="genmed" style="display:"><b>
{L_DAYS}&nbsp;<input name="days" class="post" size=4 style="border: 0px">
<span style="display: {FULL_DISPLAY};" class="gen" name="time_string">-&nbsp;&nbsp;
<input name="hours" class="post" size=2 style="border: 0px">&nbsp;:
<input name="mins" class="post" size=2 style="border: 0px">&nbsp;:
<input name="secs" class="post" size=2 style="border: 0px">
</b></span></div>
<div id="event_time" class="gen" style="display:none">{EVENT_TEXT}</div>
</td>
<td align="right" valign="center" width="20%">{IMG_RIGHT}</td>
</tr>
</table>
</form>

<script language="JavaScript" type="text/javascript">countdown();</script>
<!-- END switch_countdown_on -->

Code trying to add in:
td.inlineadtitle {
background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; border-width: 1px;
}
td.inlinead {
background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; border-width: 1px; text-align: center;
}

Post Reply

Return to “[2.0.x] MOD Database Releases”