Simple Subforums

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
196
61%
Very Good
59
18%
Good
34
11%
Fair
7
2%
Poor
26
8%
 
Total votes: 322

c.barber
Registered User
Posts: 15
Joined: Sun Feb 20, 2005 11:00 am

Post by c.barber » Sun Jan 15, 2006 6:13 pm

Hi i just installed this mod, and its great, but i see the subforums on the main page just as normal forums. How do I fix this???

This is the content of the (edited/modded) index_body.tpl file
We are not using subsilver
<!-- Start add - Search back MOD -->
<script language="javascript">
<!--
function SetLastVisit()
{
if (!document.LastVisitFrm.search_time.options[0].selected)
{
document.LastVisitFrm.submit();
}
return true;
}
//-->
</script>
<!-- End add - Search back MOD -->

<!-- mod : Loewen Enterprise - Donation MOD v1.0.0.1 -->
<table width="100%" cellspacing="0" cellpadding="2" border="0" align="center">
<tr>
<td><span class="gen">
{L_NAME_WELCOME} {U_WELCOME_NAME}<br />
</td>
</tr>
<tr>
<td align="left" valign="bottom"><span class="gensmall">{CURRENT_TIME}</span></td>
</tr>
</table>
<table width="100%" cellpadding="3" cellspacing="1" class="forumline">
<tr>
<td class="catHead" colspan="2"><span class="cattitle"><a href="{U_INDEX}" class="nav">{L_INDEX}</a></span></td>
</tr>
<tr>
<td class="row1" align="center" valign="middle" rowspan="2"><img src="templates/Chronicles/images/welcome_panel.gif" alt="" /></td>
<td class="row1" width="100%"><span class="genmed">{WELCOME_USER}</span><br /><span class="gensmall">{WELCOME_USER_INFO}</span></td>
</tr>

<!-- BEGIN switch_user_logged_in -->
<tr>
<td class="row1" width="100%"><span class="gensmall">{LAST_VISIT_DATE}<br />{WELCOME_NEWS}</span></td>
</tr>
<!-- END switch_user_logged_in -->
<!-- BEGIN switch_user_logged_out -->
<form method="post" action="{S_LOGIN_ACTION}">
<tr>
<td class="row1" valign="middle" height="28"><span class="gensmall">{L_USERNAME}:
<input class="post" type="text" name="username" size="10" />
&nbsp;&nbsp;&nbsp;{L_PASSWORD}:
<input class="post" type="password" name="password" size="10" maxlength="32" />
&nbsp;&nbsp; &nbsp;&nbsp;{L_AUTO_LOGIN}
<input class="text" type="checkbox" name="autologin" />
&nbsp;&nbsp;&nbsp;
<input type="submit" class="mainoption" name="login" value="{L_LOGIN}" /></span> </td>
</tr>
</form>
<!-- END switch_user_logged_out -->
<!-- BEGIN switch_suggest_topic -->
<tr>
<td class="row1" width="100%" colspan="2"><span class="gensmall">{WELCOME_SUGGESTED_TOPICS}&nbsp;&nbsp;<a href="{WELCOME_SUGGESTED_LINK}" class"gensmall">{WELCOME_SUGGESTED_TITLE}</a></span></td>
</tr>
<!-- END switch_suggest_topic -->
</table>
<br />
<table width="100%" cellspacing="0" cellpadding="2" border="0" align="center">
<!-- Start add - Search back MOD -->
<form name="LastVisitFrm" action="search.php" method="post">
{SELECT_TIME}
<!-- BEGIN switch_user_logged_in -->
<a href="{U_SEARCH_NEW}" class="gensmall">{L_SEARCH_NEW}</a> or <a href="{U_SEARCH_SELF}" class="gensmall">{L_SEARCH_SELF}</a>
<!-- END switch_user_logged_in -->
<td align="left" valign="bottom" class="gensmall"><a href="{U_SEARCH_UNANSWERED}" class="gensmall">{L_SEARCH_UNANSWERED}</a></td>
<!-- End add - Search back MOD -->
<tr>
</tr>
</table>

<!-- Start add - Search back MOD -->
</form>
<!-- End add - Search back MOD -->
<table class="forumborder" width="100%" cellspacing="0" cellpadding="0" border="0" align="center">
<tr>
<td colspan="2" class="title2" style="border-top:0px;" width="100%">
Latest News </td>
<tr>
</tr>
<tr>
<td class="colour1" align="left"><marquee scrollamount=2 onMouseover="this.scrollAmount=0" onMouseout="this.scrollAmount=2" BEHAVIOR=>{SITE_WELCOME}</marquee></td>
</tr>
</table>
<br />
<!-- Top Topics on Index 1.1.0 - Begin Code Addition -->
<table width="100%" cellpadding="2" cellspacing="1" border="0" class="forumline">
<tr>
<th width="25%" class="thTop" nowrap="nowrap">&nbsp;{L_TOPICSRECENT}&nbsp;</th>
<th width="38%" colspan="2" class="thTop" nowrap="nowrap">&nbsp;{L_TOPICSPOPULAR}&nbsp;</th>
<th width="37%" colspan="2" class="thTop" nowrap="nowrap">&nbsp;{L_TOPICSPOPULARVIEW}&nbsp;</th>
</tr>
<!-- BEGIN topicrecentpopular -->
<tr>
<td width="29%" class="row2" align="left" valign="middle"><span class="gensmall">{topicrecentpopular.TOPICSRECENT}</span></td>
<td width="31%" class="row2" align="left" valign="middle"><span class="gensmall">{topicrecentpopular.TOPICSPOPULAR}</span></td>
<td width="6%" class="row2" align="center" valign="middle"><span class="gensmall">{topicrecentpopular.TOPICSPOPULARC}</span></td>
<td width="29%" class="row2" align="left" valign="middle"><span class="gensmall">{topicrecentpopular.TOPICSPOPULARVIEW}</span></td>
<td width="6%" class="row2" align="center" valign="middle"><span class="gensmall">{topicrecentpopular.TOPICSPOPULARVIEWC}</span></td>
</tr>
<!-- END topicrecentpopular -->
</table>
<!-- Top Topics on Index 1.1.0 - End Code Addition -->
<!-- BEGIN catrow -->
<table width="100%" cellpadding="2" cellspacing="1" border="0" class="forumline">
<tr>
<th colspan="2" class="thCornerL" height="25" nowrap="nowrap">&nbsp;{L_FORUM}&nbsp;</th>
<th width="50" class="thTop" nowrap="nowrap">&nbsp;{L_TOPICS}&nbsp;</th>
<th width="50" class="thTop" nowrap="nowrap">&nbsp;{L_POSTS}&nbsp;</th>
<th class="thCornerR" nowrap="nowrap">&nbsp;{L_LASTPOST}&nbsp;</th>
</tr>
<tr>
<td class="catLeft" colspan="2" height="28"><span class="cattitle"><a href="{catrow.U_VIEWCAT}" class="cattitle">{catrow.CAT_DESC}</a></span></td>
<td class="rowpic" colspan="3" align="right">&nbsp;</td>
</tr>
<!-- BEGIN forumrow -->
<!-- IF ! forumrow.PARENT -->
<tr>
<td class="row1" align="center" valign="middle" height="50"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" width="46" height="25" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>
<td class="row1" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
</span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
</span><!-- IF catrow.forumrow.MODERATORS --><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /></span><!-- ENDIF -->
<!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->
<!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->
</td>
<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_TOPICS}</span></td>
<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_POSTS}</span></td>
<td class="row2" align="center" valign="middle" height="50" nowrap="nowrap"> <span class="gensmall">{catrow.forumrow.LAST_POST}</span></td>
</tr>
<!-- ENDIF -->
<!-- END forumrow -->
</table>
<br />
<!-- END catrow -->

</table>

<table width="100%" cellspacing="0" border="0" align="center" cellpadding="2">
<tr>
<td align="left"><span class="gensmall"><a href="{U_MARK_READ}" class="gensmall">{L_MARK_FORUMS_READ}</a></span></td>
<td align="right"><span class="gensmall">{S_TIMEZONE}</span></td>
</tr>
</table>
<table width="100%" cellpadding="3" cellspacing="1" border="0" class="forumline">
<tr>
<td class="catHead" colspan="2" height="28"><span class="cattitle"><a href="{U_VIEWONLINE}" class="cattitle">{L_WHO_IS_ONLINE}</a></span></td>
</tr>
<tr>
<td class="row1" align="center" valign="middle" rowspan="2"><img src="templates/Chronicles/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
<td class="row1" align="left" width="100%"><span class="gensmall">{TOTAL_POSTS}<br />{TOTAL_USERS}<br />{NEWEST_USER}</span>
</td>
</tr>
<tr>
<!-- <td class="row1" align="left"><span class="gensmall">{TOTAL_USERS_ONLINE} &nbsp; [ {L_WHOSONLINE_ADMIN} ] &nbsp; [ {L_WHOSONLINE_MOD} ]<br />{RECORD_USERS}<br />{LOGGED_IN_USER_LIST}</span></td> -->
<td class="row1" align="left"><span class="gensmall">{TOTAL_USERS_ONLINE} <!--[ {L_WHOSONLINE_ADMIN} ] [ {L_WHOSONLINE_MOD} ] -->
<!-- BEGIN colors -->
{colors.GROUPS}
<!-- END colors -->
<br />{RECORD_USERS}<br />{LOGGED_IN_USER_LIST}</span></td>
</tr>
<!-- <tr>
<td class="catHead" colspan="2" height="28"><span class="gensmall">{L_LW_LAST_DONORS}</span></span></td>
</tr>
<tr>
<td class="row1" colspan="2" align="left" width="100%"><span class="gensmall">{LW_LAST_DONORS}</span></td>
</tr>
</table> -->
<br>

<table width="100%" cellpadding="1" cellspacing="1" border="0">
<tr>
<td align="left" valign="top"><span class="gensmall">{L_ONLINE_EXPLAIN}</span></td>
</tr>
</table>
<!-- Begin: Top Posters on Index -->
<table width="100%" cellpadding="3" cellspacing="1" border="0" class="forumline">
<tr>
<td class="catHead" align ="left" colspan="2" nowrap="nowrap"><span class="genmed"><b>{L_TOP_POSTERS}</b></td>
</tr>
<tr>
<td class="row1" align="left" valign="middle" width="100%"><span class="genmed">{TOP_POSTERS}</span></td>
</tr>
</table>
<!-- End: Top Posters on Index -->
<br clear="all" />

<table cellspacing="3" border="0" align="center" cellpadding="0">
<tr>
<td width="20" align="center"><img src="templates/Chronicles/images/folder_new_big.gif" alt="{L_NEW_POSTS}"/></td>
<td><span class="gensmall">{L_NEW_POSTS}</span></td>
<td>&nbsp;&nbsp;</td>
<td width="20" align="center"><img src="templates/Chronicles/images/folder_big.gif" alt="{L_NO_NEW_POSTS}" /></td>
<td><span class="gensmall">{L_NO_NEW_POSTS}</span></td>
<td>&nbsp;&nbsp;</td>
<td width="20" align="center"><img src="templates/Chronicles/images/folder_locked_big.gif" alt="{L_FORUM_LOCKED}" /></td>
<td><span class="gensmall">{L_FORUM_LOCKED}</span></td>
</tr>
</table>

2bjenn
Registered User
Posts: 6
Joined: Tue Jan 03, 2006 5:52 pm

Post by 2bjenn » Mon Jan 16, 2006 5:24 am

Sorry if someone posted a fix for this, but I've got this error:
Parse error: parse error, unexpected '.', expecting ')' in /home/blairj1/public_html/rockforum/admin/admin_forums.php on line 412


The line doesn't appear to be anything that was touched with this mod, but the problem wasn't there before the install. The whole admin nav was replaced with that error message.

Here's that bit of code

Code: Select all

			
             $template->assign_vars(array(
		
'S_FORUM_ACTION' => append_sid("admin_forums.$phpEx"),
'S_HIDDEN_FIELDS' => $s_hidden_fields,
'S_SUBMIT_VALUE' => $buttonvalue, 
'S_CAT_LIST' => $catlist,
'S_STATUS_LIST' => $statuslist,
'S_PRUNE_ENABLED' => $prune_enabled,
In particular it's...

Code: Select all

'S_CAT_LIST' => $catlist,
...that's complaining.

Thanks in advance.

Myaj
Registered User
Posts: 54
Joined: Sun Dec 11, 2005 2:41 am

Post by Myaj » Mon Jan 16, 2006 7:22 am

Okay, I'm back :oops: . This time I'll be sure to copy/paste the code from the correct line.

Recap - trying to apply simple subforums to Aphrodite Green template. Works perfectly in subSilver, but in the green template subforums show up both as subforums and as a main forum, so they show up twice, see here:
Image

This is the only line that is not clear to me what to edit manually (I used easyMod, only errors were for the green template, most of which were obvious to edit).

Mod instructions say:

#-----[ OPEN ]------------------------------------------
#
templates/subSilver/modcp_split.tpl


#
#-----[ FIND ]------------------------------------------
#
<a href="{U_INDEX}" class="nav">{L_INDEX}</a><span class="nav">


#
#-----[ AFTER, ADD ]------------------------------------------
#
<!-- IF PARENT_FORUM --> -> <a class="nav" href="{U_VIEW_PARENT_FORUM}">{PARENT_FORUM_NAME}</a> <!-- ENDIF -->

But my file is different.. where do I add the code? This is what my file has:

<div class="forumline nav-div">
<p class="nav-header">
<a href="{U_INDEX}">{L_INDEX}</a> &raquo; <a href="{U_VIEW_FORUM}" class="nav-current">{FORUM_NAME}</a>
</p>
<div class="nav-links">
<div class="nav-links-left">
{CURRENT_TIME}
</div>
&nbsp;



Have pity on me, this is my first attempt at a phpBB board!
:oops: :roll: Or let me know if you think I'm looking at the completely wrong line/file/error to solve my issue. TIA!

Szeronic
Registered User
Posts: 95
Joined: Mon Nov 14, 2005 11:40 pm

Post by Szeronic » Mon Jan 16, 2006 12:52 pm

I think I have made a mistake or something when I tried to install this mod. Cause now I got this on subSilver:
"Forum name" Index: (under here I got:)
STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}

And when I click on the forums I get this error:

Code: Select all

Could not query subforums information

DEBUG MODE

SQL Error : 1054 Unknown column 'f.forum_parent' in 'where clause'

SELECT f.*, p.post_time, p.post_username, u.username, u.user_id FROM (( forums f LEFT JOIN posts p ON p.post_id = f.forum_last_post_id ) LEFT JOIN users u ON u.user_id = p.poster_id ) WHERE f.forum_parent = '1' ORDER BY f.cat_id, f.forum_order

Line : 785
File : viewforum.php
What's wrong with what I have done?

Marill
Registered User
Posts: 113
Joined: Sun Oct 26, 2003 10:59 pm
Location: In a padded cell
Contact:

Post by Marill » Mon Jan 16, 2006 2:01 pm

this mod was incredibly useful, a lot of thanks to the author :D

`checho`
Registered User
Posts: 63
Joined: Fri Nov 12, 2004 7:08 pm
Contact:

Post by `checho` » Mon Jan 16, 2006 3:10 pm

Myaj wrote: Okay, I'm back :oops: . This time I'll be sure to copy/paste the code from the correct line.

Recap - trying to apply simple subforums to Aphrodite Green template. Works perfectly in subSilver, but in the green template subforums show up both as subforums and as a main forum, so they show up twice, see here:


Myaj: Correct mod instructions for the Aphrodite style are posted on the following URL: http://www.phpbbstyles.com/viewtopic.php?t=11050
I will paste them here for convenince.

The two included images for the style can be found on the site above.

Hope it works,

Good luck!

Code: Select all

##############################################################  
## MOD Title: Simple Subforums MOD (Aphrodite Changes)  
## MOD Author: kvfb97 < info@kvfb97.co.uk > (Robert Dougan) http://www.kvfb97.co.uk  
## MOD Description: Aphrodite style changes for the simple subforums mod by pentapenguin  
## MOD Version: 1.0.0  
##  
## Installation Level: Easy  
## Installation Time: 10 Minutes  
##  
## Files To Edit: 7  
## templates/ca_aphrodite/index_body.tpl  
## templates/ca_aphrodite/modcp_body.tpl  
## templates/ca_aphrodite/modcp_split.tpl  
## templates/ca_aphrodite/posting_body.tpl  
## templates/ca_aphrodite/ca_aphrodite.cfg  
## templates/ca_aphrodite/viewforum_body.tpl  
## templates/ca_aphrodite/viewtopic_body.tpl  
##  
## Included Files: 2  
## templates/ca_aphrodite/images/folders.gif  
## templates/ca_aphrodite/images/folders_new.gif  
##  
## License: http://opensource.org/licenses/gpl-license.php GNU General Public License v2  
##############################################################  
## For security purposes, please check: http://www.phpbb.com/mods/  
## for the latest version of this MOD. Although MODs are checked  
## before being allowed in the MODs Database there is no guarantee  
## that there are no security problems within the MOD. No support  
## will be given for MODs not found within the MODs Database which  
## can be found at http://www.phpbb.com/mods/  
##############################################################  
## Author Notes:  
## This is only CA's Aphrodite style changes for this MOD. To get the MOD goto http://www.pentapenguin.com  
##############################################################  
## Before Adding This MOD To Your Forum, You Should Back Up All Files Related To This MOD  
##############################################################  
 
#  
#-----[ OPEN ]------------------------------------------  
#  
templates/ca_aphrodite/index_body.tpl  
 
#  
#-----[ FIND ]------------------------------------------  
#  
<!-- BEGIN forumrow -->  
 
#  
#-----[ AFTER, ADD ]------------------------------------------  
#  
<!-- IF ! forumrow.PARENT -->  
 
#  
#-----[ FIND ]------------------------------------------  
#  
<tr>  
   <td class="row3 row-center" width="30"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" width="25" height="25" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>  
   <td class="row1h{catrow.forumrow.XS_NEW} row-forum" width="70%" onclick="window.location.href='{catrow.forumrow.U_VIEWFORUM}'"><a class="forumlink{catrow.forumrow.XS_NEW}" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />  
     <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />  
     </span><span class="moderators">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span></td>  
   <td class="row2 row-center-small">{catrow.forumrow.TOPICS}</td>  
   <td class="row2 row-center-small">{catrow.forumrow.POSTS}</td>  
   <td class="row3 row-center-small" width="130">{catrow.forumrow.LAST_POST}</td>  
</tr>  
 
#  
#-----[ REPLACE WITH ]------------------------------------------  
#  
<tr>    
   <td class="row3 row-center" width="30"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" width="25" height="25" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>    
   <td class="row1h{catrow.forumrow.XS_NEW} row-forum" width="70%" onclick="window.location.href='{catrow.forumrow.U_VIEWFORUM}'"><a class="forumlink{catrow.forumrow.XS_NEW}" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />    
     <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />  
<!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->    
     <!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->  
       </span><span class="moderators"> <!-- IF catrow.forumrow.MODERATORS -->{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /><!-- ENDIF --> </span></td>    
   <td class="row2 row-center-small">{catrow.forumrow.TOTAL_TOPICS}</td>    
   <td class="row2 row-center-small">{catrow.forumrow.TOTAL_POSTS}</td>    
   <td class="row3 row-center-small" width="130">{catrow.forumrow.LAST_POST}</td>    
</tr>    
 
#  
#-----[ FIND ]------------------------------------------  
#  
<!-- END forumrow -->  
 
#  
#-----[ BEFORE, ADD ]------------------------------------------  
#  
<!-- ENDIF -->  
 
#  
#-----[ OPEN ]------------------------------------------  
#  
templates/ca_aphrodite/modcp_body.tpl  
 
 
#  
#-----[ FIND ]------------------------------------------  
#  
<a href="{U_INDEX}">{L_INDEX}</a>  
 
#  
#-----[ IN-LINE FIND ]------------------------------------------  
#  
</a>  
 
#  
#-----[ IN-LINE AFTER, ADD ]------------------------------------------  
#  
<!-- IF PARENT_FORUM -->&raquo; <a href="{U_VIEW_PARENT_FORUM}">{PARENT_FORUM_NAME}</a><!-- ENDIF -->  
 
#  
#-----[ OPEN ]------------------------------------------  
#  
templates/ca_aphrodite/modcp_split.tpl  
 
 
#  
#-----[ FIND ]------------------------------------------  
#  
<a href="{U_INDEX}">{L_INDEX}</a>  
 
#  
#-----[ AFTER, ADD ]------------------------------------------  
#  
<!-- IF PARENT_FORUM -->&raquo; <a href="{U_VIEW_PARENT_FORUM}">{PARENT_FORUM_NAME}</a><!-- ENDIF -->  
 
#  
#-----[ OPEN ]------------------------------------------  
#  
templates/ca_aphrodite/posting_body.tpl  
 
 
#  
#-----[ FIND ]------------------------------------------  
#  
<a href="{U_VIEW_FORUM}">{FORUM_NAME}</a>  
 
#  
#-----[ AFTER, ADD ]------------------------------------------  
#  
<!-- IF PARENT_FORUM -->&raquo; <a href="{U_VIEW_PARENT_FORUM}">{PARENT_FORUM_NAME}</a><!-- ENDIF -->  
 
#  
#-----[ OPEN ]------------------------------------------  
#  
templates/ca_aphrodite/ca_aphrodite.cfg  
 
 
#  
#-----[ FIND ]------------------------------------------  
#  
?>  
 
#  
#-----[ BEFORE, ADD ]------------------------------------------  
#  
 
// Begin Simple Subforums MOD  
$images['forums'] = "$current_template_images/folders.gif";  
$images['forums_new'] = "$current_template_images/folders_new.gif";  
// End Simple Subforums MOD  
 
#  
#-----[ OPEN ]------------------------------------------  
#  
templates/ca_aphrodite/viewforum_body.tpl  
 
 
#  
#-----[ FIND ]------------------------------------------  
#  
<a href="{U_INDEX}">{L_INDEX}</a>  
 
#  
#-----[ IN-LINE FIND ]------------------------------------------  
#  
</a>  
 
#  
#-----[ IN-LINE AFTER, ADD ]------------------------------------------  
#  
<!-- IF PARENT_FORUM -->&raquo; <a href="{U_VIEW_PARENT_FORUM}">{PARENT_FORUM_NAME}</a><!-- ENDIF -->  
 
 
#  
#-----[ FIND ]------------------------------------------  
#  
<tr>  
   <td align="left" valign="middle"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" alt="{L_POST_NEW_TOPIC}" /></a></td>  
</tr>  
</table>  
 
#  
#-----[ AFTER, ADD ]------------------------------------------  
#  
 
<!-- BEGIN catrow -->  
<table width="100%" cellspacing="0" class="forumline">  
<tr>  
   <td colspan="5" class="row-header"><span>{FORUM_NAME}</span></td>  
</tr>  
<tr>  
   <th colspan="2">{catrow.CAT_DESC}</th>  
   <th>{L_TOPICS}</th>  
   <th>{L_POSTS}</th>  
   <th>{L_LASTPOST}</th>  
</tr>  
<!-- BEGIN forumrow -->  
<tr>  
   <td class="row3 row-center" width="30"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" width="25" height="25" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>  
   <td class="row1h{catrow.forumrow.XS_NEW} row-forum" width="70%" onclick="window.location.href='{catrow.forumrow.U_VIEWFORUM}'"><a class="forumlink{catrow.forumrow.XS_NEW}" href="{catrow.forumrow.U_VIEWFORUM}">{catrow.forumrow.FORUM_NAME}</a><br />  
     <span class="genmed">{catrow.forumrow.FORUM_DESC}  
     </span><br /><span class="moderators">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span></td>  
   <td class="row2 row-center-small">{catrow.forumrow.TOPICS}</td>  
   <td class="row2 row-center-small">{catrow.forumrow.POSTS}</td>  
   <td class="row3 row-center-small" width="130">{catrow.forumrow.LAST_POST}</td>  
</tr>  
<!-- END forumrow -->  
</table>  
<!-- END catrow -->  
 
#  
#-----[ OPEN ]------------------------------------------  
#  
templates/ca_aphrodite/viewtopic_body.tpl  
 
 
#  
#-----[ FIND ]------------------------------------------  
#  
<a href="{U_INDEX}" class="nav">{L_INDEX}</a>  
 
 
#  
#-----[ IN-LINE FIND ]------------------------------------------  
#  
</a>  
 
 
#  
#-----[ IN-LINE AFTER, ADD ]------------------------------------------  
#  
<!-- IF PARENT_FORUM --> -> <a class="nav" href="{U_VIEW_PARENT_FORUM}">{PARENT_FORUM_NAME}</a><!-- ENDIF -->  
 
 
#  
#-----[ FIND ]------------------------------------------  
#  
<a href="{U_INDEX}">{L_INDEX}</a>  
 
 
#  
#-----[ IN-LINE FIND ]------------------------------------------  
#  
</a>  
 
 
#  
#-----[ IN-LINE AFTER, ADD ]------------------------------------------  
#  
<!-- IF PARENT_FORUM --> -> <a class="nav" href="{U_VIEW_PARENT_FORUM}">{PARENT_FORUM_NAME}</a><!-- ENDIF -->  
 
#  
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------  
#  
# EoM 

`checho`
Registered User
Posts: 63
Joined: Fri Nov 12, 2004 7:08 pm
Contact:

Post by `checho` » Mon Jan 16, 2006 3:21 pm

:) Sorry for the double post but I have a completely different question not related to the problem I hope to have helped with above.

I have created some forums that I intend to be 'mothers' of another I create inside them. For example, imagine that I have a forum called 'Hardware' and inside I create several forums called Mainboard, CPU's etc. So, the forum I named 'Hardware' will just be something like an 'entrance' to the other forums I have created and placed in it.

In this way, the index page does always show 0 posts for that forum 'Hardware' because I have disabled creating topics in it. I want to mod it in such a way that the index shows the count of topics/messages on the particular forum plus the count of topics/messages that are in the forums placed inside it.

Is it possible? Otherwise the forums I have created only to be 'mothers' of another forums will constantly show 0 topics and posts inside and people will not be attracted because they will think there's no activity. :cry:

Thank you!

c.barber
Registered User
Posts: 15
Joined: Sun Feb 20, 2005 11:00 am

Post by c.barber » Mon Jan 16, 2006 5:54 pm

any answers from my question??

JCoster
Registered User
Posts: 7
Joined: Mon Nov 28, 2005 9:24 pm

Post by JCoster » Mon Jan 16, 2006 8:35 pm

JCoster wrote: Hmm...

I installed this mod with the BlueTabs template and I can create subforums etc. alright.

However, I can't link to them from their parent forum- only from the forum index. How can I link to them from their parent forum? E.g. I have a subforum known as 'Caption Competition' in 'Tea Break.' I want it to link to teh 'Caption Competition' subforum from the 'Tea Break' board.


Hey guys.

Any answer to this original problem for me..?

Myaj
Registered User
Posts: 54
Joined: Sun Dec 11, 2005 2:41 am

Post by Myaj » Tue Jan 17, 2006 10:09 am

Checho, thank you so much, that got it working! I really appreciate the help :).

User avatar
Handsomedude
Registered User
Posts: 12
Joined: Sat Jan 14, 2006 1:18 am
Location: Grand Prairie, TX
Contact:

Post by Handsomedude » Tue Jan 17, 2006 4:57 pm

Hello,

I just download this MOD and I try to install it. It say require Extreme MOD to install it. I did have Extreme MOD installed.

Can someone help me to install this sub-forum MOD? Where I should upload this sub forum folder to able use Extreme MOD to install.

Thanks

`checho`
Registered User
Posts: 63
Joined: Fri Nov 12, 2004 7:08 pm
Contact:

Post by `checho` » Tue Jan 17, 2006 7:21 pm

Handsomedude wrote: Hello,

I just download this MOD and I try to install it. It say require Extreme MOD to install it. I did have Extreme MOD installed.

Can someone help me to install this sub-forum MOD? Where I should upload this sub forum folder to able use Extreme MOD to install.

Thanks


You install this mod as every other mod should be installed on the board. Generally the procedure can be done in 2 ways:
1) by getting the files you need from the board and editing them by hand with a simple text editor,
2) by using some automated installation feature / utility, for example the Easymod Installer.

The contents of the zip file you download does not have to be uploaded somewhere as is. You have to open the text file inside and follow the instructions. It is described in it which files you need to edit and in what way.

If you prefer to edit the files by hand, be sure to make a backup of the original so that nothing goes wrong leaving you with lost data. Also be careful to paste the code in the exact place as the instructions say.

Szeronic
Registered User
Posts: 95
Joined: Mon Nov 14, 2005 11:40 pm

Post by Szeronic » Tue Jan 17, 2006 8:35 pm

Szeronic wrote: I think I have made a mistake or something when I tried to install this mod. Cause now I got this on subSilver:
"Forum name" Index: (under here I got:)
STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}STS}

And when I click on the forums I get this error:

Code: Select all

Could not query subforums information

DEBUG MODE

SQL Error : 1054 Unknown column 'f.forum_parent' in 'where clause'

SELECT f.*, p.post_time, p.post_username, u.username, u.user_id FROM (( forums f LEFT JOIN posts p ON p.post_id = f.forum_last_post_id ) LEFT JOIN users u ON u.user_id = p.poster_id ) WHERE f.forum_parent = '1' ORDER BY f.cat_id, f.forum_order

Line : 785
File : viewforum.php
What's wrong with what I have done?


Can someone help me please? Thanks

Capper
Registered User
Posts: 94
Joined: Sat Dec 10, 2005 5:33 am
Contact:

Post by Capper » Wed Jan 18, 2006 5:06 am

I installed this mod, and now every topic that has a subcategory has switched back to the default icon
Can anyone help?

HardwareLogic Forums
http://hardwarelogic.com/forums/

Capper
Registered User
Posts: 94
Joined: Sat Dec 10, 2005 5:33 am
Contact:

Post by Capper » Wed Jan 18, 2006 6:47 am

oops, sorry, double post

Post Reply

Return to “[2.0.x] MOD Database Releases”