Simple Subforums

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
196
61%
Very Good
59
18%
Good
34
11%
Fair
7
2%
Poor
26
8%
 
Total votes: 322

honeysmom
Registered User
Posts: 65
Joined: Sun Jul 09, 2006 12:11 am

Re: Simple Subforums

Post by honeysmom » Sat May 19, 2007 3:36 pm

I was wondering if anyone knew these are the instructions in the overall_header.tpl

Code: Select all

Open: templates/subSilver/overall_header.tpl
Find
Tip: This may be a partial find and not the whole line.

@import url("templates/subSilver/formIE.css");


Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.

/* Begin Simple Subforums MOD */
a.topic-new, a.topic-new:visited { color: {T_BODY_HLINK}; }
a.topic-new:hover, a.topic-new:active { color: {T_BODY_LINK}; }
/* End Simple Subforums MOD */
I'm using a different template and don't have the @import line was wondering if anyone knew off had where I should add the new info

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}">
<head>
<meta http-equiv="Content-Type" content="text/html; charset={S_CONTENT_ENCODING}">
<meta http-equiv="Content-Style-Type" content="text/css">
{META}
{NAV_LINKS}
<title>{SITENAME} :: {PAGE_TITLE}</title>
<link rel="stylesheet" href="templates/GetawayPurple/{T_HEAD_STYLESHEET}" type="text/css">


<script language="javascript" type="text/javascript" src="templates/GetawayPurple/scripts.js"></script>
<script language="javascript" type="text/javascript" src="templates/GetawayPurple/formStyle.js"></script>
<link rel="icon" href="templates/GetawayPurple/images/favicon.ico" />
<!-- BEGIN switch_birthday_popup -->
<script language="Javascript" type="text/javascript">
<!--
	window.open('{U_BIRTHDAYS_POPUP}', '_phpbbbirthday', 'HEIGHT=225,resizable=yes,WIDTH=400');
//-->
</script>
<!-- END switch_birthday_popup -->
<!-- BEGIN switch_enable_pm_popup -->
<script language="Javascript" type="text/javascript">
<!--
	if ( {PRIVATE_MESSAGE_NEW_FLAG} )
	{
	/*	window.open('{U_PRIVATEMSGS_POPUP}', '_phpbbprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400'); */
}

//-->
</script>
<!-- END switch_enable_pm_popup -->
<link rel="stylesheet" href="templates/subSilver/fap.css" type="text/css" />

</head>

<body>
<!-- Start add - Complete banner MOD -->
<!-- Banners -->
<table width="100%" border="0" cellspacing="0" cellpadding="0">
  <tr>
    <td width="100%" colspan="3"><div align="center">{BANNER_0_IMG}</div></td>
  </tr>
  <tr>
    <td width="20%">
	 <table width="100%" border="0" cellspacing="2" cellpadding="2">
		<tr><td><div align="center">{BANNER_1_IMG}</div></td></tr>
		<tr><td><div align="center">{BANNER_2_IMG}</div></td></tr>
	</table>
    </td>
    <td width="60%">
	 <table width="100%" border="0" cellspacing="2" cellpadding="2">
		<tr><td><div align="center">{BANNER_3_IMG}</div></td></tr>
		<tr><td><div align="center">{BANNER_4_IMG}</div></td></tr>
	</table>
    </td>
    <td width="20%">
	 <table width="100%" border="0" cellspacing="2" cellpadding="2">
		<tr><td><div align="center">{BANNER_5_IMG}</div></td></tr>
		<tr><td><div align="center">{BANNER_6_IMG}</div></td></tr>
	</table>
    </td>
  </tr>
</table>
<!-- End Banners -->
<!-- End add - Complete banner MOD -->
<a name="top"></a>


<img id="formStyleTestImage" src="templates/GetawayPurple/images/spacer.gif" />


<table width="100%" height="100%" cellspacing="0" cellpadding="0" border="0" align="center" id="maintable">

<tr>
	<td width="2" class="border-left"><img src="templates/GetawayPurple/images/spacer.gif" width="2" height="200" border="0" alt="" /></td>
	<td valign="top" height="100%" class="mainrow"><table border="0" width="100%" cellspacing="0" cellpadding="0" id="logotable">
	<tr>
		<td align="center" valign="top"><div class="logo-row"><div class="logo-row2"><!-- replace this spacer.gif with ad or logo --><img src="templates/GetawayPurple/images/spacer.gif" width="1" height="0" alt="" /><!-- end of replacement --></div></div></td>
	</tr>
	</table>
<center><map name="FPMap0">
<area href="http://www.diginewsnow.com/" shape="rect" coords="364, 8, 524, 63">
<area href="http://www.diginewsnow.com/forum" shape="rect" coords="364, 71, 526, 121">
<area href="http://www.diginewsnow.com/forum/album.php" shape="rect" coords="364, 127, 531, 187">
<area href="http://www.diginewsnow.com/store" shape="rect" coords="530, 9, 661, 65">
<area href="http://www.diginewsnow.com/forum/chat/flashchat.php" shape="rect" coords="532, 69, 670, 122">
<area href="http://www.diginewsnow.com/forum/calendar.php" shape="rect" coords="535, 129, 694, 183">
<area href="http://www.diginewsnow.com/membership.htm" shape="rect" coords="420, 188, 661, 234">
</map>
<img border="0" src="http://www.diginewsnow.com/images/DNN banner forum.jpg" usemap="#FPMap0" width="735" height="235"></center>

	<table border="0" width="100%" cellspacing="0" cellpadding="0" id="buttonstable">
	<tr>


<a href="http://www.colleenscreations.com><img src="http://colleenscreations.com/images/Home.gif></a></center>
		<td align="center" valign="top" width="100%" id="header-buttons">
			<!-- BEGIN switch_user_logged_out --> 
			<a href="{U_REGISTER}">{L_REGISTER}</a> &#8226; 
			<!-- END switch_user_logged_out --> 
			<!-- BEGIN switch_user_logged_in --> 
			<a href="{U_PROFILE}">{L_PROFILE}</a> &#8226;
                  <a href="./events.php" class="mainmenu">Events</a> &#8226;
			<a href="{U_PRIVATEMSGS}">{L_PRIVATEMSGS}</a> &#8226; 
			<!-- END switch_user_logged_in --> 
			<a href="{U_SEARCH}">{L_SEARCH}</a> &#8226; 
		


<a href="{U_FAQ}">{L_FAQ}</a> &#8226; 

			<a href="{U_MEMBERLIST}">{L_MEMBERLIST}</a> &#8226; 
			
			<a href="{U_LOGIN_LOGOUT}">{L_LOGIN_LOGOUT}</a> 
		</td>
	</tr>
	</table>
<center>
<a href="http://divinedigital.com/boutique/manufacturers.php?manufacturerid=57"><img src="http://www.diginewsnow.com/images/kutnkudlykreations_banner01.gif"></a>
<a href="http://www.butternugsquash.com"><img src="http://www.diginewsnow.com/images/dstad7.gif"></a></center>
<center>
<script src="http://www.clocklink.com/embed.js"></script><script type="text/javascript" language="JavaScript">obj = new Object;obj.clockfile = "0012-red.swf";obj.TimeZone = "EST";obj.width = 100;obj.height = 100;obj.wmode = "transparent";showClock(obj);</script>
<script src="http://www.clocklink.com/embed.js"></script><script type="text/javascript" language="JavaScript">obj = new Object;obj.clockfile = "0012-red.swf";obj.TimeZone = "CST";obj.width = 100;obj.height = 100;obj.wmode = "transparent";showClock(obj);</script>
<script src="http://www.clocklink.com/embed.js"></script><script type="text/javascript" language="JavaScript">obj = new Object;obj.clockfile = "0012-red.swf";obj.TimeZone = "MST";obj.width = 100;obj.height = 100;obj.wmode = "transparent";showClock(obj);</script>
<script src="http://www.clocklink.com/embed.js"></script><script type="text/javascript" language="JavaScript">obj = new Object;obj.clockfile = "0012-red.swf";obj.TimeZone = "PST";obj.width = 100;obj.height = 100;obj.wmode = "transparent";showClock(obj);</script>
<script src="http://www.clocklink.com/embed.js"></script><script type="text/javascript" language="JavaScript">obj = new Object;obj.clockfile = "0012-red.swf";obj.TimeZone = "AWST";obj.width = 100;obj.height = 100;obj.wmode = "transparent";showClock(obj);</script>
<script src="http://www.clocklink.com/embed.js"></script><script type="text/javascript" language="JavaScript">obj = new Object;obj.clockfile = "0012-red.swf";obj.TimeZone = "WET";obj.width = 100;obj.height = 100;obj.wmode = "transparent";showClock(obj);</script>
</center>
<center>EST&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp CST&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp MST&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp PST&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp AWST&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp&nbsp WET</center>




	<table border="0" width="100%" cellspacing="0" cellpadding="0" id="content">
	<tr>
		<td class="content" valign="top">

	<!-- BEGIN switch_user_logged_in -->
	<center><div class="pm-{PRIVMSG_IMG}"><a href="{U_PRIVATEMSGS}">{PRIVATE_MESSAGE_INFO}</a></div></center>
	<!-- END switch_user_logged_in -->
{CALENDAR_BOX}

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51888
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Simple Subforums

Post by Brf » Sat May 19, 2007 9:43 pm

honeysmom wrote: where I should add the new info
Nowhere in overall_header.tpl. Yours does not have a stylesheet to add those lines to. You should just add the lines to your .css stylesheet.

honeysmom
Registered User
Posts: 65
Joined: Sun Jul 09, 2006 12:11 am

Re: Simple Subforums

Post by honeysmom » Sun May 20, 2007 1:10 am

Thanks

Any idea what the lines would read and where I would add them LOL

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51888
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Simple Subforums

Post by Brf » Sun May 20, 2007 3:26 am

Yeah. Put them in your templates/GetawayPurple/GetawayPurple.css at the very end.

honeysmom
Registered User
Posts: 65
Joined: Sun Jul 09, 2006 12:11 am

Re: Simple Subforums

Post by honeysmom » Sun May 20, 2007 7:07 pm

So I put this

Code: Select all

/* Begin Simple Subforums MOD */
a.topic-new, a.topic-new:visited { color: {T_BODY_HLINK}; }
a.topic-new:hover, a.topic-new:active { color: {T_BODY_LINK}; }
/* End Simple Subforums MOD */
Just like this at the end of my css file right?

DParadise
Registered User
Posts: 4
Joined: Sat May 12, 2007 2:15 am

Re: Simple Subforums

Post by DParadise » Sun May 20, 2007 8:26 pm

No, just perform the search you had to do in the overall_header.tlp in the xxx.css file. The search you had to do (@import...) is mentioned in there.

lancxeon
Registered User
Posts: 126
Joined: Thu Jul 20, 2006 2:51 am

Re: Simple Subforums

Post by lancxeon » Mon May 21, 2007 5:44 pm

So i installed this, I really like it. But here is the issue.

Why does it show the sub-forums still on the forum index? I want those hidden on the forum index.. know what i mean?


EDIT: Nevermind, i figured it out. :)

honeysmom
Registered User
Posts: 65
Joined: Sun Jul 09, 2006 12:11 am

Re: Simple Subforums

Post by honeysmom » Mon May 21, 2007 8:04 pm

I'm trying to verify that this code

Code: Select all

/* Begin Simple Subforums MOD */
a.topic-new, a.topic-new:visited { color: {T_BODY_HLINK}; }
a.topic-new:hover, a.topic-new:active { color: {T_BODY_LINK}; }
/* End Simple Subforums MOD */
Is the code I put in my css file after I do a search for @import.

I was not sure if this format was ok for a css file.

Thanks

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51888
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Simple Subforums

Post by Brf » Mon May 21, 2007 8:10 pm

Yes. That is the correct format.

No wait... You need to take out those {template-tag} thingees and replace them with the values that go in there from your ACP styles management screen. (Hover link color and link color)

illusorythrall
Registered User
Posts: 42
Joined: Fri Apr 20, 2007 4:43 am

Re: Simple Subforums

Post by illusorythrall » Mon May 21, 2007 10:28 pm

Discovered an issue with the "posts" and "topics" numbers on my index.php file if someone is logged out.

Basically, they show up as negative numbers.. which shouldn't be happening.. there can't be a negative amount of posts in a forum.

My guess is that the issue is in index.php somewhere, but I'm not sure where to look.

The numbers show up correctly when people are logged in.

apalsson
Registered User
Posts: 11
Joined: Mon May 21, 2007 10:30 pm

Re: Simple Subforums

Post by apalsson » Mon May 21, 2007 10:37 pm

Excellent Mod!

I installed it with EasyMod and didn't spot any errors.
I then went ahead to create some "sub forums" and noticed that I could pick any existing forum as the "parent" as opposed to before when I could only use categories.

Nevertheless, the new subforums appear on level with the "parents" but not as sub-forums of them.
Am I doing someting wrong?

ntisco
Registered User
Posts: 13
Joined: Tue Apr 24, 2007 7:31 pm

Re: Simple Subforums

Post by ntisco » Tue May 22, 2007 9:11 pm

Does it suport greek??
I have some mods will it be ok??
Is it easy to install??
Thanks

ntisco
Registered User
Posts: 13
Joined: Tue Apr 24, 2007 7:31 pm

Re: Simple Subforums

Post by ntisco » Wed May 23, 2007 6:24 pm

Anyone????
I have the php 2.0.22..its ok??

corona2k
Registered User
Posts: 2
Joined: Thu May 03, 2007 4:37 am

Re: Simple Subforums

Post by corona2k » Thu May 24, 2007 12:17 pm

Hi
I just tested this on a phpBB 2.0.22 on my local machine.
Everything is working fine except the sub forums aren't showing as sub forums in the forum index page.
They are showing as normal forums under the main forums.
But in Administration it says that they ARE sub forums under the main forums.
Here's a screeny to explain.

Image

DParadise
Registered User
Posts: 4
Joined: Sat May 12, 2007 2:15 am

Re: Simple Subforums

Post by DParadise » Thu May 24, 2007 12:46 pm

corona2k wrote:Hi
I just tested this on a phpBB 2.0.22 on my local machine.
Everything is working fine except the sub forums aren't showing as sub forums in the forum index page.
They are showing as normal forums under the main forums.
But in Administration it says that they ARE sub forums under the main forums.
Here's a screeny to explain.

Image
Same problem here. Anyone who knows how to solve it?

Post Reply

Return to “[2.0.x] MOD Database Releases”