Simple Subforums

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
196
61%
Very Good
59
18%
Good
34
11%
Fair
7
2%
Poor
26
8%
 
Total votes: 322

AuReUs ReCtoR
Registered User
Posts: 184
Joined: Tue Jan 18, 2005 10:02 pm
Location: Serbia\Belgrade\Vozdovac
Contact:

Post by AuReUs ReCtoR »


babydoll2u
Registered User
Posts: 214
Joined: Sun Sep 18, 2005 11:26 pm
Contact:

Post by babydoll2u »

I've just installed this mod on my 3rd forum and it works great... haven't had a single problem.

KUDOS to the author!! :D
Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience

babydoll2u
Registered User
Posts: 214
Joined: Sun Sep 18, 2005 11:26 pm
Contact:

Post by babydoll2u »

DS9PeaceKeeper wrote: Ok, sorted it out, but no options for sub menus, the forum management is the same, pulling my hair out here, can someone please tell me what I'm doing wrong?

I used easy mod again to install and it just kept coming up with things it couldnt find, sorted them out, and no results.


there are sweetie... I just installed this to my 3rd forum. Figuring out how to create the subforums can be a bit tricky, but it really is easy once you've created your first one.

Do this:

Log in to your ACP
Go to Forum Admin/Management
Type in the name that you want your new Sub Forum to be named
Click on Create New Forum
~ when you click on create new forum, it will take you to the General Forums Setting as usual.
~ You'll see the drop down menu beside Category/Forum. Click on that and scroll to find the forum that you want the sub-forum to go into.
~ Click on the forum name then click create new forum.

and Waa Laa... there is your sub-forum. :D
Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience

DS9PeaceKeeper
Registered User
Posts: 15
Joined: Thu Jul 14, 2005 1:50 pm

Post by DS9PeaceKeeper »

I know how to create the forums, its the sub boards I want to create, inside other boards - thats what I thought the mod did :(

User avatar
fpscops.com
Registered User
Posts: 23
Joined: Wed Sep 21, 2005 2:25 am

Post by fpscops.com »

~ You'll see the drop down menu beside Category/Forum. Click on that and scroll to find the forum that you want the sub-forum to go into.


If installed properly thats the part your over looking.


yea it does, here's a demo board ive been working on. Notice the sub-forums under Call of Duty 2.

http://12.202.188.145/phpBB2/index.php

>agb<
Registered User
Posts: 50
Joined: Wed Aug 10, 2005 5:19 am

Post by >agb< »

DS9PeaceKeeper wrote: I know how to create the forums, its the sub boards I want to create, inside other boards - thats what I thought the mod did :(


If this is the way you want to set up your board ( a subforum on the subforum) :

Category
-Forum A
--Subforum A.1
---Subsubforum A.1.a
---Subsubforum A.1.b
-Forum B
--Subforum B.1

then you have to use Categories Hierarchy for multi-level.


Simple Subforum is just one level deep:

Category
-Forum A
--Subforum A.1
--Subforum A.2
-Forum B
--Subforum B.1

babydoll2u
Registered User
Posts: 214
Joined: Sun Sep 18, 2005 11:26 pm
Contact:

Post by babydoll2u »

DS9PeaceKeeper wrote: I know how to create the forums, its the sub boards I want to create, inside other boards - thats what I thought the mod did :(

DS.. that IS what this mod is for, and if you follow my instructions, you'll have your subforum INSIDE your forum. However you can't create sub-forums inside sub-foums... if that's what you're wanting to do, you need the category hierarchy MOD as the person above me stated. .

DO you see that drop-down menu next to Category / Forum? If not, then the mod's not installed properly :wink:

Here's the board I'm putting together: http://pyphotos.net/forum
Last edited by babydoll2u on Thu Nov 24, 2005 1:09 am, edited 4 times in total.
Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience

babydoll2u
Registered User
Posts: 214
Joined: Sun Sep 18, 2005 11:26 pm
Contact:

Post by babydoll2u »

fpscops.com wrote:
~ You'll see the drop down menu beside Category/Forum. Click on that and scroll to find the forum that you want the sub-forum to go into.


If installed properly thats the part your over looking.


yea it does, here's a demo board ive been working on. Notice the sub-forums under Call of Duty 2.

http://12.202.188.145/phpBB2/index.php


exactly!


nice board btw
Last edited by babydoll2u on Thu Nov 24, 2005 1:19 am, edited 1 time in total.
Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience

>agb<
Registered User
Posts: 50
Joined: Wed Aug 10, 2005 5:19 am

Post by >agb< »



Please double check your edits in index_body.tpl :wink:

Jaddon
Registered User
Posts: 20
Joined: Sun Oct 09, 2005 11:52 am
Location: USA
Contact:

Post by Jaddon »

DS9PeaceKeeper wrote: Ok, sorted it out, but no options for sub menus, the forum management is the same, pulling my hair out here, can someone please tell me what I'm doing wrong?

I used easy mod again to install and it just kept coming up with things it couldnt find, sorted them out, and no results.


I have the same problem after installing this mod - I see no difference and still do not have sub forums. :(

Peter77sx
Registered User
Posts: 3259
Joined: Wed Nov 09, 2005 2:51 pm

Post by Peter77sx »

I have a question about sub forums in general. I am using this mod and all works good and all. but is having too many subforums ask for too many quarys? does it technicaly slow our board down?

AuReUs ReCtoR
Registered User
Posts: 184
Joined: Tue Jan 18, 2005 10:02 pm
Location: Serbia\Belgrade\Vozdovac
Contact:

Post by AuReUs ReCtoR »

>agb< wrote:


Please double check your edits in index_body.tpl :wink:


hmmm, i dont` get it, look my index_body.tpl where start subforums mod:
<!-- BEGIN forumrow --><!-- IF ! forumrow.PARENT -->
<tr>
<td height="50" align="center" valign="middle" bgcolor="E4EAF2" class="row5"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" width="33" height="28" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>
<td class="row1" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
</span> <!-- IF catrow.forumrow.MODERATORS --><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /></span><!-- ENDIF -->
<!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->
<!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->
</td>
<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_TOPICS}</span></td>
<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_POSTS}</span></td>

<td height="50" align="center" valign="middle" nowrap="nowrap" bgcolor="DFE6EF" class="row4">
<span class="gensmall">{catrow.forumrow.LAST_POST}</span></td>
</tr>
<!-- ENDIF --><!-- END forumrow -->




where to add what?! :?

User avatar
fpscops.com
Registered User
Posts: 23
Joined: Wed Sep 21, 2005 2:25 am

Post by fpscops.com »

You look all good there.

You sure your adding the description in the admin panel? :lol: [/Mr.Obvisous]

My suggestion is to make sure you have made your file edits correctly. Start with any that have to do with admin panel.

User avatar
The Suite
Registered User
Posts: 617
Joined: Sat Jul 30, 2005 11:11 am
Location: NYC, USA
Contact:

Post by The Suite »

Awesome MOD Pentapenguin, thanks a mil for this.

PentaPenguin, which MOD did you install to get this section that's on your board - Top Posting Members.

Anyone running this on .18?
Does it work without any issues?

Please advise, I really need this :-)
Much appreciloved,

The Suite
Thank you :-)
The IT Security Information Center

babydoll2u
Registered User
Posts: 214
Joined: Sun Sep 18, 2005 11:26 pm
Contact:

Post by babydoll2u »

The Suite wrote: Awesome MOD Pentapenguin, thanks a mil for this.

PentaPenguin, which MOD did you install to get this section that's on your board - Top Posting Members.

Anyone running this on .18?
Does it work without any issues?

Please advise, I really need this :-)


I'm running this MOD on .18 on 2 of my 3 forums... no problem with install and works great.... you can see my 3rd forum here:

http://pyphotos.net/forum

This is what the board looks like after creating several subforums
Last edited by babydoll2u on Thu Nov 24, 2005 5:06 am, edited 1 time in total.
Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience

Post Reply

Return to “[2.0.x] MOD Database Releases”