Birthdays

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
151
66%
Very Good
39
17%
Good
21
9%
Fair
5
2%
Poor
12
5%
 
Total votes: 228

d3rutat
Registered User
Posts: 107
Joined: Thu Oct 27, 2005 7:34 pm
Contact:

Post by d3rutat » Fri Nov 25, 2005 6:26 pm

I confirm it is ok... i used the second code... Hey, BTW, it would be cool if you could add a field: Birthdays in the following xxx days ?? :P

d3rutat
Registered User
Posts: 107
Joined: Thu Oct 27, 2005 7:34 pm
Contact:

Post by d3rutat » Fri Nov 25, 2005 6:31 pm

oh yeah, and a popup for happy birthday ;)

TerraFrost
Former Team Member
Posts: 5957
Joined: Sun Dec 26, 2004 3:40 am
Location: Austin, TX

Post by TerraFrost » Fri Nov 25, 2005 6:54 pm

v1.0.1 - which is due out shortly - is just going to contain the gmmkdate bug fix, a french translation, and a few add-on mods by 3Di. I'm planning on adding more features in v1.0.2 :)

Also, thanks for the confirmation, d3rutat! :)

EDIT: Here's the fix that seems to work the best:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
includes/usercp_viewprofile.php
#
#-----[ FIND ]------------------------------------------
#
	$birthday = create_date($birthday_format, mktime(0,0,0,$bday_month,$bday_day), $board_config['board_timezone']);
#
#-----[ REPLACE WITH ]------------------------------------
#
	$birthday = create_date($birthday_format, gmmktime(0,0,0,$bday_month,$bday_day), $board_config['board_timezone']);

User avatar
DaMnY
Registered User
Posts: 51
Joined: Sun Jan 26, 2003 10:09 am
Location: The Netherlands
Contact:

Post by DaMnY » Fri Nov 25, 2005 11:42 pm

Hmmm, there's another thing.
If I select a avatar in my Gallery then my Birthday resets.
Know Thyself

User avatar
3Di
Former Team Member
Posts: 14456
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Post by 3Di » Sat Nov 26, 2005 12:02 am

DaMnY wrote: Hmmm, there's another thing.
If I select a avatar in my Gallery then my Birthday resets.


I confirm, it resets on the edit profile screen but view profile, anyway the Author still have access to my FTP so can fix also this stuff.

edit: also the avatr selected doesn't displays on viewprofile.. but maybe this bit it's due to my default IP Country Avatar? dunno.. yet.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
✒️ Black Friday 2019 @ The Studio ▪️◾️

TerraFrost
Former Team Member
Posts: 5957
Joined: Sun Dec 26, 2004 3:40 am
Location: Austin, TX

Post by TerraFrost » Sat Nov 26, 2005 3:15 am

The fix for the avatar thing is as follows:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
includes/usercp_register.php
#
#-----[ FIND ]------------------------------------------
# this is a partial match
#
	display_avatar_gallery($mode,
#
#-----[ IN-LINE FIND ]----------------------------------
#
$user_lang,
#
#-----[ IN-LINE AFTER, ADD ]----------------------------
#
 $bday_month, $bday_day, $bday_year,
#
#-----[ OPEN ]------------------------------------------
#
includes/usercp_avatar.php
#
#-----[ FIND ]------------------------------------------
# this is only a partial match
#
function display_avatar_gallery($mode
#
#-----[ IN-LINE FIND ]----------------------------------
#
&$language,
#
#-----[ IN-LINE AFTER, ADD ]----------------------------
#
 &$bday_month, &$bday_day, &$bday_year,
#
#-----[ FIND ]------------------------------------------
# this is only a partial match
#
$params = array(
#
#-----[ IN-LINE FIND ]----------------------------------
#
'language',
#
#-----[ IN-LINE AFTER, ADD ]----------------------------
#
 'bday_month', 'bday_day', 'bday_year',
Also,
edit: also the avatr selected doesn't displays on viewprofile.. but maybe this bit it's due to my default IP Country Avatar? dunno.. yet.

Seems to work fine for me on your board. Unless I'm misunderstanding the problem?

edit: added a comma to the above code.
Last edited by TerraFrost on Sun Nov 27, 2005 9:41 am, edited 1 time in total.

User avatar
DaMnY
Registered User
Posts: 51
Joined: Sun Jan 26, 2003 10:09 am
Location: The Netherlands
Contact:

Post by DaMnY » Sat Nov 26, 2005 9:26 am

Thnx for the fix, everything works great now! :D
Know Thyself

User avatar
beggers
Registered User
Posts: 1257
Joined: Fri Nov 23, 2001 8:19 pm
Location: Las Vegas
Contact:

Post by beggers » Sat Nov 26, 2005 9:44 am

Is there a link to version 1.01? Thanks.

Scorpiuscat1
Registered User
Posts: 103
Joined: Mon Jul 18, 2005 1:55 am

Post by Scorpiuscat1 » Sat Nov 26, 2005 4:58 pm

I still have the wrong date being displayed problem.

I have tried the fixes posted here, but to no effect.

Ideas?
Visit Sci-Fi Website

Now featuring Over 500 Free Games!!!

TerraFrost
Former Team Member
Posts: 5957
Joined: Sun Dec 26, 2004 3:40 am
Location: Austin, TX

Post by TerraFrost » Sat Nov 26, 2005 7:33 pm

Is there a link to version 1.01? Thanks.

It's not finalized, yet, but here's what I have, thus far:

http://www.frostjedi.com/terra/scripts/ ... thdays.zip
I still have the wrong date being displayed problem.

I have tried the fixes posted here, but to no effect.

Ideas?

I've posted three possible fixes. Do none of the three work? If so, I really am quite clueless. Perhaps try this?:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
includes/usercp_viewprofile.php
#
#-----[ FIND ]------------------------------------------
#
   $birthday = create_date($birthday_format, mktime(0,0,0,$bday_month,$bday_day), $board_config['board_timezone']);
#
#-----[ REPLACE WITH ]------------------------------------
#
   $birthday = create_date($birthday_format, gmmktime(0,0,0,$bday_month,$bday_day), 0);
Incidently, if I had FTP access, I could find out whether or not my proposed fixes worked instantly, instead of waiting two days.

Scorpiuscat1
Registered User
Posts: 103
Joined: Mon Jul 18, 2005 1:55 am

Post by Scorpiuscat1 » Sun Nov 27, 2005 5:51 am

Looks like everything is good to go now, thanks!!!
Visit Sci-Fi Website

Now featuring Over 500 Free Games!!!

Sknydpr
Registered User
Posts: 3
Joined: Wed Nov 30, 2005 3:34 am

Post by Sknydpr » Wed Nov 30, 2005 3:41 am

TerraFrost wrote:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
includes/usercp_viewprofile.php
#
#-----[ FIND ]------------------------------------------
#
   $birthday = create_date($birthday_format, mktime(0,0,0,$bday_month,$bday_day), $board_config['board_timezone']);
#
#-----[ REPLACE WITH ]------------------------------------
#
   $birthday = create_date($birthday_format, gmmktime(0,0,0,$bday_month,$bday_day), 0);


That one worked for me. Thanks.

TerraFrost
Former Team Member
Posts: 5957
Joined: Sun Dec 26, 2004 3:40 am
Location: Austin, TX

Post by TerraFrost » Thu Dec 01, 2005 3:33 am

Thanks for letting me know! :)

The latest version (with the two modifications that have been presented above) can be found here:

www.frostjedi.com/terra/scripts/phpbb/birthdays.zip

bas_dodger
Registered User
Posts: 14
Joined: Mon Nov 21, 2005 8:37 pm

Post by bas_dodger » Thu Dec 01, 2005 5:44 pm

I tried to install this mod but i get the following error:

An error was encountered while processing the SQL commands. Further SQL processing has been halted. You may choose to complete the MOD installation anyway and perform the SQL commands manually yourself. However, at this point EM cannot guarantee the MOD will work correctly so you are best off seeking support from the Author before continuing further.

The failed line was:
ALTER TABLE phpbb_users ADD user_birthday int(8) NULL DEFAULT '0'

SQL ERROR: 1060
Duplicate column name 'user_birthday'

TerraFrost
Former Team Member
Posts: 5957
Joined: Sun Dec 26, 2004 3:40 am
Location: Austin, TX

Post by TerraFrost » Thu Dec 01, 2005 9:44 pm

My guess would be that you've either run the query, before (in which case, you can just install the MOD, normally) or that you already have Neils Birthday MOD installed.

Post Reply

Return to “[2.0.x] MOD Database Releases”