[2.0.19] XFire Messenger

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
13
59%
Very Good
6
27%
Good
2
9%
Fair
0
No votes
Poor
1
5%
 
Total votes: 22

Mondego
Registered User
Posts: 129
Joined: Sun Jan 23, 2005 1:24 am
Location: 127.0.0.1
Contact:

Post by Mondego »

thanks taragon!

the file to edit would be viewtopic_body.tpl. there was probably a [space] that somehow didn't copy over.

make sure it looks like this:

Code: Select all

{postrow.YIM_IMG} {postrow.MSN_IMG} {postrow.XFI_IMG}{postrow.XFI_IMG_ADD}
note the space between the braces.

let me know if this fixes the problem

-mondego
Taragon
Registered User
Posts: 3
Joined: Mon Aug 28, 2006 2:07 am
Location: Werkendam, The Netherlands
Contact:

Post by Taragon »

Thanks for the fast and helpfull reply!
That did the trick for me :D
Mondego
Registered User
Posts: 129
Joined: Sun Jan 23, 2005 1:24 am
Location: 127.0.0.1
Contact:

Post by Mondego »

good news! :D

-mondego.
User avatar
gatetravellers
Registered User
Posts: 39
Joined: Sun Apr 09, 2006 10:35 pm
Location: South Australia
Contact:

Post by gatetravellers »

ok just wondering this isnt what i was looking for i was just hoping to have a image just like msn but it says xfire when you click it it links you to that users profile and just like msn it has the msn pic then a : and then their infomation thats what i wanted for this
Mondego
Registered User
Posts: 129
Joined: Sun Jan 23, 2005 1:24 am
Location: 127.0.0.1
Contact:

Post by Mondego »

gatetravellers wrote: ok just wondering this isnt what i was looking for i was just hoping to have a image just like msn but it says xfire when you click it it links you to that users profile and just like msn it has the msn pic then a : and then their infomation thats what i wanted for this


hi gatetravellers,

this does do that. when you click the link below their sig, it takes you to their profile on xfire.
diggy5
Registered User
Posts: 11
Joined: Mon Jun 12, 2006 5:37 am
Location: Texas
Contact:

Post by diggy5 »

Ok, Ive got the files edited, but one problem, I dont know how to edit SQL files. so this command

Code: Select all

#
#-----[ SQL ]------------------------------------------
#

ALTER TABLE phpbb_users ADD user_xfi VARCHAR(255);
I dont know where to find the file to edit. Any help is greatly apperciated!
Mondego
Registered User
Posts: 129
Joined: Sun Jan 23, 2005 1:24 am
Location: 127.0.0.1
Contact:

Post by Mondego »

diggy5 wrote: Ok, Ive got the files edited, but one problem, I dont know how to edit SQL files. so this command

Code: Select all

#
#-----[ SQL ]------------------------------------------
#

ALTER TABLE phpbb_users ADD user_xfi VARCHAR(255);
I dont know where to find the file to edit. Any help is greatly apperciated!


hi diggy. you would have to run this query at your SQL prompt. if your host is remote, they might have installed something like PhpMyAdmin that will allow you to run this script. if your hosting the site yourself, you can login via command line if you dont have any db administration program installed.

hope this helps

-mondego
diggy5
Registered User
Posts: 11
Joined: Mon Jun 12, 2006 5:37 am
Location: Texas
Contact:

Post by diggy5 »

Thanks a bunch!
hunting_sniper
Registered User
Posts: 3
Joined: Wed Oct 11, 2006 3:25 pm

getting this error

Post by hunting_sniper »

hi all could anyone tel me why im getting this error using easymod?

Critical Error

FIND FAILED: In file [includes/functions_validate.php] could not find:

function validate_optional_fields(&$icq, &$aim, &$msnm, &$yim, &$website, &$location, &$occupation, &$interests, &$sig)
Mondego
Registered User
Posts: 129
Joined: Sun Jan 23, 2005 1:24 am
Location: 127.0.0.1
Contact:

Re: getting this error

Post by Mondego »

hunting_sniper wrote: hi all could anyone tel me why im getting this error using easymod?

Critical Error

FIND FAILED: In file [includes/functions_validate.php] could not find:

function validate_optional_fields(&$icq, &$aim, &$msnm, &$yim, &$website, &$location, &$occupation, &$interests, &$sig)


this is probably due to you installing other mods, and easymod is finding your row different than what's in my install guide. you can try shortening the row in the guide, or moving the prior modifications further out on the row.
SokudaBlade
Registered User
Posts: 12
Joined: Sat May 20, 2006 9:02 pm

Post by SokudaBlade »

Will this work even if i change different themes in my forum? I currently have it set for AcidTechex, but users can choose different themes from their profile, wondering if i need to edit the files in each themes folder?
Mondego
Registered User
Posts: 129
Joined: Sun Jan 23, 2005 1:24 am
Location: 127.0.0.1
Contact:

Post by Mondego »

SokudaBlade wrote: Will this work even if i change different themes in my forum? I currently have it set for AcidTechex, but users can choose different themes from their profile, wondering if i need to edit the files in each themes folder?


you will need to edit each template as well. depending on the template, might require a different change for each one.
SokudaBlade
Registered User
Posts: 12
Joined: Sat May 20, 2006 9:02 pm

Post by SokudaBlade »

thanks for the help :-)
SokudaBlade
Registered User
Posts: 12
Joined: Sat May 20, 2006 9:02 pm

Post by SokudaBlade »

Ok, started to work on the mod and this is the first thing to do,

#-----[ OPEN ]------------------------------------------
#
groupcp.php

#
#-----[ FIND ]------------------------------------------
#
function generate_user_info(&$row, $date_format, $group_mod, &$from, &$posts, &$joined,

#
#-----[ IN-LINE FIND ]------------------------------------------
#
&$msn_img, &$msn,

#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#
&$xfi_add_img, &$xfi_img, &$xfi,

i open my file, copy n pasted it into notepad so i can edit it and find the codes faster.. but those lines i need to find arent in there.. do i need a certain version of php or am i just completely missing it?
Mondego
Registered User
Posts: 129
Joined: Sun Jan 23, 2005 1:24 am
Location: 127.0.0.1
Contact:

Post by Mondego »

SokudaBlade wrote: Ok, started to work on the mod and this is the first thing to do,

#-----[ OPEN ]------------------------------------------
#
groupcp.php

#
#-----[ FIND ]------------------------------------------
#
function generate_user_info(&$row, $date_format, $group_mod, &$from, &$posts, &$joined,

#
#-----[ IN-LINE FIND ]------------------------------------------
#
&$msn_img, &$msn,

#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#
&$xfi_add_img, &$xfi_img, &$xfi,

i open my file, copy n pasted it into notepad so i can edit it and find the codes faster.. but those lines i need to find arent in there.. do i need a certain version of php or am i just completely missing it?


those should be on line 30 or so in groupcp.php. i even checked the latest version of phpBB2 and it's still on line 30. you may not have opened the right file, your board is heavily modified, or you may not have the real phpBB2.
Post Reply

Return to “[2.0.x] MOD Database Releases”