[01/12/06] Spam Words

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
52
76%
Very Good
9
13%
Good
4
6%
Fair
0
No votes
Poor
3
4%
 
Total votes: 68

uniterre
Registered User
Posts: 29
Joined: Mon May 29, 2006 1:28 pm
Contact:

Post by uniterre » Mon Oct 02, 2006 6:21 am

Thanks a lot for this mod. It helps me a lot to escape from the spammers. BUT !! Sometimes, they succeed in posting some posts with spam words !
When I try myself to post, it says that the word is forbidden
Code:
http://fre.4.kg/ra/non.html badword

No idea, I'm afraid.... the only thing I could think of when someone posted something similar was that somehow the bots managed to post html entities that were auto converted.


Does anyone have an idea about how we can solve the problem of auto converted html entities that don't match any of the patterns we're looking for ?

I put a lot of mods in my forum, but I keep on to receive a lot of spams !!!
Because of the purpose of my forum, I decided to let users post as guests. Maybe, it's a bad idea.

Thanks,
Alexandre[/quote]

Joe Belmaati
Registered User
Posts: 2110
Joined: Sun Sep 28, 2003 7:35 pm
Location: Denmark

Post by Joe Belmaati » Mon Oct 02, 2006 7:59 am

helmut wrote: I'd even would like to download the update before evaluation is accomplished
There is no way I'm going to post links to unreleased versions. That will make a complete mockery of this thread with support questions to unreleased versions, released versions and mass-confusion to boot. The MOD validation process seems failry slow at the moment, so I would estimate that we're looking at 2 - 4 weeks before we know, with the risk that the MOD is denied ..(!)
Image

uniterre
Registered User
Posts: 29
Joined: Mon May 29, 2006 1:28 pm
Contact:

Post by uniterre » Mon Oct 02, 2006 8:27 pm

Today, I got more than 100 spams with words listed in the spam words list ! Arggg.

Is it difficult to create or modify this mod in order to check that every post contains a specific word ?

As my forums are in french, I would like to ask everyone who wants to post something, to write a french word, for example "Bonjour".

What do you think about that idea ?

helmut
Registered User
Posts: 35
Joined: Mon Nov 10, 2003 9:18 pm
Location: Germany
Contact:

Post by helmut » Tue Oct 03, 2006 8:21 am

Joe Belmaati wrote:
helmut wrote:I'd even would like to download the update before evaluation is accomplished
There is no way I'm going to post links to unreleased versions. That will make a complete mockery of this thread with support questions to unreleased versions, released versions and mass-confusion to boot. The MOD validation process seems failry slow at the moment, so I would estimate that we're looking at 2 - 4 weeks before we know, with the risk that the MOD is denied ..(!)

I understand well and it's good that you try to avoid a big mess. I keep my finger crossed that your mod passes validation.

Still I wonder which changes will be in the update. Is there a changelog available? Will there be a maximum number of links (as suggested in one of the previous posts)? Will the Spam word mod check the message text and the subject?

windowsceportal
Registered User
Posts: 10
Joined: Thu Mar 17, 2005 7:00 pm
Location: Hungary
Contact:

Spam Words 1.0.2 failure

Post by windowsceportal » Wed Oct 04, 2006 3:06 pm

I've installed Spam Words 1.0.2 into my phpBB 2.0.18. It doesn't work properly. After that, I checked the installation steps (INSTALL.mod) several times, but I performed all of steps as it wrotes. Spam Words menu appeared in admin area. So, installation is OK. :roll:

The forum is working but if i try to post a spam post (for testing porpuse) it doesn't send me any kind of error message and saves the post. The spam words database is not empty and the spam error message is enabled in settings panel. :evil:

Any idea how to solve this problem? Please. I have no idea to solve it.
Windows CE Portál: http://www.windowsceportal.hu

Joe Belmaati
Registered User
Posts: 2110
Joined: Sun Sep 28, 2003 7:35 pm
Location: Denmark

Post by Joe Belmaati » Wed Oct 04, 2006 6:02 pm

Did you set the MOD so that it produces an error message or so that it flags posts?

In a nushell, the MOD works as advertized if installed and operated correctly. I am not sure why your installation does not work as intended.
Image

saaiberke
Registered User
Posts: 1126
Joined: Wed Jul 20, 2005 8:13 am
Location: Gent/Belgium
Contact:

Re: Spam Words 1.0.2 failure

Post by saaiberke » Wed Oct 04, 2006 6:38 pm

windowsceportal wrote: I've installed Spam Words 1.0.2 into my phpBB 2.0.18. It doesn't work properly. After that, I checked the installation steps (INSTALL.mod) several times, but I performed all of steps as it wrotes. Spam Words menu appeared in admin area. So, installation is OK. :roll:

The forum is working but if i try to post a spam post (for testing porpuse) it doesn't send me any kind of error message and saves the post. The spam words database is not empty and the spam error message is enabled in settings panel. :evil:

Any idea how to solve this problem? Please. I have no idea to solve it.


Do you have other mods installed? And which ones?

Grtz,

Nic

Nothing is easy
Registered User
Posts: 173
Joined: Sun Apr 02, 2006 1:10 am

Post by Nothing is easy » Sat Oct 07, 2006 10:16 am

I have been using this mod for a while now (am using phpBB 2.0.21) and can't thank the author enough for developing it and for his continued support.

I have a couple of questions/request though:

1) I have banned all biz sites but I also want to ban all .info/ sites. It appears that internally certain special characters are treated as end of word identifiers and .info/ in the word list is not picked up. For obvious reasons I don't want to put the word info into the spam words list. Is the Word Censor executed before this mod? If so I can modify .info/ into a string that would be recognized by Spam Words. Note: I have not installed the [url= fix yet but am about to.

2) I have the max spam offences before a ban set at 5 and monitor every log entry. Occasionally a registered user posts something that is caught as spam when it was not really spam and stupidly ignores the error message and continues to repost to try and get around the spam filter and gets his IP address banned. Ok no problem removing the IP address from the banned list but their spam offence count is not reduced so the very next offence gets them banned again. Is there a way for me to reduce their offence count when I decide that a post was not spam after all? Obviously wish this could be menu driven.

3) This one is a nice to have. It would be real nice for the Spam log to also identify what the Forum and Topic it was that the person tried to post into.

4) Finally this is a cheeky request but as I have the utmost respect for the author of this mod and many others who post here (bows several times) can someone check to see if there is a basic clash between this mod and the Prevent Guest Posters from posting links mod (Found via this link). I only have the Spam Words mod installed and just installed the Guest Poster one and it doesn't seem to work. Both were installed using Easymod so I'm a bit at a loss. As the Guest poster one seems very simple at first sight I thought it would be easier for someone with knowledge of the Spam Words mod to check that rather than the other way around.



p.s. If ever an enhancement was made that allowed my spam list to be just in English but checked against translations of all major languages then I could really relax and enjoy my own forum :lol:

windowsceportal
Registered User
Posts: 10
Joined: Thu Mar 17, 2005 7:00 pm
Location: Hungary
Contact:

Post by windowsceportal » Sun Oct 08, 2006 11:17 am

Joe Belmaati wrote: Did you set the MOD so that it produces an error message or so that it flags posts?

In a nushell, the MOD works as advertized if installed and operated correctly. I am not sure why your installation does not work as intended.


MOD is activated in admin area (Disable Spam words filter - No; How should posts that contain spam words be dealt with? - Error message), some spam words are defined. MOD produces nor error message neither flag when I try to post a spam post.

Check out my settings page:
Image
Windows CE Portál: http://www.windowsceportal.hu

windowsceportal
Registered User
Posts: 10
Joined: Thu Mar 17, 2005 7:00 pm
Location: Hungary
Contact:

Re: Spam Words 1.0.2 failure

Post by windowsceportal » Sun Oct 08, 2006 11:21 am

saaiberke wrote: Do you have other mods installed? And which ones?

Grtz,

Nic


No other MODs installed, but forum language is hungarian. Because of this, I copied "lang_spamwords_admin.php" into lang_hungarian folder.

phpBB version: 2.0.18
Windows CE Portál: http://www.windowsceportal.hu

GalaKev
Registered User
Posts: 26
Joined: Thu Jan 05, 2006 4:43 pm
Contact:

Post by GalaKev » Sun Oct 08, 2006 6:16 pm

What a wonderful Mod, it does what it says on the package. This does get the big thumbs up from myself

I have ran into one problem, while testing it on my test board.

I logged in as a normal user and posted a dodgy word. It blocked the post as should have and flagged it up as dodgy for Admin to deal with.

The ACP page for Spam does have a title for PM's sent but its not showing up for this message. Therefore the user can't see it and click to see what what has been written. All other normal PM's do have titles.

It might become more clearer if you look at this.

http://www.berwickforums.co.uk/kevppersonal/pm.JPG

A bit confussed on what I have done wrong. I did try to use easymod for this but it failed, I had to do this manually. Any ideas?

But as I said apart from this 1 problem its a superb Mod.

Joe Belmaati
Registered User
Posts: 2110
Joined: Sun Sep 28, 2003 7:35 pm
Location: Denmark

Post by Joe Belmaati » Mon Oct 09, 2006 5:22 am

Nothing is easy,
you raise some good points. I will try to get around to them soon.

GalaKev,
sounds like the database update was only partly done... do you have any way to check and confirm that the entire SQL package was run successfully?
Image

GalaKev
Registered User
Posts: 26
Joined: Thu Jan 05, 2006 4:43 pm
Contact:

Post by GalaKev » Mon Oct 09, 2006 4:17 pm

="GalaKev,
sounds like the database update was only partly done... do you have any way to check and confirm that the entire SQL package was run successfully?


Its working now. For some reason I had put a ", at the end of the of the PM title. It did not like this.

Weird, but it was not any problem in installation at all.

Thanks for your help.

Kev

Joe Belmaati
Registered User
Posts: 2110
Joined: Sun Sep 28, 2003 7:35 pm
Location: Denmark

Post by Joe Belmaati » Tue Oct 10, 2006 1:03 pm

GalaKev wrote:
="GalaKev,
sounds like the database update was only partly done... do you have any way to check and confirm that the entire SQL package was run successfully?


Its working now. For some reason I had put a ", at the end of the of the PM title. It did not like this.

Weird, but it was not any problem in installation at all.

Thanks for your help.

Kev
OK, I will try to compensate for that in an update so that a quotation mark will not cause any problems.
Image

Nothing is easy
Registered User
Posts: 173
Joined: Sun Apr 02, 2006 1:10 am

Post by Nothing is easy » Tue Oct 10, 2006 7:22 pm

Joe Belmaati wrote: Nothing is easy,
you raise some good points. I will try to get around to them soon.

GalaKev,
sounds like the database update was only partly done... do you have any way to check and confirm that the entire SQL package was run successfully?


Thanks Joe.

More nice to haves to add to the list are to make the username in the spam log a clickable link to either their profile or to the pm function when it is a registered user. Also if you do add the Forum name to the log make that a clickable link if possible.

btw I thought that I should add that the period being an end of word recognition is great because within a URL like say www.aaaaa.wxyz.bbbbbb.cccccc it is not necessary to code *wxyz* just wxyz can be used in the word list. Sometimes *string* can cause occasional unwanted problems.

Having Word Censor execute before Spam words is important I think. It allows changes to be applied that would overcome special character end of word recognition. For instance numerous spammers use Thank You! but thank you without the exclamation mark is a regular normal user phrase. Word Censor for exmple can be used to turn Thank You! into Thank xyoux so xyoux in the spam list will stop the post.

I don't suppose you or anyone else had a chance to see if that Prevent Guest Posting Links mod clashes did you? (link provided in previous post) Still can't get the damn thing to work.

Post Reply

Return to “[2.0.x] MOD Database Releases”