[2.0.19] Users viewing forum on Index

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
14
64%
Very Good
3
14%
Good
4
18%
Fair
1
5%
Poor
0
No votes
 
Total votes: 22

User avatar
Ricky_Racer
Registered User
Posts: 609
Joined: Wed Feb 12, 2003 10:02 pm

Re: [2.0.19] Users viewing forum on Index

Post by Ricky_Racer » Tue Oct 02, 2007 2:43 am

Replace

Code: Select all

$row_color = ( !($i % 2) ) ? $theme['td_color1'] : $theme['td_color2'];
                     $row_class = ( !($i % 2) ) ? 
                     $users_viewing = $forum_view_count[$forum_data[$j]['forum_id']];
                      $theme['td_class1'] : $theme['td_class2'];

                     $template->assign_block_vars('catrow.forumrow',   array(
                        'ROW_COLOR' => '#' . $row_color,
                        'ROW_CLASS' => $row_class,
with

Code: Select all

		$row_color = ( !($i % 2) ) ? $theme['td_color1'] : $theme['td_color2'];
		$row_class = ( !($i % 2) ) ? $theme['td_class1'] : $theme['td_class2'];
		$users_viewing = $forum_view_count[$forum_data[$j]['forum_id']];
		$template->assign_block_vars('catrow.forumrow', array(
			'ROW_COLOR' => '#' . $row_color,
			'ROW_CLASS' => $row_class,
What has happened is the $users_viewing = $forum_view_count[$forum_data[$j]['forum_id']]; line broke the $row_class = ( !($i % 2) ) ? $theme['td_class1'] : $theme['td_class2']; line.

User avatar
will_hough
Former Team Member
Posts: 1952
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.19] Users viewing forum on Index

Post by will_hough » Tue Oct 02, 2007 2:44 am

momoftwo wrote:thanks for the link, it was helpful, but it doesnt help with parse errors...
But it does help installing MODs

The install directions are giving you partial lines, your just adding the code in the wrong place.

Your code should look like this:

Code: Select all

							$row_color = ( !($i % 2) ) ? $theme['td_color1'] : $theme['td_color2'];
							$row_class = ( !($i % 2) ) ? $theme['td_class1'] : $theme['td_class2'];
							$users_viewing = $forum_view_count[$forum_data[$j]['forum_id']];

							$template->assign_block_vars('catrow.forumrow',	array(
								'ROW_COLOR' => '#' . $row_color,
								'ROW_CLASS' => $row_class,

momoftwo
Registered User
Posts: 188
Joined: Mon Mar 05, 2007 4:07 pm

Re: [2.0.19] Users viewing forum on Index

Post by momoftwo » Tue Oct 02, 2007 3:06 am

ok great thanks...finally got pass the parse errors!

so now i guess all is well...no more errors...but..um...why isnt it working?? It isnt showing in my page..here take a look.

http://muslimmomscafe.com/copies/phpBB1/

User avatar
will_hough
Former Team Member
Posts: 1952
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.19] Users viewing forum on Index

Post by will_hough » Tue Oct 02, 2007 3:20 am

I can't view your forums as a guest.

momoftwo
Registered User
Posts: 188
Joined: Mon Mar 05, 2007 4:07 pm

Re: [2.0.19] Users viewing forum on Index

Post by momoftwo » Tue Oct 02, 2007 3:23 am

i will pm you an account and password

User avatar
will_hough
Former Team Member
Posts: 1952
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.19] Users viewing forum on Index

Post by will_hough » Tue Oct 02, 2007 3:33 am

I see it just fine -
[edit]Image removed
Last edited by will_hough on Tue Oct 02, 2007 3:41 am, edited 1 time in total.

momoftwo
Registered User
Posts: 188
Joined: Mon Mar 05, 2007 4:07 pm

Re: [2.0.19] Users viewing forum on Index

Post by momoftwo » Tue Oct 02, 2007 3:36 am

But that was there BEFORE the mod. I wanted this to show on the index page next to each forum as pictured in the beginning of this thread.

User avatar
will_hough
Former Team Member
Posts: 1952
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.19] Users viewing forum on Index

Post by will_hough » Tue Oct 02, 2007 3:40 am

momoftwo wrote:But that was there BEFORE the mod. I wanted this to show on the index page next to each forum as pictured in the beginning of this thread.
Whoops, my fault. :oops:

You are still getting errors on the index. Looks like some sort of problem with another MOD.

momoftwo
Registered User
Posts: 188
Joined: Mon Mar 05, 2007 4:07 pm

Re: [2.0.19] Users viewing forum on Index

Post by momoftwo » Tue Oct 02, 2007 3:44 am

Whoops, my fault. :oops:
no problem
You are still getting errors on the index. Looks like some sort of problem with another MOD.
yes..its the statistics mod (the other thing i am worrying about)

So is there anything that can be done with this one to show up on my forum??

User avatar
will_hough
Former Team Member
Posts: 1952
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.19] Users viewing forum on Index

Post by will_hough » Tue Oct 02, 2007 4:01 am

Double check your installation, look over the code. Make sure things look correct.

You will want to post help with the other MOD in it's topic.

momoftwo
Registered User
Posts: 188
Joined: Mon Mar 05, 2007 4:07 pm

Re: [2.0.19] Users viewing forum on Index

Post by momoftwo » Tue Oct 02, 2007 5:25 am

ok you were correct...there was a mistake and now it works.

I know this was mentioned earlier but there was no answer on how it was done, so i need to ask again.

How do i prevent the extra break between the forum name and description & how to i get "viewing" NEXT to the forum name rather then under it.

thanks

User avatar
will_hough
Former Team Member
Posts: 1952
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.19] Users viewing forum on Index

Post by will_hough » Tue Oct 02, 2007 1:46 pm

momoftwo wrote:ok you were correct...there was a mistake and now it works.

I know this was mentioned earlier but there was no answer on how it was done, so i need to ask again.

How do i prevent the extra break between the forum name and description ~
I don't see an extra break between the name and description.
momoftwo wrote:~ & how to i get "viewing" NEXT to the forum name rather then under it.

thanks
Open: index_body.tpl
Find:

Code: Select all

	<td class="row1" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
	  	</span><span class="gensmall">
	    <!-- BEGIN switch_users_viewing -->
	    ({catrow.forumrow.USERS_VIEWING} {L_USERS_VIEWING})
	    <!-- END switch_users_viewing -->
	    </span> <span class="genmed"><br />{catrow.forumrow.FORUM_DESC}<br />
Replace with:

Code: Select all

	<td class="row1" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a></span>&nbsp;
		<span class="gensmall">
	    <!-- BEGIN switch_users_viewing -->
	    ({catrow.forumrow.USERS_VIEWING} {L_USERS_VIEWING})
	    <!-- END switch_users_viewing -->
	    </span><span class="genmed"><br />{catrow.forumrow.FORUM_DESC}<br />

momoftwo
Registered User
Posts: 188
Joined: Mon Mar 05, 2007 4:07 pm

Re: [2.0.19] Users viewing forum on Index

Post by momoftwo » Wed Oct 03, 2007 2:36 am

thanks!! It worked great!!

One last thing i need to ask...........where can i go to change the font color from black to another color?

thanks alot!! :D

User avatar
will_hough
Former Team Member
Posts: 1952
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.19] Users viewing forum on Index

Post by will_hough » Wed Oct 03, 2007 3:04 am

Looks like you are using the css in your overall_header.tpl.

Open: overall_header.tpl
Find:

Code: Select all

/* General text */
.gen,.genmed,.gensmall { color : #000000; }
/* The register, login, search etc links at the top of the page */
.mainmenu		{ font-size : 12px; color : #000000 }
/* Used for the navigation text, (Page 1,2,3 etc) and the navigation bar when in a forum */
.nav			{ font-weight: bold; font-size: 12px; color : #000000;}
/* titles for the topics: could specify viewed link colour too */
.topictitle,h1,h2	{ font-weight: bold; font-size: 12px; color : #000000; }
/* Name of poster in viewmsg.php and viewtopic.php and other places */
.name			{ font-size : 12px; color : #000000;}
/* Location, number of posts, post date etc */
.postdetails		{ font-size : 11px; color : #000000; }
There are a few more places, just look for

Code: Select all

color:#000000;
#000000 is the black hex code (Hexadecimal Color Code).
Here is a simple web color palette with a list of colors and their respective hex code. - http://www.willhough.com/hex_codes.htm

momoftwo
Registered User
Posts: 188
Joined: Mon Mar 05, 2007 4:07 pm

Re: [2.0.19] Users viewing forum on Index

Post by momoftwo » Wed Oct 03, 2007 5:01 am

hmmm...i dont have the hex numbers in my file.

Wouldnt the code i am looking for be in one of the files i edited for the mod since i am changing the color of the writing that the mod displays and nothing else?? :?:

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 23 guests