[2.0.19] Users viewing forum on Index

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
14
64%
Very Good
3
14%
Good
4
18%
Fair
1
5%
Poor
0
No votes
 
Total votes: 22

shrekOT
Registered User
Posts: 10
Joined: Sun Jun 26, 2005 3:41 am

Post by shrekOT » Fri Jan 13, 2006 5:33 am

#
#-----[ FIND ]------------------------------------------
#
'L_ONLINE_EXPLAIN' =>

#
#-----[ AFTER, ADD ]------------------------------------------
#
'L_USERS_VIEWING' => $lang['users_viewing_forum'],

#
#-----[ FIND ]------------------------------------------
#
$row_class = ( !($i % 2) ) ?

#
#-----[ AFTER, ADD ]------------------------------------------
#
$users_viewing = $forum_view_count[$forum_data[$j]['forum_id']];

#
#-----[ FIND ]------------------------------------------
#
'MODERATORS' =>

#
#-----[ AFTER, ADD ]------------------------------------------
#
'USERS_VIEWING' => $users_viewing,


I followed the code in the index.php and got errors . Then I change a little bit.
after 'L_ONLINE_EXPLAIN' => $lang['Online_explain'], instead of 'L_ONLINE_EXPLAIN' =>

after $row_class = ( !($i % 2) ) ? $theme['td_class1'] : $theme['td_class2']; instead of $row_class = ( !($i % 2) ) ?

after 'MODERATORS' => $moderator_list, instead of 'MODERATORS' =>

Then I got no error

Shanana
Registered User
Posts: 368
Joined: Sat Aug 28, 2004 4:03 am
Location: USA [from London, England]

Post by Shanana » Fri Jan 13, 2006 12:13 pm

Oh great. Why was he banned?

SupportMachine
I've Been Banned!
Posts: 17
Joined: Sun Jan 15, 2006 1:53 pm

Post by SupportMachine » Sun Jan 15, 2006 2:13 pm

shrekOT wrote: I followed the code in the index.php and got errors . Then I change a little bit.
after 'L_ONLINE_EXPLAIN' => $lang['Online_explain'], instead of 'L_ONLINE_EXPLAIN' =>

after $row_class = ( !($i % 2) ) ? $theme['td_class1'] : $theme['td_class2']; instead of $row_class = ( !($i % 2) ) ?

after 'MODERATORS' => $moderator_list, instead of 'MODERATORS' =>

Then I got no error


If you check the How to install MODS article you will see that unless shown as 'IN-LINE AFTER, ADD' you put it on the next line instead of the same.

As for the other issue (Line skipped)
-- FIND --

Code: Select all

	</span><span class="gensmall">
	<!-- BEGIN switch_users_viewing -->
	({catrow.forumrow.USERS_VIEWING} {L_USERS_VIEWING})
	<!-- END switch_users_viewing -->
	</span> <span class="genmed"><br />{catrow.forumrow.FORUM_DESC}<br />
-- REPLACE WITH --

Code: Select all

	</span><span class="gensmall">
	<!-- BEGIN switch_users_viewing -->
	({catrow.forumrow.USERS_VIEWING} {L_USERS_VIEWING})
	<!-- END switch_users_viewing -->
	</span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />

SupportMachine
I've Been Banned!
Posts: 17
Joined: Sun Jan 15, 2006 1:53 pm

Post by SupportMachine » Sun Jan 15, 2006 2:22 pm

I have created a modification to keep this mod's statistics live at all times.
http://www.phpbb.com/phpBB/viewtopic.ph ... 61#1953161

The best setting would be '1' or '0' for this mod's use.

NTUserZ
Registered User
Posts: 23
Joined: Fri Jan 06, 2006 6:59 pm

Post by NTUserZ » Mon Jan 16, 2006 6:27 pm

I'm having a little trouble installing this mod, which kind of sucks because this mod is ranked as easy :( Anyway, I know longer can see my index page, and can only access the admin section because I kept that window open before installing the mod. I realize it's kind of hard for anyone to help, but if anyone has any suggestions

SupportMachine
I've Been Banned!
Posts: 17
Joined: Sun Jan 15, 2006 1:53 pm

Post by SupportMachine » Tue Jan 17, 2006 8:41 am

If you are using any version of CH it wont work, thats all i can put it down to other than installation mistakes.

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Wed Jan 18, 2006 9:28 am

SupportMachine, your MOD has a serious flaw that causes a Parse error. In addition, it seems to break this MOD...

:roll:

SupportMachine
I've Been Banned!
Posts: 17
Joined: Sun Jan 15, 2006 1:53 pm

Post by SupportMachine » Wed Jan 18, 2006 10:18 am

NightriderXP wrote: SupportMachine, your MOD has a serious flaw that causes a Parse error. In addition, it seems to break this MOD...

:roll:

Ive tested in a live enviroment and it doesnt break the mod however, thx for the bug report, ill fix asap.

Jaysun
Registered User
Posts: 49
Joined: Wed Sep 22, 2004 8:48 am
Location: UK
Contact:

Post by Jaysun » Wed Jan 18, 2006 10:26 am

I've added this mod to my forum with no errors anywhere and also corrected the 'EXTRA LINE BREAK' that i didnt want - but I'm not getting any little 'VIEWING' messages next to the forum topic (even though there are people in that particular forum.

any ideas?

User avatar
Ricky_Racer
Registered User
Posts: 609
Joined: Wed Feb 12, 2003 10:02 pm

Post by Ricky_Racer » Wed Jan 18, 2006 11:14 am

There are a couple of other threads and posts about this
http://www.phpbb.com/phpBB/viewtopic.ph ... 07#1917707
http://www.phpbb.com/phpBB/viewtopic.ph ... highlight=
Too bad they are locked, I do believe it could be made to work with cat hierarchies,
once you have found where Ptirhiik moved the information that used to be in index.php. :lol:

Jaysun
Registered User
Posts: 49
Joined: Wed Sep 22, 2004 8:48 am
Location: UK
Contact:

Post by Jaysun » Wed Jan 18, 2006 8:49 pm

dont know how (I'm no coder) but I figured out how to solve the problem through trial and error... I'm afraid I dont know what exactly I did to cure it though

SupportMachine
I've Been Banned!
Posts: 17
Joined: Sun Jan 15, 2006 1:53 pm

Post by SupportMachine » Thu Jan 19, 2006 9:13 am

Ricky_Racer wrote: There are a couple of other threads and posts about this
http://www.phpbb.com/phpBB/viewtopic.ph ... 07#1917707
http://www.phpbb.com/phpBB/viewtopic.ph ... highlight=
Too bad they are locked, I do believe it could be made to work with cat hierarchies,
once you have found where Ptirhiik moved the information that used to be in index.php. :lol:

It should be quite easy to port to CH, Any coder expericenced with CH should be able to do it.

User avatar
Ramon Fincken
Registered User
Posts: 4835
Joined: Thu Oct 14, 2004 1:04 am
Location: NL, The Netherlands Amsterdam area @GMT +1
Contact:

Post by Ramon Fincken » Sat Jan 21, 2006 6:37 pm

With permission of the original mod author:
http://www.phpbb.com/phpBB/viewtopic.php?t=360080


Live board:
http://www.hockeyfighters.com/Forum/phpBB2/index.php Installed 1.0.1 / 65495 posts / 33 forums on index
Dev board:
http://www.creativepulses.nl/upload/phpbb/matt/ Installed 1.0.1




Rfn
Last edited by Ramon Fincken on Sat Jan 28, 2006 4:18 pm, edited 1 time in total.
Dutch quality fully managed WordPress hosting - ManagedWPHosting.nl

Before changing a file, some code or installing a MOD >> Make a backup first!

Do you like my mods? paypal me $1 :) forumsoftware[AT}creativepulses[DOT}nl [/size]
PhpBBantispam.com || Instant find your mod here

User avatar
Darezettl
Registered User
Posts: 53
Joined: Thu Jun 30, 2005 4:55 pm

Post by Darezettl » Sun Jan 22, 2006 7:18 pm

is there any way to make it compatible to simple subforums mod by cyberalien?
[...]

User avatar
Ramon Fincken
Registered User
Posts: 4835
Joined: Thu Oct 14, 2004 1:04 am
Location: NL, The Netherlands Amsterdam area @GMT +1
Contact:

Post by Ramon Fincken » Sun Jan 22, 2006 7:23 pm

Darezettl wrote: is there any way to make it compatible to simple subforums mod by cyberalien?


if your viewonline.php works then at least my mod will work for it contains the same coding ...


Rfn
Dutch quality fully managed WordPress hosting - ManagedWPHosting.nl

Before changing a file, some code or installing a MOD >> Make a backup first!

Do you like my mods? paypal me $1 :) forumsoftware[AT}creativepulses[DOT}nl [/size]
PhpBBantispam.com || Instant find your mod here

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 15 guests