SQL Backup

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
42
76%
Very Good
5
9%
Good
2
4%
Fair
1
2%
Poor
5
9%
 
Total votes: 55

Vic D'Elfant
Former Team Member
Posts: 6203
Joined: Sun May 02, 2004 6:21 pm
Location: NL, Maastricht
Contact:

Re: [2.0.20] SQL Backup

Post by Vic D'Elfant » Sat Apr 12, 2008 8:53 am

Have you made any changes to your board? MOD installs, new database version, new template, ...
midd.ag • DTP, web development & printing
http://www.midd.ag

tommmy
Registered User
Posts: 7
Joined: Thu Jul 26, 2007 9:13 pm

Re: [2.0.20] SQL Backup

Post by tommmy » Sat Apr 12, 2008 12:44 pm

yes the sql-database is upgraded to SQL 5.0.41 from SQL4. That could be it?
Here is the 2 lines in admin_backup.php

Code: Select all

	header('Content-type: text/xml');
	header('Cache-Control: no-cache');
If it is sent 2 times.. Cant we just remove this part from admin_backup.php? I thave tried to do that but i still get "phpbb_auth_access 0 1" error.
Any clues?

Vic D'Elfant
Former Team Member
Posts: 6203
Joined: Sun May 02, 2004 6:21 pm
Location: NL, Maastricht
Contact:

Re: [2.0.20] SQL Backup

Post by Vic D'Elfant » Sat Apr 12, 2008 1:06 pm

It sends it twice? Why? It should only be in the code once, and certainly should not be removed because it's there with a purpose. admin/page_header_admin.php shouldn't be included once it gets to the code which exports the XML so that's probably the cause of your problem... have there been any PHP upgrades or configuration changes recently?
midd.ag • DTP, web development & printing
http://www.midd.ag

tommmy
Registered User
Posts: 7
Joined: Thu Jul 26, 2007 9:13 pm

Re: [2.0.20] SQL Backup

Post by tommmy » Sat Apr 12, 2008 1:44 pm

yes i guess the host did the php too. Some mods crashed and some still work fine. This is my favorite and most important mod so i want to get it up again. Yes the error says it is sent twice. :|
I am currently looking over my other mods to find any possible conflicts.

Vic D'Elfant
Former Team Member
Posts: 6203
Joined: Sun May 02, 2004 6:21 pm
Location: NL, Maastricht
Contact:

Re: [2.0.20] SQL Backup

Post by Vic D'Elfant » Sat Apr 12, 2008 1:58 pm

Hrm. Any chance you could PM me a link to a phpinfo file?

Code: Select all

<?php phpinfo(); ?>
midd.ag • DTP, web development & printing
http://www.midd.ag

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25325
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

SQL Backup

Post by Paul » Sun Apr 13, 2008 9:57 am

MOD Updated to version 1.0.12
See first post for Download Link
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

Vic D'Elfant
Former Team Member
Posts: 6203
Joined: Sun May 02, 2004 6:21 pm
Location: NL, Maastricht
Contact:

Re: SQL Backup

Post by Vic D'Elfant » Sun Apr 13, 2008 10:01 am

For the record: tommmy's problem has been fixed in version 1.0.12 :)
midd.ag • DTP, web development & printing
http://www.midd.ag

User avatar
A_O_C
Registered User
Posts: 2383
Joined: Sun Jul 01, 2007 11:26 pm
Location: phpbb_

Re: SQL Backup

Post by A_O_C » Sun Apr 13, 2008 3:20 pm

Vic D'Elfant wrote:For the record: tommmy's problem has been fixed in version 1.0.12 :)
SQL Backup works fine for me on PHP5 and MySQL5. is this only if someone upgrades from PHP4 to PHP5 and MySQL4 to MySQL5?

Vic D'Elfant
Former Team Member
Posts: 6203
Joined: Sun May 02, 2004 6:21 pm
Location: NL, Maastricht
Contact:

Re: SQL Backup

Post by Vic D'Elfant » Sun Apr 13, 2008 3:36 pm

It's for any PHP version with register_long_arrays disabled, tommmy's hosting provider changed this at the same time they upgraded MySQL and PHP.
midd.ag • DTP, web development & printing
http://www.midd.ag

tommmy
Registered User
Posts: 7
Joined: Thu Jul 26, 2007 9:13 pm

Re: SQL Backup

Post by tommmy » Sun Apr 13, 2008 8:11 pm

Thank you again Vic! ;)

bugfixed
Registered User
Posts: 101
Joined: Sun Apr 04, 2004 2:57 am
Location: Turkey
Name: Murat
Contact:

Re: SQL Backup

Post by bugfixed » Tue Apr 15, 2008 9:20 am

Thanks for mod.
How to i can make: my database all tables download with this mod. This mod only works phpbb_ prefix.
Please help me.
Image

Vic D'Elfant
Former Team Member
Posts: 6203
Joined: Sun May 02, 2004 6:21 pm
Location: NL, Maastricht
Contact:

Re: SQL Backup

Post by Vic D'Elfant » Tue Apr 15, 2008 9:31 am

You wouldn't be getting any support from this point on but... ;)

Open admin/admin_backup.php

Find

Code: Select all

if ( $current_prefix == $table_prefix && intval($HTTP_POST_VARS['table__' . $current_table]) == 1 )  
Replace with

Code: Select all

if ( intval($HTTP_POST_VARS['table__' . $current_table]) == 1 )  
Find

Code: Select all

if ( $current_prefix == $table_prefix )
{
    $tables[] = $current_table;
}  
Replace with

Code: Select all

$tables[] = $current_table;  
Note that I haven't tested this, but it should work.
midd.ag • DTP, web development & printing
http://www.midd.ag

bugfixed
Registered User
Posts: 101
Joined: Sun Apr 04, 2004 2:57 am
Location: Turkey
Name: Murat
Contact:

Re: SQL Backup

Post by bugfixed » Tue Apr 15, 2008 11:38 am

Vic D'Elfant thanks for reply. Ok works :)

Download sql file. Open with "pspad" editor. But turkish characters displaying wrong. :(
example:

Code: Select all

Sanal Ã?öplük - herÅ?eyi bırakıp
must be

Code: Select all

Sanal Çöplük - herşeyi bırakıp
Try with open other editors(context, notepad++, notepad) display wrong :roll:
Image

Vic D'Elfant
Former Team Member
Posts: 6203
Joined: Sun May 02, 2004 6:21 pm
Location: NL, Maastricht
Contact:

Re: SQL Backup

Post by Vic D'Elfant » Tue Apr 15, 2008 12:41 pm

That's an encoding issue (and a problem which won't be fixed in the current version), but are you sure that you are downloading the file properly from your server? I've never had anyone else reporting this problem.
midd.ag • DTP, web development & printing
http://www.midd.ag

Coyote23
Registered User
Posts: 78
Joined: Thu Oct 05, 2006 8:55 pm
Location: Omaha, Nebraska

Re: SQL Backup

Post by Coyote23 » Fri May 09, 2008 1:20 am

I installed this Mod quite a while back and has been woking like a charm until ipowerweb moved to a new platform. Now it quits after about 4 M has been backed-up. Any suggestions? Thanks!

Post Reply

Return to “[2.0.x] MOD Database Releases”