[2.0.19] Advanced Group Color Management

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
38
64%
Very Good
10
17%
Good
3
5%
Fair
3
5%
Poor
5
8%
 
Total votes: 59

Cenobitez
Registered User
Posts: 118
Joined: Tue Aug 31, 2004 1:05 pm

Post by Cenobitez » Sun Nov 05, 2006 3:07 am

OK the Anonymous problem people keep posting...

I have installed the Link username to profile mod which included in the viewtopic.php file.

Code: Select all

# 
#-----[ FIND ]------------------------------------------------ 
# 
   'POSTER_NAME' => $poster, 

# 
#-----[ REPLACE WITH ]---------------------------------------- 
# 

   'POSTER_NAME' => ( $postrow[$i]['user_id'] != ANONYMOUS ) ? '<a href="' . append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=" . $poster_id) . '" class="name"' . $poster_color . '>' . $poster . '</a>' : $poster, 
Now the ACM errors out on this code, as it has

Code: Select all

# 
#-----[ FIND ]------------------------------------------------ 
# 
   'POSTER_NAME' => $poster, 

# 
#-----[ REPLACE WITH ]---------------------------------------- 
# 

//-- mod : Advanced Group Color Management --------------------------------------
//-- delete
//	'POSTER_NAME' => $poster,
//-- add

		'POSTER_NAME' => $colors->get_user_color($postrow[$i]['user_group_id'], $postrow[$i]['user_session_time'], $poster),

//-- fin mod : Advanced Group Color Management ---------------------------------
Now i was thinking maybe just replace one/both instances of the $poster var with the ACM code not unlike ?

Code: Select all

'POSTER_NAME' => ( $postrow[$i]['user_id'] != ANONYMOUS ) ? '<a href="' . append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=" . $poster_id) . '" class="name"' . $poster_color . '>' . $colors->get_user_color($postrow[$i]['user_group_id'], $postrow[$i]['user_session_time'], $poster) . '</a>' : $poster, 
Anyone have any idea's ??

doberberto
Registered User
Posts: 4
Joined: Sat Nov 18, 2006 11:41 am

Post by doberberto » Sat Nov 18, 2006 11:46 am

Hello! Thanks for this mod! However I have a big problem with the install. I have CH 1.6 installed on my board. So I have made the requested changes of my files. But After that, when I go on my board, It says that :


Warning: main(./../extension.inc): failed to open stream: No such file or directory in c:\program files\easyphp1-8\www\phpbb2\install\install.php on line 28

Code: Select all

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.;C:/Program Files/EasyPHP1-8\php\pear\') in c:\program files\easyphp1-8\www\phpbb2\install\install.php on line 28

Notice: Undefined variable: phpEx in c:\program files\easyphp1-8\www\phpbb2\install\install.php on line 29

Warning: main(./../common.): failed to open stream: No such file or directory in c:\program files\easyphp1-8\www\phpbb2\install\install.php on line 29

Warning: main(): Failed opening './../common.' for inclusion (include_path='.;C:/Program Files/EasyPHP1-8\php\pear\') in c:\program files\easyphp1-8\www\phpbb2\install\install.php on line 29

Fatal error: Call to undefined function: session_pagestart() in c:\program files\easyphp1-8\www\phpbb2\install\install.php on line 31
I have make all the files of the mod on my FTP...What can I do? Thanks!

PS: Sorry for my bad english, but I am french ^^

doberberto
Registered User
Posts: 4
Joined: Sat Nov 18, 2006 11:41 am

Post by doberberto » Sat Nov 18, 2006 6:08 pm

UP please!

luvz2drv
Registered User
Posts: 47
Joined: Mon Nov 21, 2005 5:31 am

no need to bump your post

Post by luvz2drv » Sat Nov 18, 2006 10:35 pm

please don't bump your post.

doberberto
Registered User
Posts: 4
Joined: Sat Nov 18, 2006 11:41 am

Post by doberberto » Sun Nov 19, 2006 9:45 am

But... I need a solution ;)

luvz2drv
Registered User
Posts: 47
Joined: Mon Nov 21, 2005 5:31 am

I will help

Post by luvz2drv » Sun Nov 19, 2006 3:44 pm

I will be glad to help

what is the site url ... and also did you use the easymod for it or how did you install the mod..

if you wish can can pm me the detials for privacy if you don't want the whole site to know the site in question

Jonathon

doberberto
Registered User
Posts: 4
Joined: Sat Nov 18, 2006 11:41 am

Post by doberberto » Sun Nov 19, 2006 5:17 pm

I m doing the board in local PHP. I don't use easy mod, I change the files manually. So... what do you want to know??

CRAZY-LARS
Registered User
Posts: 1
Joined: Thu Nov 23, 2006 4:36 pm
Location: Norway
Contact:

Post by CRAZY-LARS » Thu Nov 23, 2006 4:49 pm

I installed this MOD in this forum:
http://www.enjoyhabbo.gab.net/forum/

But the phpBB version of that forum is 2.0.21 while this MOD is ment for 2.0.19. I throught I could make it work anyway, just by fix some files by myself. So, well. I did make it work at some way. Everything looks like working, but then i noticed that the group color won't show on any username's!

So is there any version of this MOD for the latest phpBB version?

The site http://www.modmybb.com/ pretends to be down...

luvz2drv
Registered User
Posts: 47
Joined: Mon Nov 21, 2005 5:31 am

user no whos color

Post by luvz2drv » Thu Nov 23, 2006 5:34 pm

have the users updated there profile

it is in this process that it updates there color..


try that first..

devicem
Registered User
Posts: 7
Joined: Tue Nov 21, 2006 10:21 pm

Post by devicem » Fri Dec 01, 2006 12:30 pm

Hi, I have a problem...

Code: Select all

Warning: colors::include() [function.colors-include]: Unable to access ./../language/lang_/lang_main_color.php in /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/class_color.php on line 85

Warning: colors::include(./../language/lang_/lang_main_color.php) [function.colors-include]: failed to open stream: No such file or directory in /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/class_color.php on line 85

Warning: colors::include() [function.include]: Failed opening './../language/lang_/lang_main_color.php' for inclusion (include_path='.:/usr/share/php') in /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/class_color.php on line 85

Warning: Cannot modify header information - headers already sent by (output started at /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/class_color.php:85) in /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/sessions.php on line 254

Warning: Cannot modify header information - headers already sent by (output started at /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/class_color.php:85) in /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/sessions.php on line 255

Warning: Cannot modify header information - headers already sent by (output started at /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/class_color.php:85) in /www/110mb.com/s/s/c/o/m/m/u/n/sscommunity/htdocs/forum/includes/functions.php on line 949
Does anyone have any idea what I'm doing wrong ? :(

I really really like this mod on my board, in fact I'm desperate to have it :), so any help would be appreciated.

rafearcher
Registered User
Posts: 39
Joined: Sun Nov 26, 2006 12:30 am

Post by rafearcher » Mon Dec 04, 2006 6:43 am

does this mod work in 2.0.21?

i know that CRAZY-LARS mentioned he got it working in 2.0.21... but does that mean that I can't just follow the instructions? or is there andditional work that needs to be done?

rafearcher
Registered User
Posts: 39
Joined: Sun Nov 26, 2006 12:30 am

Post by rafearcher » Mon Dec 04, 2006 4:58 pm

im in pretty much the same boat devicem, luckily, I have a complete backup of my entire forum before this thing.

Here is the error screen I got:

Image

I wish there was a version of this mod without the color picker... im not afraid of editing the css file...

anywho.. im running 2.0.21
I am 99.98% sure that I installed everything correct..... so.. That means that this error has only a .02% chance of being my fault.

Sadly... I have no idea what any of these error mean.... so I cannot fix them m’self.

Any assistance in this matter would be greatly appreciated...

Frosty1
Registered User
Posts: 85
Joined: Mon Mar 06, 2006 4:55 pm

Post by Frosty1 » Thu Dec 07, 2006 6:59 am

I was going to install his on my forum (v.21) but you guys are freaking me out. Is it compatible or not?

luvz2drv
Registered User
Posts: 47
Joined: Mon Nov 21, 2005 5:31 am

This mod oes work

Post by luvz2drv » Thu Dec 07, 2006 3:22 pm

this mod does work with .21 I have it up and running no issues

I had the sam issue with the tables red errors.. go back in the thread it is listed what to do .. you have to run the create/alter tables manualing in something like phpMy admin if I remember correctly

Jonathon

Frosty1
Registered User
Posts: 85
Joined: Mon Mar 06, 2006 4:55 pm

Post by Frosty1 » Fri Dec 08, 2006 3:49 am

Ok, so I can just run easy mod to install this and then manually correct the above db errors that are shown in red in the screen capture?

Post Reply

Return to “[2.0.x] MOD Database Releases”