[2.0.19] Search Box

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
10
91%
Very Good
0
No votes
Good
0
No votes
Fair
0
No votes
Poor
1
9%
 
Total votes: 11

tony44
Registered User
Posts: 232
Joined: Sun Apr 17, 2005 4:34 pm

Post by tony44 »

Anyone get this working with BBTech?
www.teamhcn.com
Registered User
Posts: 34
Joined: Fri Dec 23, 2005 2:34 am

Post by www.teamhcn.com »

Works great with Subsilver, however with the theme I use as a default on my forums, Fusion Expanded, I've run into some formatting problems, I think because the forum nav is image-based (instead of Subsilver's text links). The closest I've come to getting the mod to work ended up with it displaying as part of the index just below the main nav, which is not what I want. Is there some way to float the arrow button that triggers the search box overtop of the search button? If not, would I have to change the link for the search button so that it opens the search box instead of the search page? You're welcome to take a look at my forums if it'll give you a better idea of what it is I'm asking, the link is in my sig. TIA :wink:
Site | Forums
=HCN= Team Cyanide
"After one taste of us, you're already dead."
runegirlie
Registered User
Posts: 173
Joined: Sun Jul 31, 2005 6:08 pm

Post by runegirlie »

Hi there .. I am trying to install your mod .. am getting the following for my alternate templates:

Warning

FIND FAILED: In file [templates/Glass/overall_header.tpl] could not find:

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/BlackAndWhite/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;<a href="{U_SEARCH}" class="mainmenu"><img src="templates/BlackAndWhite/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>&nbsp; &nbsp;<a href="{U_MEMBERLIST}" class="mainmenu"><img src="templates/BlackAndWhite/images/icon_mini_members.gif" width="12" height="13" border="0" alt="{L_MEMBERLIST}" hspace="3" />{L_MEMBERLIST}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="templates/BlackAndWhite/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp;

MOD script line #131 :: FAQ :: Report

**

any advice? I would love to use the mod, but don't want to install if it won't work for all.
User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Post by igorw »

You might have to install it manually on custom templates
runegirlie
Registered User
Posts: 173
Joined: Sun Jul 31, 2005 6:08 pm

Post by runegirlie »

Thanks much .. any guidance for that?
User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Post by igorw »

Open the templates/templatename/overall_header.tpl file with a text editor and search for "{L_SEARCH}". You can probably figure the rest out yourself
rgross
Registered User
Posts: 127
Joined: Fri Dec 10, 2004 7:22 am

Post by rgross »

Your MOD has a rather large find/replace which doesn't work for anybody who has added anything to that portion of the overall header. For anybody interested in this MOD (and I like it!), use:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/overall_header.tpl
#
#-----[ FIND ]------------------------------------------
#
						<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;<a href="{U_SEARCH}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>&nbsp; &nbsp;<a href="{U_MEMBERLIST}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_members.gif" width="12" height="13" border="0" alt="{L_MEMBERLIST}" hspace="3" />{L_MEMBERLIST}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp; 
#
#-----[ IN-LINE FIND ]------------------------------------------
#

<a href="{U_SEARCH}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>
#
#-----[ REPLACE WITH ]------------------------------------------
#

<a onclick="return searchTooltip();" href="{U_SEARCH}" class="mainmenu" id="searchlink"><img src="templates/subSilver/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH} <img src="templates/subSilver/images/icon_mini_menu_down.gif" width="8" height="5" border="0" /></a>
						<div id="searchbox" style="display:none;z-index: 100;">
						<form action="{S_SEARCH_ACTION}" method="POST">
						<table class="forumline" cellpadding="4" cellspacing="1" border="0">
						  <tr>
						    <th class="thHead" height="25"><a onclick="searchTooltip(); return false;" href="#" style="float:right;color: #FFF;font-size: 9px;font-family:Verdana, sans-serif; text-decoration: none;">(X)</a>{L_SEARCH_QUERY}</th>
						  </tr>
						  <tr>
						    <td class="row1" align="center">
						      <input type="text" style="width: 180px" class="post" name="search_keywords" size="30" /> <input class="liteoption" type="submit" value="{L_SEARCH}" />
						      <input type="hidden" name="search_terms" value="all" />
						      <input type="hidden" name="search_forum" value="-1" />
						      <input type="hidden" name="search_time" value="0" />
						      <input type="hidden" name="search_cat value="-1" />
						      <input type="hidden" name="sort_by value="0" />
						      <input type="hidden" name="sort_dir value="ASC" />
						      <input type="hidden" name="show_results value="posts" />
						      <input type="hidden" name="return_chars value="200" />
						      <input type="hidden" name="search_fields" value="all" />
						    </td>
						  </tr>
						  <tr>
						    <td class="catBottom" align="center">
							  <a href="{U_SEARCH}" class="nav">{L_ADVANCED_SEARCH}</a> 
							</td>
						  </tr>
						</table>
						</form>
						</div>
instead of

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/overall_header.tpl
#
#-----[ FIND ]------------------------------------------
#
						<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;<a href="{U_SEARCH}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>&nbsp; &nbsp;<a href="{U_MEMBERLIST}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_members.gif" width="12" height="13" border="0" alt="{L_MEMBERLIST}" hspace="3" />{L_MEMBERLIST}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp; 
#
#-----[ REPLACE WITH ]------------------------------------------
#
						<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;<a onclick="return searchTooltip();" href="{U_SEARCH}" class="mainmenu" id="searchlink"><img src="templates/subSilver/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH} <img src="templates/subSilver/images/icon_mini_menu_down.gif" width="8" height="5" border="0" /></a>
						<div id="searchbox" style="display:none;z-index: 100;">
						<form action="{S_SEARCH_ACTION}" method="POST">
						<table class="forumline" cellpadding="4" cellspacing="1" border="0">
						  <tr>
						    <th class="thHead" height="25"><a onclick="searchTooltip(); return false;" href="#" style="float:right;color: #FFF;font-size: 9px;font-family:Verdana, sans-serif; text-decoration: none;">(X)</a>{L_SEARCH_QUERY}</th>
						  </tr>
						  <tr>
						    <td class="row1" align="center">
						      <input type="text" style="width: 180px" class="post" name="search_keywords" size="30" /> <input class="liteoption" type="submit" value="{L_SEARCH}" />
						      <input type="hidden" name="search_terms" value="all" />
						      <input type="hidden" name="search_forum" value="-1" />
						      <input type="hidden" name="search_time" value="0" />
						      <input type="hidden" name="search_cat value="-1" />
						      <input type="hidden" name="sort_by value="0" />
						      <input type="hidden" name="sort_dir value="ASC" />
						      <input type="hidden" name="show_results value="posts" />
						      <input type="hidden" name="return_chars value="200" />
						      <input type="hidden" name="search_fields" value="all" />
						    </td>
						  </tr>
						  <tr>
						    <td class="catBottom" align="center">
							  <a href="{U_SEARCH}" class="nav">{L_ADVANCED_SEARCH}</a> 
							</td>
						  </tr>
						</table>
						</form>
						</div>&nbsp; &nbsp;<a href="{U_MEMBERLIST}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_members.gif" width="12" height="13" border="0" alt="{L_MEMBERLIST}" hspace="3" />{L_MEMBERLIST}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp; 
Should work fine.
User avatar
irene_haydon
Registered User
Posts: 210
Joined: Sat Apr 15, 2006 3:37 pm

Post by irene_haydon »

Hi,

I have installed this mod and it works wonderfully on my bord (2.0.20, subsilver). I have a question .. when we search using the box, all the search results are displayed as posts [Display results as:Posts], can we change some thing so that results are displayed as Topics. I tried it by changing following codes:

Code: Select all

<input type="hidden" name="show_results value="posts" />
to

Code: Select all

<input type="hidden" name="show_results value="Topics" />
I also tried using "topics" , but it also didn't work and still dispaly results as posts. Please let me know how can it be done.

Thanks.
Irene
alfatek
Registered User
Posts: 32
Joined: Sun Jan 29, 2006 12:04 am
Contact:

Post by alfatek »

Code: Select all

<input type="hidden" name="show_results value="topics" />
That should do the trick... But I only looked to the search.php html code, i haven't tested it.
boardsource
Registered User
Posts: 125
Joined: Wed Sep 27, 2006 4:28 am

Post by boardsource »

im trying to install this in the conundrum template and im having problems with the overall header part where you have to find this

Code: Select all

<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;<a href="{U_SEARCH}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>&nbsp; &nbsp;<a href="{U_MEMBERLIST}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_members.gif" width="12" height="13" border="0" alt="{L_MEMBERLIST}" hspace="3" />{L_MEMBERLIST}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp;

but the closest ive been able to find is this, which is in divs instead of tables.

Code: Select all

		<div id="menu">
			<div id="left" class="left mainmenu">
				<a href="{U_FAQ}">{L_FAQ}</a>
				<a href="{U_SEARCH}">{L_SEARCH}</a>
				<a href="{U_MEMBERLIST}">{L_MEMBERLIST}</a>
				<a href="{U_GROUP_CP}">{L_USERGROUPS}</a>
				
and i have no idea how to change the code... anyone?
User avatar
daraboth
Registered User
Posts: 4
Joined: Fri Oct 13, 2006 12:52 pm

sorry i post wrong subject, but u can help

Post by daraboth »

hi
i have problem with search and separate key break (like key space)
Mmm my langueg use unicode that it's separate by using "zero-space", so i need you to help me to write or modify some script in Search or search function that
"zero-space" = "space",are quale

hope you can help... as soon as posible.... :lol:

for view my languag (Unicode) in Php , it's ok, but i don't khow what it' will happen , ít will crash or not, when i upload it,,,,, (i just test in Localhost)
===========================
sorry i post wrong subject, but u can help
===========================
Last edited by daraboth on Fri Oct 13, 2006 1:38 pm, edited 1 time in total.
User avatar
daraboth
Registered User
Posts: 4
Joined: Fri Oct 13, 2006 12:52 pm

i like you mod but, it's have some error occur

Post by daraboth »

i don't why know, when i setup your searchbox 1.0.1
when i start ie, it's crash, and close windows explore,,,,
but when i erase some jave script that add before </head> i't has ok, your mod, it didn't work too....
==========
do you have problem as me....
can you so this problem...
thoffland
Registered User
Posts: 8
Joined: Sun Jan 02, 2005 7:27 am
Location: Arizona

Post by thoffland »

This is an excellent mod!

It works great on subsilver, but I'm using Getaway for my skin on my forum and as someone else mentioned there are some formatting issues.

Has anyone found a solution for this? I'd really like to use it!!

By the way, if you use EasyMod to install it, you will get the error that it cant find some code... but still installs perfectly. Just keep clicking next and it will be installed.

Thanks!!!
-T
User avatar
Roks
Registered User
Posts: 119
Joined: Thu Sep 14, 2006 1:15 am

Post by Roks »

Thanks for another vBulletin like feature.
User avatar
LuuLa
Registered User
Posts: 110
Joined: Thu Feb 19, 2004 4:25 pm

Post by LuuLa »

Hi

one question:
how can I force the cursor being displayed in the text area?
I don't want to click into the search box to enter the search phrase.


one hint:

Code: Select all

                        <input type="hidden" name="search_cat value="-1" />
                        <input type="hidden" name="sort_by value="0" />
                        <input type="hidden" name="sort_dir value="ASC" />
                        <input type="hidden" name="show_results value="posts" />
                        <input type="hidden" name="return_chars value="200" />
                        
... should be...

Code: Select all

                        <input type="hidden" name="search_cat value="-1" />
                        <input type="hidden" name="sort_by" value="0" />
                        <input type="hidden" name="sort_dir" value="ASC" />
                        <input type="hidden" name="show_results" value="posts" />
                        <input type="hidden" name="return_chars" value="200" />
                        
Missing quotes, I think...
Post Reply

Return to “[2.0.x] MOD Database Releases”