[2.0.19] Thumbnail-on-Dimensions mod (for Attachment mod)

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2
33%
Very Good
1
17%
Good
2
33%
Fair
1
17%
Poor
0
No votes
 
Total votes: 6

soke.on.koke
Registered User
Posts: 156
Joined: Thu Mar 31, 2005 6:16 pm
Location: dk

Post by soke.on.koke » Tue Dec 12, 2006 3:23 pm

When i click the thumbnail to get the larger picture it comes as a download..
hmm

However it dose work correct in preview

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17008
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Tue Dec 12, 2006 4:24 pm

Did you even bother reading any of the other posts??? :roll:
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

luckyou03
Registered User
Posts: 77
Joined: Thu Aug 17, 2006 8:22 pm
Location: Memphis, TN
Contact:

Post by luckyou03 » Wed Dec 13, 2006 12:50 am

mwh65 wrote: I managed to sort out the problem myself. You will need to modify the displaying.php file in the attach_mod folder ...

Code: Select all

 ** Find (around Line 839 if you have added the "Thumbnail-on-Dimensions mod" changes) **
'IMG_SRC'                                => append_sid($phpbb_root_path . 'download.' . $phpEx . '?id=' . $attachments['_' . $post_id][$i]['attach_id']),

** Change this line to read **
'IMG_SRC'                                => $filename,

SAVE CHANGES TO THE FILE


Worked perfect! thanks

mwh65
Registered User
Posts: 189
Joined: Sat Jul 12, 2003 11:10 pm

Post by mwh65 » Wed Dec 13, 2006 5:15 pm

No problem 8)

colin_bb
Registered User
Posts: 104
Joined: Tue Feb 14, 2006 8:40 pm

Post by colin_bb » Sun Dec 17, 2006 4:48 pm

Got a strange thing happening to me:

I installed the attachment mod and this mod just under a year ago, and both have worked perfectly.

Yet i just updated my forum from 2.19 to 2.20, and any new attachments that generate the thumbnail aren't showing in the post... i just get the red cross with a link to the image (which opens fine full-size). The attachments are displayed inline in the ACP. Existing thumbnails are showing fine, but new ones aren't created. Further inspection shows that the image is uploaded to the files directory, but a related thumbnail isn't created in the thumbs directory.

Any idea what could cause this? As far as i know none of the 2.20 files affected are dependant on this mod, plus like i say, both attachment mod and this one have been running perfectly for just under a year, so i'm a bit :?

Pseudonym
Registered User
Posts: 173
Joined: Mon Jan 26, 2004 8:37 am

Post by Pseudonym » Wed Dec 27, 2006 6:24 am

Hmmm. That IS a strange one, Colin. I'm currently running it on 2.21, with no problems at all.

I haven't updated to 2.22 yet, but I'm planning on doing it in the next few days. I'll report back and let you know how I get on.

colin_bb
Registered User
Posts: 104
Joined: Tue Feb 14, 2006 8:40 pm

Post by colin_bb » Thu Dec 28, 2006 12:42 am

Pseudonym wrote: Hmmm. That IS a strange one, Colin. I'm currently running it on 2.21, with no problems at all.

I haven't updated to 2.22 yet, but I'm planning on doing it in the next few days. I'll report back and let you know how I get on.


Thanks for looking into it.

A bit more info: i scrapped the update from 2.19 etc and i have a fresh install of 2.22 configued with attachment mod 2.4.5. I'm running php 4.4.2 on apache 2.059 on windows with mysql 4.1 and 5.027. I have enabled the GD extension in my php.ini, and i also have imagemagick installed at c:\imagemagick\convert.exe (test settings from ACP says configs ok): neither seem to create the thumbnail.

Also, i'm not sure if this is relevant, but now when i click the link (the thumbnail doesn't appear but a red cross and link to it do), a new window opens, but instead of displaying the image, a download dialog pops up: File Download - do you want to open or save this file? (with open, save and cancel buttons).

colin_bb
Registered User
Posts: 104
Joined: Tue Feb 14, 2006 8:40 pm

Post by colin_bb » Tue Jan 02, 2007 3:02 am

I've spent a few days looking into it, and i'm not entirely convinced that my GD library is working correctly; i keep on finding a message in my apache log 'unable to load extensions/gd2.dll' or something along them lines... i'm also getting no hint of it in my phpinfo, even though it's uncommented in the php.ini.

Do you have an acid test to determine if my gd lib is working ok?

Pseudonym
Registered User
Posts: 173
Joined: Mon Jan 26, 2004 8:37 am

Post by Pseudonym » Fri Jan 05, 2007 10:05 pm

Sorry Colin - I'm no expert when it comes to gdlib. Can you get the Attachment mod to work ok by itself?


By the way, I've just realised that although I running phpBB 2.22, my Attachment mod version is only 2.4.3. Acyd Burn used to provide a patch upgrade on his website, but I see he's taken the site offline now. Anyone know where I can get the patch?

killyouall
Registered User
Posts: 523
Joined: Tue Oct 18, 2005 3:04 am
Contact:

Post by killyouall » Sun Jan 07, 2007 6:11 am

does this work at all with the new phpbb and attachmod?

MA-N
Registered User
Posts: 8
Joined: Thu Mar 01, 2007 10:28 am

Post by MA-N » Sun Mar 04, 2007 11:29 pm

DavidIQ has damn right just change in Extension Groups Control -> Download Mode -> inline to physical

Mourgos
Registered User
Posts: 27
Joined: Thu Mar 01, 2007 8:02 am

Will this mod work with images from other hosts?

Post by Mourgos » Thu Mar 08, 2007 6:46 am

Sorry for the silly question.. :oops:
Will this mod work with images from other hosts? (like imageshack)
Does this mod saves the thumbnail in my forum's root?
Will this be compatible with AcidTech templates and 2.0.21?
Thank you :)

russell235
Registered User
Posts: 7
Joined: Fri Sep 21, 2007 4:09 am

Re: [2.0.19] Thumbnail-on-Dimensions mod (for Attachment mod)

Post by russell235 » Fri Sep 21, 2007 5:01 am

I was just getting a little red X for the thumbnail, but your code fix on page 2 fixed that. thank you.

When I click the thumb, I'm taken to a page that says "Hacking attempt" and nothing else. Admittedly, I did not test the thumbs feature before adding this mod. :( - edit, I've fixed this and it was nothing to do with your mod. :)

Also, any idea how to make the thumbs bigger? I would like to make them as big as possible without breaking my theme. :)

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17008
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: [2.0.19] Thumbnail-on-Dimensions mod (for Attachment mod)

Post by DavidIQ » Fri Oct 05, 2007 2:44 am

russell235 wrote:I was just getting a little red X for the thumbnail, but your code fix on page 2 fixed that. thank you.

When I click the thumb, I'm taken to a page that says "Hacking attempt" and nothing else. Admittedly, I did not test the thumbs feature before adding this mod. :( - edit, I've fixed this and it was nothing to do with your mod. :)

Also, any idea how to make the thumbs bigger? I would like to make them as big as possible without breaking my theme. :)
Modify $max_width in attach_mod/includes/functions_thumbs.php
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

baerenwurm
Registered User
Posts: 131
Joined: Wed Nov 06, 2002 2:38 pm
Location: Germany

Re: [2.0.19] Thumbnail-on-Dimensions mod (for Attachment mod)

Post by baerenwurm » Fri Jun 06, 2008 2:09 pm

Currently thumbnails are created even for small images (width >=250px). How can I change that?

Post Reply

Return to “[2.0.x] MOD Database Releases”