ACP User Registration

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
23
74%
Very Good
6
19%
Good
2
6%
Fair
0
No votes
Poor
0
No votes
 
Total votes: 31

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Fri Apr 28, 2006 4:20 am

beckham: Glad to see you worked your problem out. :)

Just a general note that although I try to make sure my MODs use all 3 database systems, I only have access to MySQL and only know how to tailor MySQL queries (although I try to use the SQL Parser whenever I can); however my MOD isn't tested on other DBMS's by me or the MOD Team.

Croaker56
Registered User
Posts: 15
Joined: Wed Jul 13, 2005 8:15 am

Post by Croaker56 » Tue May 02, 2006 3:52 am

When I click on "register user" I get this:
Template->make_filename(): Error - file admin/acpuser_body.tpl does not exist

Am running 2.0.20

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Tue May 02, 2006 12:50 pm

Did you upload acpuser_body.tpl to templates/subSilver/admin/?

Croaker56
Registered User
Posts: 15
Joined: Wed Jul 13, 2005 8:15 am

Post by Croaker56 » Tue May 02, 2006 8:12 pm

Evidently not. Thanks!

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Post by lefty74 » Thu May 04, 2006 10:41 pm

Thanks for this mod, so far, it works great :)

I have the Skype Mod installed so got this validation error as well

Code: Select all

Warning: Missing argument 10 for validate_optional_fields() in /home/ACCOUNTNAME/public_html/phpBB/includes/functions_validate.php on line 169
Once I added all the skype references to the files it was fine.

Thanks again. This MOD makes life so much easier...
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Fri May 05, 2006 1:20 pm

In the near future, I will be working on an upgrade to ACP User Registration, which will include MODX and also any new features that might need adding. I would like to get any suggestions that you guys have for new features that could be added to this MOD (except for registering banned users, see the third post in this topic).

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Post by lefty74 » Sun May 07, 2006 12:31 am

Fountain of Apples wrote: In the near future, I will be working on an upgrade to ACP User Registration, which will include MODX and also any new features that might need adding. I would like to get any suggestions that you guys have for new features that could be added to this MOD (except for registering banned users, see the third post in this topic).


Excellent News, Fountain of Apples , I would have some suggestions:

1. Have the option to auto-assign a password, e.g. when leaving the password field empty there will be an auto-assign

2. Have the possibility to customise some of the email text through ACP. Currently, the default email is used where at the end it says thank you for registering. What I mean is something like this:

Code: Select all

Subject: You have been registered at {SITENAME} Forums
Charset: iso-8859-1

{WELCOME_MSG} <--- editable, however a default text to pop up in the ACP which can be amended/overwritten or left as is.

If you have any questions, please contact {admin_username}, the administrator who registered you.

Please keep this email for your records. Your account information is as follows:

----------------------------
Username: {USERNAME}
Password: {PASSWORD}
----------------------------

Please do not forget your password as it has been encrypted in our database and we cannot retrieve it for you. However, should you forget your password you can request a new one from the forum.

{EMAIL_SIG}
3. Have the group assignment on the simple mode as well.

4. Have the rank assignment field on both modes

These are just ideas that came up when registering a few new users...

I do not know whether they are possible at all since I do not know anything about the programming but thought I could put them down anyway.

Cheers :D
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Sun May 07, 2006 4:45 am

I'm a little hesitant about the first idea (regarding the auto-assign password), however I'll look into it because it does have some merit.

For the e-mail, the main reason the default one is used is in the interest of reducing the number of templates and reusing them (in the interest of the coding standards). Frankly, I think the current text should suit most people, and it's fairly easy to go into lang_admin.php and edit the welcome text if you don't like it.

Adding the groups to the simple mode shouldn't be too difficult. Also, allowing to preset a rank is a good idea; I wish I had thought of that. I'll definitely look into adding that as well.

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Post by lefty74 » Sun May 07, 2006 12:47 pm

cool, thanks for taking my suggestions into consideration
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

dicks
Registered User
Posts: 75
Joined: Wed Jun 01, 2005 8:01 am

Post by dicks » Tue May 09, 2006 9:13 am

lefty74 wrote: Thanks for this mod, so far, it works great :)

I have the Skype Mod installed so got this validation error as well

Code: Select all

Warning: Missing argument 10 for validate_optional_fields() in /home/ACCOUNTNAME/public_html/phpBB/includes/functions_validate.php on line 169
Once I added all the skype references to the files it was fine.

Thanks again. This MOD makes life so much easier...


OK, I also added "Skype" to the php file and the error is gone. However in advanced mode there is no Skype field visible. I made sure to add Skype code after all parts where "YIM" is present.

Any ideas?

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Tue May 09, 2006 12:22 pm

Did you add skype in the right order for validate_optional_fields()?

However, yes, people who already have other MODs installed which edit their profile do kind of have a problem with this MOD. I might, for the next version of ACP User Registration, duplicate the validate_optional_fields() function and name it something else in order to prevent this error from showing up (at which point you would simply enter the basic registration details in ACP User Registration, and could add the MOD'ded fields later).

dicks
Registered User
Posts: 75
Joined: Wed Jun 01, 2005 8:01 am

Post by dicks » Tue May 09, 2006 12:44 pm

Yes, although I see that the $website string was added. In the validation there is $yim, $skype and then $occupation.

I switched around a few things but there is no difference. Any idea how to fix this?

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Tue May 09, 2006 12:48 pm

I wouldn't know how without being able to look at the code for both your includes/usercp_register.php file and your admin/admin_acpuser.php, however I'm leaving today on a plane trip and won't be getting back until Saturday. Sorry. :(

EDIT: One thing you could try doing: Make sure the order of the variables called in validate_optional_fields() in admin/admin_acpuser.php match the order of the variables listed in the same function's definition in includes/functions_validate.php.

dicks
Registered User
Posts: 75
Joined: Wed Jun 01, 2005 8:01 am

Post by dicks » Tue May 09, 2006 12:56 pm

Yep, that's what I did but maybe something slipped my eyes. Will send you a PM with the files and when you return appricate if you can take a quick look.

Have a safe journey!

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Post by lefty74 » Tue May 09, 2006 3:47 pm

did you add the skype field to the acpuser_body.tpl file?

it would be like

Code: Select all


FIND
	<tr> 
	  <td class="row1"><span class="gen">{L_YAHOO}:</span></td>
	  <td class="row2"> 
		<input type="text" class="post" style="width: 150px"  name="yim" size="20" maxlength="255" value="{YIM}" />
	  </td>
	</tr>


AFTER ADD

  <tr> 
	  <td class="row1"><span class="gen">{L_SKYPE}:</span></td>
	  <td class="row2"> 
		<input type="text" class="post" style="width: 150px"  name="skype" size="20" maxlength="255" value="{SKYPE}" />
	  </td>
	</tr>
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

Post Reply

Return to “[2.0.x] MOD Database Releases”