Fix For The Firefox "Remember Passwords" Problem

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
26
65%
Very Good
7
18%
Good
4
10%
Fair
0
No votes
Poor
3
8%
 
Total votes: 40

ClodTalk
Registered User
Posts: 8
Joined: Sat Feb 14, 2004 9:35 pm

Post by ClodTalk » Sat Feb 11, 2006 7:04 pm

New one seems to work for me again! I plan on installking the advance admin stuff today!

Thank you so mutch! My admins and myself are greatfull!

User avatar
MHobbit
Former Team Member
Posts: 4761
Joined: Thu Mar 18, 2004 5:32 pm
Location: There and Back Again

Post by MHobbit » Sat Feb 11, 2006 8:00 pm

I just want to note that there isn't a requirement for MODs in our MODDB to fully work with other MODs; with the more MODs you have installed (with complexity), there is less of a chance another MOD that affects the same file(s) will work.
Former phpBB MOD Team member
No private support is offered.
"There’s too many things to get done, and I’m running out of days..."

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Sat Feb 11, 2006 9:05 pm

It is nice when the MOD author is generous enough to make sure that their MOD plays nice with the rest of the board and popular MODs, like T0ny has done here. It's too bad that there are some who won't go that extra mile....

I applaud those like T0ny who will...

Image

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Sat Feb 11, 2006 11:34 pm

ClodTalk wrote: New one seems to work for me again! I plan on installking the advance admin stuff today!

Thank you so mutch! My admins and myself are greatfull!


You're most welcome. Let me know if you find any conflicts with the advance admin stuff.

MennoniteHobbit wrote: the more MODs you have installed (with complexity), there is less of a chance another MOD that affects the same file(s) will work.


Tell me about it :) . Submitting this MOD has certainly been a learning experience for me. I previously had no idea that a MOD could cause so many conflicts :( . I appreciate you stepping in to post the official line on compatability though.

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Sun Feb 12, 2006 12:30 am

T0ny, I applaud you for going that extra mile to make sure that your MOD plays nice with the others. There are several good MOD authors who would do the same and a lot that won't. I'm glad to see that you are one of the good guys...

Your MOD originally did remove a variable that was part of the standard phpBB layout. Everyone designs their MODs toward the standard, so when you removed one of the standard variables, it wasn't surprising that it would break more than one MOD that designed around the standards without removing any themselves. In this case, it wasn't that difficult for you to adjust your MOD so that it didn't break any others. That's all part of the learning process. Do no harm should be the motto of all good MOD authors...

T0ny, I think MennoniteHobbit made his comment more as a jab toward me rather than a clarification for you. I wouldn't expect anything less from him. We have a history...

Image

jp1
Registered User
Posts: 27
Joined: Thu Oct 07, 2004 2:38 am
Location: Michigan
Contact:

Post by jp1 » Sun Feb 12, 2006 5:57 am

Thank you SO much for this mod. I use Firefox exclusively, and this was driving me crazy!
-John-

niksa
Registered User
Posts: 612
Joined: Mon Sep 08, 2003 7:20 pm
Location: Future birthplace of James T. Kirk
Contact:

Post by niksa » Mon Feb 13, 2006 8:40 am

NightriderXP wrote: T0ny, I applaud you for going that extra mile to make sure that your MOD plays nice with the others. There are several good MOD authors who would do the same and a lot that won't. I'm glad to see that you are one of the good guys...


Couldn't have said it better myself. :)

TStarGermany
Registered User
Posts: 16
Joined: Fri Nov 11, 2005 7:58 pm
Contact:

Post by TStarGermany » Tue Feb 14, 2006 8:40 am

hey t0ny,thx for the mod...the new version finally works 8)

i have a suggestion/question to you ppl though..

wouldn't it have been better to use another method from keeping ff inserting username/pw into the fields? i mean..after all it's a ff "misfunction",not a phpbb one, right?

my idea would've been: keep the username/pw fields inactive/"greyed out" until you click a small button next to it which changes the elements properties to active/non-greyed-out...
this way you could prevent all kind of accidental changes in those 2 important fields, not just the ff ones...

User avatar
cubechris
Registered User
Posts: 138
Joined: Fri Aug 13, 2004 9:54 am
Location: Lincoln, UK
Contact:

Post by cubechris » Tue Feb 14, 2006 11:31 am

Many Thanks, the lastest version worked a treat, nice work, I am a big Firefox user, so this was such a pain, cheers!

:D

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Tue Feb 14, 2006 11:43 am

TStarGermany wrote: wouldn't it have been better to use another method from keeping ff inserting username/pw into the fields? i mean..after all it's a ff "misfunction",not a phpbb one, right?


The only other way to fix the problem, other than use a MOD, is to fix firefox; not something I can do :)
TStarGermany wrote: keep the username/pw fields inactive/"greyed out" until you click a small button next to it which changes the elements properties to active/non-greyed-out...


Unfortunately, setting the form fields to disabled/readonly doesn't stop firefox filling in the values. :(

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Tue Feb 14, 2006 11:47 am

Thanks to all for the positive feedback. I've submitted the v1.1.1 MOD to the MODDB (as v1.2.0), so assuming everything is OK, that should be available here soon. :)

concretemonkey
Registered User
Posts: 49
Joined: Sat Oct 23, 2004 1:05 am

Post by concretemonkey » Tue Feb 14, 2006 11:03 pm

I can concur with knightriderxp that there are incompatibility issues with some mods.

I will be installing the beta version now (after i have restored my backed up files) and am hopinf that this genuismod will work. As an exclusive FF user (previously opera) i am very grateful for your dedication to this mod.

Thanks

CM

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Tue Feb 14, 2006 11:22 pm

concretemonkey wrote: I can concur with knightriderxp that there are incompatibility issues with some mods.

I will be installing the beta version now (after i have restored my backed up files) and am hopinf that this genuismod will work. As an exclusive FF user (previously opera) i am very grateful for your dedication to this mod.


Yes, the v1.0.2 MOD is incompatable with pretty much any MOD that alter the user admin functions :oops: . However v1.1.1 (hopefully soon to be approved as v1.2.0) is a lot more compatable. Let me know how you get along with it.

martijn2
Registered User
Posts: 80
Joined: Mon Jul 18, 2005 7:10 am
Location: The Netherlands
Contact:

Post by martijn2 » Sat Feb 18, 2006 7:24 pm

Hi, I'm not sure if it is because of this mod, but whenever I now edit a user through the admin cp I get a username already taken error :(
This wasn't before like that, and I have this mod installed for some time now already :s
Anyway, here is my MODs list I have installed on my board, hope it helps...
Thanks in advance :)
Former phpBB user.

Dman8568
Registered User
Posts: 32
Joined: Sun Feb 20, 2005 4:00 am
Location: WV, USA
Contact:

MOD incompatible w/ Attachment MOD

Post by Dman8568 » Sun Feb 19, 2006 2:29 am

I'm not sure how to word this, so please bear with me...



Your MOD does not currently work with Acyd Burn's "Attachment Mod".

Looking though my files I've found how you can correct this (If you wish).


Attachment Mod Download



File Location: /attach_mod/includes/functions_includes.php
Function: attachment_quota_settings()
Line: 181
Description: "username" needs to be changed to "user_name"
- Dman8568

My MODs:
- UserGroup E-Mail Switch MOD

Post Reply

Return to “[2.0.x] MOD Database Releases”