Fix For The Firefox "Remember Passwords" Problem

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
26
65%
Very Good
7
18%
Good
4
10%
Fair
0
No votes
Poor
3
8%
 
Total votes: 40

siacono
Registered User
Posts: 30
Joined: Thu Nov 10, 2005 2:34 am

Post by siacono » Sun Feb 19, 2006 9:14 am

Ok, I installed the Beta version on my "Heavily" moded (32 mods) site which includes Acyd Burns Attachment mod. Used EM to install and went perfectly smooth, tested firefox and mod works perfectly. Tested all Attachment mod functions and works as it normally would. So far everything else in the site works perfectly as always. So in my opinion this mod is 100% compatible with my site below is a list of installed mods

Fix For The Firefox "Remember Passwords" Problem 1.1.1 T0ny
Split posts and merge in one step 1.0.3 asinshesq
Simply Merge Threads 1.0.1 Ptirhiik
SQL-MOD 0.0.1 battye
Users viewing forum on Index 1.1.0 Eminem_Fan
phpBB 2.0.18 to phpBB 2.0.19 Code Changes 1.0.0 Acyd Burn
Announces Suite
mods settings - users choices - no Profile Control Panel version 1.0.2 Ptirhiik
Announces Suite - Part 3 (without cat.hierarchy v 2.0.4 or greater) 3.0.2 Ptirhiik
Announces Suite - Part 2 (without Split topic v 2.0.0 or greater) 3.0.2 Ptirhiik
Announces Suite - Part 1 (required for all setups) 3.0.2 Ptirhiik
Announces Suite
Auto Delete Users 1.10 Nivisec
Add Admin PM Filter 0.1.0
File Attachment Mod v2 2.4.1 Acyd Burn
Account Self-Delete 1.0.0 Poupoune
Online/Offline/Hidden 2.2.7 kooky
Last topic_from - Standard user panel
Admin Userlist 2.0.2 wGEric
The Blog Mod 0.2.3c hyperion & Blogpoint.
Lock During Posting 1.0.1 drathbun
Rebuild Search 2.2.1b chatasos
Simple Hidden Users Stopper but ADMIN 1.0.2 3Di
Quick Administrator User Options and Information 1.0.0 pentapenguin
Configurable WhoIsOnline Reference Time 1.0.2 ycl6
View Avatar Gallery 1.2.2 Azharh
Forum Logo Selector MOD 1.0.4 ycl6
Block Open Proxy Registrants 2.2.1 TerraFrost
Advance Signature Divider Control 1.0.1 crxgames
Super Quick Reply 1.3.2 hayk
Watched Topics List 1.1.0 netclectic
Topics a user has started 2.0.0b Manipe
Auto-Refresh Forum 1.0.1 rossmcclymont
Bookmarks 1.0.2 DanielT
EasyMOD 0.3.0 Nuttzy

Thank you T0ny for doing such an awesome job

wonkavision
Registered User
Posts: 9
Joined: Sun Feb 05, 2006 4:42 pm

WHY A MOD?!

Post by wonkavision » Tue Feb 21, 2006 5:43 am

This should be fixed in the main distro.!
...or at least be noted in the user guide. A sleepless night and one bug report away from filing a hack/security report, I find this...and phpBB knew all along?! Grrr...

Love the MOD, hate that it even needs to be a MOD!
:wink:

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Tue Feb 21, 2006 5:57 pm

martijn2 wrote: Hi, I'm not sure if it is because of this mod, but whenever I now edit a user through the admin cp I get a username already taken error


From your list of MODs I see you are using 1.0.2 , this has compatability issues with other MODs. Version 1.1.1 (http://mods.servebbs.com/fix_firefox_pwd_1.1.1.mod) is much more 'other MOD' friendly, maybe installing that would help?
Dman8568 wrote: Your MOD does not currently work with Acyd Burn's "Attachment Mod".


You are correct, version 1.0.2 doesn't work with "Attachment Mod", however v1.1.1 does (see URL above if you want to try it)
siacono wrote: So in my opinion this mod is 100% compatible with my site below is a list of installed mods


Thanks for taking the time to test the MOD and reporting the compatabilities
wonkavision wrote: This should be fixed in the main distro.!


Perhaps, although realistically phpbb isn't broken, firefox is. A permanent fix should be down to whoever is responsible for firefox's 'Remember Password' feature

martijn2
Registered User
Posts: 80
Joined: Mon Jul 18, 2005 7:10 am
Location: The Netherlands
Contact:

Post by martijn2 » Wed Feb 22, 2006 4:00 pm

T0ny wrote:
martijn2 wrote:Hi, I'm not sure if it is because of this mod, but whenever I now edit a user through the admin cp I get a username already taken error


From your list of MODs I see you are using 1.0.2 , this has compatability issues with other MODs. Version 1.1.1 (http://mods.servebbs.com/fix_firefox_pwd_1.1.1.mod) is much more 'other MOD' friendly, maybe installing that would help?

Thanks, will try that :)
Edit: since I have 1.0.2 already installed, should I remove that version first, before installing this one, or is it an upgrade file?
Former phpBB user.

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Wed Feb 22, 2006 7:16 pm

martijn2 wrote: Edit: since I have 1.0.2 already installed, should I remove that version first, before installing this one, or is it an upgrade file?


The new version works in a much different way, so you should remove the old version first.

martijn2
Registered User
Posts: 80
Joined: Mon Jul 18, 2005 7:10 am
Location: The Netherlands
Contact:

Post by martijn2 » Thu Feb 23, 2006 3:00 pm

Ok, thanks for replying so quickly :)
Former phpBB user.

MODCAR
Registered User
Posts: 50
Joined: Thu Apr 28, 2005 2:09 am
Location: Wellington, NZ
Contact:

Post by MODCAR » Sat Feb 25, 2006 10:15 pm

smooky57 wrote:
NightriderXP wrote:Are you ever going to fix this problem? After this MOD is installed, the Management option can no longer find ANY members of the community...

Image

Image


this problem is here :

templates/subSilver/admin/user_select_body.tpl

Code: Select all

#
#-----[ FIND ]---------------------------------------------------
#

<td class="row1" align="center"><input type="text" class="post" name="username" maxlength="50" size="20" /> <input type="hidden" name="mode" value="edit" />{S_HIDDEN_FIELDS}<input type="submit" name="submituser" value="{L_LOOK_UP}" class="mainoption" /> <input type="submit" name="usersubmit" value="{L_FIND_USERNAME}" class="liteoption" onClick="window.open('{U_SEARCH_USER}', '_phpbbsearch', 'HEIGHT=250,resizable=yes,WIDTH=400');return false;" /></td>

#
#-----[ REPLACE WITH ]---------------------------------------------------
#

<td class="row1" align="center"><input type="text" class="post" name="user_name" maxlength="50" size="20" /> <input type="hidden" name="mode" value="edit" />{S_HIDDEN_FIELDS}<input type="submit" name="submituser" value="{L_LOOK_UP}" class="mainoption" /> <input type="submit" name="usersubmit" value="{L_FIND_USERNAME}" class="liteoption" onClick="window.open('{U_SEARCH_USER}', '_phpbbsearch', 'HEIGHT=250,resizable=yes,WIDTH=400');return false;" /></td>

#


I have restored all files, my user_select_body.tpl looks like the replaces version above, but still get the "user does not exist". I feel i need to get this working before installing the upgraded mod.

MODCAR
Registered User
Posts: 50
Joined: Thu Apr 28, 2005 2:09 am
Location: Wellington, NZ
Contact:

Post by MODCAR » Sat Feb 25, 2006 11:26 pm

UPDATE:

Fixed :)

MODCAR
Registered User
Posts: 50
Joined: Thu Apr 28, 2005 2:09 am
Location: Wellington, NZ
Contact:

Post by MODCAR » Sat Feb 25, 2006 11:33 pm

T0ny wrote: Further changes: http://mods.servebbs.com/fix_firefox_pwd_1.1.1.mod

This removes the edits to templates/subSilver/admin/user_select_body.tpl which are no longer needed. The good news (for eviL<3 at least) is that this version is compatable with "Enhanced Admin User Lookup"


T0ny your awesome, thanx heaps for all the work you have put into this mod! the mod team @ phpbb.com should get your latest version on their download page!

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Post by igorw » Sun Feb 26, 2006 8:41 am

Yeah, thanks! Awesome! :D

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Mon Feb 27, 2006 11:37 pm

MOD Updated to version 1.2.0
See first post for Download Link

Emperor_Slain
Registered User
Posts: 25
Joined: Mon Feb 27, 2006 10:46 pm

Post by Emperor_Slain » Sat Mar 11, 2006 10:21 am

This mod is getting mixed up with the Autofill fix mod, do I still add the _fillfix line after the user_name one?

User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Post by igorw » Sat Mar 11, 2006 12:02 pm

Emperor_Slain wrote: This mod is getting mixed up with the Autofill fix mod, do I still add the _fillfix line after the user_name one?


I think you should install either, but not both.

Emperor_Slain
Registered User
Posts: 25
Joined: Mon Feb 27, 2006 10:46 pm

Post by Emperor_Slain » Sat Mar 11, 2006 1:56 pm

eviL<3 wrote:
Emperor_Slain wrote:This mod is getting mixed up with the Autofill fix mod, do I still add the _fillfix line after the user_name one?


I think you should install either, but not both.

I am sure you can use both mods, I just added the _fillfix line in the correct places.

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Sun Mar 12, 2006 1:02 pm

Emperor_Slain wrote: I am sure you can use both mods, I just added the _fillfix line in the correct places.


This MOD and the Autofill fix MOD are both cures for the same problem. Although using both will work, you only need to use one of them.

Post Reply

Return to “[2.0.x] MOD Database Releases”