Fix For The Firefox "Remember Passwords" Problem

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply

Rating:

Excellent!
26
65%
Very Good
7
18%
Good
4
10%
Fair
0
No votes
Poor
3
8%
 
Total votes: 40

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 » Sat Apr 01, 2006 12:20 pm

MOD Updated to version 1.2.1
See first post for Download Link

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Post by RMcGirr83 » Sat Apr 01, 2006 6:11 pm

Any hope for this to be applied to CH?

No longer uses admin_ug_auth.php

pat gullett
Registered User
Posts: 7
Joined: Fri Mar 24, 2006 3:41 pm

Post by pat gullett » Wed Apr 12, 2006 2:09 pm

Really need this MOD. However, when trying to download it, I get an error that says the file no longer exists.

Any suggestions?

C2
Registered User
Posts: 76
Joined: Tue Nov 15, 2005 10:58 pm

Post by C2 » Fri Apr 14, 2006 11:55 am

Even after using this mod, my phpbb still won't remember passwords and user names.

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Fri Apr 14, 2006 1:13 pm

RMcGirr83 wrote: Any hope for this to be applied to CH?
No longer uses admin_ug_auth.php


CH? I assume this is a MOD. Unfortunately if it replaces admin_ug_auth.php then I don't think there is anything I can do to this MOD to make it compatible. Sorry :(


pat gullett wrote: Really need this MOD. However, when trying to download it, I get an error that says the file no longer exists.
Any suggestions?


Where are you trying to download it from? The link in the first post of this thread works OK for me.


C2 wrote: Even after using this mod, my phpbb still won't remember passwords and user names.


This MOD doesn't affect phpbb's ability to remember passwords or usernames, it simply stops firefox from filling in your username & password when administering users

pat gullett
Registered User
Posts: 7
Joined: Fri Mar 24, 2006 3:41 pm

Post by pat gullett » Fri Apr 14, 2006 1:35 pm

TOny wrote: Where are you trying to download it from? The link in the first post of this thread works OK for me.


I am attempting to get it from the link in the first post, same as you. When I click it, I get the waiting to download screen, then a message that the file no longer exists. Strange thing is, I can download and have, other files from phpbb.com without any problems. It's only this file.

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Fri Apr 14, 2006 2:19 pm

pat gullett wrote: I am attempting to get it from the link in the first post, same as you. When I click it, I get the waiting to download screen, then a message that the file no longer exists. Strange thing is, I can download and have, other files from phpbb.com without any problems. It's only this file.


I've just tried it again and it takes me to a page saying "Downloading fix_firefox_pwd_1.2.1.mod in 5 seconds..." and then get re-directed to http://www.phpbb.com/files/mods/fix_fir ... _1.2.1.mod which downloads OK!

Try going directly to the file using the above link and see if that works :?

mikeyb987
Registered User
Posts: 21
Joined: Thu Apr 13, 2006 5:17 am

Post by mikeyb987 » Sun Apr 16, 2006 10:18 pm

So I tried this mod and I still have my user name in where it should say the username of the person that I looked up. I changed all 4 of the files like stated in the mod saved them and then used ftp to put them back in. I then went to my site and the problem is still happening? Do I need to do something with my cookies in firefox or something. Thanks for the mods- Thanks Mike

I'm using firefox
godaddy server
phpBB2 2.0.20
No mods other than this one!!

mikeyb987
Registered User
Posts: 21
Joined: Thu Apr 13, 2006 5:17 am

Post by mikeyb987 » Mon Apr 17, 2006 12:31 am

Sorry- I found out why! I just made the mods to the subzero template and not the genElectro template I was using! Thanks for your awesome Mod!! Mike

User avatar
drumstix42
Registered User
Posts: 1100
Joined: Tue Sep 24, 2002 11:01 pm
Location: NJ
Contact:

Post by drumstix42 » Mon Apr 17, 2006 1:49 am

Thanks much for this mod. Helps out a bunch.
Need a phpBB update or mod installed? PM me for any questions and pricing!
HostMonster.com (Unlimited Space, Unlimited Transfer, Unlimited Domains, $6.95/month )

ravelink69
Registered User
Posts: 95
Joined: Thu Mar 16, 2006 4:28 am

Post by ravelink69 » Thu Apr 27, 2006 10:29 pm

i installed this mod and got this error in the left frame of the admin control pannel.

Parse error: parse error, unexpected $ in /home/linkn2/public_html/phpbb2/admin/admin_ug_auth.php on line 774


all fine and dandy, ill just go fix it...well, come to find out there are only about 728 lines in the php file....so how can it be reading a 774th line, i counted 2 times and my moderators (2 of them) counted once each. any suggestions on how to fix this?


Im using :
Firefox v. 1.5.0.2
phpbb2.0.19

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Fri Apr 28, 2006 12:23 am

ravelink69 wrote: admin/admin_ug_auth.php on line 774
all fine and dandy, ill just go fix it...well, come to find out there are only about 728 lines in the php file....so how can it be reading a 774th line, i counted 2 times and my moderators (2 of them) counted once each. any suggestions on how to fix this?

Im using :
Firefox v. 1.5.0.2
phpbb2.0.19


Absolutely no idea :(

The standard 2.0.19 admin_ug_auth.php has 999 lines, this mod adds 4 lines immediately after line 41. If you have no other MODs installed you could try re-uploading a clean version of the file.

ravelink69
Registered User
Posts: 95
Joined: Thu Mar 16, 2006 4:28 am

Post by ravelink69 » Fri Apr 28, 2006 7:19 pm

ok, i reuploaded that file...and it now has more lines. but im still getting this error even after i reinstalled everything.

Parse error: parse error, unexpected $ in /home/linkn2/public_html/phpbb2/admin/admin_ug_auth.php on line 773

so here is line 772-774 of my file.

$auth_access[$forum_id], $is_admin) : 0;
$auth_field_acl[$forum_id][$key] =
$auth_ug[$forum_id][$key];

User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Post by T0ny » Fri Apr 28, 2006 8:52 pm

ravelink69 wrote: ok, i reuploaded that file...and it now has more lines. but im still getting this error even after i reinstalled everything.

Parse error: parse error, unexpected $ in /home/linkn2/public_html/phpbb2/admin/admin_ug_auth.php on line 773

so here is line 772-774 of my file.

$auth_access[$forum_id], $is_admin) : 0;
$auth_field_acl[$forum_id][$key] =
$auth_ug[$forum_id][$key];


The only thing I can find in admin_ug_auth that looks anything like that is lines 656-658:

Code: Select all

case AUTH_ACL:
					$auth_ug[$forum_id][$key] = ( !empty($auth_access_count[$forum_id]) ) ? check_auth(AUTH_ACL, $key, $auth_access[$forum_id], $is_admin) : 0;
					$auth_field_acl[$forum_id][$key] = $auth_ug[$forum_id][$key];
it looks like that last line has been split (in your version) at the equals sign. You're not using something like dreamweaver or frontpage to upload, are you?

ravelink69
Registered User
Posts: 95
Joined: Thu Mar 16, 2006 4:28 am

Post by ravelink69 » Fri Apr 28, 2006 9:08 pm

no i upload through cpanel X. i pressed the enter on my keyboard to make the 3 lines look as they do on my cpanel. when i cut and pasted the 3 lines it combined the last 2 lines into one line so it isnt really split at all.

Post Reply

Return to “[2.0.x] MOD Database Releases”