My Quick Reply

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
55
66%
Very Good
10
12%
Good
7
8%
Fair
2
2%
Poor
9
11%
 
Total votes: 83

cornick
Registered User
Posts: 142
Joined: Fri May 19, 2006 12:55 am
Location: New York
Contact:

Re: [2.0.21] My Quick Reply

Post by cornick » Thu Sep 13, 2007 9:22 am

I'm getting a strange problem and can't figure out how to fix it.

Image

I've got some comment arrows showing up next to the quick reply button and the button doesn't work.

Can't seem to figure this out, I know it's a coding error but which file?

cornick
Registered User
Posts: 142
Joined: Fri May 19, 2006 12:55 am
Location: New York
Contact:

Re: [2.0.21] My Quick Reply

Post by cornick » Thu Sep 13, 2007 9:25 am

Nevermind, I'm an idiot. I thought I figured it out but when I uploaded the file it didn't work on the server. Helps if you change the directory on the server that the file needs to go to.

craigf136
Registered User
Posts: 9
Joined: Mon Feb 27, 2006 2:20 am

Re:

Post by craigf136 » Fri Sep 14, 2007 11:30 pm

smitjel wrote:Carefully review the edits to posting_smilies.tpl. It's tricky I'll admit, but it does work if you install it correctly. You could also install the web developer firefox extension and it will show you exactly what the javascript error is...post the error if you have to.

Also, if you've got mods installed that mess with the smilies you might have a different issue.
Hi, I've installed the mod and I had the same problem and I have resolved the smileys issue but the smilies will not work for firefox, the error reported by firefox error console is "emoticon is not defined"

In firefox, if you clikc on view smilies, the window pops up & clicking on the smilies doesn't insert them. This is also the same for view more emoticons when using the normal post reply option - this mod works for I.E. users no problem.

Any idea's as to why firefox is supplying the not defined error? - copy of posting_smilies.tpl included - using Saphic 1.5 template.

Code: Select all

<script language="javascript" type="text/javascript">
<!--
function emoticon(text) {
	text = ' ' + text + ' ';
	if (eval(opener.document.forms['post'].input)) {
		if (opener.document.forms['post'].input.createTextRange && opener.document.forms['post'].input.caretPos) {
			var caretPos = opener.document.forms['post'].input.caretPos;
			caretPos.text = caretPos.text.charAt(caretPos.text.length - 1) == ' ' ? text + ' ' : text;
			opener.document.forms['post'].input.focus();
		} else {
		opener.document.forms['post'].input.value  += text;
		opener.document.forms['post'].input.focus();
		}
	}
	else {
	if (opener.document.forms['post'].message.createTextRange && opener.document.forms['post'].message.caretPos) {
		var caretPos = opener.document.forms['post'].message.caretPos;
		caretPos.text = caretPos.text.charAt(caretPos.text.length - 1) == ' ' ? text + ' ' : text;
		opener.document.forms['post'].message.focus();
	} else {
	opener.document.forms['post'].message.value  += text;
   opener.document.forms['post'].message.focus();}
   }
}
/-->
</script>

<table width="100%" border="0" cellspacing="0" cellpadding="10" class="bodyline">
	<tr>
		<td><table width="100%" border="0" cellspacing="1" cellpadding="4" class="forumline">
			<tr>
				<th class="thHead" height="25">{L_EMOTICONS}</th>
			</tr>
			<tr>
				<td  class="row1"><table width="100" border="0" cellspacing="0" cellpadding="5">
					<!-- BEGIN smilies_row -->
					<tr align="center" valign="middle"> 
						<!-- BEGIN smilies_col -->
						<td><a href="javascript:emoticon('{smilies_row.smilies_col.SMILEY_CODE}')"><img src="{smilies_row.smilies_col.SMILEY_IMG}" border="0" alt="{smilies_row.smilies_col.SMILEY_DESC}" title="{smilies_row.smilies_col.SMILEY_DESC}" /></a></td>
						<!-- END smilies_col -->
					</tr>
					<!-- END smilies_row -->
					<!-- BEGIN switch_smilies_extra -->
					<tr align="center"> 
						<td colspan="{S_SMILIES_COLSPAN}"  class="row1"><span  class="nav"><a href="{U_MORE_SMILIES}" onclick="open_window('{U_MORE_SMILIES}', 250, 300);return false" target="_smilies" class="nav">{L_MORE_SMILIES}</a></td>
					</tr>
					<!-- END switch_smilies_extra -->
				</table></td>
			</tr>
			<tr>
				<td align="center" class="row1"><br /><span class="genmed"><a href="javascript:window.close();" class="genmed">{L_CLOSE_WINDOW}</a></span></td>
			</tr>
		</table></td>
	</tr>
</table>

smitjel
Registered User
Posts: 461
Joined: Sat Jun 11, 2005 11:40 pm
Location: Birmingham, AL

Re: Re:

Post by smitjel » Tue Sep 18, 2007 5:35 pm

craigf136 wrote:Hi, I've installed the mod and I had the same problem and I have resolved the smileys issue but the smilies will not work for firefox, the error reported by firefox error console is "emoticon is not defined"

In firefox, if you clikc on view smilies, the window pops up & clicking on the smilies doesn't insert them. This is also the same for view more emoticons when using the normal post reply option - this mod works for I.E. users no problem.

Any idea's as to why firefox is supplying the not defined error? - copy of posting_smilies.tpl included - using Saphic 1.5 template.
You simply installed it wrong...not by much though. And the reason you're seeing different results with the two browsers is because IE is so stupid it doesn't care about the error in your javascript. Here's the correct javascript function (I think yours is missing a '}'):

Code: Select all

<script language="javascript" type="text/javascript">
<!--
function emoticon(text) {
	text = ' ' + text + ' ';
	if (eval(opener.document.forms['post'].input)) {
		if (opener.document.forms['post'].input.createTextRange && opener.document.forms['post'].input.caretPos) {
			var caretPos = opener.document.forms['post'].input.caretPos;
			caretPos.text = caretPos.text.charAt(caretPos.text.length - 1) == ' ' ? text + ' ' : text;
			opener.document.forms['post'].input.focus();
		} else {
		opener.document.forms['post'].input.value  += text;
		opener.document.forms['post'].input.focus();
		}
        }
	}
	else {
	if (opener.document.forms['post'].message.createTextRange && opener.document.forms['post'].message.caretPos) {
		var caretPos = opener.document.forms['post'].message.caretPos;
		caretPos.text = caretPos.text.charAt(caretPos.text.length - 1) == ' ' ? text + ' ' : text;
		opener.document.forms['post'].message.focus();
	} else {
	opener.document.forms['post'].message.value  += text;
	opener.document.forms['post'].message.focus();
	}
}
//-->
</script>
My Quick Reply MOD for phpBB2

craigf136
Registered User
Posts: 9
Joined: Mon Feb 27, 2006 2:20 am

Re: [2.0.21] My Quick Reply

Post by craigf136 » Tue Sep 18, 2007 7:49 pm

Still doesn't work I'm afraid.

smitjel
Registered User
Posts: 461
Joined: Sat Jun 11, 2005 11:40 pm
Location: Birmingham, AL

Re: [2.0.21] My Quick Reply

Post by smitjel » Tue Sep 18, 2007 8:02 pm

craigf136 wrote:Still doesn't work I'm afraid.
I've tested this on as many browsers as I could get my hands on...it works.

Check to see if you don't have any other mods installed that might be conflicting with this one. I wish I could help...
My Quick Reply MOD for phpBB2

blazenkitty
Registered User
Posts: 3
Joined: Thu Sep 20, 2007 12:54 am

Re: [2.0.21] My Quick Reply

Post by blazenkitty » Tue Sep 25, 2007 1:29 am

I was wondering if there was any way to get this to work on something other then subsilver

smitjel
Registered User
Posts: 461
Joined: Sat Jun 11, 2005 11:40 pm
Location: Birmingham, AL

Re: [2.0.21] My Quick Reply

Post by smitjel » Tue Sep 25, 2007 2:39 am

blazenkitty wrote:I was wondering if there was any way to get this to work on something other then subsilver
It will work on any template. You just have to write the html that fits into your template.
My Quick Reply MOD for phpBB2

Sultani
Registered User
Posts: 125
Joined: Wed Dec 13, 2006 8:42 pm
Location: California, Orange County
Contact:

Re: [2.0.21] My Quick Reply

Post by Sultani » Mon Oct 01, 2007 7:53 pm

Hi there, i installed this mod and he just dont work, i cant figure it out where i messed up the code, i guess it could be on viewtopic_body.tpl file.

Im using Morpheus on my forum!

Heres what i get on the end:

Image
Even if i click on the link that says: Quick Reply i dont get anything at all!

Hope someone could help me, cause im trying to get this mod installed since one year ago!

thanks in advance
Scraablee - Free Flash Games!

Sorry for my bad english ( Im american ) :D

smitjel
Registered User
Posts: 461
Joined: Sat Jun 11, 2005 11:40 pm
Location: Birmingham, AL

Re: [2.0.21] My Quick Reply

Post by smitjel » Mon Oct 01, 2007 8:17 pm

If the form doesn't appear when you click the link, more than likely you have a javascript error. Check your edits, especially to overall_header.tpl.
My Quick Reply MOD for phpBB2

Sultani
Registered User
Posts: 125
Joined: Wed Dec 13, 2006 8:42 pm
Location: California, Orange County
Contact:

Re: [2.0.21] My Quick Reply

Post by Sultani » Mon Oct 01, 2007 8:36 pm

smitjel wrote:If the form doesn't appear when you click the link, more than likely you have a javascript error. Check your edits, especially to overall_header.tpl.

This is what i have made on overall_header.tpl:
<!-- BEGIN switch_enable_pm_popup -->
<script language="Javascript" type="text/javascript">
<!--
/*
if ( {PRIVATE_MESSAGE_NEW_FLAG} )
{
window.open('{U_PRIVATEMSGS_POPUP}', '_phpbbprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');;
}
*/
//-->
</script>
<!-- END switch_enable_pm_popup -->
<link rel="alternate" title="{L_RSS}" href="{U_RSS}" type="application/rss+xml">
<!-- My Quick Reply Mod -->
<script language="javascript" type="text/javascript">
function qr_show_hide() {
var id = 'qr_open';
var item = null;

if (document.getElementById) {
item = document.getElementById(id);
}
else if (document.all) {
item = document.all[id];
}
else if (document.layers) {
item = document.layers[id];
}

if (item && item.style) {
if (item.style.display == "none") {
item.style.display = "";
}
else {
item.style.display = "none";
}
}
else if (item) {
item.visibility = "show";
}
}
</script>
<!-- My Quick Reply Mod -->

</head>
I might could messed up on viewtopic_body.tpl, cause it´s to hard to apply this mod, on the morpheus theme, i opened the same file from subsilver to compare the location of the code, but it´s still to hard to figure it out!

This is the code from viewtopic_body.tpl:

Code: Select all

<!-- IF C_PM --><!-- DEFINE $CA_NEW_MSGS = true --><!-- ENDIF -->
{TPL_CONTENT_TOPNAV1}<table border="0" cellspacing="0" cellpadding="0" width="100%">
<tr>
	<td align="left" class="navbar-links"><a href="{U_INDEX}">{L_INDEX}</a> &raquo; <a href="{U_VIEW_FORUM}">{FORUM_NAME}</a></td>
	<td align="right" class="navbar-text">{CURRENT_TIME}</td>
</tr>
</table><!-- IF $CA_NEW_MSGS -->{TPL_CONTENT_TOPNAV2_PM}<!-- ELSE -->{TPL_CONTENT_TOPNAV2}<!-- ENDIF -->
<!-- IF $CA_NEW_MSGS --><!-- INCLUDE newpm.tpl --><!-- ENDIF -->

<table width="100%" cellspacing="0" cellpadding="2" border="0">
  <tr> 
    <td width="25%" rowspan="2" align="left" valign="bottom"><p><a target=_blank href="http://www.desinibidas.com/sendtopic/tell.cgi" onClick="window.open('http://www.desinibidas.com/sendtopic/tell.cgi?referer='+escape(window.location.href),'','width=450,height=450,status=1');return false;"><img src="http://www.desinibidas.com/forum/templates/MorpheusXPink/images/sendto.gif" width="181" height="18"></a><br>      
        <br>       
        <a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a> &nbsp; <a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a>
        </p>
    </p>
    </td>
	<td width="50%" rowspan="2" align="center" valign="top"><p><span class="gen">        <!-- IF $CA_NEW_MSGS -->
        <!-- ENDIF -->
        <a href="{U_VIEW_TOPIC}"><b><font size="4">{TOPIC_TITLE}</font></b></a></span><br>
    
	    <br>
	<!-- AddToBookmarks.com JS Settings - Place this in the body, at the top -->
			<script language="JavaScript" type="text/javascript">
				var addtoLayout=0;						// 0=Horizontal 1 row, 1=Horizontal 2 rows, 2=Vertical, 3=Vertical text only 
				var addtoMethod=1;						// 0=direct link, 1=popup window
				var AddURL = document.location.href;	// this is the page's URL
				var AddTitle = escape(document.title);	// this is the page title
			</script>
			<!-- End AddToBookmarks.com JS Settings -->
			
			<!-- AddToBookmarks.com JS - Place this where you want it to display -->
			<script language="JavaScript" src="addto/addto.js" type="text/javascript"></script>
	  <!-- End AddToBookmarks.com JS -->
	  <br>
        <script language='JavaScript' type='text/javascript' src='http://www.scraablee.com/rotate/adx.js'></script>
        <script language='JavaScript' type='text/javascript'>
<!--
   if (!document.phpAds_used) document.phpAds_used = ',';
   phpAds_random = new String (Math.random()); phpAds_random = phpAds_random.substring(2,11);
   
   document.write ("<" + "script language='JavaScript' type='text/javascript' src='");
   document.write ("http://www.scraablee.com/rotate/adjs.php?n=" + phpAds_random);
   document.write ("&what=zone:13");
   document.write ("&exclude=" + document.phpAds_used);
   if (document.referrer)
      document.write ("&referer=" + escape(document.referrer));
   document.write ("'><" + "/script>");
//-->
        </script>
        <a href='http://www.scraablee.com/rotate/adclick.php?n=a8d17a51' target='_blank'><img src='http://www.scraablee.com/rotate/adview.php?what=zone:13&n=a8d17a51' border='0' alt=''></a>	  </td>
    <td colspan="2" align="right" valign="bottom"><div align="center"></div>
	   <form action="{CA_SEARCH_INDEX}" method="post" class="inline-form"><input type="hidden" name="show_results" value="topics" /><input type="hidden" name="search_forum" value="{CA_SEARCH_FORUM}" />
		 <input type="text" name="search_keywords" class="post" size="15" />
		 <input type="submit" value="{L_SEARCH}" class="mainoption" />
	</form>
	   <p>&nbsp;</p>
    <p><span class="pagination">{PAGINATION}</span></p></td>
  </tr>
  <tr>
    <td width="9%" align="right" valign="bottom"><div align="left"></div></td>
    <td width="16%" align="right" valign="bottom">{TOPIC_TAGS}</td>
  </tr>
</table>

{POLL_DISPLAY} 

<?php

global $userdata, $board_config, $topic_id, $is_auth, $forum_topic_data, $lang, $phpEx;

if(!isset($can_reply))
{
	$can_reply = $this->style_config['quick_reply'] && $userdata['session_logged_in'] ? true : false;
	if($can_reply)
	{
		$is_auth_type = 'auth_reply';
		if(!$is_auth[$is_auth_type])
		{
			$can_reply = false;
		}
		elseif ( ($forum_topic_data['forum_status'] == FORUM_LOCKED || $forum_topic_data['topic_status'] == TOPIC_LOCKED) && !$is_auth['auth_mod'] ) 
		{
			$can_reply = false;
		}
	}
	if($can_reply)
	{
		$this->assign_block_vars('xs_quick_reply', array());
	}
}

$postrow_count = ( isset($this->_tpldata['postrow.']) ) ?  sizeof($this->_tpldata['postrow.']) : 0;
for ($postrow_i = 0; $postrow_i < $postrow_count; $postrow_i++)
{
	$postrow_item = &$this->_tpldata['postrow.'][$postrow_i];
	// set profile link and search button
	if(!empty($postrow_item['PROFILE']) && strpos($postrow_item['POSTER_NAME'], '<') === false)
	{
		$postrow_item['SEARCH_IMG2'] = str_replace('%s', htmlspecialchars($postrow_item['POSTER_NAME']), $postrow_item['SEARCH_IMG']);
		if($this->vars['TPL_CFG_TOPICVIEW'] !== 'hide')
		{
			$search = array($lang['Read_profile'], '<a ');
			$replace = array($postrow_item['POSTER_NAME'], '<a class="name" ');
			$postrow_item['POSTER_NAME'] = str_replace($search, $replace, $postrow_item['PROFILE']);
		}
	}
	// check for new post
	$new_post = strpos($postrow_item['MINI_POST_IMG'], '_new') > 0 ? true : false;
	$postrow_item['TPL_HDR1'] = $new_post ? $this->vars['TPL_HDR1_NEW'] : $this->vars['TPL_HDR1_POST'];
	$postrow_item['TPL_HDR2'] = $new_post ? $this->vars['TPL_HDR2_NEW'] : $this->vars['TPL_HDR2'];
	$postrow_item['TPL_FTR'] = $new_post ? $this->vars['TPL_FTR_NEW'] : $this->vars['TPL_FTR'];
	// set backgrounds
	$num = ($postrow_i % 2) + 1;
	$postrow_item['TPL_CLASS_POST'] = 'post' . $num;
	$postrow_item['TPL_CLASS_PROFILE'] = 'post-left' . $num;
}	

?>

<!-- IF TPL_CFG_TOPICVIEW == "above" --><!-- INCLUDE viewtopic_post_above.tpl --><!-- ENDIF -->

<!-- IF TPL_CFG_TOPICVIEW == "left" --><!-- INCLUDE viewtopic_post_left.tpl --><!-- ENDIF -->
<!-- IF TPL_CFG_TOPICVIEW == "right" --><!-- INCLUDE viewtopic_post_right.tpl --><!-- ENDIF -->
<!-- IF TPL_CFG_TOPICVIEW == "hide" --><!-- INCLUDE viewtopic_post_none.tpl --><!-- ENDIF -->


{TPL_HDR1_ORANGE} <a href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a>{TPL_HDR2}
<table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0">
<tr>
	<td class="row1g" align="left" valign="top">
	<table border="0" cellspacing="0" cellpadding="5" width="100%">
	<tr>
		<td width="26%" align="left" valign="top">
			<span class="gensmall">{S_AUTH_LIST}</span>
		</td>
		<td width="52%" align="center" valign="middle"><p>{TOPIC_TAGS}
	</p>
		  <p>
		    <!-- AddToBookmarks.com JS Settings - Place this in the body, at the top -->
            <script language="JavaScript" type="text/javascript">
				var addtoLayout=0;						// 0=Horizontal 1 row, 1=Horizontal 2 rows, 2=Vertical, 3=Vertical text only 
				var addtoMethod=1;						// 0=direct link, 1=popup window
				var AddURL = document.location.href;	// this is the page's URL
				var AddTitle = escape(document.title);	// this is the page title
			</script>
            <!-- End AddToBookmarks.com JS Settings -->
            <!-- AddToBookmarks.com JS - Place this where you want it to display -->
            <script language="JavaScript" src="addto/addto.js" type="text/javascript"></script>
            <!-- End AddToBookmarks.com JS -->
&nbsp; <br>
<span class="gensmall">{PAGE_NUMBER}</span><br>
<span class="pagination">{PAGINATION}</span></td>
	    <td width="22%" align="right" valign="top"><span class="gensmall">{S_TIMEZONE}&nbsp;&nbsp;<br />
&nbsp;&nbsp;</span>
          
          <strong>{U_BOOKMARK}</strong><br />
          <span class="gensmall">{S_WATCH_TOPIC}</span> <br>
          <a target=_blank href="http://www.desinibidas.com/sendtopic/tell.cgi" onClick="window.open('http://www.desinibidas.com/sendtopic/tell.cgi?referer='+escape(window.location.href),'','width=390,height=430,status=1');return false;"><font size="2" face="Verdana, Arial, Helvetica, sans-serif"><strong>Send
          this topic to your friends</strong></font></a> </td>
	</tr>
	</table>
	</td>
</tr>
<tr>
	<td class="catBottom" align="center" valign="middle" nowrap="nowrap"><table border="0" cellspacing="0" cellpadding="2" width="100%">
	<tr>
		<td align="left" valign="middle" nowrap="nowrap"><form method="post" action="{S_POST_DAYS_ACTION}" style="display: inline;">{S_SELECT_POST_DAYS}&nbsp;{S_SELECT_POST_ORDER}&nbsp;<input type="submit" value="{L_GO}" class="liteoption" name="submit" /></form></td>
		<td align="right" valign="middle" nowrap="nowrap"><strong>Jump to:</strong> {JUMPBOX}</td>
	</tr>
	</table>
	</td>
</tr>
</table>{TPL_FTR}

<table border="0" cellspacing="0" cellpadding="0" width="100%">
<tr>
	<td align="left" valign="middle" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a>
	<!-- BEGIN switch_my_quick_reply -->
	&nbsp;&nbsp;<a href="javascript:qr_show_hide();"><img src="{QUICK_REPLY_IMG}" border="0" alt="{L_QUICK_REPLY}" align="middle" /></a>
	<!-- END switch_my_quick_reply -->	
	</span></td>
&nbsp;	<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></td>
	<td align="right" valign="top" style="padding-top: 5px;">{S_TOPIC_ADMIN}&nbsp;</td>
</tr>
</table>
<div id="quick_reply" style="display: none; position: relative; "><form action="<?php echo append_sid('posting.'.$phpEx); ?>" method="post" name="post" style="display: inline;">{S_HIDDEN_FIELDS}{TPL_HDR1}{CA_QR_BUTTON}{TPL_HDR2}<table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0">
<tr> 
	<td class="row1" width="200" nowrap="nowrap"><span class="gen"><b><?php echo $lang['Subject']; ?>:</b></span></td>
	<td class="row2" width="100%"><input type="text" name="subject" size="45" maxlength="60" style="width:98%" tabindex="2" class="post" value="" /></td>
</tr>
<tr> 
	<td class="row1" width="200" nowrap="nowrap"><span class="gen"><b><?php echo $lang['Message_body']; ?>:<br /><img src="{T_TEMPLATE_PATH}/images/spacer.gif" width="200" height="1" border="0" alt="" /></b></span></td>
	<td class="row2" width="100%"><textarea name="message" rows="15" cols="35" style="width:98%" tabindex="3" class="post"></textarea><br />
			  <a href="javascript:void(0);" onclick="window.open('http://www.postimage.org/index.php?mode=phpbb&tpl=' + 'MorpheusXPink' + '&forumurl=' + escape(document.location.href), '_imagehost', 'resizable=yes,width=500,height=400');return false;">Add image to post</a></td>
</tr>
<tr> 
	<td class="row1" valign="top" nowrap="nowrap"><span class="gen"><b><?php echo $lang['Options']; ?>:</b></span></td>
	<td class="row2"><span class="genmed">
	<?php 
		$user_sig = ( $userdata['user_sig'] != '' && $board_config['allow_sig'] ) ? $userdata['user_sig'] : '';
		$html_on = $board_config['allow_html'] ? $userdata['user_allowhtml'] : 1;
		$bbcode_on = $board_config['allow_bbcode'] ? $userdata['user_allowbbcode'] : 0;
		$smilies_on = $board_config['allow_smilies'] ? $userdata['user_allowsmile'] : 0;
	?>
	<?php if($board_config['allow_html']) { ?>
	<label><input type="checkbox" name="disable_html" <?php echo ($html_on ? '' : 'checked="checked"'); ?> /> <span class="genmed"><?php echo $lang['Disable_HTML_post']; ?></span></label><br />
	<?php } else { ?><input type="hidden" name="disable_html" value="checked" /><?php } ?>
	<?php if($board_config['allow_bbcode']) { ?>
	<label><input type="checkbox" name="disable_bbcode" <?php echo ($bbcode_on ? '' : 'checked="checked"'); ?> /> <span class="genmed"><?php echo $lang['Disable_BBCode_post']; ?></span></label><br />
	<?php } else { ?><input type="hidden" name="disable_bbcode" value="checked" /><?php } ?>
	<?php if($board_config['allow_smilies']) { ?>
	<label><input type="checkbox" name="disable_smilies" <?php echo ($smilies_on ? '' : 'checked="checked"'); ?>  /> <span class="genmed"><?php echo $lang['Disable_Smilies_post']; ?></span></label><br />
	<?php } else { ?><input type="hidden" name="disable_smilies" value="checked" /><?php } ?>
	<?php if($user_sig) {  ?>
	<label><input type="checkbox" name="attach_sig" <?php echo ($userdata['user_attachsig'] ? 'checked="checked"' : ''); ?> /> <span class="genmed"><?php echo $lang['Attach_signature']; ?></span></label><br />
	<?php } else { ?><input type="hidden" name="attach_sig" value="" /><?php } ?>
	<label><input type="checkbox" name="notify" <?php echo ($userdata['user_notify'] ? 'checked="checked"' : ''); ?> /> <span class="genmed"><?php echo $lang['Notify']; ?></span></label><br />
	</span></td>
</tr>
<tr> 
	<td class="catBottom" colspan="2" align="center" height="25"> <input type="hidden" name="mode" value="reply" /><input type="hidden" name="t" value="<?php echo $topic_id; ?>" /><input type="submit" accesskey="s" tabindex="6" name="post" class="mainoption" value="<?php echo $lang['Submit']; ?>" />&nbsp;<input type="submit" tabindex="5" name="preview" class="mainoption" value="<?php echo $lang['Preview']; ?>" /></td>
</tr><!-- BEGIN switch_my_quick_reply -->
	<script type="text/javascript">
	function checkForm() {
		formErrors = false;
		document.post.message.value = '';
		if (document.post.input.value.length < 2) {
			formErrors = '{MQR_EMPTY_MESSAGE}';
		}
		if (formErrors) {
			alert(formErrors);
			return false;
		} else {
			if (document.post.quick_quote.checked) {
				document.post.message.value = document.post.last_msg.value;
			}
			document.post.message.value += document.post.input.value;
			return true;
		}
	}
	</script>
	<form action="{MQR_FORM_ACTION}" method="post" name="post" onsubmit="return checkForm()">
	<tbody id="qr_open" style="display:none; position:relative;">
	<tr>
		<th class="thLeft" height="26" nowrap="nowrap" width="150">{MQR_LANG_OPTIONS}</th>
		<th class="thRight" nowrap="nowrap">{MQR_LANG_QUICK_REPLY}</th>
	</tr>
	<tr>
		<td class="row1 gensmall" align="left" valign="middle" width="150">
			<a href="{MQR_SMILIES_URL}" onclick="window.open('{MQR_SMILIES_URL}', '_phpbbsmilies', 'HEIGHT=300,resizable=yes,scrollbars=yes,WIDTH=250');return false;" target="_phpbbsmilies">{MQR_LANG_SHOW_SMILIES}</a><br /><br />
			<input type="checkbox" name="quick_quote" />{MQR_QUOTE_LAST_POST}
			<!-- BEGIN switch_member_functions -->
			<br /><input type="checkbox" name="attach_sig" {switch_my_quick_reply.switch_member_functions.MQR_ATTACH_SIG_STATUS} />{switch_my_quick_reply.switch_member_functions.MQR_ATTACH_SIG}
			<!-- END switch_member_functions -->
		</td>
		<input type="hidden" name="mode" value="reply" />
		<input type="hidden" name="sid" value="{MQR_SESSION_ID}" />
		<input type="hidden" name="t" value="{MQR_TOPIC_ID}" />
		<input type="hidden" name="message" value="" />
		<input type="hidden" name="last_msg" value='{MQR_LAST_MSG}' />
		<td class="row1" valign="top">
			<table width="100%" border="0" cellspacing="0" cellpadding="0">
				<tr>
					<td class="row1" valign="top">
						<textarea name="input" cols="70" rows="7" wrap="virtual" style="width:100%" class="post"></textarea>
						<table width="100%" border="0" cellspacing="0" cellpadding="0">
							<tr align="center">
							<td>
								<input type="submit" name="preview" class="liteoption" value="{MQR_LANG_PREVIEW}" />&nbsp;<input type="submit" name="post" class="mainoption" value="{MQR_LANG_SUBMIT}" />
							</td>
							</tr>
						</table>
					</td>
				</tr>
			</table>
		</td>
	</tr>
	</tbody>
	</form>
	<!-- END switch_my_quick_reply -->
{TPL_FTR}
</form></div>


{TPL_CONTENT_BOTTOMNAV1}<table border="0" cellspacing="0" cellpadding="0" width="100%">
<tr>
	<td align="left" class="navbar-links"><a href="{U_INDEX}">{L_INDEX}</a> &raquo; <a href="{U_VIEW_FORUM}">{FORUM_NAME}</a></td>
	<td align="right" class="navbar-text">{CURRENT_TIME}</td>
</tr>
</table>{TPL_CONTENT_BOTTOMNAV2}
I can assure that the rest of the files, are correctly edited, but about the viewtopic_body.tpl file, i have almost sure that is something messed up, cause i made this part of the process kinda blind..

Any help would be awesome, thanks
Scraablee - Free Flash Games!

Sorry for my bad english ( Im american ) :D

pjjacobs
Registered User
Posts: 179
Joined: Wed Nov 15, 2006 8:08 pm

Re: [2.0.21] My Quick Reply

Post by pjjacobs » Thu Oct 04, 2007 10:52 am

Having similar problems on my board

Using the Xand style

this is what it looks like standard
Image

and after i installed the mod(several times) and double checked everything is done correctly
Image

Please any advice or if you want me to post some code etc

smitjel
Registered User
Posts: 461
Joined: Sat Jun 11, 2005 11:40 pm
Location: Birmingham, AL

Re: [2.0.21] My Quick Reply

Post by smitjel » Thu Oct 04, 2007 2:03 pm

pjjacobs wrote:Having similar problems on my board

Using the Xand style

Please any advice or if you want me to post some code etc
I have no way of knowing if it's done "correctly"...I've only written the integration into the subSilver template.
My Quick Reply MOD for phpBB2

User avatar
MaidenFan
Registered User
Posts: 43
Joined: Mon Dec 12, 2005 3:33 pm
Location: Aberystwyth, Wales, UK
Contact:

Re: [2.0.21] My Quick Reply

Post by MaidenFan » Sun Oct 07, 2007 1:42 am

Having just installed the MOD and experienced the same problem that the posters above have (namely that the quick reply box is aligned to the right - I found out why.

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/viewtopic_body.tpl

#
#-----[ FIND ]------------------------------------------
#
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0" align="center">
When you add the mass of HTML that's after that FIND command, make sure you add it before the "</table>" and not in between the "</table>" and the "<table width="100%" .... >" code. All I did was just very carefully check through the MOD instructions :)
Personal Site & Blog | Last.fm
erno @ Bash.org wrote:I've lost a machine.. literally _lost_. it responds to ping, it works completely, I just can't figure out where in my apartment it is.

Sultani
Registered User
Posts: 125
Joined: Wed Dec 13, 2006 8:42 pm
Location: California, Orange County
Contact:

Re: [2.0.21] My Quick Reply

Post by Sultani » Mon Oct 08, 2007 3:15 am

MaidenFan wrote:Having just installed the MOD and experienced the same problem that the posters above have (namely that the quick reply box is aligned to the right - I found out why.

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/viewtopic_body.tpl

#
#-----[ FIND ]------------------------------------------
#
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0" align="center">
When you add the mass of HTML that's after that FIND command, make sure you add it before the "</table>" and not in between the "</table>" and the "<table width="100%" .... >" code. All I did was just very carefully check through the MOD instructions :)

lol i put this peace of code before, betwen, after and nothing..or worst, the tables get messed :S

If anyone could help i would be grateful, here is the code wih the modification:

<td class="catBottom" align="center" valign="middle" nowrap="nowrap"><table border="0" cellspacing="0" cellpadding="2" width="100%">
<tr>
<td align="left" valign="middle" nowrap="nowrap"><form method="post" action="{S_POST_DAYS_ACTION}" style="display: inline;">{S_SELECT_POST_DAYS}&nbsp;{S_SELECT_POST_ORDER}&nbsp;<input type="submit" value="{L_GO}" class="liteoption" name="submit" /></form></td>
<td align="right" valign="middle" nowrap="nowrap"><strong>Jump to:</strong> {JUMPBOX}</td>
</tr>
</table>
</td>
</tr>
<!-- BEGIN switch_my_quick_reply -->
<script type="text/javascript">
function checkForm() {
formErrors = false;
document.post.message.value = '';
if (document.post.input.value.length < 2) {
formErrors = '{MQR_EMPTY_MESSAGE}';
}
if (formErrors) {
alert(formErrors);
return false;
} else {
if (document.post.quick_quote.checked) {
document.post.message.value = document.post.last_msg.value;
}
document.post.message.value += document.post.input.value;
return true;
}
}
</script>
<form action="{MQR_FORM_ACTION}" method="post" name="post" onsubmit="return checkForm()">
<tbody id="qr_open" style="display:none; position:relative;">
<tr>
<th class="thLeft" height="26" nowrap="nowrap" width="150">{MQR_LANG_OPTIONS}</th>
<th class="thRight" nowrap="nowrap">{MQR_LANG_QUICK_REPLY}</th>
</tr>
<tr>
<td class="row1 gensmall" align="left" valign="middle" width="150">
<a href="{MQR_SMILIES_URL}" onclick="window.open('{MQR_SMILIES_URL}', '_phpbbsmilies', 'HEIGHT=300,resizable=yes,scrollbars=yes,WIDTH=250');return false;" target="_phpbbsmilies">{MQR_LANG_SHOW_SMILIES}</a><br /><br />
<input type="checkbox" name="quick_quote" />{MQR_QUOTE_LAST_POST}
<!-- BEGIN switch_member_functions -->
<br /><input type="checkbox" name="attach_sig" {switch_my_quick_reply.switch_member_functions.MQR_ATTACH_SIG_STATUS} />{switch_my_quick_reply.switch_member_functions.MQR_ATTACH_SIG}
<!-- END switch_member_functions -->
</td>
<input type="hidden" name="mode" value="reply" />
<input type="hidden" name="sid" value="{MQR_SESSION_ID}" />
<input type="hidden" name="t" value="{MQR_TOPIC_ID}" />
<input type="hidden" name="message" value="" />
<input type="hidden" name="last_msg" value='{MQR_LAST_MSG}' />
<td class="row1" valign="top">
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td class="row1" valign="top">
<textarea name="input" cols="70" rows="7" wrap="virtual" style="width:100%" class="post"></textarea>
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr align="center">
<td>
<input type="submit" name="preview" class="liteoption" value="{MQR_LANG_PREVIEW}" />&nbsp;<input type="submit" name="post" class="mainoption" value="{MQR_LANG_SUBMIT}" />
</td>
</tr>
</table>
</td>
</tr>
</table>
</td>
</tr>
</tbody>
</form>
<!-- END switch_my_quick_reply -->


</table>{TPL_FTR}

<table border="0" cellspacing="0" cellpadding="0" width="100%">
<tr>
<td align="left" valign="middle" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a>
<!-- BEGIN switch_my_quick_reply -->
&nbsp;&nbsp;<a href="javascript:qr_show_hide();"><img src="{QUICK_REPLY_IMG}" border="0" alt="{L_QUICK_REPLY}" align="middle" /></a>
<!-- END switch_my_quick_reply -->
</span></td>
</td>
<td width="33%" align="left" valign="top" style="padding-top: 5px; padding-bottom: 5px;"><div align="center"><img src="http://desinibidas.com/forum/templates/ ... seta02.gif" width="15" height="15">&nbsp;&nbsp;<a href="{U_VIEW_OLDER_TOPIC}" class="nav">{L_VIEW_PREVIOUS_TOPIC}</a> :: <a href="{U_VIEW_NEWER_TOPIC}" class="nav">{L_VIEW_NEXT_TOPIC}</a>&nbsp;&nbsp;<img src="http://desinibidas.com/forum/templates/ ... seta01.gif" width="15" height="15"></div></td>
<td width="32%" align="right" valign="top" style="padding-top: 5px;">{S_TOPIC_ADMIN}&nbsp;</td>
</tr>
</table>
Where i go wrong? :roll:
Scraablee - Free Flash Games!

Sorry for my bad english ( Im american ) :D

Post Reply

Return to “[2.0.x] MOD Database Releases”