[2.0.19] Thank You Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
26
62%
Very Good
8
19%
Good
2
5%
Fair
2
5%
Poor
4
10%
 
Total votes: 42

dougle00
Registered User
Posts: 324
Joined: Mon Jul 10, 2006 5:34 pm
Contact:

Re: [2.0.19] Thank You Mod

Post by dougle00 » Sun Jan 27, 2008 12:06 am

Kinfule wrote:Try adding it IN-LINE after this line

Code: Select all

<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" alt="{L_POST_REPLY_TOPIC}" /></a> 
And IN-LINE Before

Code: Select all

{CA_QUICK_REPLY_BUTTON}
I made the change but it is not working. Here is the Viewtopic file any ideas where I may be going wrong?

Thanks

<div class="forumline nav-div">
<p class="nav-header">
<a href="{U_INDEX}">{L_INDEX}</a> &raquo; <a href="{U_VIEW_FORUM}">{FORUM_NAME}</a> &raquo; <a href="{U_VIEW_TOPIC}" class="nav-current">{TOPIC_TITLE}</a>
</p>
<div class="nav-links">
<div class="nav-links-left">
{CURRENT_TIME}
</div>
<a href="{U_VIEW_OLDER_TOPIC}">{L_VIEW_PREVIOUS_TOPIC}</a> | <a href="{U_VIEW_NEWER_TOPIC}">{L_VIEW_NEXT_TOPIC}</a>
</div>
</div>

<table width="100%" cellspacing="0" class="empty-table">
<tr>
<td align="left" valign="bottom"><a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" alt="{L_POST_REPLY_TOPIC}" /></a></td>
<td align="right" valign="bottom"><span class="gen">
{PAGE_NUMBER}<br />
<span class="pagination"><!-- Start add - Complete banner MOD -->
{BANNER_14_IMG}<br/>
<!-- End add - Complete banner MOD -->{PAGINATION}</span>
</span></td>
</tr>
</table>

<table class="forumline" width="100%" cellspacing="0">
<tr>
<td class="row-header" colspan="2"><span>{TOPIC_TITLE}</span></td>
</tr>
{POLL_DISPLAY}
<tr>
<th width="150">{L_AUTHOR}</th>
<th>{L_MESSAGE}</th>
</tr>
<!-- BEGIN postrow -->
<tr>
<td class="row-post-author">
<span class="post-name"><a name="{postrow.U_POST_ID}"></a>{postrow.POSTER_NAME}</span><br />
<span class="post-rank">{postrow.POSTER_RANK}<br /></span>
{postrow.RANK_IMAGE}
<span class="post-images">{postrow.POSTER_AVATAR}</span>
<div class="post-details">
{postrow.POSTER_JOINED}<br />
{postrow.POSTER_POSTS}<br />
{postrow.POSTER_FROM}<br/>{postrow.L_USER_GROUP}{postrow.L_NO_USER_GROUP}:&nbsp;{postrow.SHOW_USERGROUPS}{postrow.L_NO_USERGROUPS}
</div><br />
<img src="templates/ca_aphrodite/images/spacer.gif" width="150" height="1" alt="" />
</td>
<td class="row-post" width="100%">
<div class="post-buttons-top post-buttons">{postrow.ARROWS} <span class="img-main">{postrow.QUOTE_IMG}</span> {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}</div>
<div class="post-subject"><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" /></a> {postrow.POST_SUBJECT}&nbsp;</div>
<div class="post-text">
{postrow.MESSAGE}<br /><br />
<span class="gensmall">{postrow.EDITED_MESSAGE}</span>
{postrow.SIGNATURE}
</div>
</td>
</tr>
<tr>
<td class="row-post-date">{postrow.POST_DATE}</td>
<td class="row-post-buttons post-buttons"><span class="img-main">{postrow.PROFILE_IMG}</span> {postrow.PM_IMG} {postrow.EMAIL_IMG} {postrow.WWW_IMG} {postrow.AIM_IMG} {postrow.YIM_IMG} {postrow.MSN_IMG} {postrow.ICQ_IMG}</td>
</tr>
<tr>
<td class="spaceRow" colspan="2"><img src="templates/ca_aphrodite/images/spacer.gif" width="1" height="3" alt="" /></td>
</tr>
<!-- BEGIN thanks -->
<tr>
<td colspan="2" class="row2">
<table class="forumline" cellspacing="1" cellpadding="3" border="0" width="100%">
<tr>
<th class="thLeft">{postrow.thanks.THANKFUL}</th>
</tr>
<tr>
<td class="row2" valign="top" align="left">
<span id="hide_thank" style="display: block;" class="gensmall">
<a href="javascript: void(0);" onclick="document.all.show_thank.style.display = 'block';document.all.hide_thank.style.display = 'none'">{postrow.thanks.THANKS_TOTAL}</a> {postrow.thanks.THANKED}
</span>
<span id="show_thank" style="display: none;" class="gensmall">
{postrow.thanks.THANKS}&nbsp;
<br /><br /><div align="right"><a href="javascript: void(0);" onClick="document.all.show_thank.style.display = 'none';document.all.hide_thank.style.display = 'block'">[ {postrow.thanks.HIDE} ]</a></div>
</span>
</td>
</tr>
</table>
</td>
</tr>
<!-- END thanks -->

<!-- END postrow -->
<tr>
<td class="catBottom" colspan="2">
<form method="post" action="{S_POST_DAYS_ACTION}" style="display: inline;"><table cellspacing="0" cellpadding="0">
<tr>
<td valign="middle" nowrap="nowrap"><span class="genmed">{L_DISPLAY_POSTS}: </span></td>
<td valign="middle"> {S_SELECT_POST_DAYS} {S_SELECT_POST_ORDER} <input type="submit" value="{L_GO}" class="liteoption jumpbox" name="submit" /></td>
</tr></table></form>
</td>
</tr>
</table>

<div class="forumline nav-div">
<p class="nav-header">
<a href="{U_INDEX}">{L_INDEX}</a> &raquo; <a href="{U_VIEW_FORUM}">{FORUM_NAME}</a> &raquo; <a href="{U_VIEW_TOPIC}" class="nav-current">{TOPIC_TITLE}</a>
</p>
<div class="nav-links">
<div class="nav-links-left">
{CURRENT_TIME} | {S_TIMEZONE}
</div>
&nbsp;{S_WATCH_TOPIC}
</div>
</div>

<table width="100%" cellspacing="0" class="empty-table">
<tr>
<td align="left" valign="top"><a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" alt="{L_POST_REPLY_TOPIC}" /></a> <!-- BEGIN thanks_button -->
&nbsp;&nbsp;&nbsp;<a href="{thanks_button.U_THANK_TOPIC}"><img src="{thanks_button.THANK_IMG}" border="0" alt="{thanks_button.L_THANK_TOPIC}" align="middle" /></a>
<!-- END thanks_button -->
</span></td><!-- BEGIN thanks_button -->
&nbsp;&nbsp;&nbsp;<a href="{thanks_button.U_THANK_TOPIC}"><img src="{thanks_button.THANK_IMG}" border="0" alt="{thanks_button.L_THANK_TOPIC}" align="middle" /></a>
<!-- END thanks_button -->
</span></td>
{CA_QUICK_REPLY_BUTTON}</td>
<td align="right" valign="top"><span class="gen">
{PAGE_NUMBER}<br />
<span class="pagination">{PAGINATION}</span>
</span></td>
</tr>
</table>
{CA_QUICK_REPLY_FORM}
<table width="100%" cellspacing="0" class="empty-table">
<tr>
<!-- Start add - Complete banner MOD -->
<td align="left" valign="bottom" colspan="2">{BANNER_15_IMG}</td>
<!-- End add - Complete banner MOD -->
<td align="left" valign="top" class="gensmall">{S_AUTH_LIST}</td>
<td align="right" valign="top">
{JUMPBOX}<br />
<br />
{S_TOPIC_ADMIN}
</td>
</tr>
</table>

deny
Registered User
Posts: 565
Joined: Wed May 14, 2003 9:14 am
Location: Find-Ip-Address.org
Contact:

Re: [2.0.19] Thank You Mod

Post by deny » Tue Jan 29, 2008 4:54 pm

So far i can see this line is wrong:
{CA_QUICK_REPLY_BUTTON}</td>
You miss <td>. SO it will be:
<td>{CA_QUICK_REPLY_BUTTON}</td>
or simple if it does not works w try to add into line before

Code: Select all

<!-- END thanks_button -->
&nbsp;&nbsp;{CA_QUICK_REPLY_BUTTON}</span></td>
Geolocation of any IP address including detection of hostname,
browser, country and country code with ip address range web tool.

IP Address Locator | Email Tracking | IP Address | Check Email

deny
Registered User
Posts: 565
Joined: Wed May 14, 2003 9:14 am
Location: Find-Ip-Address.org
Contact:

Re: [2.0.19] Thank You Mod

Post by deny » Tue Jan 29, 2008 4:56 pm

Just wonder of anyone has ever release mod that integrate Thank You MOd with Attachment mod?
Simply working where you need to Thanks to be able to see Attachments?
Geolocation of any IP address including detection of hostname,
browser, country and country code with ip address range web tool.

IP Address Locator | Email Tracking | IP Address | Check Email

afghano4life
Registered User
Posts: 8
Joined: Mon Jul 16, 2007 3:50 pm

Re: [2.0.19] Thank You Mod

Post by afghano4life » Tue Feb 26, 2008 11:44 am

I am getting this error :(

No post mode specified

kmerdal
Registered User
Posts: 3
Joined: Mon May 07, 2007 11:26 pm

Re: [2.0.19] Thank You Mod

Post by kmerdal » Tue Feb 26, 2008 5:44 pm

does it work with the newest version of phpbb2.0 ???

tikristhedevil
Registered User
Posts: 5
Joined: Fri Dec 28, 2007 12:20 pm

Re: [2.0.19] Thank You Mod

Post by tikristhedevil » Wed Feb 27, 2008 11:13 am

guilty6one9 wrote:good mod, but i cant get the "thanks_mod_&_hide_bbcode" mod in the "contrib" folder to work. right from the start i cant find

$sql = "SELECT p.poster_id, p.topic_id
FROM " . POSTS_TABLE . " p
WHERE p.topic_id = $topic_id
AND p.poster_id = " . $userdata['user_id'];

in the "posting.php" file, the closest thing i get to is

$sql = "SELECT f.*, t.topic_id, t.topic_status, t.topic_type, t.topic_first_post_id, t.topic_last_post_id, t.topic_vote, p.post_id, p.poster_id" . $select_sql . "
FROM " . POSTS_TABLE . " p, " . TOPICS_TABLE . " t, " . FORUMS_TABLE . " f" . $from_sql . "
WHERE p.post_id = $post_id
AND t.topic_id = p.topic_id
AND f.forum_id = p.forum_id
$where_sql";

i dont know why i dont have the code, the "thanks" mod worked for me perfect, i took a look at the "thanks_ch" mod but it serves the same function as the "thanks" mod which i already got to work. help plz
I am having the same problem. I can not find the lines specified in the hide mod with thank mod. I think phpbb has changed a bit from the time when it was posted. Author should look into the matter, as he's the one who suggested to install hide with thank mod. May be nobody ever tried it. If author can spread a little more light, then it would be of gr8 help to users.

Tumbo
Registered User
Posts: 294
Joined: Wed Jun 01, 2005 7:20 pm
Location: Malmo/Sweden
Contact:

Re: [2.0.19] Thank You Mod

Post by Tumbo » Thu Mar 27, 2008 12:46 pm

Is there a Demo for this somewhere??

User avatar
CiberRed
Registered User
Posts: 4
Joined: Sun Aug 05, 2007 7:28 am
Location: Mexico
Contact:

Re: [2.0.19] Thank You Mod

Post by CiberRed » Sat Mar 29, 2008 6:04 am

Hi,

your MOD Thank You Mod is compatible with the MOD Hide BBcode de PhiliWeb of this form?

Image

EXCUSES I DO NOT SPEAK ENGLISH !!


Demo: http://phpbbenespanol.6te.net/phpBB2/
Idioma: Spanish

prtcat
Registered User
Posts: 39
Joined: Thu May 22, 2008 9:25 pm

Re: [2.0.19] Thank You Mod

Post by prtcat » Fri May 23, 2008 11:03 pm

i am new to this and this mod tells me to create a table in my database but it doesn't tell me how to do any of that...

can anyone post some instructions?

thanks

User avatar
choas
I've Been Banned!
Posts: 57
Joined: Fri Jan 19, 2007 7:14 pm

Re: [2.0.19] Thank You Mod

Post by choas » Sat May 24, 2008 3:40 am

prtcat wrote:i am new to this and this mod tells me to create a table in my database but it doesn't tell me how to do any of that...

can anyone post some instructions?

thanks
Go to phpMyAdmin
Click in "SQL"
Copy & paste SQL queres and click on bottun... alldone ! ;)

prtcat
Registered User
Posts: 39
Joined: Thu May 22, 2008 9:25 pm

Re: [2.0.19] Thank You Mod

Post by prtcat » Mon May 26, 2008 6:28 pm

i don't use phpMyAdmin...but i have access to the tables etc on my website cp

User avatar
Zaid
Registered User
Posts: 590
Joined: Thu Nov 08, 2007 2:06 pm
Location: South Pacific Ocean

Re: [2.0.19] Thank You Mod

Post by Zaid » Fri Jun 13, 2008 6:34 pm

So this works overall? i will try it now

Pum
Registered User
Posts: 44
Joined: Mon Aug 01, 2005 8:12 pm

Re: [2.0.19] Thank You Mod

Post by Pum » Mon Jun 30, 2008 9:50 pm

Sorry if this question asked before but is there version for phpBB 3.x?

DirtX
Registered User
Posts: 2
Joined: Sun Jun 08, 2008 9:47 am
Contact:

Re: [2.0.19] Thank You Mod

Post by DirtX » Sun Jul 06, 2008 5:29 pm

Hello. I have problem with thanks mod and simple subforum mod. because in subforums doesn´t thanks work. I need help. Thanks :)

Kaos
Registered User
Posts: 33
Joined: Sun May 25, 2008 8:00 pm

Re: [2.0.19] Thank You Mod

Post by Kaos » Thu Jul 10, 2008 12:10 am

does this work with phpbb3?
Help Me Please Thanks

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 18 guests