[2.0.21] Invitation_Only_U2U

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
37
73%
Very Good
9
18%
Good
2
4%
Fair
1
2%
Poor
2
4%
 
Total votes: 51

indepndent
Registered User
Posts: 129
Joined: Mon Feb 13, 2006 4:47 am

Post by indepndent » Mon May 01, 2006 4:37 am

Can I remove the Ip address being included with the invitation? I like the mod but don't want my Ip going with every invitation. Can it be replaced with the IP of the forum itself? Is this neccesary?


Also How do I give invites only to a specific username, without giving to all members?

Thanks

indepndent
Registered User
Posts: 129
Joined: Mon Feb 13, 2006 4:47 am

Post by indepndent » Mon May 01, 2006 5:28 am

Also upon installation I get the following errors with easymod although all appears to be functioning properly.

Code: Select all

Error Detail
 
Warning

FIND FAILED: In file [templates/template/profile_add_body.tpl] could not find:

<!-- END switch_confirm -->

MOD script line #472 :: FAQ :: Report
 

Error Detail
 
Warning

FIND FAILED: In file [templates/Template3/groupcp_info_body.tpl] could not find:

</table>
{S_HIDDEN_FIELDS}

MOD script line #740 :: FAQ :: Report
Please note that neither template is the default template for the board they are optional choices available after you register. As I will not be making those the default at all. Should I worry about those errors?

Thanks

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Mon May 01, 2006 10:44 am

That edit is about adding the new code field to the registration form. I.e. it is only relevant for the default style.

indepndent
Registered User
Posts: 129
Joined: Mon Feb 13, 2006 4:47 am

Post by indepndent » Mon May 01, 2006 11:44 am

Kellanved wrote: That edit is about adding the new code field to the registration form. I.e. it is only relevant for the default style.


OK that is what I though thanks.


Any idea about the ip address being removed?

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Mon May 01, 2006 12:16 pm

Where should the IP be removed? From the mails?

If so, comment out

Code: Select all

$email_headers .= 'X-AntiAbuse: User IP - ' . decode_ip($user_ip) . "\n";
in functions_invite.php. (around line 530)

indepndent
Registered User
Posts: 129
Joined: Mon Feb 13, 2006 4:47 am

Post by indepndent » Mon May 01, 2006 5:02 pm

Kellanved wrote: Where should the IP be removed? From the mails?

If so, comment out

Code: Select all

$email_headers .= 'X-AntiAbuse: User IP - ' . decode_ip($user_ip) . "\n";
in functions_invite.php. (around line 530)


Thank you.


How about giving the invites to a specific username?

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Mon May 01, 2006 5:58 pm

That's done on the user-admin page. (User-Admin -> Management).

Xavious
Registered User
Posts: 15
Joined: Sat Jan 28, 2006 1:37 pm

Post by Xavious » Tue May 02, 2006 6:56 pm

Excellent mod, very nicely made. Great job.

I have a feature request, however. I use this addon to let people join a usergroup when they register, but people can only enter the code to join the usergroup when they first register.

It would be cool if they could put the code into thier profile whenever they want, or even better, if they click on an area of the forum where they are not allowed, they would have the option to enter an invitation code.

Yottskry
Registered User
Posts: 5
Joined: Thu May 11, 2006 8:06 pm

Registration accepts bogus codes

Post by Yottskry » Thu May 11, 2006 8:14 pm

I'm working on a 2.0.19 board and installed this awesome mod using EasyMod 0.30. Other than some formatting problems that have to be sorted out, installation went great, no problems at all. However the registration page is accepting bogus codes:

Registration Page

Put in any code you like, and it takes you right to the registration page & process. Accepting anything as an invite code defeats the purpose - any ideas how I can fix would be really appreciated!

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Thu May 11, 2006 8:43 pm

Yes, the rule page doesn't actually check the code.
The code is only verified after submitting the registration form.

My reason for doing that is rather simple: otherwise the page could be used to DOS/brute force the board.

Yottskry
Registered User
Posts: 5
Joined: Thu May 11, 2006 8:06 pm

Post by Yottskry » Thu May 11, 2006 9:03 pm

Ah ha, I see that now. :oops: Sorry, thanks for pointing this out so quickly!! :)
Kellanved wrote: Yes, the rule page doesn't actually check the code.
The code is only verified after submitting the registration form.

My reason for doing that is rather simple: otherwise the page could be used to DOS/brute force the board.

indepndent
Registered User
Posts: 129
Joined: Mon Feb 13, 2006 4:47 am

Post by indepndent » Thu May 11, 2006 10:28 pm

I just want to say thanks again for this mod. An unexpected bonus of using this mod is that it is the ultimate spam-bot stopper. You should consider adding spambot stopper to the title. :lol: This marvelous mod when enabled to make your board invitation only will stop spam bots as well. They can't register without a code!!!!!!!!!! I don't even have visual confirmation enabled on my board anymore as it is redundant with the invitation only code. Only a pre-generated code will work. How are the bots going to defeat that? BRAVO!!!!! One of the best mods ever!

Thanks again.

Yottskry
Registered User
Posts: 5
Joined: Thu May 11, 2006 8:06 pm

Post by Yottskry » Fri May 12, 2006 12:16 pm

Yes thank you so much, this is by far one of the best mods I've ever used. Super easy to install, awesome! :D

GTF
Registered User
Posts: 29
Joined: Fri May 12, 2006 3:15 pm

No invites left

Post by GTF » Fri May 12, 2006 3:20 pm

I just installed this mod - just what I needed. :)

Just one little problem: The number of invites left shows as being (No invites left) - even though there are plenty left.

However, when you click on the link to invite, it works just fine. It's just confusing to have it reporting none left at the top of the board even though the user logged in does have invites left.

Any idea what might be causing this behavior?

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Re: No invites left

Post by Kellanved » Fri May 12, 2006 3:33 pm

GTF wrote: Any idea what might be causing this behavior?


No, that is indeed strange. The mod doesn't take group invites into account, as that would have required an additional database query. But the number of individual invites should be displayed.

The first question is: how was the mod installed? Manually or with easymod?

Post Reply

Return to “[2.0.x] MOD Database Releases”