[2.0.20] UploadPic

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply

Rating:

Excellent!
57
69%
Very Good
8
10%
Good
6
7%
Fair
4
5%
Poor
8
10%
 
Total votes: 83

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 27620
Joined: Sat Aug 16, 2003 7:36 am

[2.0.20] UploadPic

Post by Extensions Robot » Sun Apr 09, 2006 11:04 am

MOD Name: UploadPic
Author: buegelfalte
MOD Description: UploadPic adds a link to the message-editor, which allows the user to upload a picture (jpg/gif/png) and paste it to the message (standard/align left/align right, align requires the MOD "Left and Right IMG tags") with the correct BBCode ([img], or both). The uploaded image will be r ... _1_3_2.zip
mods overview page: View
File Size: 129201 Bytes

Security Score: 0

Support for this MOD needs to be asked within this topic. The phpBB Teams are not responsible or required to give anyone support for this MOD. By installing this MOD, the phpBB Support Team or phpBB MODifications Team may not be able to provide support.

This MOD has only been tested by the phpBB MOD Team with the phpBB version in the topic title. It may not work in any other versions of phpBB.
Last edited by Extensions Robot on Mon Apr 30, 2007 12:31 am, edited 1 time in total.
(this is a non-active account manager for the phpBB Extension Customisations Team)

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Sun Apr 16, 2006 3:57 am

MOD Validated/Released

Notes:
Adds a very advanced image uploader to phpBB; see above for the included features.

UnderEstimated
Registered User
Posts: 14
Joined: Wed Apr 05, 2006 12:17 am

Post by UnderEstimated » Sun Apr 16, 2006 6:40 am

gr8 work

shutterbug
Registered User
Posts: 8
Joined: Thu Apr 06, 2006 3:47 am

Post by shutterbug » Sun Apr 16, 2006 10:32 pm

This is just what I was looking for for my photography forum.

Noticed one glitch, not sure if it's intentional or why it would be...

In the uploadpic.txt file, The instruction that starts on line 393 is repeated on line 411. Other than that, the install was smooth sailing! thanks for creating an awesome mod!

adjoshua
Registered User
Posts: 4
Joined: Thu Apr 13, 2006 12:52 pm
Location: Phoenix, AZ
Contact:

Help Needed, Forum Down.

Post by adjoshua » Mon Apr 17, 2006 1:42 pm

Hi. I need help. I apologize if it seems obvious but I'm new at this.

I just installed this Mod with EasyMod and was asked to complete the installation manually. When I tried, I was told my file directory was not accurate (Warning: main(../common.): failed to open stream: No such file or directory in) ; what I used was: admin/mods/MOD_UploadPic_1_3_2/install/install_uploadpic.php.

Now When I want to access my forum I get;
"Please ensure both the install/ and contrib/ directories are deleted"

I looked for these files and tried to delete them (only found the install file, I think) but I still get this message. I manually removed this MOD's folder and nothing changed. So I try to restore my database and still the same situation.

I do see UploadPic in my ACP but I get error messages on UploadPic, UploadPic Recent, and UploadPic Users.

What can I do to fix this and what went wrong in this installation.

Thanks very much.

Joshua

User avatar
Kalipo
Registered User
Posts: 551
Joined: Mon Dec 08, 2003 1:47 pm

Post by Kalipo » Mon Apr 17, 2006 6:31 pm

shutterbug wrote: The instruction that starts on line 393 is repeated on line 411.


That's intentional.
adjoshua wrote: "Please ensure both the install/ and contrib/ directories are deleted"


Delete the install directory.



Perfect timing :D Installing this only on easyCMS for the time being.

User avatar
Liljeberg
Registered User
Posts: 34
Joined: Tue Jan 10, 2006 8:09 am

Post by Liljeberg » Mon Apr 17, 2006 8:36 pm

I'm trying to upload a 1 mb image using UploadPic but have encountered a problem. UploadPic is set to resize the image to 550x300 and rotate it 90 degrees. I think this causes the server to timeout because after a while the popup window just shows a blank page and nothing more happens. If I take a look at recent uploads in the Admin panel I see that the file has been uploaded, but not resized or rotated and is still having a temporary file name (8b7d6c4b784fd124231de6917fd0e1a7.jpg).

I understand that this problem probably has more to do with the timeout of my server than anything else, but has anyone got any ideas of what do do about it?

User avatar
Kalipo
Registered User
Posts: 551
Joined: Mon Dec 08, 2003 1:47 pm

Post by Kalipo » Mon Apr 17, 2006 9:11 pm

---edits---

Figured it out.

Edits to add later:

Ok, this MOD is GREAT. I love all the options included.

The only gripe I have (which is easy to fix really) - moving the button below the message textfield instead of up with the BBCode buttons, but that's just personal preference.

Thank you :D

buegelfalte
Registered User
Posts: 122
Joined: Wed Nov 16, 2005 1:27 pm
Location: Cologne, Germany
Contact:

Post by buegelfalte » Tue Apr 18, 2006 2:46 pm

Liljeberg wrote: I understand that this problem probably has more to do with the timeout of my server than anything else, but has anyone got any ideas of what do do about it?

Check out the FAQ, chapter I. 12., it's all there :)
http://www.beehave.de - home of humbug
no support via PM or email, read the UploadPic FAQ before posting

kornhead
Registered User
Posts: 72
Joined: Sun Jun 12, 2005 4:36 pm
Location: Russia
Contact:

Post by kornhead » Tue Apr 18, 2006 3:13 pm

Allrighty than
just one question - does it make thumbnail to safe my internet traffic? 8)

buegelfalte
Registered User
Posts: 122
Joined: Wed Nov 16, 2005 1:27 pm
Location: Cologne, Germany
Contact:

Post by buegelfalte » Tue Apr 18, 2006 3:19 pm

kornhead wrote: just one question - does it make thumbnail to safe my internet traffic? 8)

No, it resizes images to save your internet traffic ;)
http://www.beehave.de - home of humbug
no support via PM or email, read the UploadPic FAQ before posting

KingCobra777
Registered User
Posts: 5
Joined: Mon Mar 27, 2006 5:06 pm

Having a problem

Post by KingCobra777 » Wed Apr 19, 2006 4:38 pm

I ran the install srcipt and obtained the message to delete the 2 directories after it completed. No error messages, however I am unable to see the control for uploading pix.

One thing about our board is that we are using the Red Glass style. Perhaps that is part of the problem. I copied all of the files for the subSilver style into the equivalent directories, assuming that would be sufficient. Apparently there is something else missing.
Last edited by KingCobra777 on Wed Apr 19, 2006 5:07 pm, edited 1 time in total.

User avatar
Kalipo
Registered User
Posts: 551
Joined: Mon Dec 08, 2003 1:47 pm

Post by Kalipo » Wed Apr 19, 2006 4:45 pm

Look by your BBCode buttons.

If you don't see it, check your file edits.

KingCobra777
Registered User
Posts: 5
Joined: Mon Mar 27, 2006 5:06 pm

Post by KingCobra777 » Wed Apr 19, 2006 5:09 pm

How do I check my file edits?

User avatar
Kalipo
Registered User
Posts: 551
Joined: Mon Dec 08, 2003 1:47 pm

Post by Kalipo » Wed Apr 19, 2006 5:21 pm

Follow the instructions contained in the uploadpic.txt file.

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 12 guests