The humanizer

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply

Rating:

Excellent!
69
73%
Very Good
11
12%
Good
6
6%
Fair
2
2%
Poor
7
7%
 
Total votes: 95

smarketto
Registered User
Posts: 2
Joined: Tue Aug 15, 2006 2:30 pm

Post by smarketto »

Underhill,

I installed easy mod and used it to successfuly install the humanizer, noticed a couple bots got through last night so I also installed the humanizer tips today.....hopefully this slows them down some.
Underhill
Registered User
Posts: 154
Joined: Tue Sep 27, 2005 1:54 pm

Post by Underhill »

@Millennyum:

Please try this:
http://www.underhill.de/downloads/phpbb ... ertips.txt

Reg.
Underhill

Edit: Changed link for V1.1.0
Last edited by Underhill on Sat Aug 26, 2006 7:06 am, edited 1 time in total.
batlh ghajbe' De'wI'mey!
BigRed01
Registered User
Posts: 476
Joined: Mon Jan 24, 2005 9:26 am
Location: The upper midwest

Post by BigRed01 »

Underhill wrote: Hi,

better replace the attribute "ruhuman" with another:

http://www.underhill.de/downloads/phpbb ... ertips.txt

Between V1.0.3 and 1.0.5 where only spelling or formating changes...


Reg.
Underhill


Thanks, worked like a charm :wink:
Dante101
Registered User
Posts: 5
Joined: Sun Jul 23, 2006 7:49 pm

Post by Dante101 »

I've been having around 1 spambot per day register on my forum (even with visual confirm turned on). I installed this Wednesday, tested it and everything looked good; but when I checked back on Thursday I found 4 new spambots registered. Somehow they got through. :(

But thanks anyway - I'm always thankful for people making new mods! :D
Underhill
Registered User
Posts: 154
Joined: Tue Sep 27, 2005 1:54 pm

Post by Underhill »

@dante101:

Did you tried this?
http://www.phpbb.com/phpBB/viewtopic.ph ... 64#2336364

Reg.
Underhill
batlh ghajbe' De'wI'mey!
German_AC
Registered User
Posts: 13
Joined: Fri Aug 18, 2006 3:30 pm

Post by German_AC »

I installed the mod, but in the register page it doesn't appears the first time. When you fill the form and click "send", then it shows the error message "you should respond...." and then the option appears under visual confirmation part.

Any idea will be apreciated!
Thanks!
User avatar
JCLIFF
Registered User
Posts: 46
Joined: Mon Aug 15, 2005 4:52 pm
Location: Boston, MA
Contact:

Post by JCLIFF »

German_AC wrote: I installed the mod, but in the register page it doesn't appears the first time. When you fill the form and click "send", then it shows the error message "you should respond...." and then the option appears under visual confirmation part.

Any idea will be apreciated!
Thanks!


If you're getting the error prompting a response but couldn't view the question in the form prior to submitting, then you should check this file:

templates/**YourTheme**/profile_add_body.tpl
User avatar
JCLIFF
Registered User
Posts: 46
Joined: Mon Aug 15, 2005 4:52 pm
Location: Boston, MA
Contact:

Post by JCLIFF »

Dante101 wrote: I've been having around 1 spambot per day register on my forum (even with visual confirm turned on). I installed this Wednesday, tested it and everything looked good; but when I checked back on Thursday I found 4 new spambots registered. Somehow they got through. :(

But thanks anyway - I'm always thankful for people making new mods! :D


Likewise. In the past few days, from @gawab.com and @gmx.de in particular, I've seen an increase as well.
User avatar
JCLIFF
Registered User
Posts: 46
Joined: Mon Aug 15, 2005 4:52 pm
Location: Boston, MA
Contact:

Post by JCLIFF »

Underhill wrote: @dante101:

Did you tried this?
http://www.phpbb.com/phpBB/viewtopic.ph ... 64#2336364

Reg.
Underhill


Awesome! Thx.
User avatar
Warpcore
Registered User
Posts: 15
Joined: Sat Aug 12, 2006 11:47 am
Contact:

Post by Warpcore »

underhill love the ease of installing the mod, just a little question though.

how do i change the text colour thats displayed?, as I use Galaxian template & the blue, doesnt show well
Millennyum
Registered User
Posts: 92
Joined: Sun Apr 10, 2005 11:19 am
Location: Netherlands
Contact:

Post by Millennyum »

Underhill wrote: @Millennyum:

Please try this:
http://www.underhill.de/downloads/phpbb ... raddon.txt

Reg.
Underhill


Ehmm... thanks, but that's not what I meant. :oops: I don't want a drop down box in stead of a radio button, I want a text box. Something with <input type="text">. And then something like
if ($name_of_text_input_field != "<my_code>") then <show_error_message>


What I cannot figure out myself is how to change the part that assigns the variable, to get it to work with a text field. I guess that is this part:
$ruhuman = ( isset($HTTP_POST_VARS['ruhuman']) ) ? ( ($HTTP_POST_VARS['ruhuman']) ? TRUE : 0 ) : 0;


Could you please help me again? :?
Dr.Thrax
Registered User
Posts: 4
Joined: Mon Aug 21, 2006 9:51 pm

Post by Dr.Thrax »

Hi, I am very new to being admin on phpbb forums. We have also had terrible problems with spambots lately...
So far I have installed a mod that won't let guests post within 5 seconds (it was efficient for a while but those pests found a way around it)
Now we have the Yes/No dropdown menu and it does slow them down a bit, but we still get spam.

I would prefer NOT to turn off guest posting so I do realise that it will be harder to prevent spam, but which mod is the most recent one you people suggest I install?

Thanks in advance. I'm happy to be a part of the community
Underhill
Registered User
Posts: 154
Joined: Tue Sep 27, 2005 1:54 pm

Post by Underhill »

Hi,
Warpcore wrote: how do i change the text colour thats displayed?, as I use Galaxian template & the blue, doesnt show well


Please give the URL of your "templates/xxx/profile_add_body.tpl"-Files (PM if you want) - I will see what i can do...


Reg.
Underhill
batlh ghajbe' De'wI'mey!
User avatar
Warpcore
Registered User
Posts: 15
Joined: Sat Aug 12, 2006 11:47 am
Contact:

Post by Warpcore »

Underhill wrote: Hi,
Warpcore wrote:how do i change the text colour thats displayed?, as I use Galaxian template & the blue, doesnt show well


Please give the URL of your "templates/xxx/profile_add_body.tpl"-Files (PM if you want) - I will see what i can do...


Reg.
Underhill


PM'd thanks :D
corinaw
Registered User
Posts: 15
Joined: Sat May 27, 2006 4:14 am

Can I have more options than just YES or NO? Would it help?

Post by corinaw »

First, thanks so much for this MOD. I have been just plagued by spam bots, until I installed this.

I have installed the humanizer, humanizer dropdown, humanizer tips, then the mod where the website url is missing when the user registers.

It seem like the spammers are catching up to me now- I’ve had about 6 spam registrations today, (I can tell by the other fields like occupation and interest listing pills and porn)

I want to try more options to the humanizer rather than just yes or no, as it seems it is too easy for the spam bots to just guess option 2. I’m thinking 3,4, or more options to this field would make it that much more difficult. (WOULD THIS HELP? )

Can anyone help by showing me where to modify the mod?

Thank you

Note this is the basic info I have in my forum, it is the dropdown format of humanizer

includes/usercp_register.php


// The humanizer MOD
'ARE_U_HUMAN_YES' => ( $ruhuman ) ? 'selected="selected"' : '',
'ARE_U_HUMAN_NO' => ( !$ruhuman ) ? 'selected="selected"' : '',



templates/subSilver/profile_add_body.tpl

<!-- The humanizer MOD -->
<!-- BEGIN switch_register -->
<tr>
<td class="row1"><span class="gen">{L_ARE_U_HUMAN} *</span><br /><span class="gensmall">{L_ARE_U_HUMAN_EXPLAIN}</span></td>
<td class="row2">
<select name="ruhuman">
<option value="1" {ARE_U_HUMAN_YES}>{L_YES}</option>
<option value="0" {ARE_U_HUMAN_NO}>{L_NO}</option>
</select>
</td>
</tr>
<!-- END switch_register -->
Post Reply

Return to “[2.0.x] MOD Database Releases”