[2.0.21] Country Flags MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
26
57%
Very Good
8
17%
Good
5
11%
Fair
2
4%
Poor
5
11%
 
Total votes: 46

sundgot
Registered User
Posts: 11
Joined: Mon Jan 22, 2007 1:03 am

Post by sundgot » Mon Jan 22, 2007 5:34 pm

radr57 wrote: Hello.
I am trying to install this wonderful mod; however I ran into some problems with the installation steps.

I've chosen method 3, as the easyMOD cannot be used on my server.
1) I've downloaded the zip file in my admin/mods directory.
2) I've unzipped it.
3) I've run the file db_update_en.txt "manually" (I opened it in web browser window).

There is no result whatsoever.
Any guidance will be greatly appreciated.


Read: install_en.txt
That is what you need to do... :!:
You need to edit php and template files...

radr57
Registered User
Posts: 48
Joined: Wed Jan 17, 2007 5:21 am

Post by radr57 » Mon Jan 22, 2007 6:42 pm

Everything line by line????
Holy cow... I'll try...

sundgot
Registered User
Posts: 11
Joined: Mon Jan 22, 2007 1:03 am

Post by sundgot » Mon Jan 22, 2007 6:57 pm

radr57 wrote: Everything line by line????
Holy cow... I'll try...


EasyMod:
http://www.phpbb.com/phpBB/catdb.php?cat=26
But, that's the same amount of work... :roll:

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Re: Jan Mayen

Post by ycl6 » Tue Jan 23, 2007 10:12 am

sundgot wrote: Jan Mayen is a part of Norway.
Not a own country. :roll:

http://en.wikipedia.org/wiki/Jan_mayen

Jan Mayen Island, a part of the Kingdom of Norway,
is a 55 km long (southwest-northeast) and 373 km² large
arctic volcanic island in the Arctic Ocean, partly covered by glaciers.

Code: Select all

## MOD Title: Country/Location Flags MOD

## MOD Description: This mod allows your registered board members to select the flag of their country/location.
~Mac

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 » Tue Jan 23, 2007 10:17 am

sundgot wrote: In the left admin menu frame:
Parse error: syntax error, unexpected T_VARIABLE in
/mounted-storage/home19d/sub001/sc19806-FFHE/forum/phpBB2_test/admin/admin_users.php on line 1054


And after submit in the new user reg. process:

Could not insert data into groups table

DEBUG MODE
INSERT INTO phpbb_groups
(group_name, group_description, group_single_user, group_moderator)
VALUES ('', 'Personal User', 1, 0)

Line : 662
File : usercp_register.php

1. Check your codes, most likely you make a mistake, e.g. missing "," or opening/closing curly brackets.

2. I execute the SQL in my database without error. I do not know why your script can't execute that in your database. And anyway, my MOD doesn't edit anything near this:

Code: Select all

			$sql = "INSERT INTO " . GROUPS_TABLE . " (group_name, group_description, group_single_user, group_moderator)
				VALUES ('', 'Personal User', 1, 0)";
			if ( !($result = $db->sql_query($sql)) )
			{
				message_die(GENERAL_ERROR, 'Could not insert data into groups table', '', __LINE__, __FILE__, $sql);
			}
~Mac

WeB-DeMoN
Registered User
Posts: 14
Joined: Fri Jan 26, 2007 11:31 am

Post by WeB-DeMoN » Sun Jan 28, 2007 8:37 am

I followed the directions to teh best of my knowledge. Afriend had errors when trying to install with easy mod....... When things went wrong he hd me attempt to fix it. when i run the db_update.php I get the follwoing error in there. Im kinda new to editing php sorry for any stupid easy mistakes I may have made.


INSERT INTO phpbb_flags(flag_id,flag_image,flag_name) VALUES('','cs.gif','Costa Rica');

Successful
INSERT INTO phpbb_flags(flag_id,flag_image,flag_name) VALUES('','iv.gif','Cote d'Ivoire');

Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'Ivoire')' at line 1
INSERT INTO phpbb_flags(flag_id,flag_image,flag_name) VALUES('','hr.gif','Croatia');

Successful
INSERT INTO phpbb_flags(flag_id,flag_image,flag_name) VALUES('','cu.gif','Cuba');

How do I fix this?

Also images arent showing up

WeB-DeMoN
Registered User
Posts: 14
Joined: Fri Jan 26, 2007 11:31 am

Post by WeB-DeMoN » Sun Jan 28, 2007 8:57 am

Ok well apparently the mod works in everything but my explorer. I use opera. Any ideas why everything shows in I.E and firefox but not opera?

WeB-DeMoN
Registered User
Posts: 14
Joined: Fri Jan 26, 2007 11:31 am

Post by WeB-DeMoN » Sun Jan 28, 2007 2:32 pm

*bump*

radr57
Registered User
Posts: 48
Joined: Wed Jan 17, 2007 5:21 am

Post by radr57 » Sun Jan 28, 2007 10:07 pm

I've finally done all changes to the files and when I open my profile I can choose the countries and flag icons show properly. However
1) When I open my forum CP I don't have the left panel with all controls, instead I see this:
Parse error: parse error, unexpected T_VARIABLE in /home/*******/public_html/forum/admin/admin_users.php on line 1015

The line reads:
$sql = "SELECT *

2) When I try to open any topic I get this:
Parse error: parse error, unexpected '.', expecting ')' in /home/*******/public_html/forum/viewtopic.php on line 1170


The line reads:
'POSTER_FROM' => $poster_from, . $poster_from_flag


Any ideas what went wrong?

WeB-DeMoN
Registered User
Posts: 14
Joined: Fri Jan 26, 2007 11:31 am

Post by WeB-DeMoN » Mon Jan 29, 2007 2:42 am

Ill look at my coding lines for you. There is a small typo in there some where. If possible I post your lines in the viewtopic.php and I will help you out. Mine is runnning nad since no one else is doing support for this threadd obviously someone esle will.

WeB-DeMoN
Registered User
Posts: 14
Joined: Fri Jan 26, 2007 11:31 am

Post by WeB-DeMoN » Mon Jan 29, 2007 2:55 pm

radr57 do you not need help??

radr57
Registered User
Posts: 48
Joined: Wed Jan 17, 2007 5:21 am

Post by radr57 » Mon Jan 29, 2007 6:02 pm

Yes, please.

WeB-DeMoN
Registered User
Posts: 14
Joined: Fri Jan 26, 2007 11:31 am

Post by WeB-DeMoN » Tue Jan 30, 2007 11:59 am

oops

WeB-DeMoN
Registered User
Posts: 14
Joined: Fri Jan 26, 2007 11:31 am

Post by WeB-DeMoN » Tue Jan 30, 2007 12:00 pm

What is th coding error you get exactly? what lines and what lines are they?

Sheldon469
Registered User
Posts: 128
Joined: Wed Jan 28, 2004 2:32 am
Location: USA
Contact:

Country Flag MOD

Post by Sheldon469 » Tue Jan 30, 2007 9:16 pm

Hello all,

So I want to add this Mod to my forum. I currently have NO Mods installed so with that said.........what is the best method to install this MOD??

Should it be manually or via EM???

So those successful, please provide the steps you took to get yours going the first time around. THANKS!

Here is my forum: http://caribbeantalk.org/forums/index.php
Alpine Talk For the Alpine Enthaustist in you!

Post Reply

Return to “[2.0.x] MOD Database Releases”