[2.0.20] ConfusaBOT ACP

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
9
56%
Very Good
1
6%
Good
3
19%
Fair
1
6%
Poor
2
13%
 
Total votes: 16

stuie
Registered User
Posts: 4
Joined: Tue May 30, 2006 12:04 pm
Location: Australia
Contact:

Post by stuie » Sun Aug 13, 2006 8:38 am

Hi guys, has anyone tested this mod with 2.0.19?

User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Post by EXreaction » Sun Aug 13, 2006 5:51 pm

It should work with 2.0.19.

Just make sure to get backups of the files you changed first. ;)

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Mon Aug 14, 2006 7:58 pm

Most of the stuff in this MOD was actually done with 2.0.11, but the FIND statements are only checked against 2.0.20. Since it isn't recommended to be using older versions, though, the official statement is "This MOD is not supported on versions older than 2.0.20". :wink:
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

Delia_35
Registered User
Posts: 4
Joined: Tue Aug 01, 2006 12:33 am

Post by Delia_35 » Wed Aug 16, 2006 3:54 am

Hi,
I just updated to 2.0.21. I'm trying to install this MOD but the:

Code: Select all

#-----[ FIND ]------------------------------------------
#
	"L_ALLOW_AUTOLOGIN_EXPLAIN" => $lang['Allow_autologin_explain'],

appears to be out of date. I can't find it in admin/admin_board.php at all. Is there an updated version of this MOD?

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Fri Aug 18, 2006 12:23 am

In the unmodified version of PHPBB 2.0.21, this line is #178 in the file, part of this block:

Code: Select all

	"L_VISUAL_CONFIRM" => $lang['Visual_confirm'], 
	"L_VISUAL_CONFIRM_EXPLAIN" => $lang['Visual_confirm_explain'], 
	"L_ALLOW_AUTOLOGIN" => $lang['Allow_autologin'],
	"L_ALLOW_AUTOLOGIN_EXPLAIN" => $lang['Allow_autologin_explain'],
	"L_AUTOLOGIN_TIME" => $lang['Autologin_time'],
	"L_AUTOLOGIN_TIME_EXPLAIN" => $lang['Autologin_time_explain'],
	"L_COOKIE_SETTINGS" => $lang['Cookie_settings'], 
But, it really does not matter where you put this particular piece of code; the spot chosen was to be consistent with where it gets placed in the subSilver template.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

Elnrik
Registered User
Posts: 1
Joined: Mon Sep 04, 2006 3:14 pm

installation?

Post by Elnrik » Mon Sep 04, 2006 3:15 pm

Most MODs I am familliar with have a .txt file detailing installation.
How do I install this mod?

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Tue Sep 05, 2006 12:17 am

The file with ".MOD" in the ZIP is the text file you seek - the other files are for the new format for MODs, "MODx".
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

gat3w3y
Registered User
Posts: 4
Joined: Wed Aug 30, 2006 12:27 am

Post by gat3w3y » Thu Sep 07, 2006 2:21 am

hmm when trying to install the mod I got this

Code: Select all

Critical Error

FIND FAILED: In file [includes/usercp_register.php] could not find:

$error_msg = '';

MOD script line #173 :: FAQ :: Report
any ideas? im running 2.0.19 of phpbb

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Thu Sep 07, 2006 1:49 pm

I do not have an unmodified copy of v2.0.19 here to check against, but in 2.0.18, .20, and .21, this line is about line 76, just after the end of the function show_coppa(). The sequence should be:

Code: Select all

	$template->pparse('body');

}
//
// ---------------------------------------

$error = FALSE;
$error_msg = '';
If it is not there in your copy, some other MOD must have removed it or changed it...

The key, though, is that the code this find is in front of goes after show_coppa().
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Post by EXreaction » Thu Sep 07, 2006 7:36 pm

I have every version back to 2.0.0 for just these types of occasions! :D

In the default 2.0.19 it looks exactly the same. A mod must have changed it or mabey the spacing is different. :)

User avatar
LukeSkiewalker
Registered User
Posts: 10
Joined: Wed Aug 03, 2005 11:00 pm

Post by LukeSkiewalker » Fri Sep 22, 2006 7:55 pm

Okay on this forum: http://heartofthealliance.com/phpBB2/ I have made it so that clicking the under 13 COPPA link is disabled. I had no desire to have anyone under 13 posting on my forums so I made so that you agreed that you were at least 13. Since that is the case will this mod even work for me?

Also, does this still work on bots who parse the registration pages to get the variables?

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Sat Sep 23, 2006 5:04 am

Yes, it should be as effective for you as it is for anyone else, since I assume you're still using the COPPA variable, just not allowing for it to be anything but true...
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

User avatar
nedostizni
Registered User
Posts: 391
Joined: Tue Mar 04, 2003 7:25 pm

Post by nedostizni » Fri Sep 29, 2006 12:27 am

I have downloaded the ConfusaBOT_ACP_v100a and found some problems during editing my files to install this MOD:


1) At includes/usercp_register.php i couldn`t find the

Code: Select all

$error_msg = '';
so i couldn`t add the

Code: Select all

// change to test for new setting of agreed
if ( isset($HTTP_POST_VARS[$board_config['agreed_var']]))
{
	if ($HTTP_POST_VARS[$board_config['agreed_var']] != $board_config['agreed_val'])
		unset($HTTP_POST_VARS[$board_config['agreed_var']]);
}
if ( isset($HTTP_GET_VARS[$board_config['agreed_var']]))
{
	if ($HTTP_GET_VARS[$board_config['agreed_var']] != $board_config['agreed_val'])
		unset($HTTP_GET_VARS[$board_config['agreed_var']]);
}

2) At language/lang_english/lang_admin.php i couldn`t find the

Code: Select all

$lang['Autologin_time_explain'] =
so i couldn`t add this part (wich goes in new line after the one showen above)

Code: Select all

// ConfusaBOT variables
$lang['Agreed_Var']= "Agreed variable";
$lang['Agreed_Var_explain']= "Case-sensitive HTML form variable name for terms agreement"; 
$lang['Agreed_Val']= "Agreed value";
$lang['Agreed_Val_explain']= "Case-sensitive HTML form variable <i>value</i> for terms agreement";
$lang['Coppa_Var']= "COPPA variable";
$lang['Coppa_Var_explain']= "Case-sensitive HTML form variable name for COPPA compliance";

3) At templates/subSilver/admin/board_config_body.tpl i couldn`t find the

Code: Select all

<td class="row1">{L_AUTOLOGIN_TIME}
so i couldn`t add the

Code: Select all

	<tr>
		<td class="row1">{L_AGREED_VAR}<br /><span class="gensmall">{L_AGREED_VAR_EXPLAIN}</span></td>
		<td class="row2"><input class="post" type="text" size="40" maxlength="255" name="agreed_var" value="{AGREED_VAR}" /></td>
	</tr>
	<tr>
		<td class="row1">{L_AGREED_VAL}<br /><span class="gensmall">{L_AGREED_VAL_EXPLAIN}</span></td>
		<td class="row2"><input class="post" type="text" size="40" maxlength="255" name="agreed_val" value="{AGREED_VAL}" /></td>
	</tr>
	<tr>
		<td class="row1">{L_COPPA_VAR}<br /><span class="gensmall">{L_COPPA_VAR_EXPLAIN}</span></td>
		<td class="row2"><input class="post" type="text" size="40" maxlength="255" name="coppa_var" value="{COPPA_VAR}" /></td>
	</tr>

Why there are some code missings in my files? I am using the phpBB 2.0.19.

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Fri Sep 29, 2006 1:57 am

nedostizni wrote: Why there are some code missings in my files? I am using the phpBB 2.0.19.


If you note that the title is "[2.0.20] ConfusaBOT ACP", and the oldest version it's intended to be used on is 2.0.20, and some of the strings you are looking for are relatively new... and the language variable $lang['Autologin_time_explain'] and template variable {L_AUTOLOGIN_TIME} are both part of the changes you'd be making when you update your system.

In the case of the string you're looking for in includes/usercp_register.php, though, EXreaction says it's been in every version since 2.0.0. It's around line 76 of the file (look a few messages above yours).

Updating should be done first...
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Post by EXreaction » Fri Sep 29, 2006 2:02 am

espicom wrote: EXreaction says it's been in every version since 2.0.0.


No, no, I said I have every version back to 2.0.0 on my data drive just for checking. :P

It actually first appears in 2.0.18. :)

Post Reply

Return to “[2.0.x] MOD Database Releases”