[2.0.20] ConfusaBOT ACP

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply

Rating:

Excellent!
9
56%
Very Good
1
6%
Good
3
19%
Fair
1
6%
Poor
2
13%
 
Total votes: 16

User avatar
nedostizni
Registered User
Posts: 391
Joined: Tue Mar 04, 2003 7:25 pm

Post by nedostizni » Fri Sep 29, 2006 4:21 pm

thanks for the reply.
For now i can`t update it to the 2.0.20 version, i must keep it at 2.0.19. So i there any way i could use this mod with these version? If not, then some other mode wich enables the Spam BOTs?

Thanks.

User avatar
nedostizni
Registered User
Posts: 391
Joined: Tue Mar 04, 2003 7:25 pm

Post by nedostizni » Sat Sep 30, 2006 6:51 pm

nedostizni wrote: thanks for the reply.
For now i can`t update it to the 2.0.20 version, i must keep it at 2.0.19. So i there any way i could use this mod with these version? If not, then some other mode wich enables the Spam BOTs?

Thanks.


any help please. thanks.

User avatar
JezUK1
Registered User
Posts: 735
Joined: Wed Jul 27, 2005 11:12 pm
Location: England, Somerset
Contact:

Post by JezUK1 » Sat Oct 07, 2006 12:31 pm

This mod is out of this world! I have had so many bots / spammers for ages. Since installing this mod I have not had one in weeks..Thanks so much for this mod its brill....If any of you guys get spamed loads. Use this mod!!!!
Jez

ControlThis.co.uk - Your online model shop

remid1985
Registered User
Posts: 47
Joined: Wed Jun 04, 2003 9:17 pm

Post by remid1985 » Mon Oct 16, 2006 10:27 am

In fact I changed this agreement question in just two lines few years ago

I accept
or
I don't accept

but a lot of spam can subscribe .
So my question is :
is it useful to install this mod?
www.fansdefoot.com my phpbb portal I made

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Wed Oct 18, 2006 7:45 am

Two years ago this change was 99.99% effective. Today, it's about 30-40%, on its own. Bots are smarter, and parse the pages. I see log entries where they even get the changed variable values right... but I also see log entries where they try every combination that has been listed in the posts on this topic and the original one the MOD is based upon, one right after another, hoping to get through.

This is one layer that allows you to make your board different. The more different you are, the less likely they get through. One of the Instant Ban MODs is "more effective" on its own than this, but it, too, is a layer of difference you can add.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

User avatar
Nomad Of Norad
Registered User
Posts: 37
Joined: Wed Dec 14, 2005 2:43 pm
Location: Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
Contact:

Post by Nomad Of Norad » Tue Oct 31, 2006 6:27 am

Okay, I installed the ConfusaBOT ACP mod using EasyMOD, but I cannot find the new menu items it is supposed to have added to the Admin page.

Looking through the .MOD file now, I see this:
## Author Notes:
## This MOD makes the "agreed" and "coppa" variables used in the registration screen more
## easily adjustable through the Admin Control Panel. This MOD requires phpBB v2.0.20 or later.
## Prior to installing this mod, you need to add the following configuration items to your
## phpbb_config table:
##
## INSERT INTO phpbb_config (config_name,config_value) VALUES ('agreed_var','IAmInAgreement');
## INSERT INTO phpbb_config (config_name,config_value) VALUES ('agreed_val','Yes');
## INSERT INTO phpbb_config (config_name,config_value) VALUES ('coppa_var','Under13');
##


and then I see this bit:
#
#-----[ SQL ]-------------------------------------------
#
INSERT INTO phpbb_config (config_name,config_value) VALUES ('agreed_var','IAmInAgreement');
INSERT INTO phpbb_config (config_name,config_value) VALUES ('agreed_val','Yes');
INSERT INTO phpbb_config (config_name,config_value) VALUES ('coppa_var','Under13');
#


...which looks like the part of the process that is supposed to insert the new variables into the SQL database.

Correct me if I'm wrong, but isn't EasyMOD supposed to handle all elements of installing the mod to the system, including inserting whatever new elements are supposed to be added into the SQL database?

Am I missing something here? Is there a seperate insert-this-set-of-new-variables-into-the-SQL-database script somewhere that is supposed to be used with this mod? (So I don't have to manually go and insert them into the SQL database before installing ConfusaBOT ACP with EasyMOD?)

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Tue Oct 31, 2006 7:23 am

EasyMOD is supposed to handle the program elements, SQL, and the subSilver template. Other templates may or may not be touched, depending upon many things, from what my spies tell me. I do not personally use EM, so I can not say.

Switch to the subSilver template, and see if the options are there. If they are, the problem is in your normal template, and the changes are easily accomplished.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

User avatar
Nomad Of Norad
Registered User
Posts: 37
Joined: Wed Dec 14, 2005 2:43 pm
Location: Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
Contact:

Post by Nomad Of Norad » Tue Oct 31, 2006 9:22 pm

espicom wrote: EasyMOD is supposed to handle the program elements, SQL, and the subSilver template. Other templates may or may not be touched, depending upon many things, from what my spies tell me. I do not personally use EM, so I can not say.

Switch to the subSilver template, and see if the options are there. If they are, the problem is in your normal template, and the changes are easily accomplished.


I did just that. Switched from WhatIsReal to subSilver, and then went to the Admin page, and there it was! Made the changes I needed, then switched back to WahtIsReal... and the menu items weren't there. I then created a test account, to see if the changes to the Coppa and stuff had gone into effect, and they had. Even in WhatIsReal. Hehe...

Someone needs to develop an automated front end proggy to help sysops take the changes made to subSilver and the like and copy-and-paste them as appropriate to the other themes... :D

I.e., the sysop could pull up the particular interface, tell it to "examine these theme's code files and compare them against this theme's code files and let me select what bits to copy over to them as a group..."

Does that sound like a workable add-on? Maybe the maker of the EasyMOD plug-in could do it...

On a different note, can someone point me to a set of proggies to test the anti-spammer changes? Where do spammers get their auto-signup proggies? Are they free?

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Thu Nov 02, 2006 12:50 am

Actually, it's simplest to copy the subSilver admin/ folder to the other templates, because that makes sure you have ALL the options in place, and you're not affecting what the users see. You can do this selectively for other templates, because 90% of what is "special" about a template is in overall_header.tpl.

I'd have simply copied the affected template files from subSilver, and only tweak the orignals if the subSilver files were "too different" from the rest of the site.

The future of EM is well beyond the scope of this topic, especially since it has its own support area. I hear a great many wishes for EM from both developers and users, and they're behind changes being made to MODs themselves - the XML-based MOD file now included in most approved MODs is because of this.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

n1h
Registered User
Posts: 5
Joined: Thu Nov 16, 2006 7:36 am
Location: venice, california
Contact:

ConfusaBOT_ACP_v100a with phpBB 2.0.21

Post by n1h » Thu Nov 16, 2006 7:54 am

Hello,

Is ConfusaBOT_ACP_v100a compatible with phpBB 2.0.21?
I edited the files and uploaded without any problems. I have the following
values in my db and they show up in ACP:

agreed_var IAmInAgreement
agreed_val YepYep
coppa_var Under13

Everything seemed to be working nicely until I tried to create a test account.
It just returns me to the Registration Agreement Terms page after filling out
the form. Did I miss something?
Thanks in advance,

-Niles

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Thu Nov 16, 2006 8:28 am

To my knowledge, nothing changed between 2.0.20 and .21 that affects the code that is looked for or modified by this MOD, and several people I know have it installed on both updated-to-2.0.21 and installed-fresh-2.0.21 forums. A link would be helpful...
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

dpicella
Registered User
Posts: 33
Joined: Thu Nov 16, 2006 6:20 am

Has Confusa Bot Lost Effectiveness??

Post by dpicella » Thu Nov 16, 2006 4:13 pm

The Confuse Mod is a good idea, but I am guessing that it has already lost its effectiveness.

I saw one post a few months ago rating effectiveness around 60%

I changed these values manually last night, got up - more spam... So I have not tried the mod.

I'm thinking instant ban is better.

The bots have probably figured out by now just to go the the agree page or the home page first and follow links to the registration form.

Anyway, the days are number on this mod.

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Thu Nov 16, 2006 8:16 pm

Yes, the effectiveness of changing the variables alone is now very low. On my boards, the bots adapt to the change pretty quickly, but most have been banned by their first, don't-bother-to-check attempt, and at least have to change IPs before trying again.

As stated here and elsewhere, I've combined this with Instant Ban, in that the default values for the variable names and values are in Instant Ban's list of things to trigger banning. No human should ever trip that ban; the bots do all the time, even if they put the correct variable in.

I've had some bots try five or six different variable names as a "shotgun" approach, using the ones published as examples in this and related topics, which is why I do not publish the values I really use, and only about half of the "triggers" I use for blocking a registration are published... The key is to make your board unique enough that their automated tools don't work, and making them work is too "expensive" to them in terms of time and programming.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

n1h
Registered User
Posts: 5
Joined: Thu Nov 16, 2006 7:36 am
Location: venice, california
Contact:

infinte loop

Post by n1h » Thu Nov 16, 2006 8:45 pm

espicom wrote: A link would be helpful...


http://www.fuckitall.com/bbs/index.php

that is the link to my forum if you have time to check it out.
crap. i appear to be censored due to my domain name.

f u c k i t a l l.com (no spaces) should go where the *beep* is

thanks,
-niles

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Thu Nov 16, 2006 9:06 pm

OK, when I go to your site and click register, it takes me to the COPPA page, then clicking on "over 13" takes me to a standard register form... but the template you're using has not been modified yet. I take it you only applied the changes to the subSilver template?

Copying profile_add_body.tpl from subSilver to your preferred template should make it work.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

Post Reply

Return to “[2.0.x] MOD Database Releases”