[Tool] phpBB 2.0.20 to phpBB 2.0.21 Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
9
53%
Very Good
2
12%
Good
5
29%
Fair
0
No votes
Poor
1
6%
 
Total votes: 17

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 27978
Joined: Sat Aug 16, 2003 7:36 am

[Tool] phpBB 2.0.20 to phpBB 2.0.21 Changes

Post by Extensions Robot » Sat Jun 10, 2006 3:04 pm

Classification: 48 phpBB Installation & Upgrade Tools

MOD Name: phpBB 2.0.20 to phpBB 2.0.21 Changes
Author: Graham
MOD Description: Code Changes from phpBB 2.0.20 to 2.0.21

This is the same ZIP posted in the 2.0.21 release announcement.
If you already have installed that one, you should not install this MOD otherwise you would cause damage to your board.



MOD Version: 1.0.0
Installation Level: Easy
Installation Time: ~ 45 Minutes

Download File: phpBB-2.0.21-codechanges.zip (Preferred) phpBB-2.0.21-codechanges.zip (Alternate)
File Size: 15520 Bytes

Support for this MOD needs to be asked within this topic. The phpBB Teams are not responsible or required to give anyone support for this MOD. By installing this MOD, the phpBB Support Team or phpBB MODifications Team may not be able to provide support.

This MOD has only been tested by the phpBB MOD Team with the phpBB version in the topic title. It may not work in any other versions of phpBB.

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Post by webmacster87 » Sat Jun 10, 2006 5:56 pm

MOD Validated/Released

Notes:
Use these instructions to update your board to 2.0.21 if it is heavily modified. Make sure you run install/update_to_lastest.php after making the code changes.
EDIT: This includes the patch for the languages bug as mentioned in the 2.0.21 release announcement.

User avatar
bill survival
Registered User
Posts: 64
Joined: Tue Jul 26, 2005 1:44 am
Contact:

Post by bill survival » Sat Jun 10, 2006 6:19 pm

I get this when I go their... :(




HTTP 500 - Internal server error
Internet Explorer

groundfighter
Registered User
Posts: 1909
Joined: Sat Nov 08, 2003 2:15 am
Location: Las Vegas, NV
Contact:

Post by groundfighter » Sat Jun 10, 2006 6:34 pm

bill survival wrote: I get this when I go their... :(




HTTP 500 - Internal server error
Internet Explorer


When you go where?

Forau
Registered User
Posts: 57
Joined: Sat Apr 26, 2003 9:44 pm
Contact:

Post by Forau » Sat Jun 10, 2006 7:18 pm

When clicking the preferred link, SourceForge automatically redirects the user to a download mirror that fails to work. Stopping the page that loads right after clicking that link and choosing a different mirror seems to solve the problem.

Spiritsilver
Registered User
Posts: 6
Joined: Tue Jan 24, 2006 3:09 am

Post by Spiritsilver » Sun Jun 11, 2006 12:52 am

if possible can i get the sql statements... as everytime ive tried runnin update to latest it never works for me... so ive gotten used to addin them in manually... thanks in advanced...

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq » Sun Jun 11, 2006 1:53 am

Spiritsilver wrote: if possible can i get the sql statements... as everytime ive tried runnin update to latest it never works for me... so ive gotten used to addin them in manually... thanks in advanced...


This is not a good practice, but here are the sql queries for mysql if you're really sure you've updated everything through 2.0.20:

Code: Select all

INSERT INTO phpbb_config (config_name, config_value) VALUES ('search_min_chars', '3');

DELETE FROM phpbb_sessions;

DELETE FROM phpbb_sessions_keys;

UPDATE phpbb_config SET config_value = '.0.21' WHERE config_name = 'version';

OPTIMIZE TABLE phpbb_auth_access, phpbb_banlist, phpbb_categories, phpbb_config, phpbb_disallow, phpbb_forum_prune, phpbb_forums, phpbb_groups, phpbb_posts, phpbb_posts_text, phpbb_privmsgs, phpbb_privmsgs_text, phpbb_ranks, phpbb_search_results, phpbb_search_wordlist, phpbb_search_wordmatch, phpbb_sessions_keys, phpbb_smilies, phpbb_themes, phpbb_themes_name, phpbb_topics, phpbb_topics_watch, phpbb_user_group, phpbb_users, phpbb_vote_desc, phpbb_vote_results, phpbb_vote_voters, phpbb_words;
(I hope someone else will check me on this since I did this quickly by taking a look at the update_to_latest.php code.)

Kajin
Registered User
Posts: 112
Joined: Wed Jun 15, 2005 5:06 am
Location: Moonside
Contact:

Post by Kajin » Sun Jun 11, 2006 1:56 am

Can this be installed with easymod?
Image

Timtam1234
Registered User
Posts: 815
Joined: Sun Mar 26, 2006 5:43 am
Location: Australia

Post by Timtam1234 » Sun Jun 11, 2006 2:01 am

Yes it can.

Narc0sis
Registered User
Posts: 662
Joined: Tue Apr 09, 2002 12:59 am
Contact:

Post by Narc0sis » Sun Jun 11, 2006 2:18 am

amazing, after i update and try to post i get a blank page of nothing.

after i revert to the old files, same thing.

sheesh what is going on with this update?

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq » Sun Jun 11, 2006 2:29 am

Narc0sis wrote: amazing, after i update and try to post i get a blank page of nothing.

after i revert to the old files, same thing.

sheesh what is going on with this update?


The update works fine...you made a mistake in how you installed it. If you didn't use easymod, consider saving yourself (and people giving support) trouble in the future by using easymod.

You say you've still got a white screen when you revert back to your original files....you need to look in your php error log and tell us what error message you are getting in order for anyone to help.
Last edited by asinshesq on Sun Jun 11, 2006 2:32 am, edited 1 time in total.

Spiritsilver
Registered User
Posts: 6
Joined: Tue Jan 24, 2006 3:09 am

Post by Spiritsilver » Sun Jun 11, 2006 2:30 am

asinshesq wrote: This is not a good practice, but here are the sql queries for mysql if you're really sure you've updated everything through 2.0.20:

(I hope someone else will check me on this since I did this quickly by taking a look at the update_to_latest.php code.)



ive gotten used to addin all the queries in through the sql from playin round with adr code... seems lots easier to me myself if the code is done right for hte update of my tables.... anyhow.. thanks asinshesq.... :D ill prolly update tomorrow since i still have a few mods to tweek tonight.... just needed to get things in order first before i do the update... :D thanks again..

Dzonatas
Registered User
Posts: 5
Joined: Fri Jun 09, 2006 1:00 am

Post by Dzonatas » Sun Jun 11, 2006 2:35 am

this is the error I got from update_to_latest.php

Code: Select all

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /var/www/admin/mods/2.0.20-2.0.21/install/update_to_latest.php on line 46

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/admin/mods/2.0.20-2.0.21/install/update_to_latest.php on line 46

Warning: main(./../config.): failed to open stream: No such file or directory in /var/www/admin/mods/2.0.20-2.0.21/install/update_to_latest.php on line 47

Warning: main(): Failed opening './../config.' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/admin/mods/2.0.20-2.0.21/install/update_to_latest.php on line 47
Please read: INSTALL.html before attempting to update.
Also, there was no INSTALL.html file to be found.

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq » Sun Jun 11, 2006 2:43 am

Dzonatas wrote: this is the error I got from update_to_latest.php

Code: Select all

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /var/www/admin/mods/2.0.20-2.0.21/install/update_to_latest.php on line 46

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/admin/mods/2.0.20-2.0.21/install/update_to_latest.php on line 46

Warning: main(./../config.): failed to open stream: No such file or directory in /var/www/admin/mods/2.0.20-2.0.21/install/update_to_latest.php on line 47

Warning: main(): Failed opening './../config.' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/admin/mods/2.0.20-2.0.21/install/update_to_latest.php on line 47
Please read: INSTALL.html before attempting to update.
Also, there was no INSTALL.html file to be found.


Sounds like you ldidnt copy the install folder under your root phpbb2 folder (that's where it needs to be). Copy it there and then browse to it with your browser.

Narc0sis
Registered User
Posts: 662
Joined: Tue Apr 09, 2002 12:59 am
Contact:

Post by Narc0sis » Sun Jun 11, 2006 2:46 am

asinshesq wrote:
Narc0sis wrote:amazing, after i update and try to post i get a blank page of nothing.

after i revert to the old files, same thing.

sheesh what is going on with this update?


The update works fine...you made a mistake in how you installed it. If you didn't use easymod, consider saving yourself (and people giving support) trouble in the future by using easymod.

You say you've still got a white screen when you revert back to your original files....you need to look in your php error log and tell us what error message you are getting in order for anyone to help.


never had to use easymod ever, i prefer doing it manually. I really haven't encountered problems like this before and i've been updating the same way since before 2.0.0 became final.

Heres what the error_log says

[10-Jun-2006 19:21:56] PHP Fatal error: Call to undefined function: dss_rand() in /home/deviant/public_html/phpBB2/includes/bbcode.php on line 276

this is odd because this file wasn't even changed.

Post Reply

Return to “[2.0.x] MOD Database Releases”