[2.0.21] User Shield

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
52
79%
Very Good
8
12%
Good
4
6%
Fair
1
2%
Poor
1
2%
 
Total votes: 66

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Sun Dec 10, 2006 7:45 pm

You're most welcome jodeci and that's great news. Good luck to you!


Best regards,
Wolf :wink:

skaloumbakas
Registered User
Posts: 179
Joined: Wed Sep 25, 2002 11:26 am
Location: Athens Hellas

I GOT IT!!!

Post by skaloumbakas » Sun Dec 10, 2006 9:05 pm

So far, so good - fingers crossed!

MOD is working fine with my good old version... :oops:

GREAT MOD!!!

So far, I was doing the deletes of the spambods through the phpMyAdmin, (not so difficult) but your MOD does things much faster and the most important, inactive users are hidden from the crowd...

Keep up with the good work wolfy.

PS. And another thing: I have changed "stealth" with "shield" in the coding of the .php's :wink:
Christos Skaloumbakas

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Sun Dec 10, 2006 9:30 pm

:D ... music to my ears. Great news and thank you so much for the kind words.


Best regards,
Wolf :wink:

Nikodemz
Registered User
Posts: 3
Joined: Tue Sep 12, 2006 11:17 pm

Post by Nikodemz » Fri Dec 15, 2006 7:36 pm

Wolf,

Thank you for the great mod. The installation went through quite well even with a number of other mods installed on my board.

The one thing I'm having a little issue with is that the Email icon is not showing in the Memberlist for Registered users, but it does show for my Admin user. Is that by design or did I mess something up?

I've done quite a bit of editing to the memberlist so it's entirely possible that I screwed something up or that another mod is conflicting. I have the following mod installed: Memberlist Access http://www.phpbb.com/phpBB/viewtopic.ph ... memberlist which restricts access to the memberlist to only registered users but it shouldn't effect the individual fields in the list.

Thanks for any help you can give.

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Fri Dec 15, 2006 8:21 pm

Hi Nikodemz,
Nikodemz wrote: The one thing I'm having a little issue with is that the Email icon is not showing in the Memberlist for Registered users, but it does show for my Admin user. Is that by design or did I mess something up?

hehehe... This is phpBB default behavior. This issue (if it's what I believe it is) was reported a while back by a User Shield user. Here's the reply which explains in detail what might also be your case.
  • A reply in this thread on October 5th 2006 wrote...
[/url]
Nikodemz wrote: Thank you for the great mod. The installation went through quite well even with a number of other mods installed on my board.


Thank you very much for the kind words and let me know if the above explanation takes care of your concerns.


Best regards,
Wolf :wink:

bper
Registered User
Posts: 63
Joined: Wed Jan 26, 2005 4:32 am
Location: Washington State

Post by bper » Mon Dec 18, 2006 3:59 pm

Hi Wolf - I have been using the user shield a couple months now and it works very well. You have designed an excellent powerful tool for the administrator. I am now getting such a number of spammers each day, I have had to go to admin activation to stop them. User activation only slows about half of them down. The rest just register and post there junk.

I have one question about the program. Since going to admin activation, I have asked new registers in an announcment on the forum site to enter a couple words under interests, so I can key in on these and know they are not spammers. Most spammers do not go through the trouble to read any announcements in the forum before registering.

Is it possible to change the www field to make it the interests field? That way when I click non-activated members and it brings up the form to delete or activate them, I could find the key words quicker with this change. I can then check the boxes and activate the ones that have the key words. The rest get deleted. Works smooth as long as you don't click the wrong box. :oops:

Thanks for any input. I realize I may need to change one of the files, but I didn't want to mess with it until asking first - bper :D

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Mon Dec 18, 2006 4:45 pm

Hi bper,
bper wrote: Is it possible to change the www field to make it the interests field?

Yes, no biggie. But I don't have the time at this moment to set you up with the needed modifications. Will try later on this pm or early evening. Sounds good?


Regards,
Wolf

bper
Registered User
Posts: 63
Joined: Wed Jan 26, 2005 4:32 am
Location: Washington State

Post by bper » Mon Dec 18, 2006 7:53 pm

Thanks wolf, I will moniter this thread until you have the time. Please do not rush, I know it's a busy time of the year for everyone - bper :D

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Mon Dec 18, 2006 10:52 pm

There you go:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
memberlist.php

#
#-----[ FIND ]------------------------------------------
#
# this is a partial line match
#
$mode_types_text = 

#
#-----[ IN-LINE FIND ]------------------------------------------
#
$lang['Sort_Website']

#
#-----[ IN-LINE REPLACE WITH ]------------------------------------------
#
$lang['Interests']

#
#-----[ FIND ]------------------------------------------
#
	'L_WEBSITE' => $lang['Website'],

#
#-----[ REPLACE WITH ]------------------------------------------
#
	'L_WEBSITE' => $lang['Interests'],

#
#-----[ FIND ]------------------------------------------
#
		$order_by = "user_website $sort_order LIMIT $start, " . $board_config['topics_per_page'];

#
#-----[ REPLACE WITH ]------------------------------------------
#
		$order_by = "user_interests $sort_order LIMIT $start, " . $board_config['topics_per_page'];

#
#-----[ FIND ]------------------------------------------
#
# this is a partial line match
#
$sql = "SELECT username

#
#-----[ IN-LINE FIND ]------------------------------------------
#
user_allowavatar

#
#-----[ IN-LINE AFTER, ADD ]------------------------------------------
#
, user_interests

#
#-----[ FIND ]------------------------------------------
#
		$www_img = ( $row['user_website'] ) ? '<a href="' . $row['user_website'] . '" target="_userwww"><img src="' . $images['icon_www'] . '" alt="' . $lang['Visit_website'] . '" title="' . $lang['Visit_website'] . '" border="0" /></a>' : '';

#
#-----[ REPLACE WITH ]------------------------------------------
#
		$www_img = $row['user_interests'];

#
#-----[ FIND ]------------------------------------------
#
		$www = ( $row['user_website'] ) ? '<a href="' . $row['user_website'] . '" target="_userwww">' . $lang['Visit_website'] . '</a>' : '';

#
#-----[ REPLACE WITH ]------------------------------------------
#
		// $www = ( $row['user_website'] ) ? '<a href="' . $row['user_website'] . '" target="_userwww">' . $lang['Visit_website'] . '</a>' : '';

#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/memberlist_body.tpl

#
#-----[ FIND ]------------------------------------------
#
	  <td class="{memberrow.ROW_CLASS}" align="center">&nbsp;{memberrow.WWW_IMG}&nbsp;</td>

#
#-----[ REPLACE WITH ]------------------------------------------
#
	  <td class="{memberrow.ROW_CLASS}" align="center"><span class="gen">&nbsp;{memberrow.WWW_IMG}&nbsp;</span></td>

#
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------
#
# EoM

Let me know if this is what you were looking for. Make a copy of the 2 files you are about to modify before you do so, as you probably already know. :wink:


Best regards,
Wolf

bper
Registered User
Posts: 63
Joined: Wed Jan 26, 2005 4:32 am
Location: Washington State

Post by bper » Tue Dec 19, 2006 5:01 am

Hi Wolf - I have installed it and am having a problem in the interest column boxes. The interest column seems to have replaced the www column ok, but I get the output below after each name in the list.

\{memberrow.WWW_IMG\}

I double checked everything, but maybe I did something wrong. I went ahead and changed it back to normal from backups until I hear from you - bper :D

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Tue Dec 19, 2006 6:09 pm

Double check this line again:

Code: Select all

<td class="{memberrow.ROW_CLASS}" align="center"><span class="gen">&nbsp;{memberrow.WWW_IMG}&nbsp;</span></td>
... and make sure it's identical. If it is identical, then can you link me to your memberlist.php (renaming it to memberlist.txt) and I'll look it over for you.

bper
Registered User
Posts: 63
Joined: Wed Jan 26, 2005 4:32 am
Location: Washington State

Post by bper » Tue Dec 19, 2006 7:21 pm

Hi Wolf - It works perfect now. I found a couple of extra slashes in that line. I'm sure I did it somehow in the copying. Thank you so much for your efforts in helping me do this. Since I switched to admin activation and activate only those that have the correct keywords in the interests field, I have not had one spammer get in.

I'm sure not everyone legitimate wanting to register reads the announcement first about the registration policies, but if they want to post bad enough, they will eventually find it. The current forum members are just happy to see the spammers gone. Your program makes it very easy to get rid of them before they are activated - bper :D :D :D

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Tue Dec 19, 2006 7:33 pm

Very good news bper! Glad to see that's all it took and good luck to you.


Best regards,
Wolf :wink:

telsea
Registered User
Posts: 19
Joined: Sun May 07, 2006 9:53 pm

Post by telsea » Wed Dec 20, 2006 2:12 pm

Hi Wolf,

Great mod but I have a couple problems...

1. I don't see User Shield in my ACP.
2. On the front page it only displays 7 non-active members, when there are more than that.

Thanks in advance!

User avatar
Perry Dror
Registered User
Posts: 12
Joined: Fri Jun 09, 2006 11:23 pm
Location: Asheville, NC
Contact:

Post by Perry Dror » Wed Dec 20, 2006 2:57 pm

I just installed User Shield. It doesn't stop spammers from registering, but it really makes it easier to delete them, and keeps my board memebers from accidently getting exposed to some shocking porn (and I am not easily shocked).

Are there any MODs that stop the bots from registering, which can be installed by EasyMOD? Most of the MODs I saw were scripts, with no instructions as to how and where to insert these scripts.

Thanks!

Perry
It takes a community to raise a village.

Post Reply

Return to “[2.0.x] MOD Database Releases”