[2.0.21] User Shield

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
52
79%
Very Good
8
12%
Good
4
6%
Fair
1
2%
Poor
1
2%
 
Total votes: 66

User avatar
will_hough
Former Team Member
Posts: 1933
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.21] User Shield

Post by will_hough » Tue Nov 06, 2007 8:47 pm

thecomputergal wrote:I am also having the problem with not being able to delete spammers in the User Shield inactive users window. Has anyone found a fix for this?

Thanks!
Did you run the SQL?
R.I.P. D¡cky

thecomputergal
Registered User
Posts: 6
Joined: Thu Jun 28, 2007 9:02 pm
Location: Missoula, Montana
Contact:

Re: [2.0.21] User Shield

Post by thecomputergal » Mon Nov 12, 2007 4:24 am

Thanks for the reply, but I'm not sure exactly what you mean "run the SQL." I installed the User Shield mod to give the guy who deletes the spammers a quick way to do it. Now we can't delete from that window because of a missing group id. The problem started all the sudden about two weeks ago.

User avatar
will_hough
Former Team Member
Posts: 1933
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.21] User Shield

Post by will_hough » Mon Nov 12, 2007 2:11 pm

thecomputergal wrote:Thanks for the reply, but I'm not sure exactly what you mean "run the SQL." I installed the User Shield mod to give the guy who deletes the spammers a quick way to do it. Now we can't delete from that window because of a missing group id. The problem started all the sudden about two weeks ago.
The MOD was working fine and now it's not?
R.I.P. D¡cky

thecomputergal
Registered User
Posts: 6
Joined: Thu Jun 28, 2007 9:02 pm
Location: Missoula, Montana
Contact:

Re: [2.0.21] User Shield

Post by thecomputergal » Mon Nov 12, 2007 6:35 pm

Yes, that's correct. We have been using User Shield for a number of months, and it has been a great tool for dumping spammers. We have our forum set so that folks have to be approved before they can post. But, they were still showing up in the Memberlist before they were approved. User Shield hides them until they are approved.

It's my guess that someone has figured out how to get in the list without a Group ID; so, the delete function fails. I was wondering if anyone had built a patch or found some other solution.

Wolf has always given great responses to questions, but he doesn't seem to be available any more.

Thanks for your response!

User avatar
will_hough
Former Team Member
Posts: 1933
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.21] User Shield

Post by will_hough » Mon Nov 12, 2007 7:11 pm

Has anyone been messing with files, installing MODs?
R.I.P. D¡cky

ChakraGoddess
Registered User
Posts: 3
Joined: Wed Aug 29, 2007 9:46 am

Re:

Post by ChakraGoddess » Mon Nov 12, 2007 11:59 pm

Wo1f wrote: [*]Using the XML installation file type:
  1. Extract "install_user_shield_v1_x_x.xml" along with "modx.subsilver.en.xsl" into the same folder on your local machine
  2. Launch the XML installation file (double-click on "install_user_shield_v1_x_x.xml"), to display it's content in your default browser
  3. Follow the installation instructions until completion
  4. When done, proceed with #2 (Database update)
  5. You can safely ignore the [SQL] action at the beginning of the installation file (will be taken care of in step #2)
  6. You can safely ignore the TXT installation file type in the zip package
[/list]
hi Wolf,

Got the file unzipped alright (yes!) but the .xml file is reading as an error when I try and open it. Got anything easier? ;-)

User avatar
will_hough
Former Team Member
Posts: 1933
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.21] User Shield

Post by will_hough » Tue Nov 13, 2007 2:13 pm

There is a text file thats easy to use.

contrib/install_user_shield_v1_2_1.txt
R.I.P. D¡cky

charmedseed
Registered User
Posts: 1
Joined: Fri Nov 16, 2007 4:41 pm

Re: [2.0.21] User Shield

Post by charmedseed » Fri Nov 16, 2007 4:42 pm

I'm trying to install with EasyMod, having followed the instructions on the first post of this thread. But I keep getting this error message:
Critical Error

FIND FAILED: In file [memberlist.php] could not find:

WHERE user_id <> " . ANONYMOUS;

MOD script line #281 :: FAQ :: Report
I've made sure to CHMOD to 755 on the folder, what else should I do?

thecomputergal
Registered User
Posts: 6
Joined: Thu Jun 28, 2007 9:02 pm
Location: Missoula, Montana
Contact:

Re: [2.0.21] User Shield

Post by thecomputergal » Sat Nov 17, 2007 1:19 am

Will,

Back to not being able to delete new users in the User Shield Mode, no, there were no files changed. In fact, I did a test and registered a test account. I was able to delete that particular account.

It seems that User Shield creates a query ?mode=inactive on the memberlist.php file. When that particular query string is passed in, each member has a checkbox by their name that is supposed to allow choice to delete.

However, those entries that are spammers don't allow for deleting. Also the Select All and Unselect All links don't work. I'm guessing that there is a new programming twist in the programming the spammers are using that bypasses the default group_id field entry, leaving it empty. That causes the query to delete the member to fail, giving this message:
Could not delete group for this user

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2

DELETE FROM NewForumgroups WHERE group_id =

Line : 429
File : memberlist.php

Unfortunately, I don't know enough about the overall working of phpBB to fix the problem! I checked all my file dates, and no changes have been made to the files. I'm guessing this one will need a hole patched!

Thanks for all your help!

User avatar
will_hough
Former Team Member
Posts: 1933
Joined: Mon Feb 06, 2006 8:47 pm
Location: Michigan
Name: Will Hough
Contact:

Re: [2.0.21] User Shield

Post by will_hough » Sun Nov 18, 2007 3:40 am

charmedseed wrote:I'm trying to install with EasyMod, having followed the instructions on the first post of this thread. But I keep getting this error message:
Critical Error

FIND FAILED: In file [memberlist.php] could not find:

WHERE user_id <> " . ANONYMOUS;

MOD script line #281 :: FAQ :: Report
I've made sure to CHMOD to 755 on the folder, what else should I do?
You may need to install this by hand. Your file structure may have been altered by another mod. The error is telling you that Easy MOD can not find the code in memberlist.php

Code: Select all

		WHERE user_id <> " . ANONYMOUS;
R.I.P. D¡cky

JustForMilitary
Registered User
Posts: 9
Joined: Tue Jan 02, 2007 1:45 pm
Contact:

Re: [2.0.21] User Shield...NEED HELP

Post by JustForMilitary » Sun Mar 30, 2008 9:44 am

I need help....I installed this MOD manually, but do not understand what to do about the DIY instructions. Yes, I am fairly new to all of this. I do not have an install folder, not sure how to "update" the config file, nor do I know how to get the update file in the files to even run it....I need help. I have completed all the other functions of the MOD manually.

Here is the DIY part I do not understand:

IMPORTANT ***** If you are NOT using EasyMOD to install User Shield, you MUST update the CONFIG table by following these instructions ***** IMPORTANT
IMPORTANT ***** Remember to change the default TABLE PREFIX in file "update_config_v1_2_1.php" if your board does not use " phpbb_ ". ***** IMPORTANT

1] Run this file: update_config_v1_2_1.php - located in the install folder off the root of your forum ( eg. In your browser URL field, type the following: http://yoursite.com/yourforumroot/insta ... v1_2_1.php )

Once done a message confirming a successful update will be displayed along with a reminder to delete the "install" folder including it's content, before returning to your forum.

Also, the SQL part in the beginning....what do I need to do here...not understanding where exactly or what exactly I need to do with this:
INSERT INTO `phpbb_config` (`config_name`, `config_value`)
VALUES ('username_hide_inac', '1');

Help please??
Active duty US military, retired, or a family member...drop me an e-mail to hear about a place you must see. It's awesome!

JustForMilitary
Registered User
Posts: 9
Joined: Tue Jan 02, 2007 1:45 pm
Contact:

Re: [2.0.21] User Shield

Post by JustForMilitary » Sun Mar 30, 2008 10:01 am

update.....OK, I got the DIY install part completed, ran sucessfully and then deletd install file. I can not get th SQL part though in the beginning of the MOD??? When I log into my board and try to view the memberlist I get this:
Parse error: syntax error, unexpected '"' in /home/jejainc/public_html/forum/memberlist.php on line 367

help???
Active duty US military, retired, or a family member...drop me an e-mail to hear about a place you must see. It's awesome!

aosfyc
Registered User
Posts: 58
Joined: Tue Jul 19, 2005 6:21 pm

Re: [2.0.21] User Shield

Post by aosfyc » Tue Apr 01, 2008 2:16 am

Has anyone else experienced problems after updating to 2.0.23? I have had this running for a while now, and haven't had any problems, but just yesterday after upgrading to 2.0.23, the Who Is Online data in the index.php page is coming up with incorrect data.
Our users have posted a total of 2896 articles
We have 509 registered users and non-active registered users
Whereas before where the "non-active" verbiage is I had the number of inactive users.

Any ideas?

Thanks!!

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20444
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [2.0.21] User Shield

Post by RMcGirr83 » Tue Apr 01, 2008 10:16 am

charmedseed wrote:I'm trying to install with EasyMod, having followed the instructions on the first post of this thread. But I keep getting this error message:
Critical Error

FIND FAILED: In file [memberlist.php] could not find:

WHERE user_id <> " . ANONYMOUS;

MOD script line #281 :: FAQ :: Report
I've made sure to CHMOD to 755 on the folder, what else should I do?
find this in memberlist.php

Code: Select all

	$sql = "SELECT count(*) AS total
		FROM " . USERS_TABLE . "
		WHERE user_id <> " . ANONYMOUS;
and change it to this

Code: Select all

	$sql = "SELECT count(*) AS total
		FROM " . USERS_TABLE . "
		WHERE user_id <> " . ANONYMOUS . " $hide_inactive_on";
// User Stealth mod - added  $hide_inactive_on above
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20444
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [2.0.21] User Shield

Post by RMcGirr83 » Tue Apr 01, 2008 10:22 am

empressamermaids wrote:Critical Error

FIND FAILED: In file [includes/functions.php] could not find:

WHERE user_id <> " . ANONYMOUS;

MOD script line #517 :: FAQ :: Report

This is the error message I get after trying to install User Shield with EasyMod. Is the syntax wrong?
Find this in functions.php

Code: Select all

		case 'usercount':
			$sql = "SELECT COUNT(user_id) AS total
				FROM " . USERS_TABLE . "
				WHERE user_id <> " . ANONYMOUS;
			break;
and change it to this

Code: Select all


		case 'usercount':
// User Stealth mod - start
	$hide_inactive_on = ( $board_config['username_hide_inac'] ) ? 'AND user_active = 1' : 'AND user_active >= 0';
// User Stealth mod - end
			$sql = "SELECT COUNT(user_id) AS total
				FROM " . USERS_TABLE . "
				WHERE user_id <> " . ANONYMOUS . " $hide_inactive_on ";
// User Stealth mod - added $hide_inactive_on above
			break;
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 6 guests

cron