[2.0.21] User Shield

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
52
79%
Very Good
8
12%
Good
4
6%
Fair
1
2%
Poor
1
2%
 
Total votes: 66

Venicewebsite
Registered User
Posts: 2
Joined: Thu Jul 05, 2007 3:09 am

Re: [2.0.21] User Shield

Post by Venicewebsite » Mon Jul 09, 2007 1:27 am

Hey guys,

I figured it out and works great but I ran into an issue with the Forum not showing the number of posts anymore and it says: Our users have posted a total of 0 articles We have 18 registered users

My Forum is located here http://peppertreepublishing.com/publishers-forum

Any Ideas where I screwed up? maybe I deleted an extra line somewhere while installing the extra security.

Venicewebsite

DonnaL
Registered User
Posts: 3
Joined: Sat Jul 14, 2007 5:21 am
Location: US
Contact:

Re: [2.0.21] User Shield

Post by DonnaL » Sat Jul 14, 2007 5:29 am

Hey all..great mod wolf :)

I manually installed this mod, it seems to be working, only thing is, all members are hidden from me too and im site admin, I have to turn the feature off to see all the inactive users.

It also shows the setting twice in the configuratin in ACP and I see no filter at all to bulk delete or anything like that..

Any help would be appreciated..

Thanks Donna...
Last edited by DonnaL on Sun Jul 15, 2007 12:32 am, edited 1 time in total.

DonnaL
Registered User
Posts: 3
Joined: Sat Jul 14, 2007 5:21 am
Location: US
Contact:

Re: [2.0.21] User Shield

Post by DonnaL » Sun Jul 15, 2007 12:18 am

Ok I managed to sort out the double setting in ACP, and I also managed to get the non-active link to show on the index page, now the only thing is, I dont know why, or if its supposed to, when I pull up non-active list its only showing 1 person per page, and same when I go to view my members list, it says I have 113 non active but I can only view about 8 non active 1 per page?

Image

jskor
Registered User
Posts: 25
Joined: Mon Mar 19, 2007 8:28 pm

[2.0.21] User Shield

Post by jskor » Fri Jul 27, 2007 5:53 pm

Wolf,

I need an assist if you would. Easy Mod shows the shield as being installed but it has stopped working all of a sudden. People are appearing in my memberlist and I have lost the interface\ability to remove them enmasse.

The ACP doesn't exist anymore

~jskor

User avatar
rogersjr
Registered User
Posts: 54
Joined: Mon Aug 18, 2003 11:33 pm
Location: Australia
Contact:

Re: [2.0.21] User Shield

Post by rogersjr » Thu Aug 16, 2007 11:01 pm

I installed user shield in June and it has worked perfectly until last week. Although I can see the new members I cannot delete them. Instead I get the error message below. I had made no changes to any phpbb files, it simply worked one day and not the next. Can anyone suggest what I can do to make this excellent mod work again?


Could not delete group for this user

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2

DELETE FROM phpbb_groups WHERE group_id =

Line : 445
File : memberlist.php

DonnaL
Registered User
Posts: 3
Joined: Sat Jul 14, 2007 5:21 am
Location: US
Contact:

Re: [2.0.21] User Shield

Post by DonnaL » Mon Aug 20, 2007 6:40 pm

I am still having the problem of only seeing one user in the member list and no option to delete all the unactivated, anyone know when wolf will be around to assist? I posted my original post ages ago.

User avatar
rogersjr
Registered User
Posts: 54
Joined: Mon Aug 18, 2003 11:33 pm
Location: Australia
Contact:

Re: [2.0.21] User Shield

Post by rogersjr » Mon Aug 20, 2007 9:11 pm

My problem just fixed itself and is now working correctly. No idea why. Perhaps it was some change being made by the host company on their server.

jonathanes
Registered User
Posts: 5
Joined: Fri Aug 24, 2007 2:47 pm
Location: Oxfordshire, England, UK
Contact:

Re: [2.0.21] User Shield

Post by jonathanes » Fri Aug 24, 2007 7:28 pm

As sweet as a nut 8-)

Installed using EasyMOD and worked first time and does everything I had been looking for...and a few more things :D

voted: Excellent!

User avatar
apfan
Registered User
Posts: 168
Joined: Thu Jun 02, 2005 4:15 am
Location: PhpBB 2.22.x For president!

Post by apfan » Sat Aug 25, 2007 11:47 am

Wo1f wrote:
RicardM wrote: Error : Duplicate entry 'username_hide_inac' for key 1
So I assume that means I had already done it.

Yes, that's correct. It does confirm that the database entry is there. Have you rechecked the edits for these 2 files:

1] admin/admin_board.php
2] templates/subSilver/admin/board_config_body.tpl

Looking good?
Sorry for bumping this old error but i am getting the exactly same error message?
I have alredy checked the files stated above.

Help please

mdm0173
Registered User
Posts: 4
Joined: Thu Sep 06, 2007 8:59 am

Re: [2.0.21] User Shield

Post by mdm0173 » Sun Sep 09, 2007 6:45 am

I'm having an issue with this MOD ... I inherited this phpBB and when I manually updated it to the most recent version everytime someone registers it says "Invalid or Inactive User" - meaning that no one can register.

Any one else run into this problem?

Tom_in_AZ
Registered User
Posts: 24
Joined: Sat Nov 05, 2005 8:23 am

Re: [2.0.21] User Shield

Post by Tom_in_AZ » Fri Sep 14, 2007 2:21 am

I have Easymod 0.3.0 and phpBB 2.0.22 working. I went to install User Shield and it is not completely working right just yet. It shows up in my ACP, it is turned on as well, however the line above it is blank with a yes/no question that I have no clue what it is for. The only other mod is Memberlist Access. Is it me or am I missing something. Thanks in advance.

Image


Here is a copy of my info.

MOD Title: User Shield 1.2.1 install_user_shield_v1_2_1.mod
Description: Hides usernames and corresponding profile data from all except the Administrator until activated. Manage (activate or delete) non-activated members from the memberlist.
Author: Wo1f N/A J. C. Woof N/A
Installed: Sep 13 2007 06:19 pm
phpBB version: 2.0.22
Processed Themes: AcidTechBlood; subSilver
Processed Languages: belarusian; kurdish; turkish; slovak; basque; mongolian; uighur; lithuanian; korean; bulgarian; farsi; japanese; croatian; russian_tu; arabic; breton; indonesian; romanian_no_diacritics; french; norwe
Files Edited: 116
admin/admin_board.php
includes/functions.php
includes/usercp_viewprofile.php
index.php
language/lang_albanian/lang_admin.php
language/lang_albanian/lang_main.php
language/lang_arabic/lang_admin.php
language/lang_arabic/lang_main.php
language/lang_asturian/lang_admin.php
language/lang_asturian/lang_main.php
language/lang_azerbaijani/lang_admin.php
language/lang_azerbaijani/lang_main.php
language/lang_basque/lang_admin.php
language/lang_basque/lang_main.php
language/lang_belarusian/lang_admin.php
language/lang_belarusian/lang_main.php
language/lang_bosnian/lang_admin.php
language/lang_bosnian/lang_main.php
language/lang_breton/lang_admin.php
language/lang_breton/lang_main.php
language/lang_bulgarian/lang_admin.php
language/lang_bulgarian/lang_main.php
language/lang_catalan/lang_admin.php
language/lang_catalan/lang_main.php
language/lang_chinese_simplified/lang_admin.php
language/lang_chinese_simplified/lang_main.php
language/lang_chinese_traditional/lang_admin.php
language/lang_chinese_traditional/lang_main.php
language/lang_croatian/lang_admin.php
language/lang_croatian/lang_main.php
language/lang_dutch/lang_admin.php
language/lang_dutch/lang_main.php
language/lang_english/lang_admin.php
language/lang_english/lang_main.php
language/lang_esperanto/lang_admin.php
language/lang_esperanto/lang_main.php
language/lang_estonian/lang_admin.php
language/lang_estonian/lang_main.php
language/lang_farsi/lang_admin.php
language/lang_farsi/lang_main.php
language/lang_finnish/lang_admin.php
language/lang_finnish/lang_main.php
language/lang_french/lang_admin.php
language/lang_french/lang_main.php
language/lang_frisian/lang_admin.php
language/lang_frisian/lang_main.php
language/lang_german/lang_admin.php
language/lang_german/lang_main.php
language/lang_german_formal/lang_admin.php
language/lang_german_formal/lang_main.php
language/lang_greek/lang_admin.php
language/lang_greek/lang_main.php
language/lang_hebrew/lang_admin.php
language/lang_hebrew/lang_main.php
language/lang_hungarian/lang_admin.php
language/lang_hungarian/lang_main.php
language/lang_indonesian/lang_admin.php
language/lang_indonesian/lang_main.php
language/lang_italian/lang_admin.php
language/lang_italian/lang_main.php
language/lang_japanese/lang_admin.php
language/lang_japanese/lang_main.php
language/lang_korean/lang_admin.php
language/lang_korean/lang_main.php
language/lang_kurdish/lang_admin.php
language/lang_kurdish/lang_main.php
language/lang_lithuanian/lang_admin.php
language/lang_lithuanian/lang_main.php
language/lang_macedonian/lang_admin.php
language/lang_macedonian/lang_main.php
language/lang_mongolian/lang_admin.php
language/lang_mongolian/lang_main.php
language/lang_norwegian/lang_admin.php
language/lang_norwegian/lang_main.php
language/lang_norwegian_nynorsk/lang_admin.php
language/lang_norwegian_nynorsk/lang_main.php
language/lang_polish/lang_admin.php
language/lang_polish/lang_main.php
language/lang_portuguese_brazil/lang_admin.php
language/lang_portuguese_brazil/lang_main.php
language/lang_romanian/lang_admin.php
language/lang_romanian/lang_main.php
language/lang_romanian_no_diacritics/lang_admin.php
language/lang_romanian_no_diacritics/lang_main.php
language/lang_russian/lang_admin.php
language/lang_russian/lang_main.php
language/lang_russian_tu/lang_admin.php
language/lang_russian_tu/lang_main.php
language/lang_serbian/lang_admin.php
language/lang_serbian/lang_main.php
language/lang_serbian_cyrillic/lang_admin.php
language/lang_serbian_cyrillic/lang_main.php
language/lang_slovak/lang_admin.php
language/lang_slovak/lang_main.php
language/lang_spanish/lang_admin.php
language/lang_spanish/lang_main.php
language/lang_spanish_argentina/lang_admin.php
language/lang_spanish_argentina/lang_main.php
language/lang_thai/lang_admin.php
language/lang_thai/lang_main.php
language/lang_turkish/lang_admin.php
language/lang_turkish/lang_main.php
language/lang_uighur/lang_admin.php
language/lang_uighur/lang_main.php
language/lang_vietnamese/lang_admin.php
language/lang_vietnamese/lang_main.php
language/lang_welsh/lang_admin.php
language/lang_welsh/lang_main.php
memberlist.php
profile.php
templates/AcidTechBlood/admin/board_config_body.tpl
templates/AcidTechBlood/index_body.tpl
templates/AcidTechBlood/memberlist_body.tpl
templates/subSilver/admin/board_config_body.tpl
templates/subSilver/index_body.tpl
templates/subSilver/memberlist_body.tpl
Database Alterations: Tables Added: 0 Tables Altered: 0 Rows Added: 0

xgator
Registered User
Posts: 21
Joined: Fri May 06, 2005 4:52 pm

Re: [2.0.21] User Shield

Post by xgator » Tue Sep 25, 2007 4:36 pm

I am having the same problem with User Shield. I have it installed on 2.0.22. It willonly show the first person in the active list and the first in the inactive list. I have gone over all of the mods that I did (manually) and they all look correct. Any help would be greatly appreciated.

sasully
Registered User
Posts: 1
Joined: Wed Oct 24, 2007 7:09 pm

can't open install_user_shield_v1_2_1.txt

Post by sasully » Wed Oct 24, 2007 7:30 pm

Sorry, but I have the same problem ksimm reported a year ago. Trying to install User Shield with EasyMOD -- my first MOD install, actually. Downloaded and sucessfully installed EasyMOD. Downloaded the Usershield .zip file, unpacked it locally. Copied the local 'contrib' folder to my remote phpBB2/admin/mods/ folder. Logged in to to my phpBB board's ACP (v.2.0.22). Selected the 'Install Mod' option, submitted my EasyMOD password. Got this message:

"Could not open [./mods/contrib/install_user_shield_v1_2_1.txt] for reading."

Now, I'm assuming "." expands to
path_to_my_website/phpBB2/admin

because that's where mods/contrib/install_user_shield_v1_2_1.txt currently lives:
path_to_my_website/phpBB2/admin/mods/contrib/install_user_shield_v1_2_1.txt]

NB that 'path_to_my_website' in this case equates, in Dreamweaver (which is what I use for development/ftp), to :
./htdocs/my_website

where "." is whatever path Network Solutions assigns to its customers when it assigns them space on its server.

I've checked all permissions, they're fine.

Is there something special about the path that needs tweaking? Or is this an EasyMOD issue? I really, really don't want to have to do a manual install of UserShield.

narfnarf
Registered User
Posts: 2
Joined: Mon Oct 08, 2007 6:36 am

Re: [2.0.21] User Shield

Post by narfnarf » Fri Nov 02, 2007 9:15 am

THANK YOU for this very needed mod.

(It should have been built into phpBB. This and Admin Userlist, EasyMod, AutoCookies, RSS_Content_Syndicator, Security Question, spamwords, mod_rewrite, Anti-Spam ACP, m2f .. :) )

thecomputergal
Registered User
Posts: 6
Joined: Thu Jun 28, 2007 9:02 pm
Location: Missoula, Montana
Contact:

User Shield Delete problem

Post by thecomputergal » Tue Nov 06, 2007 2:54 pm

I am also having the problem with not being able to delete spammers in the User Shield inactive users window. Has anyone found a fix for this?

Thanks!

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 19 guests