[2.0.21] Delete User MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
31
76%
Very Good
5
12%
Good
2
5%
Fair
2
5%
Poor
1
2%
 
Total votes: 41

User avatar
mosheen
Registered User
Posts: 259
Joined: Wed Apr 06, 2005 12:16 am
Location: Asheville, NC
Contact:

Re: [2.0.21] Delete User MOD

Post by mosheen » Tue Apr 01, 2008 2:51 am

ycl6 wrote:For those of you wan to try/test the new (unvalidated) 1.0.3 version, you may download it at Sourceforge

~Mac
Here it is
Interested in Random Avatars for your board? Click here
Need to Enable Avatars By Post Count? Click here
Want HTML in your polls? Click here

FleshSouffle
Registered User
Posts: 32
Joined: Sun Jun 10, 2007 10:27 am

Re: [2.0.21] Delete User MOD

Post by FleshSouffle » Sat May 03, 2008 6:58 am

I can't seem to make this work.
I am running 2.0.22 - is that the problem?
I just get this error whenever I click any of the "user delete" buttons anywhere in the forum....


Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@nothingbettertodo.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

User avatar
mosheen
Registered User
Posts: 259
Joined: Wed Apr 06, 2005 12:16 am
Location: Asheville, NC
Contact:

Re: [2.0.21] Delete User MOD

Post by mosheen » Sun May 04, 2008 4:51 am

There is a file called "delete_user.php" included in the zip download of this mod.

Copy it over to the root of the phpBB install
Interested in Random Avatars for your board? Click here
Need to Enable Avatars By Post Count? Click here
Want HTML in your polls? Click here

FleshSouffle
Registered User
Posts: 32
Joined: Sun Jun 10, 2007 10:27 am

Re: [2.0.21] Delete User MOD

Post by FleshSouffle » Sun May 04, 2008 12:30 pm

mosheen wrote:There is a file called "delete_user.php" included in the zip download of this mod.

Copy it over to the root of the phpBB install
That is the very first thing I did as per the install instructions.
I still get the error.

User avatar
mosheen
Registered User
Posts: 259
Joined: Wed Apr 06, 2005 12:16 am
Location: Asheville, NC
Contact:

Re: [2.0.21] Delete User MOD

Post by mosheen » Sun May 04, 2008 3:35 pm

When I typed the address of your site and guessed a couple of times as to the location of your forum install, I found it, then added "delete_user.php" to the end and got a 404, file not found.

http://nothingbettertodo.net/forum/delete_user.php

If the file was in place, you should get the following error: "Sorry, but no such user exists." rather than a 404 file not found.
Interested in Random Avatars for your board? Click here
Need to Enable Avatars By Post Count? Click here
Want HTML in your polls? Click here

FleshSouffle
Registered User
Posts: 32
Joined: Sun Jun 10, 2007 10:27 am

Re: [2.0.21] Delete User MOD

Post by FleshSouffle » Mon May 05, 2008 9:50 am

mosheen wrote:When I typed the address of your site and guessed a couple of times as to the location of your forum install, I found it, then added "delete_user.php" to the end and got a 404, file not found.

http://nothingbettertodo.net/forum/delete_user.php

If the file was in place, you should get the following error: "Sorry, but no such user exists." rather than a 404 file not found.
You did not read the error. It is an Internal Server Error, not a Not Found error. The "404" component of the message is only referring to the lack of any error pages being found to display in the event of an error - not the lack of the php file itself. The file is definitely there. It shows up in the directory listing on ftp client.
I get the following message when I click the link above...
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@nothingbettertodo.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at nothingbettertodo.net Port 80
That does not sound like a normal 404 error to me.
Is it possible the file is corrupt?

If the file was indeed missing, like you seem to be suggesting, this is the error message which should appear (but doesn't)....
Not Found
The requested URL /forum/somefile.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at http://www.nothingbettertodo.net Port 80

FleshSouffle
Registered User
Posts: 32
Joined: Sun Jun 10, 2007 10:27 am

Re: [2.0.21] Delete User MOD

Post by FleshSouffle » Mon May 05, 2008 10:13 am

Working on the theory that the file might be corrupt, I am going to try redownload the zip and upload the php file again to my server....

EDIT: it did not work. I still get an internal server error after downloading the mod zip again.

User avatar
mosheen
Registered User
Posts: 259
Joined: Wed Apr 06, 2005 12:16 am
Location: Asheville, NC
Contact:

Re: [2.0.21] Delete User MOD

Post by mosheen » Mon May 05, 2008 6:00 pm

Just trying to help. Sorry I confused the 404 File Not Found with the 404 File Not Found. Good luck with it.

FleshSouffle
Registered User
Posts: 32
Joined: Sun Jun 10, 2007 10:27 am

Re: [2.0.21] Delete User MOD

Post by FleshSouffle » Mon May 05, 2008 9:50 pm

No problem ;)
Hang on... are you trying to be sarcastic? :P

So..... anyone else have any idea what causes the Internal Server Error?

FleshSouffle
Registered User
Posts: 32
Joined: Sun Jun 10, 2007 10:27 am

Re: [2.0.21] Delete User MOD

Post by FleshSouffle » Wed May 07, 2008 10:46 pm

So is this thread dead again now?

I might try the unvalidated version of this mod instead then, as clearly there is something screwy with the contents of the php file which is choking my server....

FleshSouffle
Registered User
Posts: 32
Joined: Sun Jun 10, 2007 10:27 am

Re: [2.0.21] Delete User MOD

Post by FleshSouffle » Fri May 09, 2008 9:22 pm

I solved the Internal Server Error problem. I just had to chmod the file permissions of the php file to 644.
Now the mod works without the server choking on it.

sifuadam
Registered User
Posts: 2
Joined: Thu May 29, 2008 4:54 am

Re: [2.0.21] Delete User MOD

Post by sifuadam » Thu May 29, 2008 5:00 am

Okay I loaded everything at least I think I did.

I am a bit green at this MOD stuff, but I did load a spambot stop at one time that got those full registrations to stop.

So here is my problem I get these X's to delete users, once I click on the X to delete the unwanted to users I get a page that looks like the script to the delete_user.php.

What is wrong here?

sifuadam
Registered User
Posts: 2
Joined: Thu May 29, 2008 4:54 am

Re: [2.0.21] Delete User MOD

Post by sifuadam » Thu May 29, 2008 5:20 am

some how I just reloaded the delete_user.php page and it works now...

okay this works good BUT how do I MASS DELETE.

User avatar
mosheen
Registered User
Posts: 259
Joined: Wed Apr 06, 2005 12:16 am
Location: Asheville, NC
Contact:

Re: [2.0.21] Delete User MOD

Post by mosheen » Thu May 29, 2008 10:24 pm

ycl6 wrote:For those of you wan to try/test the new (unvalidated) 1.0.3 version, you may download it at Sourceforge

~Mac
The unvalidated version that Mac refers to here contains the delete multiple users optional add-on.
Interested in Random Avatars for your board? Click here
Need to Enable Avatars By Post Count? Click here
Want HTML in your polls? Click here

yellowzm
Registered User
Posts: 1
Joined: Fri Jun 06, 2008 3:53 am

Re: [2.0.21] Delete User MOD

Post by yellowzm » Fri Jun 06, 2008 4:29 am

I'm really new to phpbb, and as a result I have run into a problem with installing this using easymod.

Code: Select all

Installation Failed
EasyMOD encountered the following error(s). A general error could be ABC. A critical error means D and you should do XYZ.


Error Detail 
  
Critical Error

FIND FAILED: In file [memberlist.php] could not find:

$search = '<a href="' . $temp_url . '">' . sprintf($lang['Search_user_posts'], $username) . '</a>'; 

MOD script line #90 :: FAQ :: Report 
So I need to know how to fix this? I think I have it but would appreciate if someone would check this and let me know if i'm right.

I opened the memberlist.php and found:

Code: Select all

$temp_url = append_sid("search.$phpEx?search_author=" . urlencode($username) . "&showresults=posts");
		$search_img = '<a href="' . $temp_url . '"><img src="' . $images['icon_search'] . '" alt="' . $lang['Search_user_posts'] . '" title="' . $lang['Search_user_posts'] . '" border="0" /></a>';
		$search = '<a href="' . $temp_url . '">' . $lang['Search_user_posts'] . '</a>';
It is not the same and this was the closest thing I was able to find...

what can I do that will allow easymod to find it and finish the install?



Thanks in advance for the help!

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 9 guests