Page 1 of 4

EMFF 0.4 BBCode MOD

Posted: Thu Jul 20, 2006 5:07 pm
by Extensions Robot
MOD Name: EMFF 0.4 BBCode MOD
Author: Martin Truckenbrodt
MOD Description: adds a W3C compatible mp3 file flash player to forum posts


MOD Version: 1.0.1

Download File: emff_mod_1.0.1a.mod
mods overview page: View
File Size: 5925 Bytes

Support for this MOD needs to be asked within this topic. The phpBB Teams are not responsible or required to give anyone support for this MOD. By installing this MOD, the phpBB Support Team or phpBB MODifications Team may not be able to provide support.

This MOD has only been tested by the phpBB MOD Team with the phpBB version in the topic title. It may not work in any other versions of phpBB.

Posted: Sat Aug 05, 2006 7:01 am
by MarkTheDaemon
MOD Validated/Released

Notes:
This MOD adds a mp3 file player to forum posts. It requires the Multiple BBCode MOD installed for the MOD to work.

Posted: Sat Aug 05, 2006 8:49 am
by coruscant
This will be a great feature for my podcasting site's forum!
But what is the phpbb version, because I never heard of 'EMFF 0.4'

Posted: Sun Aug 06, 2006 3:21 pm
by Harki
I rated this MOD excellent - actually I had been waiting for something similar for quite a while. Thanks a lot. :)

By the way, there appears to be a bug in it, if I'm not completely mistaken... Note the lines marked bold: they are superfluous and (as a $replacements[] belonging to the $patterns[] is missing) will confuse the BBCode system.

//Begin EMFF Mod
//[emff ]and[/emff]code..
$patterns[] = "#\[emff:$uid\](.*?)\[/emff:$uid\]#si";
$replacements[] = $bbcode_tpl[emff];
//[emff]and[/emff]code..
$patterns[] = "#\[emff:$uid\](.*?)\[/emff:$uid\]#si";

//End EMFF Mod

Posted: Sun Aug 06, 2006 7:01 pm
by allesgutevn
can anyone postt a demo for me? :lol:

Posted: Sun Aug 06, 2006 10:34 pm
by Harki
http://konjunktiv2.de/thema5891.html

I'm sorry for linking to my own forum... ;)

Posted: Mon Aug 07, 2006 1:01 am
by Kellanved
MOD Repacked


As Harki has pointed out, the released file had a bug. We have corrected the issue.

Posted: Mon Aug 07, 2006 6:55 pm
by Martin Truckenbrodt
Hello,
this is my second validated MOD. 8)
Thank you very much to the MOD validation team for their time checking my MOD. But please next time send me a PM when my MOD is released! :evil: :wink:
And thank you very much to Kellanved for repacking my MOD. I'm a newbee in creating of BBCode . :oops:

Author Notes:
Requires Multiple BBCode MOD http://www.phpbb.com/phpBB/viewtopic.php?t=74705

Demo:
http://www.martin-truckenbrodt.com/cgi/ ... ?f=11&t=97 - phpBB3 version of this MOD

FAQ:
The most frequent problem is that the *.swf files of the EMFF are stored into the wrong folder.

Additional Information:
EMFF 0.4 includes some more players with more buttons. I used the standard player in my MOD cause I think it offers enough buttons to play mp3 files in forum posts. If you want to use an other player please look at the EMFF author's websites for more details at least about height and width. You can find the URLs under Author Notes in the MOD file.

phpBB3 version of the MOD:
http://www.martin-truckenbrodt.com/cgi/ ... m.php?f=11

Bye Martin

Posted: Tue Aug 22, 2006 4:04 am
by Dx_at_dxzone.com.ar
a really simple idea that rocks, just installing it

Posted: Fri Aug 25, 2006 5:31 am
by amir abbas
thanks

very useful mod

Posted: Mon Sep 11, 2006 10:19 am
by sickmusic
thanks.. its great.

one limitation is that it cannot play mp3s with Long filenames.

----

can someone please help me with a script that can be run as a cron job that will:

1. search through phpbb_post_text for all occurrences of the EMFF bbcode tag.
2. Update an XML file for a podcast playlist.

----

Many thanks

What am I doing wrong

Posted: Sun Sep 17, 2006 7:47 am
by BestTableTalk
All I see is a light grey box (container) where the movie or player controls should be.
if I look at the source of the page it show correct object info and path.
I have copied the emff_standard.swf to my MP3 directory, I have bbcode enabled, when I mouse over the box it states "click here blah blah" I have reinstalled the phpbb2 and the mod same thing. I installed the mod with the easymod but i also checked the install against the file and it all seems to read ok.
Any help would be great
Bruce
:cry:

Posted: Sun Sep 17, 2006 6:20 pm
by Martin Truckenbrodt
Hello,
please read the install.txt of the MOD again.

The most frequent problem is that the *.swf files of the EMFF are stored into the wrong folder.

Bye Martin

Posted: Mon Nov 06, 2006 12:53 am
by Coyote23
I also get a gray box on my board.
I have read the instructions and they are hard to figure out.

First I downloaded into phpBB/emff_mod the directories code, codegenerator, docs and skins.
Second I changed the php and tpl files as suggested.
then I went to the code generator at http://www.marcreichelt.de
and came up with this.
Please insert the following code into your website:

<object type="application/x-shockwave-flash" data="emff_lila.swf?src=example.mp3" width="200" height="55">
<param name="movie" value="emff_lila.swf?src=example.mp3">
<param name="quality" value="high">
<param name="bgcolor" value="#0000ff">
</object>
Note: To use this code you have to copy the file "emff_lila.swf" out of the "skins" directory into the directory of your website!


So where do I insert this?
Or where am I going wrong?

Posted: Mon Nov 06, 2006 11:19 am
by Martin Truckenbrodt
Hello,
there ist no need to use the code generator!
My MOD is the code!

Please look here: http://www.phpbb.com/phpBB/viewtopic.ph ... 72#2435972

Bye Martin