Simple Colored Usergroups

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
29
66%
Very Good
8
18%
Good
3
7%
Fair
1
2%
Poor
3
7%
 
Total votes: 44

runegirlie
Registered User
Posts: 173
Joined: Sun Jul 31, 2005 6:08 pm

Re: Simple Colored Usergroups

Post by runegirlie » Thu Jul 12, 2007 7:26 am

Punkboy wrote:How install it????
Read directions?

squeek
Registered User
Posts: 173
Joined: Sat Jan 20, 2007 12:43 am

Re: Simple Colored Usergroups

Post by squeek » Thu Jul 12, 2007 8:41 am

i just noticed, it doesnt show the group colours in the admin index. is there a way to achieve this? thanks

squeek
Registered User
Posts: 173
Joined: Sat Jan 20, 2007 12:43 am

Re: Simple Colored Usergroups

Post by squeek » Thu Jul 12, 2007 12:41 pm

it's ok i now have it working in the admin index, i also have it working on a the Buddylist mod, Member Websites mod, Who Viewed My Profile mod. finally it works all over the board and with only a small edit required here and there. this mod is 100% tip top 8-)

BIG thanks for this MOD 8-)

darkcloudinc
Registered User
Posts: 14
Joined: Tue Jun 12, 2007 4:49 pm

Re: Simple Colored Usergroups

Post by darkcloudinc » Thu Jul 12, 2007 6:24 pm

I'm getting this error when I'm in the edit window:

Code: Select all

Warning: Invalid argument supplied for foreach() in /mnt/w0401/d31/s30/b02b7700/www/gods/includes/usercp_register.php on line 884
I looked and it has this:

Code: Select all

	// SIMPLE COLORED USERGROUPS MOD START
	$group_values = '';
	$group_count = 0;
	foreach($color_groups['groupdata'] AS $color_group)
	{
		if ( in_array($userdata['user_id'], $color_group['group_users']) )
		{
			$group_priority_selected = ( $userdata['group_priority'] == $color_group['group_id'] ) ? ' selected="selected"' : '';
			$group_values .= '<option value="' . $color_group['group_id'] . '"' . $group_priority_selected . '>' . $color_group['group_name'] . '</option>';
			$group_count++;
		}
	}
	if ( $group_values && $group_count > 1)
	{
		$group_drop_down = '<select name="group_priority">' . $group_values . '</select>';
		$template->assign_block_vars('switch_color_groups', array());
	}
	else
	{
		$group_priority = 0;
	}
	// COLOR GROUPS END
which as it clearly states is from the color group.

anyone care to help?

Nevermind, the solution was as simple as creating a group for the user to be in.

Punkboy
Registered User
Posts: 12
Joined: Sun Jul 08, 2007 7:13 pm

Re: Simple Colored Usergroups

Post by Punkboy » Thu Jul 12, 2007 8:31 pm

runegirlie wrote: Read directions?
I download th mod and i dont know what i do? i only know that i dont have the contrib folder in my forum now because my forum has been intalled and is online now.
What i need do?, submit the admin file? or what? pls help :oops:

anniecuk
Registered User
Posts: 17
Joined: Sun Jul 15, 2007 7:36 pm

Re: Simple Colored Usergroups

Post by anniecuk » Sun Jul 15, 2007 11:10 pm

i have installed this mod, everything went fine aart from one thing, The legend and users are grey :(

Any help WILL be areciated as i have been goin round in circles for ast hour trying to work it out.

Thanx :roll:

anton1o
Registered User
Posts: 131
Joined: Thu Apr 06, 2006 10:30 pm

Re: Simple Colored Usergroups

Post by anton1o » Sat Jul 21, 2007 3:50 am

Hey guys, ive got a queery..

How do i make Hidden User groups show in the list, Ive got Permissions set on each group and if i change them to Closed they will show on the forum as an annoying
Moderator: Yada, Yada, Yada.

So i keep them hiden, but now that they are hidden they wont show up in the tool bar?

Also the text that says Legend: isnt showing i only have the : if anybody knows a quick fix for that would be great.

:D

http://www.KNGRacing.com

Tixylix
Registered User
Posts: 24
Joined: Thu Jun 01, 2006 2:47 am
Contact:

Re: Simple Colored Usergroups

Post by Tixylix » Mon Jul 23, 2007 8:56 am

At the bottom of my forum, it claims that no user groups exist, when I actually have around 10 or more...

Image

My username is also not appearing as an administrator, even though I am one.

I am using the DAJ_Glass theme BTW, the same as the mod creator - it'd be great if he could also help me get it to look half normal too, LOL!

Thanks :D

anton1o
Registered User
Posts: 131
Joined: Thu Apr 06, 2006 10:30 pm

Re: Simple Colored Usergroups

Post by anton1o » Mon Jul 23, 2007 10:47 am

Tixylix; i had a similar error. Make sure the groups are set to Close and not Hidden.

Also go over the groups and set a colour to them also, If you cant do that as i couldnt meant there was a coding issue :)

Tixylix
Registered User
Posts: 24
Joined: Thu Jun 01, 2006 2:47 am
Contact:

Re: Simple Colored Usergroups

Post by Tixylix » Tue Jul 24, 2007 4:52 am

Yeah, I suppose that would help... LOL

Thanks, the most simple mistake can stuff it all - Not setting it up!

anton1o
Registered User
Posts: 131
Joined: Thu Apr 06, 2006 10:30 pm

Re: Simple Colored Usergroups

Post by anton1o » Tue Jul 24, 2007 10:04 am

Exactly, try and test everything every posting somethings not working.. If you think 1 part isnt working but really its not all working your wasting yourtime trying to fix 1 part.

ps. Anybody know a fix for my issue please?

comuter
Registered User
Posts: 158
Joined: Mon Jan 16, 2006 2:08 pm

Post by comuter » Thu Jul 26, 2007 2:13 am

to the maker maybe you should add some kind of group rank so people can use color and rank at the same time rather then using 2 different mods to accomplish this. :D

User avatar
phorum.ws
Registered User
Posts: 108
Joined: Fri Jul 20, 2007 1:00 pm
Location: Australia
Name: Jay
Contact:

Re: Simple Colored Usergroups

Post by phorum.ws » Thu Jul 26, 2007 6:55 am

Nice script, i got it working 100% and made a few mods. the only thing is once you make the order for the groups, and try to change it, it all gets jumbled up.. eg. first i added Elite Mod in first position, then realized it did not display my admin, so i created the admin group, and then put that first, then the edlite mod is now in last place, and will not move. even if i put something after elite mod, it automatically adds it after Admin. as if elite mod was still in position 1. maybe a bug to look at? thanks,
Learning CSS, jQuery, Javascript - A Project Manager @Code_Collective Community-Based Dev Collaborative

User avatar
DizzyDazzle
Registered User
Posts: 39
Joined: Sun Oct 08, 2006 11:50 pm

Re: Simple Colored Usergroups

Post by DizzyDazzle » Fri Jul 27, 2007 3:39 pm

Hi can anyhelp me, i would like to color just ONE group on my index page in the "Moderators:" section on each forum. As i only want one group to be colored and only on the index i would rather not install a whole MOD as i'm sure it is a simple edit.

To explain more i have a group called "Mod Team" which has all moderators of my board as members. Members automatically gain Moderator status when added and the [ Moderator ] part is already in the legend as phpBB default. but when the "Mod Team" group is listed as the moderator for each forum it uses the default color for my template, but i would like the group to be the same color as the Moderators themselves. here is an example of what i am tryin to achieve:

Currently a typical forum looks like this:

Test Forum
This is a test forum.
Moderators:Test Mod, Mod Team <-----the group is in default color for my template.


How i would like it to be:

Test Forum
This is a test forum.
Moderators:Test Mod, Mod Team <-----the group color is the same as a Moderators default color.

sorry if this is not the place to post this question but i see alot of people who visit this MODs thread seem to know alot about colorising usergroups. i hope i explained clearly and be very gratefull if anyone can help. i'm sure it is a simple edit as i only want to color the group on the index and dont need it to show in the legend but i am not experienced with PHP.

thanks.

X.Homer.X
Registered User
Posts: 66
Joined: Fri Jul 27, 2007 5:02 pm

Re: Simple Colored Usergroups

Post by X.Homer.X » Fri Jul 27, 2007 5:09 pm

Hello there. I recently installed this mod on my forums (which are still in development) and it installed perfectly, and works very well, except for one little thing. The legend does not span the names horizontally across the bottom of the page, but rather in one column on the right of the page. My forum is http://theforsakenclan.freehostia.com . If you could take a look at it and if you could maybe post a reply on how i can fix this it would be greatly appreciated. :D

That is a picture above of what happens on my forum.

EDIT: Im sorry, it appears this question has already been answered. I have deleted the picture.

Post Reply

Return to “[2.0.x] MOD Database Releases”