[20/11/06] Anti-Spam ACP

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
51
69%
Very Good
14
19%
Good
2
3%
Fair
2
3%
Poor
5
7%
 
Total votes: 74

User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: [20/11/06] Anti-Spam ACP

Post by EXreaction »

Dezio wrote: I've the same problem on the signature with 2.0.8 version
My users now can't modify their own signature :)


...

It is because you have another mod installed with a template switch over the signature.
Dezio
Registered User
Posts: 29
Joined: Mon Mar 05, 2007 11:11 pm

Re: [20/11/06] Anti-Spam ACP

Post by Dezio »

ok I've resolve it :P
User avatar
libralion
Registered User
Posts: 365
Joined: Tue May 13, 2003 9:25 am

Captcha code is not working

Post by libralion »

Hello all,
This is a great mod! Thanks Exreaction!
The only thing is that I can't get the captcha code to work.
This is what I get in the ACP:
Warning: imagettftext() [function.imagettftext]: Could not read font in /home/tinaturner/domains/tina-turner.nl/public_html/phpBB2/includes/usercp_captcha.php on line 270

I already uploaded the better_captcha folder and the usercp_captcha.php again, but still the same message.
I do have the GD2 library and also Freetype Support enabled.
Line 270 from usercp_captcha.php looks like this:

imagettftext($img, $size, $angle, $x_pos, $y_pos, $color2, font() , $code[$j]);

Is that correct?

Johanna
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: [20/11/06] Anti-Spam ACP

Post by EXreaction »

Make sure you are uploading the fonts in binary mode.
User avatar
libralion
Registered User
Posts: 365
Joined: Tue May 13, 2003 9:25 am

Re: [20/11/06] Anti-Spam ACP

Post by libralion »

EXreaction wrote: Make sure you are uploading the fonts in binary mode.


No that didnot work either.
Now I get 2 different errors:

Warning: imagettftext() [function.imagettftext]: Problem loading glyph in /home/tinaturner/domains/tina-turner.nl/public_html/phpBB2/includes/usercp_captcha.php on line 270

Warning: imagettftext() [function.imagettftext]: Could not read font in /home/tinaturner/domains/tina-turner.nl/public_html/phpBB2/includes/usercp_captcha.php on line 270

Isn't it easier to make the script so that it refers to 1 font, for instance in the root folder of the server?
I don't know how to do that, but I came across some posts from other people on other forums that say that the includes sometimes give errors.
What else can I do?

Johanna
User avatar
libralion
Registered User
Posts: 365
Joined: Tue May 13, 2003 9:25 am

Re: [20/11/06] Anti-Spam ACP

Post by libralion »

Ok I uploaded the better_captcha folder and the usercp_captcha.php from a new download and now it works!
I am happy!
Thanks Exreaction.

Johanna
Last edited by libralion on Sat Apr 28, 2007 10:03 am, edited 1 time in total.
JulieJesta
Registered User
Posts: 116
Joined: Mon Oct 16, 2006 8:39 am
Location: England
Contact:

Re: [20/11/06] Anti-Spam ACP

Post by JulieJesta »

cool! love it love it!

i'm using this on a brand new board, yet i get an error... not sure which mod is cuasing error. all mods were installed by easymod to a vanilla version of the newest 2x phpbb.

when i post it says : Invalid Session. Please resubmit the form.
is this from your mod? if not where might i ask for help? do you think auto cookies might help me?
Julie, Mum to 1 boy, 1 boyfriend, and many fluffy pets. :)
http://www.parentstime.co.uk
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: [20/11/06] Anti-Spam ACP

Post by EXreaction »

JulieJesta wrote: cool! love it love it!

i'm using this on a brand new board, yet i get an error... not sure which mod is cuasing error. all mods were installed by easymod to a vanilla version of the newest 2x phpbb.

when i post it says : Invalid Session. Please resubmit the form.
is this from your mod? if not where might i ask for help? do you think auto cookies might help me?


Not from my mod. I have no idea what mod does that.

Auto cookies only really helps if you have problems logging in and staying logged in.
northgafab
Registered User
Posts: 4
Joined: Fri Apr 13, 2007 1:18 pm

Re: [20/11/06] Anti-Spam ACP

Post by northgafab »

Seamless install
Perfect MOD

Does EXACTLY what it says will do.
Highly recommended MOD.
BusinessDigest
Registered User
Posts: 1
Joined: Fri May 04, 2007 10:36 am

Re: [20/11/06] Anti-Spam ACP

Post by BusinessDigest »

northgafab wrote: Seamless install
Perfect MOD

Does EXACTLY what it says will do.
Highly recommended MOD.

Hi everyone, I totally agree! Just joined today only to add my approval of this excellent Anti-Spam 2.0.8, which is easy to install (saving my forum from the wrath of a rabid russian spammer since going live last week).
Spoof email addresses 0, Spammers 0 = Great MOD!... :lol:
JulieJesta
Registered User
Posts: 116
Joined: Mon Oct 16, 2006 8:39 am
Location: England
Contact:

Re: [20/11/06] Anti-Spam ACP

Post by JulieJesta »

excraction,
can i ask you you consider merging the mod MPH into future versions of this ACP. mph lists all ip addy's a member has posted from, and jioned from. then it compares this ip to all other registered ips and emails. if it finds a match, it warns you that a member has 2 accounts. I've found that members sometimes have spare accounts for spamming a board with affil links, or friends webadresses... and a main account for posting proper messages.

also, was wondering, any plans to put in an option in admin for us to hide new members yet to post? you already allow us to hide un-activated members, but being able to hide inactive and no-post members, that would be fantastic.
i'm not complaining... just thinking aloud. :)
thanks for replying to my previous question. ;)

(ps, just been to your site ex... and i like your blog, is it safe and availabler to download? couldnt see it linked from your site. thanks!)
Julie, Mum to 1 boy, 1 boyfriend, and many fluffy pets. :)
http://www.parentstime.co.uk
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: [20/11/06] Anti-Spam ACP

Post by EXreaction »

Sorry, but the Anti-Spam ACP is not going to get any more features.

Also, there are no reported bugs with it except for some people have problems with the captcha (which seems to be a rare server configuration issue more than anything). So unless someone finds a way to fix that, there will probably not be a next version.

The User Blog mod for phpBB3 is still in Alpha stages. It seems stable enough to use as it is, but I have been making many major changes to the codebase, so I am sure that I am missing a few bugs. Also, with future versions the code may change enough to make it impossible to upgrade, so you could lose any data. The Alpha 2 package is available for download (to test it) on my website; Lithium Studios. You can find it in the phpBB3 Modifications forum.
estado3
Registered User
Posts: 5
Joined: Tue Apr 03, 2007 4:50 pm

Re: [20/11/06] Anti-Spam ACP

Post by estado3 »

I can't get this mod to install with easymod, however that aside, I am wondering which file I need to edit, so that I overwrite the website field on user profile any member puts with a choice of my own?
User avatar
EXreaction
Former Team Member
Posts: 5666
Joined: Sun Aug 21, 2005 9:31 pm
Location: Wisconsin, U.S.
Name: Nathan

Re: [20/11/06] Anti-Spam ACP

Post by EXreaction »

estado3 wrote: I can't get this mod to install with easymod, however that aside, I am wondering which file I need to edit, so that I over write the website any member puts with a choice of my own?


Well, your installation problem aside...why would you want to do that?

You'd just need to edit the profile_add_body.tpl file to do it however.
cincin
Registered User
Posts: 6
Joined: Mon Feb 13, 2006 8:22 pm

Re: [20/11/06] Anti-Spam ACP

Post by cincin »

Hello all,

This MOD seems awesome, looking forward to not being spammed so much.

I've just updated my phpBB from 2.0.20 to 2.0.21, then to 2.0.22. Everything went well.

Then I installed Anti-Spam ACP 2.0.8, manually.

Now the only problem is that if I lookup a user's profile in the Admin panel User Management it comes up blank... all I see in the right frame is the phpBB copyright notice.

I followed the instructions to the T, the admin pages work fine, the captcha demos are working etc...

What is the most common cause of this ?

I looked back in this thread until it was apparent that the posts were for previous versions of Anti-Spam ACP, such as 2.0.5.

Also, what does ACP stand for ?

Thanks a lot, I'm hoping I wont have to reinstall it...
Post Reply

Return to “[2.0.x] MOD Database Releases”