Page 4 of 50

Anti-Spam ACP file locations

Posted: Sun Nov 26, 2006 7:15 pm
by mrbaze
rdalen wrote: Is the Anti-Spam ACP.mod file missing in the Anti_Spam_ACP_v1.1.02a.zip file or am I missing something?


By the way, I had some issues in this regard. I am using EasyMod to install, and the structure of the MOD file hierarchy was not what was expected (though, in EXreaction's defense, the MOD never claimed to be EMC)

I just looked at the copy warning errors (issued by EasyMod after I moved the file s into my mods directory) and then manually copied the files needed. There were only 3 or 4, so it took about 5 minutes longer than I expected.

Look in the Contrib and Root folders and all will be revealed. :-)

Posted: Sun Nov 26, 2006 7:18 pm
by EXreaction
rdalen wrote: Is the Anti-Spam ACP.mod file missing in the Anti_Spam_ACP_v1.1.02a.zip file or am I missing something?


It says on the bottom of my first post where it is. ;)
http://www.phpbb.com/phpBB/viewtopic.ph ... 68#2600268

Posted: Sun Nov 26, 2006 7:24 pm
by Phil
Looks interesting. Will have to install in the near future :lol:

Posted: Sun Nov 26, 2006 7:53 pm
by mrbaze
EXreaction wrote:
rdalen wrote:Is the Anti-Spam ACP.mod file missing in the Anti_Spam_ACP_v1.1.02a.zip file or am I missing something?


It says on the bottom of my first post where it is. ;)
http://www.phpbb.com/phpBB/viewtopic.ph ... 68#2600268



DOH! Had I read this clear instruction in the above-referenced post:
To install this with easymod you must copy the .mod file from the contrib folder to the root folder of the mod and upload the entire thing(the .mod file must be in the same folder that has a folder named root/).


it would have been even easier to install! As it was even with my failure to RTFM it installed pretty easily and works great.

Hide website field or notify that it's not used?

Posted: Sun Nov 26, 2006 7:56 pm
by mrbaze
Is it possible to hide the website field on the registration form? Or insert a message stating that it is not allowed and that an entry there will flag the registrant as a spambot?

I'd like to allow it eventually, but not on registration. I think this MOD can do that but I'm missing something. I also have no idea which file to modify to add text message to the registration form (kind of a PHP newbie, but able to edit most simple HTML pages OK)

Any thoughts would be appreciated.

Re: Hide website field or notify that it's not used?

Posted: Sun Nov 26, 2006 8:11 pm
by EXreaction
mrbaze wrote: Is it possible to hide the website field on the registration form? Or insert a message stating that it is not allowed and that an entry there will flag the registrant as a spambot?

I'd like to allow it eventually, but not on registration. I think this MOD can do that but I'm missing something. I also have no idea which file to modify to add text message to the registration form (kind of a PHP newbie, but able to edit most simple HTML pages OK)

Any thoughts would be appreciated.


Did you look at the menu for my mod in your admin control panel? :)

Can I have a link to your forums?

Very Cool!!!

Posted: Sun Nov 26, 2006 11:38 pm
by joeschmoe
Welll done mod!!! 2 thumbsup!!!!

Thanks Hopefully this will stop all these bots from registering...

Posted: Mon Nov 27, 2006 12:06 am
by Juzman
Thanks for the mod, but I think something isnt right.

I installed the mod 2 days ago, in the ACP I have: Number of spammers stopped by this mod since installation: 0

I also have had 4 registrations since installing it, and also a spam post.

Any ideas what could be wrong, my forum is here: http://forum.austech.org

Posted: Mon Nov 27, 2006 3:48 am
by EXreaction
Juzman wrote: Thanks for the mod, but I think something isnt right.

I installed the mod 2 days ago, in the ACP I have: Number of spammers stopped by this mod since installation: 0

I also have had 4 registrations since installing it, and also a spam post.

Any ideas what could be wrong, my forum is here: http://forum.austech.org


From what I can see, it is working fine.

What is wrong with it?

Posted: Mon Nov 27, 2006 8:31 am
by kingkhan007
Sorry all I see is dots and values "10", I cannot see any text. Can you please explain to me what changes to be made in language_main.php ?

Activation email

Posted: Mon Nov 27, 2006 10:37 am
by SpacePower
Have installed your mod. Thank you so much for it. I think almost every running forum has the same spam problem so this is a good start to prevent them to post.

My question is if someone has registered and filled out some fields e.g. website which are observed during registration do they still get the activation email although I was notified of spam bot suspect?

Posted: Mon Nov 27, 2006 12:05 pm
by MiVo_NL
I've installed this mod, but I get an error message when people want to register and editing their profile:

Parse error: syntax error, unexpected $end in /home/michelvo/public_html/mivonet/forum/includes/template.php(127) : eval()'d code on line 391

I've checked everything, but can't find it.

Forums location: www.mivo.net/forum

EDIT: It's solved now, I made a silly typo :oops: :oops:

Re: Activation email

Posted: Mon Nov 27, 2006 6:00 pm
by EXreaction
kingkhan007 wrote: Sorry all I see is dots and values "10", I cannot see any text. Can you please explain to me what changes to be made in language_main.php ?


It tells you in the mod install file. There are changes to lang_admin, and maybe lang_main that you have to do(depending if they were done in main or not).

SpacePower wrote: Have installed your mod. Thank you so much for it. I think almost every running forum has the same spam problem so this is a good start to prevent them to post.

My question is if someone has registered and filled out some fields e.g. website which are observed during registration do they still get the activation email although I was notified of spam bot suspect?


If their registration is denied because of a spam attempt they won't get an email. If they go past the checks(not enter in anything that is not allowed) it should work just like it normally would.

Posted: Tue Nov 28, 2006 3:29 am
by joeschmoe
Is there any way to stop the bots from registering? Your ACP is working however, I have had about 20 or so registrations since the install and the e-mails are for activation of the account.

What am I missing here????

Posted: Tue Nov 28, 2006 4:13 am
by EXreaction
joeschmoe wrote: Is there any way to stop the bots from registering? Your ACP is working however, I have had about 20 or so registrations since the install and the e-mails are for activation of the account.

What am I missing here????



You can try other captchas. :)
http://www.phpbb.com/phpBB/viewtopic.php?t=473222