security_question

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20368
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: security_question

Post by RMcGirr83 » Wed Jun 04, 2008 12:03 am

More than likely you have conflicting <! -- BEGIN and <! -- END switches being applied. That is, one is nested inside another.

Double check the edits to templates/xxx/profile_add_body.tpl and if you are really, really stuck you can contact me via PM and I will attempt to assist you.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

box123
Registered User
Posts: 5
Joined: Tue Mar 01, 2005 5:38 pm

Re: security_question

Post by box123 » Tue Jun 10, 2008 12:43 am

I installed the mod by hand. Did the sql insertion.

I can see the question and a blank for the answer.

But it matters not if I leave it blank or wrong answer. It registers them.

help?

http://in-memory-of-pets.com/phpbb2

Frank

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20368
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: security_question

Post by RMcGirr83 » Tue Jun 10, 2008 12:50 am

You misapplied the edits to usercp_register.php, namely this part

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
      rawurlencode($website);
   }

# 
#-----[ AFTER, ADD ]------------------------------------------
#
      // Start securityquestion mod
         if ( ($mode == 'register') && (strtoupper($HTTP_POST_VARS['answer']) != strtoupper($board_config['securityanswer'])) )
         {
         message_die(GENERAL_MESSAGE, $lang['securityquestion_invalid'] . '<meta http-equiv="refresh" content="3;url=' . append_sid("profile.$phpEx?mode=register&agreed=true.") . '">');message_die(GENERAL_MESSAGE, $message);
         }
      // End securityquestion mod
So double check the edits to that file, pay particular attention to the parens.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

jabguit
Registered User
Posts: 4
Joined: Sat Feb 09, 2008 1:24 pm

Re: security_question

Post by jabguit » Tue Jun 10, 2008 6:37 pm

I installed the MOD as instructed, but I can't see it in my admin Configuration. In phpMyAdmin the additional lines of code are there in the phpbb.config file.

Why can't I see it in my Admin Configuration board?
Last edited by jabguit on Tue Jun 10, 2008 6:39 pm, edited 1 time in total.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20368
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: security_question

Post by RMcGirr83 » Tue Jun 10, 2008 6:38 pm

You need to update all templates with the edits given for subSilver.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

jabguit
Registered User
Posts: 4
Joined: Sat Feb 09, 2008 1:24 pm

Re: security_question

Post by jabguit » Tue Jun 10, 2008 6:40 pm

Where do I find those?

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20368
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: security_question

Post by RMcGirr83 » Tue Jun 10, 2008 6:44 pm

By downloading the mod from the first post in this topic.

The most important thing you can do when installing a MOD is to backup all your files and you data. If you take this simple precaution, you will find yourself having a lot less headaches.

After backing up the data you have two options for installing the MOD:
  1. EasyMOD: EasyMOD is a modification itself, but it makes installing MODs very simple. This option in recommended, especially for beginners.
  2. Manual: Installing a MOD by hand is much more time consuming, however you have more control over the process. It is a good idea to become familiar with how it is done, as sometimes EasyMOD can not install a MOD.
For more information on installting MODs, have a look at these Knowledge Base articles.

Knowledge Base - How to Install MODs
Knowledge Base - Installing MODs the Right Way
And this topic http://www.phpbb.com/community/viewtopi ... 16&t=61611
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

jabguit
Registered User
Posts: 4
Joined: Sat Feb 09, 2008 1:24 pm

Re: security_question

Post by jabguit » Tue Jun 10, 2008 6:55 pm

Thanks. I'll try to reinstall it manually.

jabguit
Registered User
Posts: 4
Joined: Sat Feb 09, 2008 1:24 pm

Re: security_question

Post by jabguit » Wed Jun 11, 2008 5:36 pm

Well, I installed the EasyMod, and security_question_mod to my forum's root directory, and I've had no spammers since, when I'd usually get 20-30 per day!

User avatar
BobN
Registered User
Posts: 113
Joined: Sun Sep 12, 2004 4:00 pm
Location: Virginia USA
Contact:

Re: security_question

Post by BobN » Tue Jun 17, 2008 9:47 pm

Hi,

I have installed this mod according to the directions but it doesn't show during registration? It said it installed the tables correctly.
Thank You,
Bob Norris
Development Specialist

http://www.sitechatters.com

James N
Registered User
Posts: 1737
Joined: Sat May 20, 2006 12:57 pm
Contact:

Re: security_question

Post by James N » Thu Jun 19, 2008 12:41 pm

Have you edited all the files as listed (including your default style if it is not subSilver)?

anodyzed
Registered User
Posts: 15
Joined: Sun May 14, 2006 10:46 pm
Location: Washington State
Contact:

Re: security_question

Post by anodyzed » Sun Jun 22, 2008 12:14 am

Go to your php myadmin. Most likely http://www.yoursitename.com/forum/myadmin
Enter your SQL user name and password.
Select your database from the drop down menu on the left. Then just click the SQL tab. Then you will get an empty SQL query window.
Cut and paste

Code: Select all

    INSERT INTO phpbb_config (config_name, config_value) VALUES ('securityquestion','How many days in a year?');
    INSERT INTO phpbb_config (config_name, config_value) VALUES ('securityanswer','365');
in to the window,
press go.
If you click on phpbb_config and browse through it, on the last page you will see the new rows in alphabetical order. Then just log out.

If you are still having problems, then download this ZIP file unzip it, and follow the instructions in the Read Me.
As I use my FTP program to peek and poke around in my forum directories, I can't find a "php myadmin' or anything like it. So I didn't know what to do with those first two lines you have in the quote above.

I installed the mod manually, thought I did it line by line, thought everything worked.
I addressed the file name that is located in the root/install directory of the mod, but got a 404 error. So I deleted the install directory, and loaded the board. I went to register, found the spot in the registration where it asks the question but no question was there. And no answer would qualify the item.

Finally, to get the forum open again, I copied back (with FTP) all the files I'd changed. Now it works as before, but ... Your mod is THE mod I need. Suggestion?

Anodyzed

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20368
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: security_question

Post by RMcGirr83 » Sun Jun 22, 2008 1:02 am

phpmyadmin is found by accessing your hosts cpanel, where you are allowed to set up databases and such.

In lieu of that, you can also use this code to update your board.

Code: Select all

<?php
/***************************************************************************
 *                               db_update.php
 *                            -------------------
 *
 *   copyright            : ©2003 Freakin' Booty ;-P & Antony Bailey
 *   project              : http://sourceforge.net/projects/dbgenerator
 *   Website              : http://freakingbooty.no-ip.com/ & http://www.rapiddr3am.net
 *
 ***************************************************************************/

/***************************************************************************
 *
 *   This program is free software; you can redistribute it and/or modify
 *   it under the terms of the GNU General Public License as published by
 *   the Free Software Foundation; either version 2 of the License, or
 *   (at your option) any later version.
 *
 ***************************************************************************/

define('IN_PHPBB', true);
$phpbb_root_path = './';
include($phpbb_root_path . 'extension.inc');
include($phpbb_root_path . 'common.'.$phpEx);

//
// Start session management
//
$userdata = session_pagestart($user_ip, PAGE_INDEX);
init_userprefs($userdata);
//
// End session management
//


if( !$userdata['session_logged_in'] )
{
	$header_location = ( @preg_match('/Microsoft|WebSTAR|Xitami/', getenv('SERVER_SOFTWARE')) ) ? 'Refresh: 0; URL=' : 'Location: ';
	header($header_location . append_sid("login.$phpEx?redirect=db_update.$phpEx", true));
	exit;
}

if( $userdata['user_level'] != ADMIN )
{
	message_die(GENERAL_MESSAGE, 'You are not authorised to access this page');
}


$page_title = 'Updating the database';
include($phpbb_root_path . 'includes/page_header.'.$phpEx);

echo '<table width="100%" cellspacing="1" cellpadding="2" border="0" class="forumline">';
echo '<tr><th>Updating the database</th></tr><tr><td><span class="genmed"><ul type="circle">';


$sql = array();
$sql[] = "INSERT INTO " . $table_prefix . "config (config_name, config_value) VALUES ('securityquestion','How many days in a year?')";
$sql[] = "INSERT INTO " . $table_prefix . "config (config_name, config_value) VALUES ('securityanswer','365')";

for( $i = 0; $i < count($sql); $i++ )
{
	if( !$result = $db->sql_query ($sql[$i]) )
	{
		$error = $db->sql_error();

		echo '<li>' . $sql[$i] . '<br /> +++ <font color="#FF0000"><b>Error:</b></font> ' . $error['message'] . '</li><br />';
	}
	else
	{
		echo '<li>' . $sql[$i] . '<br /> +++ <font color="#00AA00"><b>Successfull</b></font></li><br />';
	}
}


echo '</ul></span></td></tr><tr><td class="catBottom" height="28">&nbsp;</td></tr>';

echo '<tr><th>End</th></tr><tr><td><span class="genmed">Installation is now finished. Please be sure to delete this file now.<br /></span></td></tr>';
echo '<tr><td class="catBottom" height="28" align="center"><span class="genmed"><a href="' . append_sid("index.$phpEx") . '">Have a nice day</a></span></td></table>';

include($phpbb_root_path . 'includes/page_tail.'.$phpEx);

?>
save the code as db_update.php, copy it to your forum root and browse to it, like http://www.mysite.com/forum/db_update.php for example, then delete it off your website. You will need to be logged onto the forum as an admin to be able to run it.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

anodyzed
Registered User
Posts: 15
Joined: Sun May 14, 2006 10:46 pm
Location: Washington State
Contact:

Re: security_question

Post by anodyzed » Sun Jun 22, 2008 1:24 am

After 31 pages, I'm almost CODE blind!

BUT, my host DID have a control panel that let me get to the database, and run the myphpadmin thing.
I inserted the two lines.

Then I copied all six modded files,
I deleted the install directory
tried to register and it asked!

I logged in as admin, edited the question, deleted that test registration,
seems all is working now

THANK YOU! This has been an ALL DAY experience for me. Have I mentioned I hate proramming? Rather go to a dentist.

But its working, I am VERY thankful.

John
aka Anodyzed

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20368
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: security_question

Post by RMcGirr83 » Sun Jun 22, 2008 1:42 am

anodyzed wrote:Rather go to a dentist.
I went to a dentist on Monday and had three wisdom teeth extracted, I would prefer to read code. ;)
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 11 guests

cron