Page 4 of 32

Re: security_question

Posted: Sat Jul 14, 2007 8:08 am
by James N
Once you have run the SQsql.php file it adds the default question and answer in to your database. If you log on to phpmyadmin, choose your forums database, open the config section and go to page 3 you will find the Q&A are there.

What did you use to edit the files? DO NOT use a wordprocessor or Dreamweaver as it screws up the coding. I use the one in my sig. Its free and does the job perfectly.

Also remember if your default style is not subSilver, then you need to do the template edits to those as well.

From what you say you do not have any other MODs installed that might cause the error, so I has to be an editing problem.

Re: security_question

Posted: Sat Jul 14, 2007 11:29 am
by tonydav
I've recently installed the mod on my BB (http://www.cgsob.co.uk).

Brilliant! Was getting tens of porn/viagra merchants registering every day.

Since the install, not one dodgy registration!

My thanks & best wishes to James N.

Re: security_question

Posted: Sat Jul 14, 2007 2:56 pm
by isculpt
I was working with dream weaver on a mac. Looks like the text editor that you suggest is windows base. Do you know of another? I'll search this forum to see what I can find. It seems strange that Dreamweaver would not work, but I trust you. Also does putting spaced or returns in the code matter? For example you say after ____ put _____ and I put a return before I insert what was copied? I know that would not matter in html, so I thought I should ask about the mod codes.

Thanks again. I really hope to get this right as I want to add a few more to help me with this spam and administration.

Re: security_question

Posted: Sat Jul 14, 2007 3:40 pm
by James N
Dreamweaver adds code that it need (but you dont want) and thats the cause of your problem.

A basic text editor will do the job perfectly well (eg Notepad on Windows) I assume the TextEdit you have will work OK. Try it ans see I guess

Adding the code is as you say.

FIND line of code

Leave space

ADD Block of code

DONT add it on the same line as the FIND command

EDIT:- Found this that you might find useful http://forums.macrumors.com/showthread.php?t=60216

Re: security_question

Posted: Sat Jul 14, 2007 3:53 pm
by isculpt
I found textedit on my mac and also found that other used it, however it does not allow me to search and edit. I wonder if i need to set the preferences differently? I'm posting in another spot to see if anyone can help. Thanks. I'll get back to you soon. I am sure the dreamweaver thing must be it.

the space that you mention is a return or just a space?

Re: security_question

Posted: Sat Jul 14, 2007 3:59 pm
by James N
Return aka line space

In that link I left above it looks like theres a free editor out there, but obviously using a PC I have no idea how good it would be for you.

Maybe this one? http://www.barebones.com/products/textw ... ndex.shtml

Re: security_question

Posted: Sat Jul 14, 2007 4:18 pm
by isculpt
because my text editor on the mac is not working I enter what I refer to as my Jean Luc Pecard mode

"OPTIONS"

So if all else fails, I'll copy your code to my flash drive along with the forum folder that needs to be changed, bring it to a pc, edit it in notepad, copy it back to my flashdrive, stick it in my computer and then ....
Can I upload them using dreamweaver?

Seems like a lot of work, but for now I may try this.

Re: security_question

Posted: Sat Jul 14, 2007 4:27 pm
by James N
isculpt wrote: Can I upload them using dreamweaver?
You are better off using a 'real' FTP program. I dont know whats available for MACs though.

Re: security_question

Posted: Sat Jul 14, 2007 5:22 pm
by isculpt
Did all of the above, on mac and tried the ftp from dreamweaver to see. I receive this error " when trying to register"
Parse error: parse error, unexpected T_STRING in /data/bridgetm/public_html/forum/includes/usercp_register.php on line 86

any suggestions?

Also just got a reply, after posting this post, from another mac user who uses the textedit on the mac he said "
I generally just use Text-edit for everything (even coding HTML these
days). Just make sure in preferences to select 'ignore rich text
commands in HTML files' or you'll get some weirdness.

The thing to watch with find instructions is that if the code the mod
asks you to find is several lines long then it won't work. Instead
just do a find for the first line of text, then look to see if the
lines following it are correct."

I did not have that checked when uploading the last changes. Don't know if it would make a difference and if it is what was responsible for giving me that code. I thought I would post his comment here in case there are other mac users out there. ( we are a lonely bunch)

Re: security_question

Posted: Sat Jul 14, 2007 5:32 pm
by James N
isculpt wrote:Did all of the above, on mac and tried the ftp from dreamweaver to see. I receive this error " when trying to register"
Parse error: parse error, unexpected T_STRING in /data/bridgetm/public_html/forum/includes/usercp_register.php on line 86

any suggestions?
I *think* dreamweaver has corrupted something on upload.

Ive had a look on http://mac.softpedia.com/ and there are a few free FTP programs out there. I think you will need one of those.

Its not easy when the majority are 'against you' is it? :lol:

Re: security_question

Posted: Sun Jul 15, 2007 12:37 am
by isculpt
tried again on the mac using a different editor and fetch to ftp the new files and it still did not work,

tried again on the pc and received this error
Parse error: parse error, unexpected $ in /data/bridgetm/public_html/forum/includes/template.php(127) : eval()'d code on line 309

Do you know what that means?

the step that you told me to do
"Once you have run the SQsql.php file it adds the default question and answer in to your database. If you log on to phpmyadmin, choose your forums database, open the config section and go to page 3 you will find the Q&A are there." I ftp'd that with DW, I don't think thatmatters though, thought I should mention it. Yes the last time I looked the question is in the admin panel, and whatever did that I have not changed in all of my other changes, mostly because it seemed to work and I am not sure how it was changed, it was magic. Any thoughts on the above comment.

Re: security_question

Posted: Sun Jul 15, 2007 8:05 am
by James N
I think its all down to Dreamweaver.

PM sent

Re: security_question

Posted: Sun Jul 15, 2007 9:45 pm
by isculpt
thanks to everyone, especially James. I loaded up reinstalled all of the files, changed ftp clients and text editing clients ( though with your files I did not need to edit anything) Now it is on to the next mod.

Thank you

Re: security_question

Posted: Sun Jul 15, 2007 10:23 pm
by isculpt
woops!

James Though the registration page is asking the question, The one I changed it to, I must have somehow deleted it from the admin page because i can not see it anymore. Just this one last thing and I promise I won't bug you again.

Bridgette

Re: security_question

Posted: Sun Jul 15, 2007 11:52 pm
by calrissian
I've installed this great security mod...

Works fine for Subsilver template.

However, for the Aeolus template users get the following error when they click on the 'Profile' menu button.

Parse error: syntax error, unexpected $end in /home/username/public_html/phpBB2/includes/template.php(127) : eval()'d code on line 327

--
In practice, none of my forum members are able to edit their profile at the moment, they get that error.

I'm not sure how to progress from here. I've read around a bit, but am kinda lost as to what to do, and I'd like to stick with the Aeolus template.

*other than the above issue, the mod works fine. Any suggestions, most appreciated.