Page 3 of 3

Re: Forum Title Link

Posted: Sun Oct 28, 2007 5:24 pm
by azra
thanks..i installed the mod, and it works great!

thank you for your help ;)

Re: Forum Title Link

Posted: Sun Oct 28, 2007 8:39 pm
by xmenfile
quahappy wrote:Sorry for taking so long to get back to you. Been very busy trying to fix a "bug" with my own forum layout only to find out after many hours it's IE7 not being web standard!!

Have you managed to sort this one xmenfile?

Sorry no, I am not able to figure it out.

Re: Forum Title Link

Posted: Sun Oct 28, 2007 9:27 pm
by quahappy
xmenfile wrote:Hi,

I haved installed and when fine, except my index file layout. please help

Code: Select all

<center><script type="text/javascript"><!--
google_ad_client = "pub-4157398074485335";
google_ad_width = 728;
google_ad_height = 90;
google_ad_format = "728x90_as";
google_ad_type = "text_image";
//2007-08-26: hotdealsfinder.info/clearance, hotdealsfinder.info/coupons, hotdealsfinder.info/discount, hotdealsfinder.info/onsale
google_ad_channel = "6597707948+0463420267+1005924403+9309232264";
//-->
</script>
<script type="text/javascript"
  src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></center>
<!-- mod : announces -->
<table width="100%" cellspacing="0" cellpadding="2" border="0" align="center">
  <tr> 
	<td align="left" valign="bottom"><span class="gensmall">{CURRENT_TIME}</span></td>
  </tr>
</table>
<table width="100%" cellpadding="3" cellspacing="1" class="forumline">
  <tr> 
	<td class="catHead" colspan="2"><span class="cattitle"><a href="{U_INDEX}" class="nav">{L_INDEX}</a></span></td>
  </tr>
  <tr> 
	<td class="row1" align="center" valign="middle" rowspan="2"><img src="templates/RedSilver/images/welcome_panel.gif" alt="" /></td>
	<td class="row1" width="100%"><span class="genmed">{WELCOME_USER}</span><br /><span class="gensmall">{WELCOME_USER_INFO}</span></td>
  </tr>
  <!-- BEGIN switch_user_logged_in -->
  <tr> 
	<td class="row1" width="100%"><span class="gensmall">{LAST_VISIT_DATE}<br />{WELCOME_NEWS}</span></td>
  </tr>
  <!-- END switch_user_logged_in -->
  <!-- BEGIN switch_user_logged_out -->
  <form method="post" action="{S_LOGIN_ACTION}">
  <tr> 
      <td class="row1" valign="middle" height="28"><span class="gensmall">{L_USERNAME}: 
	<input class="post" type="text" name="username" size="10" />
	&nbsp;&nbsp;&nbsp;{L_PASSWORD}: 
	<input class="post" type="password" name="password" size="10" maxlength="32" />
	&nbsp;&nbsp; &nbsp;&nbsp;{L_AUTO_LOGIN} 
	<input class="text" type="checkbox" name="autologin" />
	&nbsp;&nbsp;&nbsp; 
	<input type="submit" class="mainoption" name="login" value="{L_LOGIN}" /></span> </td>
  </tr>
  </form>
  <!-- END switch_user_logged_out -->
  <!-- BEGIN switch_suggest_topic -->
  <tr> 
	<td class="row1" width="100%" colspan="2"><span class="gensmall">{WELCOME_SUGGESTED_TOPICS}&nbsp;&nbsp;<a href="{WELCOME_SUGGESTED_LINK}" class"gensmall">{WELCOME_SUGGESTED_TITLE}</a></span></td>
  </tr>
  <!-- END switch_suggest_topic -->
</table>

<table width="100%" cellspacing="0" cellpadding="2" border="0" align="center">
  <tr>
	<td align="right" valign="bottom" class="gensmall"><a href="{U_SEARCH_UNANSWERED}" class="gensmall">{L_SEARCH_UNANSWERED}</a></td>
  </tr>
</table>
{BOARD_ANNOUNCES}

<table width="100%" cellpadding="2" cellspacing="1" border="0" class="forumline">
  <tr> 
	<th colspan="2" class="thCornerL" height="25" nowrap="nowrap">&nbsp;{L_FORUM}&nbsp;</th>
	<th width="50" class="thTop" nowrap="nowrap">&nbsp;{L_TOPICS}&nbsp;</th>
	<th width="50" class="thTop" nowrap="nowrap">&nbsp;{L_POSTS}&nbsp;</th>
	<th class="thCornerR" nowrap="nowrap">&nbsp;{L_LASTPOST}&nbsp;</th>
  </tr>
  <!-- BEGIN catrow -->
  <tr> 
	<td class="catLeft" colspan="2" height="28"><span class="cattitle"><a href="{catrow.U_VIEWCAT}" class="cattitle">{catrow.CAT_DESC}</a></span></td>
	<td class="rowpic" colspan="3" align="right">&nbsp;</td>
  </tr>
  <!-- BEGIN forumrow -->
  <tr> 
	<td class="row1" align="center" valign="middle" height="50"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" width="46" height="25" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>
	<td class="row1" width="100%" height="50"><table width="100%" cellpadding="2" cellspacing="0" border="0">
		<tr><td><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_ICON_IMG}</a></td>
			<td width="100%"><span class="forumlink"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
  				</span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
  				</span><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span>
  			</td>
	<!-- BEGIN not_link -->  			
  		</tr>
  	</table></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOPICS}</span></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.POSTS}</span></td>
	<td class="row2" align="center" valign="middle" height="50" nowrap="nowrap"> <span class="gensmall">{catrow.forumrow.LAST_POST}</span></td>
	<!-- END not_link -->
	<!-- BEGIN is_link -->
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.LINK_STATS}</span></td>
	<!-- END is_link -->	
  </tr>
  <!-- END forumrow -->
  <!-- END catrow -->
</table>

<table width="100%" cellspacing="0" border="0" align="center" cellpadding="2">
  <tr> 
 	<td align="left">
 	<!-- BEGIN switch_user_logged_in -->
 		<span class="gensmall"><a href="{U_MARK_READ}" class="gensmall">{L_MARK_FORUMS_READ}</a></span>
 	<!-- END switch_user_logged_in -->
 	</td>
	<td align="right"><span class="gensmall">{S_TIMEZONE}</span></td>
  </tr>
</table>

<table width="100%" cellpadding="3" cellspacing="1" border="0" class="forumline">
  <tr> 
	<td class="catHead" colspan="2" height="28"><span class="cattitle"><a href="{U_VIEWONLINE}" class="cattitle">{L_WHO_IS_ONLINE}</a></span></td>
  </tr>
  <tr> 
	<td class="row1" align="center" valign="middle" rowspan="2"><object type="application/x-shockwave-flash" data="relog.swf" width="80" height="80">
	<param name="movie" value="relog.swf" />
	<param name="WMode" value="Transparent" />
</object></td>
	<td class="row1" align="left" width="100%"><span class="gensmall">{TOTAL_POSTS}<br />{TOTAL_USERS}<br />{NEWEST_USER}</span>
	</td>
  </tr>
  <tr> 
	<td class="row1" align="left"><span class="gensmall">{TOTAL_USERS_ONLINE} &nbsp; [ {L_WHOSONLINE_ADMIN} ] &nbsp; [ {L_WHOSONLINE_MOD} ]<br />{RECORD_USERS}<br />{LOGGED_IN_USER_LIST}</span></td>
  </tr>
</table>


<table width="100%" cellpadding="1" cellspacing="1" border="0">
<tr>
	<td align="left" valign="top"><span class="gensmall">{L_ONLINE_EXPLAIN}</span></td>
</tr>
</table>

<br clear="all" />
<!-- BEGIN switch_user_logged_out -->
{SUBSCRIBE_FORM}
<!-- END switch_user_logged_out -->
<table cellspacing="3" border="0" align="center" cellpadding="0">
  <tr> 
	<td width="20" align="center"><img src="templates/RedSilver/images/folder_new_big.gif" alt="{L_NEW_POSTS}"/></td>
	<td><span class="gensmall">{L_NEW_POSTS}</span></td>
	<td>&nbsp;&nbsp;</td>
	<td width="20" align="center"><img src="templates/RedSilver/images/folder_big.gif" alt="{L_NO_NEW_POSTS}" /></td>
	<td><span class="gensmall">{L_NO_NEW_POSTS}</span></td>
	<td>&nbsp;&nbsp;</td>
	<td width="20" align="center"><img src="templates/RedSilver/images/folder_locked_big.gif" alt="{L_FORUM_LOCKED}" /></td>
	<td><span class="gensmall">{L_FORUM_LOCKED}</span></td>
  </tr>
</table>
Thank you
Assuming your <template>/index_body.tpl is still the same as above, do this:

Code: Select all

#
#-----[ FIND and DELETE the following line ]---------------------------------
#

<!-- BEGIN not_link -->           


#
#-----[ FIND ]---------------------------------
#

   <td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOPICS}</span></td>
   <td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.POSTS}</span></td>
   <td class="row2" align="center" valign="middle" height="50" nowrap="nowrap"> <span class="gensmall">{catrow.forumrow.LAST_POST}</span></td>

#
#-----[ BEFORE, ADD ]---------------------------------
#

<!-- BEGIN not_link --> 
That should fix it. Basically the <!-- BEGIN not_link --> was in the wrong place.

Re: Forum Title Link

Posted: Thu Nov 01, 2007 7:21 pm
by AmyJ
HELP! I tried to install this last night. I get a white screen for my board index. The other forum pages and topics, etc show. But I get a white screen for the board index. I reverted everything back and still get a white screen. I can't figure out what I've done. Any pointers???

PHP 2.0.22
http://www.cottinghamhuntingclub.com/membersarea

Re: Forum Title Link

Posted: Fri Nov 02, 2007 2:13 pm
by quahappy
AmyJ wrote:HELP! I tried to install this last night. I get a white screen for my board index. The other forum pages and topics, etc show. But I get a white screen for the board index. I reverted everything back and still get a white screen. I can't figure out what I've done. Any pointers???

PHP 2.0.22
http://www.cottinghamhuntingclub.com/membersarea
I looked at your site last night and as you say, the other forum pages are there (if I use /membersarea/viewforum. At a guess I'd say your index.php is corrupt. Viewing the source reveals nothing. Have you tried uploading a complete fresh index.php from phpBB2.0.22 files (from this site)? That should work then it's a case of re-inserting any MOD code changes.

EDIT: Just checked your site again... and index.php is now there!

Re: Forum Title Link

Posted: Thu Nov 22, 2007 10:19 pm
by quahappy
Just a small question that someone may be able to help me with. I have this MOD installed of which the links are grouped together to form one "forum" section (there are four links: Arcade Games Room, Live Chat Roon, Daily Horoscopes, Daily word). What I'd like to do (which I have tried without much luck), is remove this:

Forum Topics Posts Last Post

So this section looks more contained as the above is not necessary. I have tried doing this in <template>/index_body.tpl:

Code: Select all

	<!-- BEGIN is_link -->
<tr> 
	<th colspan="2">{L_FORUM}</th>
	<th>{L_TOPICS}</th>
	<th>{L_POSTS}</th>
	<th>{L_LASTPOST}</th>
</tr> 
	<!-- END is_link -->
... but surprised to find that didn't remove the Forum / Topics, etc text.

Anyone got another suggestion?

Many thanks!

Re: Forum Title Link

Posted: Mon Nov 26, 2007 9:06 pm
by quahappy
No one got any suggestions? :D

Re: Forum Title Link

Posted: Sat Jan 10, 2009 12:36 pm
by quahappy
Old topic but I have solved my request above (not to show Forum Topics Posts Last Post under a Forum category title for one block at my site that just contains Forum Links:

Open <yourtemplate>/index_body.tpl

FIND

Code: Select all

<tr> 
	<th colspan="2">{L_FORUM}</th>
	<th>{L_TOPICS}</th>
	<th>{L_POSTS}</th>
	<th>{L_LASTPOST}</th>
</tr> 
BEFORE, ADD

Code: Select all

<!-- IF catrow.CAT_DESC <> 'replace this text with exact name of category' -->
In above FIND. ADD, AFTER </tr>

Code: Select all

<!-- ENDIF -->
Not the cleanest solution but it works and now my forum block that just contains forum title links looks much better. Of course, it's no good doing the above if your category block contains a mixture of forum title links and forums!