Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

leozak
Registered User
Posts: 28
Joined: Mon Mar 10, 2003 5:49 pm
Location: Winnipeg, Manitoba

Post by leozak »

Thanks Morpheus,

I changed the setting to use GD instead of ImageMagick and it works perfectly again.

Pengrus: You change the settings in Admin Console -> Extensions -> Special Categories -> Click 'Yes' under the 'Make use of GD2 Extension' option.
derek_budd
Registered User
Posts: 1
Joined: Wed Mar 24, 2004 7:45 pm

phpbb 2.0.7

Post by derek_budd »

I just downloaded and installed 2.0.7. Are there any issues with using the attachment mod with this version? can the pre-edited files be used?

Thanks
pengrus
Registered User
Posts: 566
Joined: Mon Dec 02, 2002 6:13 am
Contact:

Post by pengrus »

leozak,

Thanks! That worked. I do not have the description for the YES or No option, it is blank.

I still wonder why the ImageMagick does not work...

Also i think it might stopped working after I upgraded to 2.07.... Don't know.

Thanks for your help!
User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Re: phpbb 2.0.7

Post by morpheus2matrix »

derek_budd wrote: I just downloaded and installed 2.0.7. Are there any issues with using the attachment mod with this version? can the pre-edited files be used?

Thanks


Yes, you can :wink:
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:
timbercrawler
Registered User
Posts: 99
Joined: Mon Jul 21, 2003 1:25 am
Location: Seattle
Contact:

Post by timbercrawler »

I want to know how you specify attachment dimensions, that would be great if i could do that! Can I?
SuperStyro
Registered User
Posts: 5
Joined: Thu Mar 25, 2004 8:19 am

Post by SuperStyro »

I just need to figure out how to add phpbb_attach_quota table back in to my database with a sql script file.

I get this error when logged in on any account while looking at everyone else's profile besides my own....

Could not get User Quota

DEBUG MODE

SQL Error : 1146 Table 'mysql.phpbb_attach_quota' doesn't exist

SELECT l.quota_limit FROM phpbb_attach_quota q, phpbb_quota_limits l WHERE (q.user_id = 8 ) AND (q.user_id <> 0) AND (q.quota_type = 1) AND (q.quota_limit_id = l.quota_limit_id) LIMIT 1

Line : 184
File : c:\inetpub\wwwroot\phpscript\phpbb2\attach_mod\posting_attachments.php


I am using MySQL 4 and I just cannot get the correct format down in the sql file to add the table i guess.

I am pretty sure that it is something like this for the sql file.

CREATE TABLE [phpbb_attach_quota] (
[user_id] [int] NOT NULL,
[group_id] [int] NOT NULL,
[quota_type] [tinyint] NOT NULL,
[quota_limit_id] [int] NOT NULL
);


I hope this is all that is just needed

Thanks,
Styro


PS I think i also need something like with this in an sql file

ALTER TABLE [phpbb_attach_quota] WITH NOCHECK ADD
CONSTRAINT [DF_phpbb_attach_quota_user_id] DEFAULT (0) FOR [user_id],
CONSTRAINT [DF_phpbb_attach_quota_group_id] DEFAULT (0) FOR [group_id],
CONSTRAINT [DF_phpbb_attach_quota_quota_type] DEFAULT (0) FOR [quota_type],
CONSTRAINT [DF_phpbb_attach_quota_quota_limit_id] DEFAULT (0) FOR [quota_limit_id]
User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix »

camm15h wrote: Users and mods are having a problem uploading attachments, apart from the admin. :? This is the error:

Code: Select all

The Attachment/Image must be less than 125 pixels wide and 125 pixels high.
Any ideas? Can't see a setting for attachment upload size limits.


Admin Console -> Extensions -> Special Categories
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:
User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix »

timbercrawler wrote: I want to know how you specify attachment dimensions, that would be great if i could do that! Can I?



Admin Console -> Extensions -> Special Categories
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:
User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix »

SuperStyro wrote: I just need to figure out how to add phpbb_attach_quota table back in to my database with a sql script file.

I get this error when logged in on any account while looking at everyone else's profile besides my own....

Could not get User Quota

DEBUG MODE

SQL Error : 1146 Table 'mysql.phpbb_attach_quota' doesn't exist

SELECT l.quota_limit FROM phpbb_attach_quota q, phpbb_quota_limits l WHERE (q.user_id = 8 ) AND (q.user_id <> 0) AND (q.quota_type = 1) AND (q.quota_limit_id = l.quota_limit_id) LIMIT 1

Line : 184
File : c:\inetpub\wwwroot\phpscript\phpbb2\attach_mod\posting_attachments.php


I am using MySQL 4 and I just cannot get the correct format down in the sql file to add the table i guess.

I am pretty sure that it is something like this for the sql file.

CREATE TABLE [phpbb_attach_quota] (
[user_id] [int] NOT NULL,
[group_id] [int] NOT NULL,
[quota_type] [tinyint] NOT NULL,
[quota_limit_id] [int] NOT NULL
);


I hope this is all that is just needed

Thanks,
Styro


PS I think i also need something like with this in an sql file

ALTER TABLE [phpbb_attach_quota] WITH NOCHECK ADD
CONSTRAINT [DF_phpbb_attach_quota_user_id] DEFAULT (0) FOR [user_id],
CONSTRAINT [DF_phpbb_attach_quota_group_id] DEFAULT (0) FOR [group_id],
CONSTRAINT [DF_phpbb_attach_quota_quota_type] DEFAULT (0) FOR [quota_type],
CONSTRAINT [DF_phpbb_attach_quota_quota_limit_id] DEFAULT (0) FOR [quota_limit_id]


Have you try to re-run mod_table_inst.php file ?
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:
pengrus
Registered User
Posts: 566
Joined: Mon Dec 02, 2002 6:13 am
Contact:

Post by pengrus »

I heard that there is a way to recreate all the thumbnails by change the table thumbnail flag in database to ZERO, then run create_thumbnails.php (from the script folder).

Anyone knows which exact table name is this thumbnail flag?


Thank you!
nantawani
Registered User
Posts: 1
Joined: Thu Mar 25, 2004 6:40 pm

does this one can use with phpbb 2.0.7

Post by nantawani »

does this one can use with phpbb 2.0.7
User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Re: does this one can use with phpbb 2.0.7

Post by morpheus2matrix »

nantawani wrote: does this one can use with phpbb 2.0.7


Like i've already said in the thread : Yes :wink:
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:
matt.steinruck
Registered User
Posts: 18
Joined: Fri Feb 06, 2004 9:20 pm

can somebody PLEASE help? attachment not attaching

Post by matt.steinruck »

ive been through this whole process twice now... installed the attachment mod twice over, and everything looks and feels fine, EXCEPT

when i try to attach something, it just simply doesnt attach. i dont get any errors or anything. just...nothing happens.

more:
in the attachment box, i click "browse"
go grab a file, standard .doc
and click "Attach File"
the page refreshes.
theres nothing in the attachment box,
its like it just ignored my whole request.
(it did, actually)

all my chmods are set ok. and it seesm like everything else is status quo. ive checked all the lines of code and stuff...it just simply doesnt work, and its driving me nuts.

ive posted here before, with no results. can anyone please help??
thanks in advance.
matt
timbercrawler
Registered User
Posts: 99
Joined: Mon Jul 21, 2003 1:25 am
Location: Seattle
Contact:

Post by timbercrawler »

have you created a folder on your server called files/ or something similair and poited it at that in the admin panel attachment management pane. it has to have somewhere to put them. Just a guess.

Anyone know....

where I can hange the color of the table cell that the error is in when someone tries to post a photo that is too big? Right now mine is set to 500x500 and if it is bigger than that (a brilliantpiece of code) it displays an error up top of the compose page with a blue background. Where is the blue color and/or text color defined?

Thanks!
swimma
Registered User
Posts: 136
Joined: Mon Jul 14, 2003 3:52 am

Post by swimma »

oh no...
i just tried to update my mod..and now i get this message on my forum home page...

Fatal error: Call to undefined function: attach_sql_query() in /disk1/www-data/crstonline/phpbb2/attach_mod/attachment_mod.php on line 78

Line 78 is as follows:
if ( !($result = attach_sql_query($sql)) )

Please help
Thank you
Post Reply

Return to “[2.0.x] MOD Database Releases”