Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 » Wed Jul 20, 2005 12:49 pm

MOD Updated to version 2.3.14
See first post for Download Link

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Re: For the creator of this MOD

Post by Tux_Rules » Wed Jul 20, 2005 2:26 pm

weaversp wrote: Just upgraded to 2.0.17

Attachment does not show in viewtopic
shows in post preview
have tried sync and reinstall of mod

please advise


You wouldn't happen to have the Redirect User Fix MOD installed would you? That seems to break this MOD. Don't forget to upgrade the Attach MOD to 2.3.14!

zentex
Registered User
Posts: 21
Joined: Thu Jul 14, 2005 1:58 pm
Location: Georgia

Re: For the creator of this MOD

Post by zentex » Wed Jul 20, 2005 2:57 pm

Tux_Rules wrote: You wouldn't happen to have the Redirect User Fix MOD installed would you?


Speaking of which, how hard is it to get a note thrown on the Redirect Mod that it's incompatible with AttachMod? I've seen other mod's that say they are incompatile with X Mod

tonyz
Registered User
Posts: 4
Joined: Wed Jul 20, 2005 4:05 pm
Location: Woodstock, ON Canada
Contact:

What went wrong?

Post by tonyz » Wed Jul 20, 2005 4:18 pm

Hi experts,
I recently installed the attach Mod (1st mod ever) on a version 2.0.11 board.
Everything seems to show up in tha Admin panel with attachments and extentions control, and it all seems to be good with the 'test settings'. However when you go to the board, nothing shows up that gives ability to attach files. We have gone back and double-checked the install and it seems fine to the best of our ability (we're not programmers - just designers!)
Have we left something out here?
Any help is greatly appreciated!

User avatar
mosmos
Registered User
Posts: 24
Joined: Tue Jul 19, 2005 10:17 am
Contact:

Re: [2.0.16] Attachment Mod

Post by mosmos » Wed Jul 20, 2005 4:21 pm

Is it possible add more attach fields with a simple click? If it's yes, would you please send me the instructions of the code? Thank you

jiteshpanchal
Registered User
Posts: 2
Joined: Wed Jul 20, 2005 4:28 pm

Error after installing Attach Mod 2.3.14

Post by jiteshpanchal » Wed Jul 20, 2005 4:32 pm

Hi, I have installed the attach mod on phpBB2 version 2.0.17. After executing the mod_table_inst.php file, I received a message that installation has completed successfully. However, I get the following message when I access the control panel --

Fatal error: Call to undefined function: get_var() in C:\phpBB2\admin\admin_attach_cp.php on line 62

I reallly appreciate your help. Thanks.

zentex
Registered User
Posts: 21
Joined: Thu Jul 14, 2005 1:58 pm
Location: Georgia

Re: [2.0.16] Attachment Mod

Post by zentex » Wed Jul 20, 2005 5:14 pm

mosmos wrote: Is it possible add more attach fields with a simple click? If it's yes, would you please send me the instructions of the code? Thank you


If you mean "How can I allow more than 3 attachments per post?" (which is what I think you're asking) Yes.

Go to: ACP -> Attachments -> Managment -> Maximum Number of Attachments. Set this to the desired number.
tonyz wrote: I recently installed the attach Mod (1st mod ever) on a version 2.0.11 board.
Everything seems to show up in tha Admin panel with attachments and extentions control, and it all seems to be good with the 'test settings'. However when you go to the board, nothing shows up that gives ability to attach files.


phpBB 2.0.11? seems old for a "recent" install, 2.0.17 just came out.

Anyways, Is the Mod disabled in the Management Console? There is an option to turn it off.

Does it show up for Admins and/or Moderators? This would be a permissions issue.

User avatar
mosmos
Registered User
Posts: 24
Joined: Tue Jul 19, 2005 10:17 am
Contact:

Re: [2.0.16] Attachment Mod

Post by mosmos » Wed Jul 20, 2005 5:28 pm

I meant that add more upload fields instead of waiting to refreshing page after the first attchment. I mean i want to attach 10 pictures or files in the same time not one by one. In this mod, if you want to add 10 pictures, you should add them one by one and it takes some much time and it also clumsy for the people who wants to post 5 or more pictures within the same topic. Is it possible add simple link or button to add more attach fields under the first field? thanks.

hmartin
Registered User
Posts: 118
Joined: Mon Jun 06, 2005 2:49 am
Location: /home/
Contact:

Post by hmartin » Wed Jul 20, 2005 6:18 pm

I'm trying to install version 2.3.14 on phpBB 2.0.17. The MOD says

Code: Select all

#

#-----[ FIND ]---------------------------------------------
# around line 742
			unset($delete_type);
		}
#-----[ AFTER, ADD ]--------------------------------------- 
# the Line have to be added AFTER the closing brace
$attachment_mod['pm']->delete_all_pm_attachments($mark_list);
However, I'm unable to find a closing brace following the unset($delete_type); line. Help?

kuraitenshi
Registered User
Posts: 8
Joined: Mon Jun 27, 2005 7:15 pm

Post by kuraitenshi » Wed Jul 20, 2005 6:19 pm

Tux_Rules wrote:
kuraitenshi wrote:I'm having an issue with this mod, could someone please help me out?

I've installed the files to the correct location, yet I'm recieving this error upon going to the forums/install/mod_table_inst.php step.

Cant find schemas/attach_mysql_schema.sql

The file is there. I don't know what I'm doing wrong.


Is the schemas/attach_mysql_schema.sql inside of the install driectory?


Yes, sir. It sure is.

tonyz
Registered User
Posts: 4
Joined: Wed Jul 20, 2005 4:05 pm
Location: Woodstock, ON Canada
Contact:

Re: [2.0.16] Attachment Mod

Post by tonyz » Wed Jul 20, 2005 7:55 pm

zentex wrote:
tonyz wrote:I recently installed the attach Mod (1st mod ever) on a version 2.0.11 board.
Everything seems to show up in tha Admin panel with attachments and extentions control, and it all seems to be good with the 'test settings'. However when you go to the board, nothing shows up that gives ability to attach files.


phpBB 2.0.11? seems old for a "recent" install, 2.0.17 just came out.

Anyways, Is the Mod disabled in the Management Console? There is an option to turn it off.

Does it show up for Admins and/or Moderators? This would be a permissions issue.



No it is definitely 'enabled' in the management Console.
Permissions is set for ADMIN to Post Files and REG to download.
I just want to be able to post some of our skating video clips for the registered users only, then later allow REG's to post files as well.

Version 2.0.11 was the only version available to me via my web provider - this was a standard feature that they are providing and I didn't have to do anything to set up other than selecting the 'Bulletin Board' option in my features set, when setting up my web server space.
I'm not sure if I can upgrade this version independently of my provider needing to do something. I certainly have access to all the files on my site.
I'm wondering if Attachment Mod only works in higher versions - is this a known issue? As I said, this is our first Mod, so there is nothing else that we know of that would conflict with it.

zentex
Registered User
Posts: 21
Joined: Thu Jul 14, 2005 1:58 pm
Location: Georgia

Re: [2.0.16] Attachment Mod

Post by zentex » Wed Jul 20, 2005 8:18 pm

tonyz wrote: Version 2.0.11 was the only version available to me via my web provider...I'm not sure if I can upgrade this version independently of my provider...I'm wondering if Attachment Mod only works in higher versions - is this a known issue?


The nifty part of phpBB is that you do not need command-line access to install/upgrade/modify it. A friend of mine does all his installing/modifying on his computer, then uploads it via FTP to his webspace.

I don't have any issues with 2.3.13+ on phpBB 2.0.15 (which is what I run); I also have one 2.0.14 Board that is running attach v2.3.11.

But it's always best to run semi-current with any software (looking at some changelogs, there are quite a few security fixes done since 2.0.11).

But back to your situation:

Assuming you added in all the code properly, Did you run the .sql script in the install folder?

tonyz
Registered User
Posts: 4
Joined: Wed Jul 20, 2005 4:05 pm
Location: Woodstock, ON Canada
Contact:

Re: [2.0.16] Attachment Mod

Post by tonyz » Wed Jul 20, 2005 8:28 pm

zentex wrote: Assuming you added in all the code properly, Did you run the .sql script in the install folder?


Yes, and it reported successful. I'm beginning to think I need to upgrade my board to 2.0.15. As I'm not sure how to do this is it kind of like what we just did in applying this Mod? Should I worry about losing anything?

zentex
Registered User
Posts: 21
Joined: Thu Jul 14, 2005 1:58 pm
Location: Georgia

Re: [2.0.16] Attachment Mod

Post by zentex » Wed Jul 20, 2005 8:32 pm

tonyz wrote: Yes, and it reported successful. I'm beginning to think I need to upgrade my board to 2.0.15. As I'm not sure how to do this is it kind of like what we just did in applying this Mod? Should I worry about losing anything?


odd.

2.0.17 is out :-)

It depends on how you do it. I'm about to upgrade my .15 to .17. I'm going the route of the "patch" package.

If you don't have command-line access and/or are not comfortable going such a route you have 2 other choices; a fresh-install (loose everything) or the "changes" package; where you upload the files that have changed and then you'll need to re-apply the attach mod to the files that you uploaded from the changes package.

You'll prolly wanna do the "changes" route. you'll see a zip file in the package you download that will say 2.0.11 to 2.0.17; this is the zip file you wanna get the changed files from.

If you need any more pointers on upgrading your board, PM me (as to not get off-topic in this thread)

egalvez
Registered User
Posts: 24
Joined: Tue Aug 31, 2004 1:06 am

Post by egalvez » Thu Jul 21, 2005 1:29 am

AM 2.3.14 came out two days before phpBB 2.0.17 did, if I'm not mistaken. AM 2.3.14 is listed as working with phpBB 2.0.16. Will AM 2.3.14 work fine with phpBB 2.0.17? I'm seeing unanswered questions on the opentools.de web site about this, one of which is mine. Mind you, I'm not complaining, just confused and wondering what to do with my 2.0.16 boards that have AM 2.3.13 on them. Please advise. Thank you.
Last edited by egalvez on Thu Jul 21, 2005 1:54 am, edited 1 time in total.

Post Reply

Return to “[2.0.x] MOD Database Releases”