Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

spdr
Registered User
Posts: 49
Joined: Mon Apr 25, 2005 10:54 pm

Post by spdr » Thu Jul 21, 2005 1:31 am

is it possible to make this mod upload files to a seperate server? because the server i use supports php, but is only 100 megs, and i found a free one that hosts much more than that. im not sure if my new host does, and i dont think so becuase it seems to be mainly for media and general files.

Theangryone
Registered User
Posts: 333
Joined: Wed Jun 22, 2005 4:16 am
Contact:

Post by Theangryone » Thu Jul 21, 2005 5:26 am

upgrade to 2.0.17 manually... I did, and the mod is working fine...

akira01
Registered User
Posts: 38
Joined: Sun Jun 19, 2005 2:28 am

Post by akira01 » Thu Jul 21, 2005 5:31 am

spdr wrote: is it possible to make this mod upload files to a seperate server? because the server i use supports php, but is only 100 megs, and i found a free one that hosts much more than that. im not sure if my new host does, and i dont think so becuase it seems to be mainly for media and general files.

In ACP, go into Attachment Mod Config, then select FTP and enter your second server accounts info and click Submit. To check whether it works or not, click Test Server.

User avatar
digitalmayhem
Registered User
Posts: 34
Joined: Sat Apr 20, 2002 4:31 am
Location: Sydney

Post by digitalmayhem » Thu Jul 21, 2005 6:37 am

EDITED: Found the problem... :)
phpBB User

Necromonkey
Registered User
Posts: 49
Joined: Fri Aug 13, 2004 9:38 am
Location: Copenhagen, Denmark

Post by Necromonkey » Thu Jul 21, 2005 9:43 am

Necromonkey wrote:
Tux_Rules wrote:
Necromonkey wrote:http://krusty.dk/forum/
Attachment mod installation

Everything was fine and dandy, I used the EM instructions and got a Installation Completed Succesfully. But now I have no contact with the cp and all I get is this:
Warning: main(): Unable to access ./attach_mod/attachment_mod.php in /hsphere/local/home/krusty/krusty.dk/forum/common.php on line 226

Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory in /hsphere/local/home/krusty/krusty.dk/forum/common.php on line 226

Warning: main(): Unable to access ./attach_mod/attachment_mod.php in /hsphere/local/home/krusty/krusty.dk/forum/common.php on line 226

Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory in /hsphere/local/home/krusty/krusty.dk/forum/common.php on line 226

Warning: main(): Failed opening './attach_mod/attachment_mod.php' for inclusion (include_path='.:/usr/local/lib/php') in /hsphere/local/home/krusty/krusty.dk/forum/common.php on line 226

Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/krusty/krusty.dk/forum/common.php:226) in /hsphere/local/home/krusty/krusty.dk/forum/includes/sessions.php on line 206

Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/krusty/krusty.dk/forum/common.php:226) in /hsphere/local/home/krusty/krusty.dk/forum/includes/sessions.php on line 207

Fatal error: Call to undefined function: include_attach_lang() in /hsphere/local/home/krusty/krusty.dk/forum/includes/functions.php on line 290


What's going on?

Thanks!


Did you also run the install/mod_table_inst.php? As far as I know, easymod does not install SQL items.


Yes i did. It was completed without problems. After that I wanted to acces the cp to run the EM attachment mod installation, but couldn't get access before I deleted the Install directory. So I did. Could that have anything to do with my problems?


Please, can anyone help? I totally lost here. http://krusty.dk/forum2/

baggiesmad
Registered User
Posts: 167
Joined: Wed Jun 22, 2005 10:32 am

Post by baggiesmad » Thu Jul 21, 2005 9:50 am

Will this mod work with my forum??

click here

zentex
Registered User
Posts: 21
Joined: Thu Jul 14, 2005 1:58 pm
Location: Georgia

Post by zentex » Thu Jul 21, 2005 10:25 am

egalvez wrote: Will AM 2.3.14 work fine with phpBB 2.0.17?


I'm running Attach 2.3.14 on pBB 2.0.17 just fine and w/o a hitch
Necromonkey wrote: It was completed without problems. After that I wanted to acces the cp to run the EM attachment mod installation, but couldn't get access before I deleted the Install directory...Could that have anything to do with my problems?


doubtful. you are supposed to remove the install/ dir after you run the scripts inside it.
vannquish wrote: Will this mod work with my forum??


I don't see why it wouldn't....

statm
Registered User
Posts: 447
Joined: Thu Jul 21, 2005 11:03 am
Location: NC, USA
Name: Matt
Contact:

Post by statm » Thu Jul 21, 2005 11:20 am

hmartin wrote: I'm trying to install version 2.3.14 on phpBB 2.0.17. The MOD says

Code: Select all

#

#-----[ FIND ]---------------------------------------------
# around line 742
			unset($delete_type);
		}
#-----[ AFTER, ADD ]--------------------------------------- 
# the Line have to be added AFTER the closing brace
$attachment_mod['pm']->delete_all_pm_attachments($mark_list);
However, I'm unable to find a closing brace following the unset($delete_type); line. Help?


I had the problem.. I used EM to install it.. But I ended up having to change the line number to 750 (vanilla phpbb+easymod only) because thats where the unset($delete_type); was and then I looked over the privmsg code and the } wasnt there in the first place. So I took out } from the install file.. and then it worked fine..

oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock » Thu Jul 21, 2005 12:48 pm

Just updated and a problem occured, so did a clean install of 2.17 (all OK) and then reinstalled the MOD - All OK - But :

Fatal error: Call to undefined function: get_var() in /home/httpd/vhosts/antique-locks.com/httpdocs/phpBB2/admin/admin_attach_cp.php on line 62

I get this when I try to view the attachment control panel .. any suggestions .

TA.

Paul

MentalMaze
Registered User
Posts: 531
Joined: Sun Nov 23, 2003 8:22 am
Location: Seattle
Contact:

Post by MentalMaze » Thu Jul 21, 2005 1:56 pm

statm wrote:
hmartin wrote:I'm trying to install version 2.3.14 on phpBB 2.0.17. The MOD says

Code: Select all

#

#-----[ FIND ]---------------------------------------------
# around line 742
			unset($delete_type);
		}
#-----[ AFTER, ADD ]--------------------------------------- 
# the Line have to be added AFTER the closing brace
$attachment_mod['pm']->delete_all_pm_attachments($mark_list);
However, I'm unable to find a closing brace following the unset($delete_type); line. Help?


I had the problem.. I used EM to install it.. But I ended up having to change the line number to 750 (vanilla phpbb+easymod only) because thats where the unset($delete_type); was and then I looked over the privmsg code and the } wasnt there in the first place. So I took out } from the install file.. and then it worked fine..


2.0.17 changed that line,
Now simply find:

Code: Select all

		unset($delete_type);
Then add the code after that!
When I whisper of deep dark space or
Ponder upon that of the rhyme of time
I find there is no change in the words of rhyme
Whereas there is in both space and time

Caedus
Registered User
Posts: 23
Joined: Sat Nov 30, 2002 3:06 pm
Location: The Netherlands
Contact:

Post by Caedus » Thu Jul 21, 2005 2:29 pm

I don't know if this has been adressed before, but I hope someone will help me anyway.

The thing is, if I restrict download access to certain files via this mod, then people can still directly download that file if they know the correct link. How can I make sure that only people with the correct settings can access and download those files?
:arrow: Caedus

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Re: For the creator of this MOD

Post by Tux_Rules » Thu Jul 21, 2005 4:29 pm

zentex wrote:
Tux_Rules wrote:You wouldn't happen to have the Redirect User Fix MOD installed would you?


Speaking of which, how hard is it to get a note thrown on the Redirect Mod that it's incompatible with AttachMod? I've seen other mod's that say they are incompatile with X Mod


Try posting in the Redirect MOD support thread as well as e-mail the author. One of the 2 ways would catch someones attention.

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Re: Error after installing Attach Mod 2.3.14

Post by Tux_Rules » Thu Jul 21, 2005 4:36 pm

jiteshpanchal wrote: Hi, I have installed the attach mod on phpBB2 version 2.0.17. After executing the mod_table_inst.php file, I received a message that installation has completed successfully. However, I get the following message when I access the control panel --

Fatal error: Call to undefined function: get_var() in C:\phpBB2\admin\admin_attach_cp.php on line 62

I reallly appreciate your help. Thanks.


Either you missed uploading a file, or if you did any editing to install there is a line of code off somewhere. It could be as simple as adding a line before a ; instead of after. Double check all files. Do you have any other MODs and was the board a clean 2.0.17 or update?

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Re: [2.0.16] Attachment Mod

Post by Tux_Rules » Thu Jul 21, 2005 4:39 pm

mosmos wrote: I meant that add more upload fields instead of waiting to refreshing page after the first attchment. I mean i want to attach 10 pictures or files in the same time not one by one. In this mod, if you want to add 10 pictures, you should add them one by one and it takes some much time and it also clumsy for the people who wants to post 5 or more pictures within the same topic. Is it possible add simple link or button to add more attach fields under the first field? thanks.


To the best of my knowledge, you have to wait for the page to refresh. I think Acyd Burn wrote it this way to save on possible bottlenecks when posting several large files at once, as well as the naming structure. You could contact him to see if there is a way around it.

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Re: [2.0.16] Attachment Mod

Post by Tux_Rules » Thu Jul 21, 2005 4:53 pm

tonyz wrote:
zentex wrote:
tonyz wrote:I recently installed the attach Mod (1st mod ever) on a version 2.0.11 board.
Everything seems to show up in tha Admin panel with attachments and extentions control, and it all seems to be good with the 'test settings'. However when you go to the board, nothing shows up that gives ability to attach files.


phpBB 2.0.11? seems old for a "recent" install, 2.0.17 just came out.

Anyways, Is the Mod disabled in the Management Console? There is an option to turn it off.

Does it show up for Admins and/or Moderators? This would be a permissions issue.



No it is definitely 'enabled' in the management Console.
Permissions is set for ADMIN to Post Files and REG to download.
I just want to be able to post some of our skating video clips for the registered users only, then later allow REG's to post files as well.

Version 2.0.11 was the only version available to me via my web provider - this was a standard feature that they are providing and I didn't have to do anything to set up other than selecting the 'Bulletin Board' option in my features set, when setting up my web server space.
I'm not sure if I can upgrade this version independently of my provider needing to do something. I certainly have access to all the files on my site.
I'm wondering if Attachment Mod only works in higher versions - is this a known issue? As I said, this is our first Mod, so there is nothing else that we know of that would conflict with it.


If you have access to all the files, then you can update to the newest version. If the attach MOD is the only MOD, then just upload a fresh copy of 2.0.17 with the attach MOD installed. You can do this by:

A: Download version 2.0.17 and Attach MOD 2.3.14 to your computer. Unzip both (and remember that attachmod 2.3.14 now has 2 downloads, 1 for the added files and one for the pre-modified files), add the attachment MOD to 2.0.17 and then upload all of the files except the config.php and run the /install/update_to_latest.php and the /install/attach_update_23x_to_latest.php

B: Double check your editing and make sure you uploaded all files. If you used version 2.3.14, the pre-modified files are a seperate download. These need to be added unless you manually edited for the changes.

Per Acyd Burn:
As of version 2.3.14, the pre-modified files are released seperatly. You can download
pre-modified files for the latest phpBB Version at http://www.opentools.de
or http://www.sourceforge.net/projects/acydmods

C: Look at my signature. Might be the easiest.

Post Reply

Return to “[2.0.x] MOD Database Releases”