Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
Brf
Support Team Member
Support Team Member
Posts: 52314
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf »

When you do a search you can display results as "posts", rather than "topics". Then you can go directly to the page with that post.
User avatar
thedom
Registered User
Posts: 29
Joined: Fri Sep 17, 2004 11:13 pm
Contact:

Post by thedom »

Hi,

The mod is working very well, except that I have a problem with big files (bigger than 10MB I think).

Each time someone (even me) try to download those big .zip files, there is a problem encoutered when opening the archive :
Cannot open file: it does not appear to be a valid archive.
If you downloaded this file, try downloading the file again


I uploaded the file again and again but still the same problem.
If discovered that if I download the files with my ftp, no problem when opening them. 8O

I finally had the idea to give the direct links to download those big files.
And everybody can now open them if they download them with the direct links. 8O
But, of course, the download counter is not incremented. :roll:

Any idea of what could be wrong ?
Did anybody experiment the same problem with big files ?

Thank you for your help.
PA.
Registered User
Posts: 12
Joined: Tue Aug 23, 2005 8:53 am
Location: Australia
Contact:

Post by PA. »

My system had been working fine but now I get the following message when attaching a pjg to a post.
Could not insert new word matches

DEBUG MODE

INSERT INTO phpbb_search_wordmatch (post_id, word_id, title_match) SELECT 146, word_id, 1 FROM phpbb_search_wordlist WHERE word_text IN ('äcacia', 'ridge', 'rainmaker')

Line : 251
File : functions_search.php

Thanks for any help.
ramit
Registered User
Posts: 49
Joined: Fri Dec 09, 2005 7:56 am

Post by ramit »

I dove in and did the mod.
Very well done. I have other mods so I couldn't out right use the pre-moded files, but they were great to have just to use a double check.

I have one Question with ImageMagick.
I am suppose to have it in our useable library where I rent server space, from www.pair.com

They gave me the address.
/usr/local/lib/ImageMagick

I tried and upload a jpg and I get a nice thumbnail.

I tried to upload a pdf file, and I get an error message at top of the page where I'm posting the new topic that the file can't be uploaded.

If I make the pdf extension, Special Category "none".. of then it works fine. If I turn off "make a thumbnail" it works fine too. OF course I just get a link in the posting.

Seems the ImageMagick isn't working? Just the GD2?


On the Manage Special Categories admin panel......

Does enabling "Make use of GD2 Extension" use what's rolled into the php 1st..or instead of the ImageMagick?

Or does the "Make use of GD2 Extension" need to be enabled for the ImageMagick to work?

Or do I need to turn off "Make use of GD2 Extension" to have ImageMagick to work instead of the GD?

--------------------------------

Update.
by trial and error and poking around via FTP, I did find the right address for "convert" for imagemagic.
And played with the GD.

But no matter what I do I get the following error at the top of the posting new topic page after clicking "Add Attachment" for the pdf file:

Upload Error: Could not upload Attachment to ./files/psc108_lifelink_cc_144.pdf.

I can get a jpg to work fine.. but not a pdf. The imagemagic says it supports pdf's. Can the mod support pdf's?



TIA
-Bob
User avatar
nims
Registered User
Posts: 310
Joined: Sun Aug 13, 2006 12:29 pm
Contact:

Post by nims »

Hi friends, Thanks for all the help.

I am looking for a way to do following with attach MOD.

When thumbnail is created for an attached image there shud be an option to delete or to keep the original image.
If the user decides to keep the original image, the thumbnail shud be clickable to open in a new window, with full size image.
Outsource content writing - Freelance Content Writers
*** Everything related to kids - Kids ***
SEO- search engine optimisation melbourne
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52314
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf »

PA. wrote: My system had been working fine but now I get the following message when attaching a pjg to a post.
Could not insert new word matches

DEBUG MODE

INSERT INTO phpbb_search_wordmatch (post_id, word_id, title_match) SELECT 146, word_id, 1 FROM phpbb_search_wordlist WHERE word_text IN ('äcacia', 'ridge', 'rainmaker')

Line : 251
File : functions_search.php

Thanks for any help.


That has nothing to do with attachments. I am guessing that error is because your database cannot handle the 8-bit letter in that first word.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52314
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf »

ramit wrote: I tried to upload a pdf file,


A pdf file should probably be extension-group "document". I doubt you can make a thumbnail of it though.
cuong_vm84
Registered User
Posts: 5
Joined: Mon Oct 23, 2006 12:13 pm

fatal error

Post by cuong_vm84 »

Hello everybody

Can you help me, please?

I did exactly steps by instruction ( install.txt)

But I got this problem like this.

Fatal error: Cannot redeclare attach_faq_include() (previously declared in c:\program files\easyphp1-8\www\phpbb\attach_mod\includes\functions_includes.php:18) in c:\program files\easyphp1-8\www\phpbb\attach_mod\includes\functions_includes.php on line 18

Can u help me, please?

Thank you very much
ramit
Registered User
Posts: 49
Joined: Fri Dec 09, 2005 7:56 am

Post by ramit »

Brf wrote:
ramit wrote:I tried to upload a pdf file,


A pdf file should probably be extension-group "document". I doubt you can make a thumbnail of it though.


I had PDF ext on it's own original, so I could spec it's own icon before attempting the thumbnail. Same for a spreadsheet.
That all worked fine.

Then figured I'd tackle the thumbnail.
Set up the Special Categories on that admin panel.
Then played with the extenstion and what group it's in...
PDF on it's own
Tried it as a "document" group.
Tried it as "image" group.

Either way there are only 4 selections under "special group", image seemed the most likely.... none,image,flash,stream.

Still no effected on getting a PDF to upload and a thumbnail made, still gets the same error message.

Upload Error: Could not upload Attachment to ./files/psc108_lifelink_cc_144.pdf.

ImageMagick says it's supports PDF.

Does anyone know for sure if the mod does or doesnt??

tia
-Bob
Bramster
Registered User
Posts: 605
Joined: Sun Jul 27, 2003 10:40 am

Post by Bramster »

Does anyone know for sure if the mod does or doesnt??


You can upload any file, the mod does not care at all, including PDF
Navy & Merchant Marine Forum:
www.DutchFleet.net
ramit
Registered User
Posts: 49
Joined: Fri Dec 09, 2005 7:56 am

Post by ramit »

Bramster wrote:
Does anyone know for sure if the mod does or doesnt??


You can upload any file, the mod does not care at all, including PDF


It's not if it will upload, it's if the mod handles making a thumbnail of the PDF.

Yes, the upload works fine and a link is made, but making a thumbnail only works for the jpg I tried and doesnt work for the pdf.

Once I invoke to make a thumbnail for the pdf, I get the above mentioned error. If I don't invoke making a thumbnail for a pdf, it uploads fine and I get the basic link within the post.

ImageMagick says it's supports PDF.
Does the mod support making a thumbnail of a PDF?
The Founder
Registered User
Posts: 24
Joined: Thu May 06, 2004 6:46 pm

Blank Control Panel for Attachement Mod

Post by The Founder »

My Control Panel for the attachement mod is literally blank... however all the other features of phpbb are working.. other than the control panel of the attachement mod.

Has anyone else run into this?
ramit
Registered User
Posts: 49
Joined: Fri Dec 09, 2005 7:56 am

Post by ramit »

I just did the mod last night.

Except for my issue of pdf uploads making a thumbnail, the install went perfect and all worked well.

I have a few other mods already, so couldn't use the pre-moded files.

But did use the premoded files just as a check as I went along.

There are many many files to upload and 30 to mod.
And it a bit tedious.
The Founder
Registered User
Posts: 24
Joined: Thu May 06, 2004 6:46 pm

Re: Blank Control Panel for Attachement Mod

Post by The Founder »

The Founder wrote: My Control Panel for the attachement mod is literally blank... however all the other features of phpbb are working.. other than the control panel of the attachement mod.

Has anyone else run into this?


I really need some assistance on this (if possible).

It's a standard phpbb install of the latest version with no mods at all. I did the simple install (IE: copy everything over) as per the "install_using_premod_files.txt" instructions.

It installed everything appeared to be correct.

I went to the admin control panel to enable it, and I got a blank screen for any of the control panel parts that have to do with this mod.

The rest of the forum is intact.

I would like some advice on this.. I literally read though the entire nearly 2000 pages of this thread... and found a few cases of this happening.. however no one replied to any of those guys, hence why I feel it's actually a bug problem and needs to be reported..

Unless someone has a solution I don't know what to do.. I am at wits end with this.
rgnrkx
Registered User
Posts: 2
Joined: Fri Oct 27, 2006 3:02 am

Post by rgnrkx »

Hi all,

Is there any way to make thumbnails open the original in the web browser instead of making it download to the computer?
Post Reply

Return to “[2.0.x] MOD Database Releases”