Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
bamavamp
Registered User
Posts: 62
Joined: Wed Jan 24, 2007 5:13 am
Location: sweet home alabama

Re: Attachment Mod

Post by bamavamp »

Whew, thank you both!
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17375
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

OpKiD wrote: Upload Error: Could not upload Attachment to ./files/00_550.jpg.


I get a error saying like this when i try to upload file or a image to the forum.... i have even uninstall the mod and reinstalled still the prob is there...i didnt play with database side when i did uninstall i only uninstalled forum files things...

You missed the step that states you have to make the files directory writeable by all (777).
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
OpKiD
Registered User
Posts: 21
Joined: Tue Apr 03, 2007 12:21 pm

Re: Attachment Mod

Post by OpKiD »

DavidIQ wrote:
OpKiD wrote: Upload Error: Could not upload Attachment to ./files/00_550.jpg.


I get a error saying like this when i try to upload file or a image to the forum.... i have even uninstall the mod and reinstalled still the prob is there...i didnt play with database side when i did uninstall i only uninstalled forum files things...

You missed the step that states you have to make the files directory writeable by all (777).


i have done it.. but still the same error shows up...
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17375
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Is that forum hosted on a Windows server? Because it would be impossible to set it to 777 since that's only for Unix servers. It would have to be done a different way.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
OpKiD
Registered User
Posts: 21
Joined: Tue Apr 03, 2007 12:21 pm

Re: Attachment Mod

Post by OpKiD »

DavidIQ wrote: Is that forum hosted on a Windows server? Because it would be impossible to set it to 777 since that's only for Unix servers. It would have to be done a different way.



Its a unix server...
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17375
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Well...that error only happens if the files directory doesn't exist, is in the wrong place, or doesn't have the correct permissions. Take your pick... there really is no other solution. Try setting the permissions using some other program (FileZilla, CuteFTP, etc.).
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
OpKiD
Registered User
Posts: 21
Joined: Tue Apr 03, 2007 12:21 pm

Re: Attachment Mod

Post by OpKiD »

yeah the directory is there... but still the permissions ...
OpKiD
Registered User
Posts: 21
Joined: Tue Apr 03, 2007 12:21 pm

Re: Attachment Mod

Post by OpKiD »

do i have to change the webserver permissions also?
fwgarden
Registered User
Posts: 31
Joined: Tue Oct 24, 2006 4:48 am
Location: Auckland
Contact:

Re: Attachment Mod

Post by fwgarden »

is there any language pack for this mod-i want simplified chinese.?

if yes, where to download?

if no,what can i do?
steveapple
Registered User
Posts: 3
Joined: Tue Apr 03, 2007 2:40 pm

Re: Attachment Mod

Post by steveapple »

The admin database backup utility does not automatically backup the attachment mod tables. To do so you need to add in the new attachmod tables into the list as follows:

Open
admin/admin_db_utilities.php

Search for:
$tables = array('auth_access', 'banlist', 'categories', 'config', 'disallow', 'forums', 'forum_prune', 'groups', 'posts', 'posts_text', 'privmsgs', 'privmsgs_text', 'ranks', 'search_results', 'search_wordlist', 'search_wordmatch', 'sessions', 'smilies', 'themes', 'themes_name', 'topics', 'topics_watch', 'user_group', 'users', 'vote_desc', 'vote_results', 'vote_voters', 'words', 'confirm', 'sessions_keys');

Replace with:
$tables = array('attach_quota', 'attachments', 'attachments_config', 'attachments_desc', 'auth_access', 'banlist', 'categories', 'config', 'disallow', 'extension_groups', 'extensions', 'forbidden_extensions', 'forums', 'forum_prune', 'groups', 'posts', 'posts_text', 'privmsgs', 'privmsgs_text', 'quota_limits', 'ranks', 'search_results', 'search_wordlist', 'search_wordmatch', 'sessions', 'smilies', 'themes', 'themes_name', 'topics', 'topics_watch', 'user_group', 'users', 'vote_desc', 'vote_results', 'vote_voters', 'words', 'confirm', 'sessions_keys');

save and close file.
Usual indemnities apply -- Make a backup first!
Regards, Steve Appleton
cmb1998
Registered User
Posts: 31
Joined: Sat Mar 11, 2006 3:37 am

Re: Attachment Mod

Post by cmb1998 »

I am getting a file error when trying to DL the attachment mod... Is it just me or is there a problem with this site?

Thanks,

Chris

Error Below ->

Home ‹ Search Error 404: Not FoundOopsies… what you have requested is gone!
I’m only a computer server and can only give you what I’ve got. I’ve searched and search and searched, yet there was no document of this name. So as they say… “this page is an ex-parrot”, perhaps you should use the search?
cmb1998
Registered User
Posts: 31
Joined: Sat Mar 11, 2006 3:37 am

Re: Attachment Mod

Post by cmb1998 »

Nevermind. I found it here -> http://www.phpbb.com/community/viewtopi ... 1#p2898412

Thanks,

Chris
User avatar
inferno5
Registered User
Posts: 24
Joined: Sun Feb 04, 2007 6:59 pm
Contact:

Re: Attachment Mod

Post by inferno5 »

Hello... I have been using attachment mod on different databases for a while now... Amazing MOD
However,
I just installed this MOD on a new installation of phpBB (the only mods I installed prior to this were EasyMod and Xtreme Styles). Everything went smoothly and I have configured the settings and extensions in the ACP perfectly as well. When clicked on "Test Settings" it says "Everything Seems to be Working"

The problem is that while posting or private messaging, I do not see any option whatsoever for attaching a file... I thought maybe I made a mistake in posting.php or privmsg.php but after hours of searching, I found nothing.

Just for details sake, in ACP >> Attachments >> Management >> Disable Attachment Mod is set to "No". I have even checked all the MySQL tables, especially the phpbb_attachments_config and they all look fine to me.

This makes me wonder "Am I missing something"??
I know that there are no other mods required for it to work but could the problem be installation of Xtreme Styles Mod??

If you would like to have a look at some specific files or any further information, just reply and I ll provide you with the links to all those files in .txt or .zip format.

Please just let me know... I am dying for it to work...

Thanks
Free Fun | Games | Music | Movies etc >> Click here
User avatar
David Wilding
Registered User
Posts: 5
Joined: Mon Nov 27, 2006 9:54 pm
Location: Provo, UT
Contact:

Re: Attachment Mod

Post by David Wilding »

Hi,

Today has been my first day ever dealing with MODs. I successfully installed EasyMod and then used it to install another MOD and it was a breeze. Is there a version of Attachment MOD, or one being developed, that can be installed using EasyMod?

Dave
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17375
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

inferno5 wrote: Hello... I have been using attachment mod on different databases for a while now... Amazing MOD
However,
I just installed this MOD on a new installation of phpBB (the only mods I installed prior to this were EasyMod and Xtreme Styles). Everything went smoothly and I have configured the settings and extensions in the ACP perfectly as well. When clicked on "Test Settings" it says "Everything Seems to be Working"

The problem is that while posting or private messaging, I do not see any option whatsoever for attaching a file... I thought maybe I made a mistake in posting.php or privmsg.php but after hours of searching, I found nothing.

Just for details sake, in ACP >> Attachments >> Management >> Disable Attachment Mod is set to "No". I have even checked all the MySQL tables, especially the phpbb_attachments_config and they all look fine to me.

This makes me wonder "Am I missing something"??
I know that there are no other mods required for it to work but could the problem be installation of Xtreme Styles Mod??

If you would like to have a look at some specific files or any further information, just reply and I ll provide you with the links to all those files in .txt or .zip format.

Please just let me know... I am dying for it to work...

Thanks

Are you using subSilver? Otherwise you need to edit your style manually.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
Post Reply

Return to “[2.0.x] MOD Database Releases”