Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

HVAC Tech Forum
Registered User
Posts: 108
Joined: Sun Feb 25, 2007 9:45 pm
Contact:

Re: Attachment Mod

Post by HVAC Tech Forum »

DavidIQ wrote: Remove the edit you did to faq.php

Almost tooooo simple! Thanks. My brain was not working today. 8O
Manuito
Registered User
Posts: 2
Joined: Thu May 03, 2007 11:27 pm

Re: Attachment Mod

Post by Manuito »

Hello,

Would it be possible to allow a guest to see that there is an attachment, but not to let him download it?

Thanks a lot, it's a very nice mod and works perfectly!!
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Manuito wrote: Hello,

Would it be possible to allow a guest to see that there is an attachment, but not to let him download it?

Thanks a lot, it's a very nice mod and works perfectly!!

http://phpbb.davidiq.com/viewtopic.php?t=19
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
wads24
Registered User
Posts: 578
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: Attachment Mod

Post by wads24 »

how do i make the image a thumbnail?

also, on the download.php, when i click on the file to open it, it goes to //files/image.jpg
how do i remove the "//", so that it is only 1 "/"?

thanks in advance
Thanks in advance for a reply.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

ACP -> Management
The directory should just be files not /files. For thumbs look in Special Categories.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
hponce
Registered User
Posts: 40
Joined: Mon Apr 10, 2006 2:22 pm

Re: Attachment Mod

Post by hponce »

I just install attachmod in my phpBB 2.0.22 , i do it manually, everything was fine, I wrote a new post and i attach files with no problem, even i prevew it and it shows the attachment well, but when i finally post the message the attachment does not appear. can you tell my what is wrong??
User avatar
wads24
Registered User
Posts: 578
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: Attachment Mod

Post by wads24 »

DavidIQ wrote: ACP -> Management
The directory should just be files not /files. For thumbs look in Special Categories.


i checked in admin, and it is just "files", there is no "/" infront of hit... i think it is the download.php file that is for some reason making the file come up as "//files/picture.jpg
Thanks in advance for a reply.
Katachi
Registered User
Posts: 26
Joined: Mon Dec 06, 2004 6:04 pm

Re: Attachment Mod

Post by Katachi »

I have the Attachement MOD installed and everything works fine except for the thumbnail creation. I receive these errors after uploading an attachement:
Warning: imagejpeg: unable to open '/mnt/ja2/03/710/00000002/htdocs/dpit/forum/files/thumbs/t_flowmap_544.jpg' for writing in /mnt/ja2/03/710/00000002/htdocs/dpit/forum/attach_mod/includes/functions_thumbs.php on line 212


Ok ok, I searched this topic and found the answer to my problem. I needed to create the "thumbs" folder first *cough* :D I love the search function.

thx and take care!
scorpus
Registered User
Posts: 2
Joined: Thu May 03, 2007 2:22 pm
Contact:

Re: Attachment Mod

Post by scorpus »

DavidIQ wrote: I'm not understanding how you installed this mod. You used the premodified files and then proceeded to edit the files again?


no i haven't use modified files because i m using spam mod.
i just copy attachment mod files such as in the instructions, modify files that i need to modify and install tables from install.php
Crazy-S
Registered User
Posts: 138
Joined: Wed Feb 07, 2007 12:41 am
Contact:

Re: Attachment Mod

Post by Crazy-S »

I have had this mod installed for awhile now, and my members love it.

I do encounter problems sometimes...

I am looking for suggestions on 2 things.

The first is this error, I only receive it sometimes, not always when uploading large files...
Error 500 - Internal server error

An internal server error has occured!
Please try again later.


The second thing is, for transparent images, like .png files, is there any way to change the default color from black background to either white, or an offset of white?
Visit Crazy-Software.com for some great personalized gift making software!

Like Personalized candy Wrappers? Then visit Our Community
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

hponce wrote: I just install attachmod in my phpBB 2.0.22 , i do it manually, everything was fine, I wrote a new post and i attach files with no problem, even i prevew it and it shows the attachment well, but when i finally post the message the attachment does not appear. can you tell my what is wrong??

If you have a redirection mod installed you'll need to remove it.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

wads24 wrote:
DavidIQ wrote: ACP -> Management
The directory should just be files not /files. For thumbs look in Special Categories.


i checked in admin, and it is just "files", there is no "/" infront of hit... i think it is the download.php file that is for some reason making the file come up as "//files/picture.jpg

Maybe in your forum configuration you have an extra '/' somewhere. Download.php wouldn't add that extra character out of nowhere.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52111
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

Crazy-S wrote: when uploading large files...
Error 500 - Internal server error
The default server limit for uploaded files is 2M. If you need to upload something larger than that, you will need to change your php.ini file on the server.
transparent images, like .png files, is there any way to change the default color from black background to either white, or an offset of white?


The HTML for that is found in viewtopic_attach_body.tpl

Code: Select all

		<td colspan="2" align="center"><br /><img src="{postrow.attach.cat_images.IMG_SRC}" alt="{postrow.attach.cat_images.DOWNLOAD_NAME}" border="0" /><br /><br /></td>

There is no "class" on that TD, so it is inheriting the standard TD classes for your template.If you want to change it, you could always tack in a style="background-color: #F0F0F0" or something between the "align="center" and the ">"
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

scorpus wrote:
DavidIQ wrote: I'm not understanding how you installed this mod. You used the premodified files and then proceeded to edit the files again?


no i haven't use modified files because i m using spam mod.
i just copy attachment mod files such as in the instructions, modify files that i need to modify and install tables from install.php

You may have duplicated the common.php edit. Check that.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
wads24
Registered User
Posts: 578
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: Attachment Mod

Post by wads24 »

DavidIQ wrote:
wads24 wrote:
DavidIQ wrote: ACP -> Management
The directory should just be files not /files. For thumbs look in Special Categories.


i checked in admin, and it is just "files", there is no "/" infront of hit... i think it is the download.php file that is for some reason making the file come up as "//files/picture.jpg

Maybe in your forum configuration you have an extra '/' somewhere. Download.php wouldn't add that extra character out of nowhere.



no where in my config do I have a "/".... non of my other links do that... anyone else know why when clicking on the thumbnail, it goes to "//files/picture.jpg
Thanks in advance for a reply.
Post Reply

Return to “[2.0.x] MOD Database Releases”