Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

zarmenas
Registered User
Posts: 8
Joined: Fri May 04, 2007 11:42 am

Re: Attachment Mod

Post by zarmenas »

hi everyone!

I have a problem with this MOD - everytime I try to upload a file, I get error message "tried to upload empty file"....
Ichecked and double checked MOD's settings - seems fine. in phpinfo.php settings look like this:
file_uploads = On
memory_limit = 32M
post_max_size = 10M
upload_max_filesize = 10M

directories in the server are chmod'ed to 777 (/files)

this error accours no matter if php-safemode is on or off.

could someone please help me out of this misery?

thanks,

-zarmenas-
User avatar
wads24
Registered User
Posts: 582
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: Attachment Mod

Post by wads24 »

I have had this mod before, but I remember that there was a upload quota bar that was viewable on the users profile. Did they take this feature off, or did I miss part of the install?
Thanks in advance for a reply.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

wads24 wrote: no where in my config do I have a "/".... non of my other links do that... anyone else know why when clicking on the thumbnail, it goes to "//files/picture.jpg

I was talking about the script path, etc. but I guess you must have a "special" version of this mod that adds an extra slash to the URL path :roll: something that I've never seen anyone else report...
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

zarmenas wrote: hi everyone!

I have a problem with this MOD - everytime I try to upload a file, I get error message "tried to upload empty file"....
Ichecked and double checked MOD's settings - seems fine. in phpinfo.php settings look like this:
file_uploads = On
memory_limit = 32M
post_max_size = 10M
upload_max_filesize = 10M

directories in the server are chmod'ed to 777 (/files)

this error accours no matter if php-safemode is on or off.

could someone please help me out of this misery?

thanks,

-zarmenas-

How big is the file?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
wads24
Registered User
Posts: 582
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: Attachment Mod

Post by wads24 »

DavidIQ wrote:
wads24 wrote: no where in my config do I have a "/".... non of my other links do that... anyone else know why when clicking on the thumbnail, it goes to "//files/picture.jpg

I was talking about the script path, etc. but I guess you must have a "special" version of this mod that adds an extra slash to the URL path :roll: something that I've never seen anyone else report...


ok, well thanks bud... i do appreciate the help
Thanks in advance for a reply.
zarmenas
Registered User
Posts: 8
Joined: Fri May 04, 2007 11:42 am

Re: Attachment Mod

Post by zarmenas »

it seems the filesize has no influence. no matter if I try to upload 2Kb or 2Mb - the same error...
User avatar
wads24
Registered User
Posts: 582
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: Attachment Mod

Post by wads24 »

Code: Select all

re: <!-- BEGIN switch_upload_limits --><!-- END switch_upload_limits -->
when I remove the above from profile_view_body.tpl, then I can see the quota bar, but when they are there, then the quota bar doesn't show. Am I missing a setting in admin to turn this feature on?
Thanks in advance for a reply.
hponce
Registered User
Posts: 40
Joined: Mon Apr 10, 2006 2:22 pm

Re: Attachment Mod

Post by hponce »

DavidIQ wrote:
hponce wrote: I just install attachmod in my phpBB 2.0.22 , i do it manually, everything was fine, I wrote a new post and i attach files with no problem, even i prevew it and it shows the attachment well, but when i finally post the message the attachment does not appear. can you tell my what is wrong??

If you have a redirection mod installed you'll need to remove it.


I have not redirection mod installed,
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52115
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

hponce wrote: I have not redirection mod installed,
He is refering to the mod that removes the "click here to view your new post" screen you normally see immediately after posting.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52115
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

wads24 wrote: Am I missing a setting?

You might be missing this line in usercp_viewprofile:

Code: Select all

display_upload_attach_box_limits($profiledata['user_id']); 
The quotas should show if you are viewing your own profile, or if you are an admin.
Manuito
Registered User
Posts: 2
Joined: Thu May 03, 2007 11:27 pm

Re: Attachment Mod

Post by Manuito »

Hi, thanks a lot for the answer!!

Is there a way to allow only a certain group to upload files, while all others can download them?

Thanks again
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Set the forum permission for download and/or upload to private for that particular forum. Then in group permissions change those accordingly for the group (in advanced mode).
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
hponce
Registered User
Posts: 40
Joined: Mon Apr 10, 2006 2:22 pm

Re: Attachment Mod

Post by hponce »

Brf wrote:
hponce wrote: I have not redirection mod installed,
He is refering to the mod that removes the "click here to view your new post" screen you normally see immediately after posting.


How can I do that??
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17323
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Do you have the page that confirms your posting after you hit submit? Because if you do then you most likely missed the viewtopic.php or viewtopic_body.tpl edits.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
zarmenas
Registered User
Posts: 8
Joined: Fri May 04, 2007 11:42 am

Re: Attachment Mod

Post by zarmenas »

DavidIQ wrote: How big is the file?


it seems the filesize has no influence. no matter if I try to upload 2Kb or 2Mb - the same error...
Post Reply

Return to “[2.0.x] MOD Database Releases”