Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

pipemann
Registered User
Posts: 31
Joined: Tue Aug 14, 2007 7:41 am
Location: Norway
Contact:

attachment appear twice

Post by pipemann »

During update to 2.4.5 version of att. mod. came this error. Most of the uploaded attachments appear twice or 3 times in the posts. I think that its some within double ID`s in the database, but I am not sure how to solve. Any script? Have tried to run repair of the actual tables.

I had some trouble during update, and "update_to_latest" was run multiple times.

Any tips how to fix? :cry:

PM
Cp299
Registered User
Posts: 99
Joined: Thu Jul 17, 2003 12:21 am

Re: Attachment Mod

Post by Cp299 »

Still having the problem with default settings when editing users/groups!

Every time I edit a group or a user, their default is set to "Standard", and not "Not Assigned" meaning it changes their settings every time. When editing a user, it would override their group setting thus making them have more/less space.

How do I get the default to "Not Assigned"?
abhishek1711
Registered User
Posts: 528
Joined: Tue Apr 17, 2007 6:08 am
Location: India
Contact:

Re: Attachment Mod

Post by abhishek1711 »

hi david my issue still persisists....pictures still appear as files...
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

abhishek1711 wrote:hi david my issue still persisists....pictures still appear as files...
Ok...what extension group are your picture extensions in (jpg, gif, etc.)? Are they in the images extension group? In extensions group control Images should have the special category Images selected and download mode should be set to physical. In special categories the Display Images Inline setting should be on. Let me know if you fix your issue with any of this.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Cp299 wrote:Still having the problem with default settings when editing users/groups!

Every time I edit a group or a user, their default is set to "Standard", and not "Not Assigned" meaning it changes their settings every time. When editing a user, it would override their group setting thus making them have more/less space.

How do I get the default to "Not Assigned"?
Are they members of a group? Do you have any other mods installed? The default is to set this drop-down to Not Assigned so either they're in a usergroup or you have some other mod changing the default.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: attachment appear twice

Post by DavidIQ »

pipemann wrote:During update to 2.4.5 version of att. mod. came this error. Most of the uploaded attachments appear twice or 3 times in the posts. I think that its some within double ID`s in the database, but I am not sure how to solve. Any script? Have tried to run repair of the actual tables.

I had some trouble during update, and "update_to_latest" was run multiple times.

Any tips how to fix? :cry:

PM
Although it wasn't needed, did you update the files? My bet is that you have the edits on viewtopic.php and viewtopic_body.tpl duplicated.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Bandwith problem

Post by DavidIQ »

Fred_Spider wrote:Someone help me please:
The file, in my server, that have more KBytes transferred is download.php. OK, that's normal for a site with many downloads. But checking more precisely i've realized that something is wrong with this file: I've compared the Kbytes transfered of this file with the portal.php file and check this out:
Well there's nothing really wrong with the file. You have to realize that download.php is used for every single attached file including images even if the image isn't downloaded. The portal file is only used when clicked on.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: How do I make db/directory writeable for attachments?

Post by DavidIQ »

Zrob wrote:Hello, I have just finished half of the installation for the attachment mod and I have one thing to do. After I ran the install.php that creates the tables in the data base, it said directory not writable how do I change this? other that that so far so good.

Thanks for any info :!:
Using your favorite FTP program change the permissions to the files directory.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
abhishek1711
Registered User
Posts: 528
Joined: Tue Apr 17, 2007 6:08 am
Location: India
Contact:

Re: Attachment Mod

Post by abhishek1711 »

thnks tht works...was my ignorance causing this silly mistake. okie now the pics are displayed like a attachment...any better way to show them as normal part of the post , like within the posts with test before/after them
User avatar
steve8675537
Registered User
Posts: 215
Joined: Mon Mar 19, 2007 6:02 pm
Location: phpbb3 newbie

Re: Attachment Mod

Post by steve8675537 »

does this mod work ok with ez portal? i see it says something about nuke ports - although i dont know what that means.
User avatar
lord_jlp
Registered User
Posts: 2
Joined: Sat May 13, 2006 2:19 pm
Location: Strasbourg, France
Contact:

Re: Attachment Mod

Post by lord_jlp »

Hi all,

As the excellent "Attachment MOD" has not be devolopped for being integrated with phpnuke, where could I find a port of this MOD for phpnuke ?

Many thanks in advance for your help,
Regards.
:: LorD JLP... ::
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

lord_jlp wrote:Hi all,

As the excellent "Attachment MOD" has not be devolopped for being integrated with phpnuke, where could I find a port of this MOD for phpnuke ?

Many thanks in advance for your help,
Regards.
I think I've seen something over at the phpNuke forums.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

abhishek1711 wrote:thnks tht works...was my ignorance causing this silly mistake. okie now the pics are displayed like a attachment...any better way to show them as normal part of the post , like within the posts with test before/after them
You'll need to edit viewtopic_attach_body.tpl to your liking specifically under the images section in there.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

steve8675537 wrote:does this mod work ok with ez portal? i see it says something about nuke ports - although i dont know what that means.
I don't see why not. phpNuke is a total mashup of phpBB2.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52298
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

steve8675537 wrote:does this mod work ok with ez portal? i see it says something about nuke ports - although i dont know what that means.
Attachments are done to posts, not to portal pages. Whatever portal page you are using is irrelevant.
Post Reply

Return to “[2.0.x] MOD Database Releases”