Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
steve8675537
Registered User
Posts: 215
Joined: Mon Mar 19, 2007 6:02 pm
Location: phpbb3 newbie

Re: Attachment Mod

Post by steve8675537 »

ok thanks :)
User avatar
u8out
Registered User
Posts: 11
Joined: Thu May 31, 2007 3:57 pm

Re: Attachment Mod - not seeing Add Attachment box

Post by u8out »

I'm fairly new to phpbb, but have a forum up and running. I've just installed the attachment mod. The test says it's configured okay, but when I go to the forum, I'm not seeing the Add Attachment box. (Also, if I change the admin setting to use the Attachment Posting Control Panel, I don't see that, either, when I open my forum.) I'm not seeing any error messages; just not seeing the Attachment box when I try to post or reply to a post.

I'm guessing there's an obvious administration control I need to enable. Would appreciate any leads on what might be missing or wrong.
User avatar
steve8675537
Registered User
Posts: 215
Joined: Mon Mar 19, 2007 6:02 pm
Location: phpbb3 newbie

Re: Attachment Mod

Post by steve8675537 »

I'm trying this out on a test board, first thing i notice is i get this when running the insall.php

__________

Checking attachment mod storage directory:
files/ Directory found, Directory not writeable - please make sure you make it writeable before using the attachment mod

____________

Is that anything to worry about ? it did say it completed this stage successfully at the bottom
Last edited by steve8675537 on Tue Aug 14, 2007 5:52 pm, edited 1 time in total.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52298
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod - not seeing Add Attachment box

Post by Brf »

u8out wrote: The test says it's configured okay,
What test?

Did you follow all of the instructions in the install.txt?
User avatar
steve8675537
Registered User
Posts: 215
Joined: Mon Mar 19, 2007 6:02 pm
Location: phpbb3 newbie

Re: Attachment Mod

Post by steve8675537 »

I meant the installer

I'm using the pre_modded files and following those instructions just on a test board first. It says in step number IV:

# If the installer told you to make the upload path writeable, you have to chmod it to 777
# (or change the owner to you httpd-servers owner) to upload files if you do not use the ftp upload feature.
# if you only have plain ftp-access change the 'Attribute' of your files-directory to rwxrwxrwx.

I dont know what that means, how would i do that?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52298
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf »

Right-click on the directory in your FTP program and CHMOD that directory to 777.
User avatar
steve8675537
Registered User
Posts: 215
Joined: Mon Mar 19, 2007 6:02 pm
Location: phpbb3 newbie

Re: Attachment Mod

Post by steve8675537 »

yup that done it, test successful
User avatar
u8out
Registered User
Posts: 11
Joined: Thu May 31, 2007 3:57 pm

Re: Attachment Mod - not seeing Add Attachment box

Post by u8out »

Re: the test. I mean the test you can run from Administration Panel->Attachments->Management. It's the button that says "Test Settings."

I used the instructions from install_using_premod_files.txt.

Oh, and here's one more piece of data. When trying to post, I see a list of user permissions in the bottom right corner. They say:
You can post new topics in this forum
You can reply to topics in this forum
You can edit your posts in this forum
You can delete your posts in this forum
You can vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
So, there's that bit that says I'm not allowed to attach files to this forum. Makes it sound like a Forum or user permission issue, but I'm not seeing anything in those administration screens.

And now that I see this, I've found one more thing. When logged as the forum admin, I can see/use the Add Attachments box. It's when I'm logged in as a forum user that I cannot. What setting is controlling that?
Last edited by u8out on Tue Aug 14, 2007 10:14 pm, edited 1 time in total.
pipemann
Registered User
Posts: 31
Joined: Tue Aug 14, 2007 7:41 am
Location: Norway
Contact:

Re: attachment appear twice

Post by pipemann »

DavidIQ wrote:[
Although it wasn't needed, did you update the files? My bet is that you have the edits on viewtopic.php and viewtopic_body.tpl duplicated.
I just checked it without any result. I have not modified this files, downloaded changed files only.
When looking into database table (attachment_ID)its seems like ID`s appearing 3 times.
So what I probably need is a method for repairing database. I am not very experienced with sql commands.
Anybody have some tips?

PM
Alphy420
Registered User
Posts: 6
Joined: Fri Aug 19, 2005 7:19 am

Re: Attachment Mod

Post by Alphy420 »

hello, i would jus like to know if this mod has like a lil windows media player box in the post after i have attached the .wmv file to play it, or if it takes u 2 to a different page to play the video file

Also, do the video files have Hotlink prevention so other users cant obtain the url of the file and use it on the site and use up all ur BW. Would it be possible for the user to find the actual url of the video or does attach mod hide it? even from the Right Click > View Source method?

Finally, Does the attach mod have a catagory system for its downloads? or video cat for its video files ?
(i don't think the above might be true but doesn't hurt askin :)
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52298
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod - not seeing Add Attachment box

Post by Brf »

u8out wrote: And now that I see this, I've found one more thing. When logged as the forum admin, I can see/use the Add Attachments box. It's when I'm logged in as a forum user that I cannot. What setting is controlling that?
Then it is a permissions issue.
Go into Forum permissions in Advanced Mode.
The two attachment mod permissions are on the far right.
Zrob
Registered User
Posts: 214
Joined: Sat Dec 30, 2006 2:27 am

Re: How do I make db/directory writeable for attachments?

Post by Zrob »

DavidIQ wrote:
Zrob wrote:Hello, I have just finished half of the installation for the attachment mod and I have one thing to do. After I ran the install.php that creates the tables in the data base, it said directory not writable how do I change this? other that that so far so good.

Thanks for any info :!:
Using your favorite FTP program change the permissions to the files directory.
I changed the CHMOD in the FTP on that file to read and write!

Thank you for the help!
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ »

Alphy420 wrote:hello, i would jus like to know if this mod has like a lil windows media player box in the post after i have attached the .wmv file to play it, or if it takes u 2 to a different page to play the video file
Plays the file within the post
Alphy420 wrote:Also, do the video files have Hotlink prevention so other users cant obtain the url of the file and use it on the site and use up all ur BW. Would it be possible for the user to find the actual url of the video or does attach mod hide it? even from the Right Click > View Source method?
I believe it hides it by means of the download.php which feeds the file as an id which would make it hard to figure out where the file is actually at.
Alphy420 wrote:Finally, Does the attach mod have a catagory system for its downloads? or video cat for its video files ?
(i don't think the above might be true but doesn't hurt askin :)
No.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17442
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: attachment appear twice

Post by DavidIQ »

pipemann wrote:I just checked it without any result. I have not modified this files, downloaded changed files only.
When looking into database table (attachment_ID)its seems like ID`s appearing 3 times.
So what I probably need is a method for repairing database. I am not very experienced with sql commands.
Anybody have some tips?

PM
Have you tried the Synchronize Attachments link?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
pipemann
Registered User
Posts: 31
Joined: Tue Aug 14, 2007 7:41 am
Location: Norway
Contact:

Re: attachment appear twice

Post by pipemann »

[quote="DavidIQ"[Have you tried the Synchronize Attachments link?[/quote]

Yes. No result. Well, I will try studying the database this afternoon.
Thanks so far ;)
Post Reply

Return to “[2.0.x] MOD Database Releases”