Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

ChronicTom
Registered User
Posts: 3
Joined: Sun Apr 13, 2008 2:49 am

Re: Attachment Mod

Post by ChronicTom » Mon Apr 21, 2008 6:32 pm

Ok, I seem to be having a problem.

After installing this mod, all seemed to work great, until I tried to modify a user.

It give me this error trying to load the edit profile page now.

Fatal error: Cannot redeclare group_select() in /forum/attach_mod/includes/functions_selects.php on line 18


Line 18 in that file is;

function group_select($select_name, $default_group = 0)

I just went through the install file twice over, line by line, there are no mistakes in the edits.

What do I try now? I have no control over user membership now.

Tom

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf » Mon Apr 21, 2008 7:16 pm

There should be no other instance of group_select, unless it is in one of your other mods.

eddystone
Registered User
Posts: 145
Joined: Thu Aug 05, 2004 3:38 am

Re: Attachment Mod

Post by eddystone » Tue Apr 22, 2008 8:52 am

I have had this mode for years,

Worked fine....

All of a sudden when i go to upload pics i get a blank page???

The post isn't created???

Any ideas?

eddy

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17087
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ » Tue Apr 22, 2008 12:23 pm

Check with your host. If you haven't changed anything then chances are they did.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

eddystone
Registered User
Posts: 145
Joined: Thu Aug 05, 2004 3:38 am

Re: Attachment Mod

Post by eddystone » Sun Apr 27, 2008 6:48 am

Yep a hosting issue....!

mr_india
Registered User
Posts: 3
Joined: Tue Apr 29, 2008 10:15 am

Re: Attachment Mod

Post by mr_india » Tue Apr 29, 2008 10:20 am

Dear all

My attachment mod is working ok. But it is not allowing upload of a file more than 2Mb to any forum member. Even I tried to keep the setting as unlimited.Same file I can attach as an administrator. No isues with hosting provider as max values as per phpinfo are 64Mb.

Please guide me.

Regards

PRADEEP

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17087
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ » Tue Apr 29, 2008 12:23 pm

You have not provided enough information to provide any useful help. Your post is as helpful as a Windows "A general exception has occured" text box. Please let us know exactly what happens when you try and go over 2MB
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

mr_india
Registered User
Posts: 3
Joined: Tue Apr 29, 2008 10:15 am

Re: Attachment Mod

Post by mr_india » Tue Apr 29, 2008 1:12 pm

Dear DavidIQ

Suppose A forum member try to attach a .pdf file of 3MB with his message. It gives a message " Too big file. Max allowed 2MB " . The same file if I try to attach ( I am administrator of the board )with my meaasage, the attachment is ok.

Means it is allowing attachment of a 3MB file to the administrator, but denying it to attach to a member(non administrator).

I have changed max allowable limit to 'unlimited' through attachment admin. As per phpinfo.php file max allowed is 64M ( Server config )

Let me know whats need to change ?

Regards

PRADEEP

mr_india
Registered User
Posts: 3
Joined: Tue Apr 29, 2008 10:15 am

Re: Attachment Mod

Post by mr_india » Tue Apr 29, 2008 1:45 pm

Dear DavidIQ

problem solved. It was admin (my) mistake. In 'Extention group control' max file size was set to 2MB.

Regards

PRADEEP

User avatar
bamavamp
Registered User
Posts: 62
Joined: Wed Jan 24, 2007 5:13 am
Location: sweet home alabama

Re: Attachment Mod

Post by bamavamp » Sat May 03, 2008 3:44 am

We have had this mod installed and working for well over a year. We have now decided that we want to give different Groups different levels of attachment space. However, under the Groups--Management function there is nothing there for us to set Quota Limits for each individual group as there should be.
Is there another way to do this that we have overlooked and if not, any ideas on which files need to be adjusted in order for this function to work? Again we have no problems with any other functions of the attachment mod--we can give individuals different quota's but not Groups.
Thanks in advance!

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17087
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ » Sat May 03, 2008 4:02 am

You need to manage the group in admin. If you don't see the quota options then you missed 2 edits that go into that page.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
bamavamp
Registered User
Posts: 62
Joined: Wed Jan 24, 2007 5:13 am
Location: sweet home alabama

Re: Attachment Mod

Post by bamavamp » Sat May 03, 2008 5:36 am

I did state I tried to use the admin function under Group--Management and it was not there, my question was which file(s) are related to that function so that I do not have to re-check every single file that had to be edited.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Attachment Mod

Post by Brf » Sat May 03, 2008 11:51 am

Hmmm.... I can see the quota in User Admin Management, but I dont see it in Group Admin either :P

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17087
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Attachment Mod

Post by DavidIQ » Sat May 03, 2008 12:13 pm

It's one of these two edits that you're missing:

Code: Select all

# 
#-----[ OPEN ]---------------------------------------------
# 
admin/admin_groups.php

# 
#-----[ FIND ]---------------------------------------------
# around line 59
if ( isset($HTTP_POST_VARS['edit']) || isset($HTTP_POST_VARS['new']) )

# 
#-----[ BEFORE, ADD ]---------------------------------------
# 
attachment_quota_settings('group', $HTTP_POST_VARS['group_update'], $mode);

# 
#-----[ OPEN ]---------------------------------------------
# 
admin/admin_ug_auth.php

# 
#-----[ FIND ]---------------------------------------------
# around line 91
// ---------------
// Start Functions

# 
#-----[ BEFORE, ADD ]---------------------------------------
# 
attach_setup_usergroup_auth($forum_auth_fields, $auth_field_match, $field_names);
Looks like Brf is missing it too :lol:
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
bamavamp
Registered User
Posts: 62
Joined: Wed Jan 24, 2007 5:13 am
Location: sweet home alabama

Re: Attachment Mod

Post by bamavamp » Sat May 03, 2008 1:46 pm

The lines for those files are already in there exactly as the instructions said and it stil didn't work.

So I decided to look at other possible group control files in the instructions and this is what was missing:

Code: Select all

#-----[ OPEN ]---------------------------------------------
# 
templates/subSilver/admin/group_edit_body.tpl

# 
#-----[ FIND ]---------------------------------------------
# around line 48
	<!-- END group_edit -->

# 
#-----[ BEFORE, ADD ]---------------------------------------
# 
	<tr> 
	  <td class="row1"><span class="gen">{L_UPLOAD_QUOTA}</span></td>
	  <td class="row2">{S_SELECT_UPLOAD_QUOTA}</td>
	</tr>
	<tr> 
	  <td class="row1"><span class="gen">{L_PM_QUOTA}</span></td>
	  <td class="row2">{S_SELECT_PM_QUOTA}</td>
	</tr>
Thanks anyway I should have looked more carefully at the files before posting I guess, but hopefully this will help out brf.

Post Reply

Return to “[2.0.x] MOD Database Releases”