Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

pkban
Registered User
Posts: 6
Joined: Sat Jun 28, 2003 7:35 am

Fileattachment - permissions confusions

Post by pkban »

Hi all,
Sorry if this is a stupid question, but I can't get it really to work my way.
I have set up a forum with 2.05 and the attachment mod.

I have set the forums permissions to "register".
I would like people being able to post attachments when they have registered - but I can only post when ranked as administrator, not user.

Is there a way of setting this up?

Cheers folks,
PK

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix »

SeanMcQ wrote: Will this mod still work with 2.0.4?


yes, it work
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Mysticssjgoku
Registered User
Posts: 23
Joined: Fri Jun 27, 2003 7:47 am
Location: waukegan illinois
Contact:

Post by Mysticssjgoku »

hmm, ok i installed the attachment mod and when i change the maximum size and everything to unlimited or 10mb it does it in the tables, but it wont do it when i try to attach something, i can still only attach a maximum of 2mb. help

heres the contents of my posting_attachments.php and other files

http://planetdbz.gotdns.com/code.zip

TangyPeach
Registered User
Posts: 59
Joined: Tue Aug 27, 2002 3:39 pm
Contact:

Post by TangyPeach »

I need some help if anyone has a few minutes to spare.
(attachment mod v.237 on a 2.0.4 board is what i'm using.)

This morning, tryin to post, my board started popping up this error. I have no clue what to do about it.
Could not get Attachment Informations for post number 10619

DEBUG MODE

SQL Error : 1016 Can't open file: 'phpbb_attachments_desc.MYI'. (errno: 145)

SELECT a.post_id, d.* FROM phpbb_attachments a, phpbb_attachments_desc d WHERE ( a.post_id IN (10619)) AND (a.attach_id = d.attach_id) ORDER BY d.filetime DESC

Line : 541
File : /home/candy/public_html/forum/attach_mod/includes/functions_attach.php


If anyone can give me an ideal as what I need to do, please, I'd be grateful.

(I did find the file, but, I don't know what i'm looking for.)
www.thepeachpit.com

dont laugh, im new at this... *smiles*

TangyPeach
Registered User
Posts: 59
Joined: Tue Aug 27, 2002 3:39 pm
Contact:

Post by TangyPeach »

I got this error when trying to pm a member.
FAQ Search Memberlist Usergroups
Profile You have no new messages Log out [ TangyPeach ]

thepeachpit.com Forum Index
General Error

Could not query Total Filesize

DEBUG MODE

SQL Error : 1016 Can't open file: 'phpbb_attachments_desc.MYI'. (errno: 145)

SELECT filesize FROM phpbb_attachments_desc WHERE attach_id IN (698,760,762,921,922,923,926,941,957,958,
959,960,962,1020,1102,1167,1168,1203,1227,1271,
1295,1296,1302,1303,1307,1331,1395,1396,1398,
1444,1446,1459,1462,1464,1467,1468,1469,1484,
1513,1544,1545,1546,1549,1551,1552,1553,1565,
1566,1567,1568,1569,1571,1576,1578,1591,1592,
1597,1598,1599,1600,1601,1615,1622,1623,1626,
1627,1628,1630,1631,1632,1633,1634,1639,1648,
1666,1667,1668,1669,1686,1687,1689,1691,1704,
1708,1709,1710,1711,1712,1714,1768,1770,1773,
1774,1775,1776,1777,1779,1780,1781,1782,1784,
1793,1800,1801,1814,1824,1825,1826,1827,1828,
1829,1830,1832,1848,1850,1856,1857,1858,1859,
1860,1863,1865,1883,1885,1898,1899,1900,1901,
1902,1903,1905,1912,1913,1933,1934,1935,1937,
1938,1939,1940,1941,1942,1943,1944,1945,1960,
1967,1968,2015,2016,2017,2019,2020,2022,2024,
2025,2031,2047,2085,2086,2087,2088,2089,2094,
2096,2097,2098,2099,2100,2101,2102,2103,2104,
2105,2106,2107,2108,2109,2116,2130,2132,2133,
2136,2138,2139,2140,2141,2153,2154,2155,2156,
2157,2160,2161,2170,2174,2175,2176,2188,2189,
2195,2197,2199,2218,2219,2220,2223,2224,2225,
2226,2227,2231,2233,2235,2236,2237,2238,2239,
2240,2241,2246,2250,2251,2252,2253,2254,2255,
2256,2257,2258,2261,2263,2264,2266,2267,2268,
2290,2292,2293,2298,2299,2301,2307,2315,2328,
2329,2331,2333,2334,2335,2336,2347,2348,2349,
2350,2351,2352,2353,2354,2377,2383,2384,2385,
2387,2388,2389,2400,2401,2402,2418,2419,2421,
2439,2458,2459,2462,2463,2464,2465,2467,2471,
2472,2473,2474,2475,2485,2515,2516,2518,2519,
2520,2523,2528,2529,2530,2531,2541,2543,2544,
2545,2548,2550,2551,2552,2556,2559,2565,2568,
2569,2570,2571,2572,2573,2574,2575,2576,2577,
2578,2579,2580,2584,2592,2617,2618,2619,2631,
2632,2633,2637,2660,2671,2688,2698,2700,2716,
2719,2748,2749,2756,2765,2771,2781,2782,2783,
2784,2785,2787,2789,2792,2798,2817,2818,2819,
2866,2874,2882,2883,2887,2888,2889,2890,2891,
2892,2893,2894,2897,2907,2912,2922,2923,2924,
2925,2926,2928,2929,2930,2932,2933,2934,2938,
2943,2951,2952,2954,2956,2957,2958,2959,2960,
2961,2974,2975,2976,2995,3029,3030,3031,3032,
3033,3034,3035,3036,3037,3039,3040,3041,3059,
3073,3074,3075,3076,3077,3078,3079,3080,3081,
3131,3132,3133,3135,3137,3141,3151,3152,3172,
3190,3196,3201,3216,3232,3234,3235,3236,3237,
3238,3245,3247,3270,3275,3281,3282,3310,3322,
3349,3417,3418,3419,3420,3421,3422,3430,3432,
3451,3455,3476,3479,3480,3481,3495,3496,3499,
3502,3529,3619,3620,3621,3622,3623,3624,3625,
3627,3628,3629,3630,3631,3671,3684,3685,3686,
3702,3703,3704,3705,3706,3712,3817,3848,3880,
3892,3895,3896,3900,3902,3903,3905,3906,3910,
3916,3932,3937,3938,3939,3962,4004,4005,4006,
4007,4028,4037,4038,4039,4040,4041,4043,4044,
4045,4046,4055,4097,4119,4146,4173,4185,4186,
4187,4213,4214,4215,4239,4240,4241,4274,4313,
4314,4315,4328,4374,4404,4443,4465,4466,4557,
4597,4635,4636,4637,4664,4666,4667,4668,4669,
4674,4686,4697,4698,
4731,4732,4733,4758,4767,4776,4777,4890,
4993,4994,4998,5000,5001,5002,5010,5027,5028,
5042,5073,5129,5222,5233,5234,5237,5249,5300,5362,
5363,5373,5404,5405,5406,5407,5463,5485,5486,5487,
5489,5490,5491,5492,5494,5495,5497,5506,5543,5716,
5727,5783,5808,5844,5858,5892,5898,6162,6366,6384,
6396,6485,6508,6509,6511,6553,6554,6604,6642,6643,
6644,6645,6646,6647,6648,6649,6650,6651,6739,6741,
6823,6848,6854,6869,6872,6930,6932,6933,6941,6977,
7035,7092,7095,7096,7097,7098,7099,7100,7101,7102,
7103,7155,7172,7193,7225,7243,7244,7245,7260,7298,
7307,7309,7352,7385,7386,7387,7388,7397,7398,7399,
7400,7401,7402,7403,7404,7405,7406,7407,7408,7409,
7410,7411,7433,7443,7450,7452,7508,7520,7521,7522,
7657,7680,7821,7822,7844,7860,7871,7877,7886,7890,
7891,7893,7897,7903,7905,7906,7907,7908,7913,7914,
7976,7997,8008,8009,8021,8022,8023,8029,8036,8050,
8058,8060,8063,8064,8065,8087,8195,8196,8197,8199,
8213,8214,8215,8231,8284,8389,8420,8462,8494,8500)

Line : 618
File : /home/candy/public_html/forum/attach_mod/includes/functions_attach.php

Go to Administration Panel


Powered by phpBB 2.0.4 © 2001, 2002 phpBB Group


anyone know what I should look for as a error in the functions_attach.php ??
www.thepeachpit.com

dont laugh, im new at this... *smiles*

fooh
Registered User
Posts: 9
Joined: Mon Jun 16, 2003 10:52 pm

Post by fooh »

TangyPeach wrote: I got this error when trying to pm a member.



We're also getting an error when trying to reply to a PM:
Could not get Attachment Informations for private message number 131380

DEBUG MODE

SQL Error : 1016 Can't open file: 'phpbb_attachments_desc.MYI'. (errno: 145)

SELECT a.privmsgs_id, d.* FROM phpbb_attachments a, phpbb_attachments_desc d WHERE ( a.privmsgs_id IN (131380)) AND (a.attach_id = d.attach_id) ORDER BY d.filetime DESC

Line : 592
File : /home/candy/public_html/forum/attach_mod/includes/functions_attach.php


And when trying to access certain threads, we get the same error. This seems to have come out of nowehere, as no changes have been made to the board since the 23rd.




Oh, and hiya, Tangy! :P

TangyPeach
Registered User
Posts: 59
Joined: Tue Aug 27, 2002 3:39 pm
Contact:

Post by TangyPeach »

lol, thanks Fooh! and Hi Ya... :wink:
www.thepeachpit.com

dont laugh, im new at this... *smiles*

Mysticssjgoku
Registered User
Posts: 23
Joined: Fri Jun 27, 2003 7:47 am
Location: waukegan illinois
Contact:

Post by Mysticssjgoku »

hmm, ok i installed the attachment mod and when i change the maximum size and everything to unlimited or 10mb it does it in the tables, but it wont do it when i try to attach something, i can still only attach a maximum of 2mb. help

heres the contents of my posting_attachments.php and other files

http://planetdbz.gotdns.com/code.zip

TangyPeach
Registered User
Posts: 59
Joined: Tue Aug 27, 2002 3:39 pm
Contact:

Post by TangyPeach »

btw, thanks Acyd... I din't have to go that far, but, I did get my problem resolved. Very cool of you to help. Keep up the good work. :wink:
www.thepeachpit.com

dont laugh, im new at this... *smiles*

User avatar
nubianniht
Registered User
Posts: 338
Joined: Thu Jun 05, 2003 4:02 am
Contact:

Post by nubianniht »

Can This Be Done With The File Attachment Mod?

i installed the file attachment mod 2.3.7. now 2.3.8
basically what i wanted to is this.
for example:

if you're logged on as a registered user you see this in a topic with an image attachment:
Image

if you're logged on as a guest you see this in a topic with an image attachment:
Image
absolutely nothing.
which may confuse some guests if there' re a bunch of laughing smilies as replies in one of those cases where someone posted a funny image.
i know you could set the download permissions to all but i'm trying to save on my monthly network data transfer quota which really ain't much.

so basically i want my guest to be able to click on a link that someone posted as an attachment.
like this image i photoshopped below:

Image

is this possible?
any help will be greatly appreciated
thanks in advance

-nub

TangyPeach
Registered User
Posts: 59
Joined: Tue Aug 27, 2002 3:39 pm
Contact:

Post by TangyPeach »

My fix was sort lived.

Has there been any occurances of software issues on servers before?

Everything was working fine, till a few minutes ago, and out of the blue, I get this error.
Could not query Extensions.

DEBUG MODE

SQL Error : 1054 Unknown column 'g.forum_permissions' in 'field list'

SELECT g.allow_group, g.max_filesize, g.cat_id, g.forum_permissions FROM phpbb_extension_groups g, phpbb_extensions e WHERE (g.group_id = e.group_id) AND (e.extension = 'jpg') LIMIT 1

Line : 1014
File : /home/candy/public_html/forum/attach_mod/posting_attachments.php


any ideals? suggestions?
www.thepeachpit.com

dont laugh, im new at this... *smiles*

pkban
Registered User
Posts: 6
Joined: Sat Jun 28, 2003 7:35 am

Post by pkban »

Mysticssjgoku wrote: hmm, ok i installed the attachment mod and when i change the maximum size and everything to unlimited or 10mb it does it in the tables, but it wont do it when i try to attach something, i can still only attach a maximum of 2mb. help

heres the contents of my posting_attachments.php and other files

http://planetdbz.gotdns.com/code.zip


Hi,
Usually PHP is limited to 2 MB upload. Try to ask your webhost to increase the limit!
Cheers,
PK

User avatar
reidsb
Registered User
Posts: 32
Joined: Mon May 19, 2003 3:27 am
Contact:

Post by reidsb »

ok so be careful : if you are using the pre-modified files of the latest version (2.3., they are for phpBB 2.0.5 and not phpBB 2.0.4.


Ok, I will try updating to 2.05 and see if that helps at all.

Matt Cruea
Registered User
Posts: 17
Joined: Fri Jun 27, 2003 6:32 am
Location: Marietta, Georgia
Contact:

Post by Matt Cruea »

Ouch. This error seems really nasty.

My board doesn't even show up. It just gives me this error message:
Fatal error: Call to undefined function: include_attach_lang() in /home/virtual/site23/fst/var/www/html/Board/includes/functions.php on line 254


When I installed, I did all the rewriting by hand, just to make sure everything was done perfectly. When I saw this, I decided I should just upload the stuff that came with it. So I uploaded the function.php from the config file (upon a look at it, it was EXACTLY what I had typed).

This errors hurts me. Physically. -_-

Matt Cruea
Registered User
Posts: 17
Joined: Fri Jun 27, 2003 6:32 am
Location: Marietta, Georgia
Contact:

Post by Matt Cruea »

After some deep, DEEP searching (I read this entire thread and half of Acyd's forum), I came upon a thread there that solved my problem. It seemed to have to do with my common.php file. I don't know what the problem was, but I uploaded the pre-edit file and it worked.

Hooray.

Post Reply

Return to “[2.0.x] MOD Database Releases”