Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Post by Tux_Rules »

Caedus wrote: I don't know if this has been adressed before, but I hope someone will help me anyway.

The thing is, if I restrict download access to certain files via this mod, then people can still directly download that file if they know the correct link. How can I make sure that only people with the correct settings can access and download those files?


Have you tested this? Usually the file is appended with a _231.zip or sorts, so unless the person new that, they would not be able to download it.

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Post by Tux_Rules »

oldlock wrote: Just updated and a problem occured, so did a clean install of 2.17 (all OK) and then reinstalled the MOD - All OK - But :

Fatal error: Call to undefined function: get_var() in /home/httpd/vhosts/antique-locks.com/httpdocs/phpBB2/admin/admin_attach_cp.php on line 62

I get this when I try to view the attachment control panel .. any suggestions .

TA.

Paul

Either you missed uploading a file, or if you did any editing to install there is a line of code off somewhere.

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Post by Tux_Rules »

Note to all:

The download from here does NOT include the pre-modified files for an install. It is a seperate download:
As of version 2.3.14, the pre-modified files are released seperatly. You can download
pre-modified files for the latest phpBB Version at http://www.opentools.de
or http://www.sourceforge.net/projects/acydmods

tonyz
Registered User
Posts: 4
Joined: Wed Jul 20, 2005 4:05 pm
Location: Woodstock, ON Canada
Contact:

Re: [2.0.16] Attachment Mod

Post by tonyz »

Tux_Rules wrote: If you have access to all the files, then you can update to the newest version. If the attach MOD is the only MOD, then just upload a fresh copy of 2.0.17 with the attach MOD installed.


Ok, so are you suggesting I upgrade to the newest version of phpBB - which would include the Attach Mod in that install? Do I lose any of the board as it stands now? Would I have to uninstall the Attach Mod on my current Board?

(Why does it all have to be so difficult !) :cry:

irish_rage
Registered User
Posts: 10
Joined: Fri Jul 15, 2005 7:46 am

Nosebleed

Post by irish_rage »

Does this attachment mood worl for nosebleed template?

Necromonkey
Registered User
Posts: 49
Joined: Fri Aug 13, 2004 9:38 am
Location: Copenhagen, Denmark

Re: Nosebleed

Post by Necromonkey »

irish_rage wrote: Does this attachment mood worl for nosebleed template?


http://www.mikelothar.com/viewtopic.php ... hement+mod

Necromonkey
Registered User
Posts: 49
Joined: Fri Aug 13, 2004 9:38 am
Location: Copenhagen, Denmark

Post by Necromonkey »

Tux_Rules wrote: Sounds like EM put a line or so of code in the wrong place. I don't trust EM. Open the common.php and look to make sure these lines are correct:

Code: Select all

#-----[ OPEN ]--------------------------------------------- 
# 
common.php

#
#-----[ FIND ]---------------------------------------------
# around line 225
	$board_config[$row['config_name']] = $row['config_value'];
}

# 
#-----[ AFTER, ADD ]-------------------------------------- 
# After the closing brace
include($phpbb_root_path . 'attach_mod/attachment_mod.'.$phpEx);
As that appears to match the lines numbers in the error.


No, it's correct. No errors there:

Code: Select all

	message_die(CRITICAL_ERROR, "Could not query config information", "", __LINE__, __FILE__, $sql);
}

while ( $row = $db->sql_fetchrow($result) )
{
	$board_config[$row['config_name']] = $row['config_value'];
}
include($phpbb_root_path . 'attach_mod/attachment_mod.'.$phpEx);

I ran the clean tables mod, trying to clean up the mess I made :roll:

This is the current error:
Warning: main(): Unable to access ./attach_mod/attachment_mod.php in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: main(): Unable to access ./attach_mod/attachment_mod.php in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: main(): Failed opening './attach_mod/attachment_mod.php' for inclusion (include_path='.:/usr/local/lib/php') in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/krusty/krusty.dk/forum2/common.php:226) in /hsphere/local/home/krusty/krusty.dk/forum2/includes/sessions.php on line 206

Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/krusty/krusty.dk/forum2/common.php:226) in /hsphere/local/home/krusty/krusty.dk/forum2/includes/sessions.php on line 207

Fatal error: Call to undefined function: include_attach_lang() in /hsphere/local/home/krusty/krusty.dk/forum2/includes/functions.php on line 290

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Re: [2.0.16] Attachment Mod

Post by Tux_Rules »

tonyz wrote:
Tux_Rules wrote: If you have access to all the files, then you can update to the newest version. If the attach MOD is the only MOD, then just upload a fresh copy of 2.0.17 with the attach MOD installed.


Ok, so are you suggesting I upgrade to the newest version of phpBB - which would include the Attach Mod in that install? Do I lose any of the board as it stands now? Would I have to uninstall the Attach Mod on my current Board?

(Why does it all have to be so difficult !) :cry:


I would suggest updateing to 2.0.17. The files from here do NOT include the attach mod. I do have the complete pre-modded board at my forum (register, log-in) as well as the pre-modded install files for just the atach MOD install, which means that you can update to 2.0.17 then take the pre-modded install files ( http://www.tuxrules.com/penguin/viewtopic.php?p=163#163 ),upload them and run the install/attach_update_23x_to_latest.php (seeing as that you have allready installed the mod once)

To update to phpbb version 2.0.17, download it from here, upload all files except:
config.php
and run the install/update_to_latest.php
Delete the install/ and contrib/ directories, log in and make sure everything looks good (shouldn't have no problems, I've done this to boards running 2.0.4)
Once done, you can then upload the attachmod files I put together and run the:
install/attach_update_23x_to_latest.php (seeing as that you have allready installed the mod once)

You can go to my forum and save some trouble. Once registered and logged in, visit this link:
http://www.tuxrules.com/penguin/viewtopic.php?p=208#208
and follow the instructions in the zip file (which is basically what I put here).

And if it were easy, we wouldn't be here :wink:

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Post by Tux_Rules »

Necromonkey wrote: This is the current error:
Warning: main(): Unable to access ./attach_mod/attachment_mod.php in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: main(): Unable to access ./attach_mod/attachment_mod.php in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: main(): Failed opening './attach_mod/attachment_mod.php' for inclusion (include_path='.:/usr/local/lib/php') in /hsphere/local/home/krusty/krusty.dk/forum2/common.php on line 226

Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/krusty/krusty.dk/forum2/common.php:226) in /hsphere/local/home/krusty/krusty.dk/forum2/includes/sessions.php on line 206

Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/krusty/krusty.dk/forum2/common.php:226) in /hsphere/local/home/krusty/krusty.dk/forum2/includes/sessions.php on line 207

Fatal error: Call to undefined function: include_attach_lang() in /hsphere/local/home/krusty/krusty.dk/forum2/includes/functions.php on line 290
The way I read these errors, the files:

Code: Select all

Unable to access ./attach_mod/attachment_mod.php
Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory
Is that either the file is not there or the permissions are not set properly (644)

Code: Select all

Fatal error: Call to undefined function: include_attach_lang()
Same thing: either the attach language files are missing, or permissions are wrong.

Necromonkey
Registered User
Posts: 49
Joined: Fri Aug 13, 2004 9:38 am
Location: Copenhagen, Denmark

Post by Necromonkey »

Tux_Rules wrote: The way I read these errors, the files:

Code: Select all

Unable to access ./attach_mod/attachment_mod.php
Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory
Is that either the file is not there or the permissions are not set properly (644)


Found the file in admin/mods/attach_mod It's there and the permissions are 644.
Tux_Rules wrote:

Code: Select all

Fatal error: Call to undefined function: include_attach_lang()
Same thing: either the attach language files are missing, or permissions are wrong.


Couldn't find it, where do I look?

Would it be possible to delete everything, including db, and then uploading your phpbb2 + attachment mod combo and restoring the database with my backup files? I'm trying not to loose anything in the forum.

I really appreciate your help Tux_Rules!

User avatar
Tux_Rules
Registered User
Posts: 958
Joined: Sat Apr 24, 2004 10:48 pm
Location: Afton, Michigan
Contact:

Post by Tux_Rules »

Necromonkey wrote:
Tux_Rules wrote:
The way I read these errors, the files:

Code: Select all

Unable to access ./attach_mod/attachment_mod.php
Warning: main(./attach_mod/attachment_mod.php): failed to open stream: No such file or directory
Is that either the file is not there or the permissions are not set properly (644)


Found the file in admin/mods/attach_mod It's there and the permissions are 644.
Tux_Rules wrote:

Code: Select all

Fatal error: Call to undefined function: include_attach_lang()
Same thing: either the attach language files are missing, or permissions are wrong.


Couldn't find it, where do I look?

Would it be possible to delete everything, including db, and then uploading your phpbb2 + attachment mod combo and restoring the database with my backup files? I'm trying not to loose anything in the forum.

I really appreciate your help Tux_Rules!


If you save (or do not upload) the empty config.php file, you can upload the new files without having to go thru the install process again. When you upload the new files, just to be safe run the:
attach_update_23x_to_latest.php
just to make sure. You shouldn't have to delete the database and then restore it.

LazyD
Registered User
Posts: 3
Joined: Fri Jul 22, 2005 8:24 am

Post by LazyD »


oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock »

Tux_Rules wrote:
oldlock wrote:Just updated and a problem occured, so did a clean install of 2.17 (all OK) and then reinstalled the MOD - All OK - But :

Fatal error: Call to undefined function: get_var() in /home/httpd/vhosts/antique-locks.com/httpdocs/phpBB2/admin/admin_attach_cp.php on line 62

I get this when I try to view the attachment control panel .. any suggestions .

TA.

Paul

Either you missed uploading a file, or if you did any editing to install there is a line of code off somewhere.


I did a full upload of the mod - just as per the instructions - I downloaded the mod from opentools.de I also have the missing text as per the LazyD post above.

When I did the initial update and it did not work, I cleared everything off the server and did a clean install & then applied the mod - with exactly the same result ...........

Paul

Necromonkey
Registered User
Posts: 49
Joined: Fri Aug 13, 2004 9:38 am
Location: Copenhagen, Denmark

Post by Necromonkey »

Tux_Rules wrote: If you save (or do not upload) the empty config.php file, you can upload the new files without having to go thru the install process again. When you upload the new files, just to be safe run the:
attach_update_23x_to_latest.php
just to make sure. You shouldn't have to delete the database and then restore it.


Could you be a little more specific, please :? . Do I upload your phpbb + attachment mod combo and owerwrite my exitsting forum files? And then replace the config with my old excisting one? And that's it?

jiteshpanchal
Registered User
Posts: 2
Joined: Wed Jul 20, 2005 4:28 pm

Post by jiteshpanchal »

oldlock (Paul) and LazyD: I had exactly the same problem. I just realized that I forgot to add the PhpBB2 pre-modified flies. These files are not in the attachment mod zip. These files can be downloaded from:

http://prdownloads.sourceforge.net/acyd ... p?download

Thanks

Post Reply

Return to “[2.0.x] MOD Database Releases”