Attachment Mod

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
2035
71%
Very Good
444
16%
Good
175
6%
Fair
54
2%
Poor
156
5%
 
Total votes: 2864

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17069
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Tue May 30, 2006 2:48 pm

Elfintod wrote: Howdy folks,

I apologize for posting this. I tried searching this thread for instances of the word Control Panel but the search page is busted for some reason. It keeps giving me errors.

Anyway, here's my problem.

I'm running a current version of phpbb on my site. Standard stuff really. I don't have any other mods so i used the pre-modded files for this mod. All went pretty well it seems. I followed the instructions for pre-modded files step by step. When I go to the control panel it shows the links to modify the config for attachments but when I click on any of the links to configure them the page comes up blank.

I thought maybe it was because i'm using a template other than subsilver so I went back and changed to the sub-silver template and made sure the pre-mod files for that template were loaded in that directory. Still not working.

Has anyone run into this before or have a clue what this might be caused by? Happy to provide screen shots or any other info needed.

Try uploading all the files again or using a different upload method or program. Try CuteFTP and make sure the transfer type is set to Binary.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

enrique.delgado
Registered User
Posts: 21
Joined: Tue Jan 31, 2006 7:47 pm

Upgrading with a MOD

Post by enrique.delgado » Tue May 30, 2006 4:40 pm

Hi,

Sorry if this has been answered before but, I wanted to ask for tips as to how to upgrade my phpBB installation if it has this MOD.

I hace 2.0.19 and I want to update to 2.0.20. I only have this MOD added. Should I upgrade it to .20 as normal and then re-install this mod?

How do you guys do it?

Thanks!

groundfighter
Registered User
Posts: 1909
Joined: Sat Nov 08, 2003 2:15 am
Location: Las Vegas, NV
Contact:

Post by groundfighter » Tue May 30, 2006 4:45 pm

There is a changed files only version of the upgrade that will allow you to upgrade to the latest version without losing mod functionality, thank goodness I have like 50 mods installed . :wink:

enrique.delgado
Registered User
Posts: 21
Joined: Tue Jan 31, 2006 7:47 pm

Post by enrique.delgado » Tue May 30, 2006 4:48 pm

groundfighter wrote: There is a changed files only version of the upgrade that will allow you to upgrade to the latest version without losing mod functionality, thank goodness I have like 50 mods installed . :wink:


Hmm, I think that's what I've downloaded but, it says that if I have any mods, that I have to reinstall them. I'm looking at this page: http://www.phpbb.com/support/documents. ... radeSTABLE

groundfighter
Registered User
Posts: 1909
Joined: Sat Nov 08, 2003 2:15 am
Location: Las Vegas, NV
Contact:

Post by groundfighter » Tue May 30, 2006 4:50 pm

Try this link http://www.phpbb.com/phpBB/catdb.php?cat=48 and the appropriate version to version

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17069
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Tue May 30, 2006 6:57 pm

There are no changes from 2.0.19 to 2.0.20 in regards to this MOD. So hypothetically all you have to upgrade are the actual phpBB files from .19 to .20. Have fun! :lol:
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

enrique.delgado
Registered User
Posts: 21
Joined: Tue Jan 31, 2006 7:47 pm

Post by enrique.delgado » Tue May 30, 2006 8:02 pm

DavidIQ wrote: There are no changes from 2.0.19 to 2.0.20 in regards to this MOD. So hypothetically all you have to upgrade are the actual phpBB files from .19 to .20. Have fun! :lol:


Wooo, very tempting...

Solid Strike
Registered User
Posts: 147
Joined: Sun Jun 19, 2005 11:09 am
Location: England
Contact:

Post by Solid Strike » Tue May 30, 2006 9:27 pm

Nice MOD! But what file code changes do I need to make to add the Add Attachment button to the next line?

Image
oO | Naruto-Board.com | Oo

MODs Installed : EasyMOD - Nuttzy | Fix For The Firefox "Remember Passwords" Problem - T0ny | Today At/Yesterday At - netclectic | Advanced IP Results - dESiLVer | Welcome on Index - cherokee red | Moderator CP - kooky | Disable Board Message - damnian | Advanced time management - -=ET=- | Prune User Posts - R45 | Custom Title MOD - Aexoden | Online/Offline/Hidden - kooky | Group Icons - TacoV | eXtreme Styles | Simple Subforums | YouTube | Report Posts (Alpha)

betty77
Registered User
Posts: 43
Joined: Thu Mar 09, 2006 4:48 pm

Post by betty77 » Wed May 31, 2006 12:03 am

Does anyone know how can I remove those borders surrounding the pictures? I did a search to no avail. Thanks!

[CCCP]SMILEY
Registered User
Posts: 4
Joined: Tue May 30, 2006 2:46 am

Post by [CCCP]SMILEY » Wed May 31, 2006 2:27 am

please help me out guys. what i basically did was go to FTP manager with all the files and put all the files that are part of this mod into the places they belonged. when i put in install folder and contrib folders i went to my forum and it told me to dlete them, i did that then got the four errors below

Fatal error: Call to undefined function: include_attach_lang() in /home/cs151647/public_html/forum/admin/admin_attachments.php on line 58

Fatal error: Call to undefined function: include_attach_lang() in /home/cs151647/public_html/forum/admin/admin_extensions.php on line 54

Fatal error: Call to undefined function: include_attach_lang() in /home/cs151647/public_html/forum/admin/admin_attachments.php on line 58

Fatal error: Call to undefined function: include_attach_lang() in /home/cs151647/public_html/forum/admin/admin_attach_cp.php on line 52


what am i doing wrong

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17069
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Wed May 31, 2006 3:45 am

betty77 wrote: Does anyone know how can I remove those borders surrounding the pictures? I did a search to no avail. Thanks!

You'll need to edit viewtopic_attachments.tpl. Notice how there's different categories. You should be able to do what you need to do once you look at the file though.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17069
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Wed May 31, 2006 3:47 am

Solid Strike wrote: Nice MOD! But what file code changes do I need to make to add the Add Attachment button to the next line?

Image

That's a picture of this line in add_attachment_body.tpl:

Code: Select all

	<tr> 
		<td class="row1"><span class="gen"><b>{L_FILE_COMMENT}</b></span></td> 
		<td class="row2"><span class="genmed"><textarea name="filecomment" rows="3" cols="35" size="40" class="post">{FILE_COMMENT}</textarea></span>
		<input type="submit" name="add_attachment" value="{L_ADD_ATTACHMENT}" class="liteoption" /> </span></td> 
	</tr> 
Edit to what you need. I'd assume all you need to do is add a <br /> tag before the <input type=... part
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17069
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Wed May 31, 2006 3:48 am

[CCCP]SMILEY wrote: please help me out guys. what i basically did was go to FTP manager with all the files and put all the files that are part of this mod into the places they belonged. when i put in install folder and contrib folders i went to my forum and it told me to dlete them, i did that then got the four errors below

Fatal error: Call to undefined function: include_attach_lang() in /home/cs151647/public_html/forum/admin/admin_attachments.php on line 58

Fatal error: Call to undefined function: include_attach_lang() in /home/cs151647/public_html/forum/admin/admin_extensions.php on line 54

Fatal error: Call to undefined function: include_attach_lang() in /home/cs151647/public_html/forum/admin/admin_attachments.php on line 58

Fatal error: Call to undefined function: include_attach_lang() in /home/cs151647/public_html/forum/admin/admin_attach_cp.php on line 52


what am i doing wrong

This is getting old...you didn't do the edits in docs/install.txt. Furthermore I don't think you ran the install/install.php script before deleting it did you?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

[CCCP]SMILEY
Registered User
Posts: 4
Joined: Tue May 30, 2006 2:46 am

Post by [CCCP]SMILEY » Wed May 31, 2006 3:53 am

sorry for not knowing what to do. but i dont know how to exactly RUN the install.php. and what edits do i have to do in the install txt. and whever i try to execute the install.php it says theres nothing assoisiated with it

thanks

User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17069
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Post by DavidIQ » Wed May 31, 2006 4:12 am

Need to reupload the install folder and open the install.php file in a browser. All of the edits listed in install.txt need to be done. If you need to know how to do that then check How to Install MODs for an explanation.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.

Post Reply

Return to “[2.0.x] MOD Database Releases”